<style>
a:link, a:visited {
  background-color: transparent;
  color: #FFFFFF;
  text-align: none;
  text-decoration: underline;
	text-decoration-style: solid;
  text-decoration-thickness: 5px;
  text-decoration-color: none;
  display: inline-block;
}

a:hover, a:active {
	color: #FFFFFF !important;
	text-decoration: solid;
	text-decoration-thickness: 5px;
}
	.entry-content a {
    text-decoration: solid;
		text-decoration-thickness: 5px;
}
	
	
</style>
<script type="text/javascript" async="async" src="https://widgets.outbrain.com/outbrain.js"></script>
<center><script data-ad-client="ca-pub-7953118887885734" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script></center>

<!DOCTYPE html>
<!--[if IE 8]>
<html class="no-js g1-off-outside lt-ie10 lt-ie9" id="ie8" lang="en-GB" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb#" prefix="og: https://ogp.me/ns#"><![endif]-->
<!--[if IE 9]>
<html class="no-js g1-off-outside lt-ie10" id="ie9" lang="en-GB" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb#" prefix="og: https://ogp.me/ns#"><![endif]-->
<!--[if !IE]><!-->
<html class="no-js g1-off-outside" lang="en-GB" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb#" prefix="og: https://ogp.me/ns#"><!--<![endif]-->
<head>
	<meta charset="UTF-8"/>
	<link rel="profile" href="http://gmpg.org/xfn/11"/>
	<link rel="pingback" href="https://grungecake.com/xmlrpc.php"/>

	<!--||  JM Twitter Cards by Julien Maury 11.1.10  ||-->
<meta name="twitter:card" content="app">
<meta name="twitter:creator" content="@theyams">
<meta name="twitter:site" content="@grungecake">
<meta name="twitter:title" content="Watch Meek Mill&#8217;s new artist Tafia show us how he&#8217;s &#8216;Been On It&#8217;">
<meta name="twitter:description" content="He isn&#039;t quite like his competitors.">
<meta name="twitter:image" content="https://grungecake.com/wp-content/uploads/2022/02/tafia-been-on-it-grungecake-thumbnail.jpg">
<!--||  /JM Twitter Cards by Julien Maury 11.1.10  ||-->
<script type="text/javascript">
  WebFontConfig = {"google":{"families":["Arimo:r:latin,latin-ext","Arimo:r,i,b,bi:latin,latin-ext"]}};
  (function() {
    var wf = document.createElement('script');
    wf.src = 'https://grungecake.com/wp-content/mu-plugins/wpcomsh/vendor/automattic/custom-fonts/js/webfont.js';
    wf.type = 'text/javascript';
    wf.async = 'true';
    var s = document.getElementsByTagName('script')[0];
    s.parentNode.insertBefore(wf, s);
	})();
</script><style id="jetpack-custom-fonts-css"></style>
<script>window._wca = window._wca || [];</script>

<meta name="viewport" content="initial-scale=1.0, minimum-scale=1.0, height=device-height, width=device-width" />
<meta property="og:locale" content="en_GB" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Watch Meek Mill&#039;s new artist Tafia show us how he&#039;s &#039;Been On It&#039;" />
<meta property="og:description" content="He isn&#039;t quite like his competitors." />
<meta property="og:url" content="https://grungecake.com/tafia-been-on-it/articles/86973" />
<meta property="og:site_name" content="GRUNGECAKE" />
<meta property="article:publisher" content="https://facebook.com/grungecake" />
<meta property="article:tag" content="Been On It" />
<meta property="article:tag" content="Tafia" />
<meta property="article:section" content="Music" />
<meta property="article:published_time" content="2022-02-25T02:32:20-05:00" />
<meta property="article:modified_time" content="2022-02-25T02:41:06-05:00" />
<meta property="og:updated_time" content="2022-02-25T02:41:06-05:00" />
<meta property="og:image" content="https://grungecake.com/wp-content/uploads/2022/02/tafia-been-on-it-grungecake-thumbnail.jpg" />
<meta property="og:image:secure_url" content="https://grungecake.com/wp-content/uploads/2022/02/tafia-been-on-it-grungecake-thumbnail.jpg" />
<meta property="og:image:width" content="1200" />
<meta property="og:image:height" content="1200" />

	<!-- This site is optimized with the Yoast SEO plugin v18.2 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>Watch Meek Mill&#039;s new artist Tafia show us how he&#039;s &#039;Been On It&#039; - GRUNGECAKE</title>
	<link rel="canonical" href="https://grungecake.com/tafia-been-on-it/articles/86973" />
	<meta name="twitter:label1" content="Written by" />
	<meta name="twitter:data1" content="Richardine Bartee" />
	<meta name="twitter:label2" content="Estimated reading time" />
	<meta name="twitter:data2" content="1 minute" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://grungecake.com/#organization","name":"GRUNGECAKE","url":"https://grungecake.com/","sameAs":["http://facebook.com/grungecake","http://instagram.com/grungecake","https://twitter.com/grungecake"],"logo":{"@type":"ImageObject","@id":"https://grungecake.com/#logo","inLanguage":"en-GB","url":"https://grungecake.com/wp-content/uploads/2015/11/grungecake-logo-482.png","contentUrl":"https://grungecake.com/wp-content/uploads/2015/11/grungecake-logo-482.png","width":482,"height":300,"caption":"GRUNGECAKE"},"image":{"@id":"https://grungecake.com/#logo"}},{"@type":"WebSite","@id":"https://grungecake.com/#website","url":"https://grungecake.com/","name":"GRUNGECAKE","description":"Global music discovery","publisher":{"@id":"https://grungecake.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://grungecake.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-GB"},{"@type":"ImageObject","@id":"https://grungecake.com/tafia-been-on-it/articles/86973#primaryimage","inLanguage":"en-GB","url":"https://grungecake.com/wp-content/uploads/2022/02/tafia-been-on-it-grungecake-thumbnail.jpg","contentUrl":"https://grungecake.com/wp-content/uploads/2022/02/tafia-been-on-it-grungecake-thumbnail.jpg","width":1200,"height":1200,"caption":"Photo: Courtesy of the publicist"},{"@type":"WebPage","@id":"https://grungecake.com/tafia-been-on-it/articles/86973#webpage","url":"https://grungecake.com/tafia-been-on-it/articles/86973","name":"Watch Meek Mill's new artist Tafia show us how he's 'Been On It' - GRUNGECAKE","isPartOf":{"@id":"https://grungecake.com/#website"},"primaryImageOfPage":{"@id":"https://grungecake.com/tafia-been-on-it/articles/86973#primaryimage"},"datePublished":"2022-02-25T07:32:20+00:00","dateModified":"2022-02-25T07:41:06+00:00","breadcrumb":{"@id":"https://grungecake.com/tafia-been-on-it/articles/86973#breadcrumb"},"inLanguage":"en-GB","potentialAction":[{"@type":"ReadAction","target":["https://grungecake.com/tafia-been-on-it/articles/86973"]}]},{"@type":"BreadcrumbList","@id":"https://grungecake.com/tafia-been-on-it/articles/86973#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://grungecake.com/"},{"@type":"ListItem","position":2,"name":"Watch Meek Mill&#8217;s new artist Tafia show us how he&#8217;s &#8216;Been On It&#8217;"}]},{"@type":"Article","@id":"https://grungecake.com/tafia-been-on-it/articles/86973#article","isPartOf":{"@id":"https://grungecake.com/tafia-been-on-it/articles/86973#webpage"},"author":{"@id":"https://grungecake.com/#/schema/person/6990e9e1103b0cc4af066b02ecc2a6eb"},"headline":"Watch Meek Mill&#8217;s new artist Tafia show us how he&#8217;s &#8216;Been On It&#8217;","datePublished":"2022-02-25T07:32:20+00:00","dateModified":"2022-02-25T07:41:06+00:00","mainEntityOfPage":{"@id":"https://grungecake.com/tafia-been-on-it/articles/86973#webpage"},"wordCount":157,"commentCount":0,"publisher":{"@id":"https://grungecake.com/#organization"},"image":{"@id":"https://grungecake.com/tafia-been-on-it/articles/86973#primaryimage"},"thumbnailUrl":"https://grungecake.com/wp-content/uploads/2022/02/tafia-been-on-it-grungecake-thumbnail.jpg","keywords":["Been On It","Tafia"],"articleSection":["Music"],"inLanguage":"en-GB","potentialAction":[{"@type":"CommentAction","name":"Comment","target":["https://grungecake.com/tafia-been-on-it/articles/86973#respond"]}]},{"@type":"Person","@id":"https://grungecake.com/#/schema/person/6990e9e1103b0cc4af066b02ecc2a6eb","name":"Richardine Bartee","image":{"@type":"ImageObject","@id":"https://grungecake.com/#personlogo","inLanguage":"en-GB","url":"https://grungecake.com/wp-content/uploads/2022/01/richardine-bartee-2022-grungecake-ceo-96x96.jpg","contentUrl":"https://grungecake.com/wp-content/uploads/2022/01/richardine-bartee-2022-grungecake-ceo-96x96.jpg","caption":"Richardine Bartee"},"description":"Her unprejudiced love for people, the arts, and business have taken her this far. Join Richardine on her journey as she writes history into existence, one article at a time. Richardine is a member of the Recording Academy/GRAMMYs, and a GRAMMY U Mentor. She is the Press Agent for SMADE/AFRO NATION FOUNDER; Director of Content for Duke Concept; Follow her on Instagram and Twitter.","sameAs":["https://grungecake.com","https://facebook.com/richardinebartee","https://instagram.com/richardinebartee","https://www.linkedin.com/profile/view?id=54150000&trk=spm_pic","https://www.pinterest.com/grungecake","http://myspace.com/richardine","https://www.youtube.com/user/grungecakerecords","https://theyams.tumblr.com"],"url":"https://grungecake.com/author/richardine"}]}</script>
	<!-- / Yoast SEO plugin. -->



<!-- Search Engine Optimisation by Rank Math - https://s.rankmath.com/home -->
<title>Watch Meek Mill&#039;s new artist Tafia show us how he&#039;s &#039;Been On It&#039; - GRUNGECAKE</title>
<meta name="description" content="He isn&#039;t quite like his competitors."/>
<meta name="robots" content="index, follow, max-snippet:-1, max-video-preview:-1, max-image-preview:large"/>
<link rel="canonical" href="https://grungecake.com/tafia-been-on-it/articles/86973" />
<meta property="og:locale" content="en_GB" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Watch Meek Mill&#039;s new artist Tafia show us how he&#039;s &#039;Been On It&#039; - GRUNGECAKE" />
<meta property="og:description" content="He isn&#039;t quite like his competitors." />
<meta property="og:url" content="https://grungecake.com/tafia-been-on-it/articles/86973" />
<meta property="og:site_name" content="GRUNGECAKE" />
<meta property="article:author" content="https://facebook.com/richardinebartee" />
<meta property="article:tag" content="Been On It" />
<meta property="article:tag" content="Tafia" />
<meta property="article:section" content="Music" />
<meta property="og:updated_time" content="2022-02-25T02:41:06-05:00" />
<meta property="og:image" content="https://grungecake.com/wp-content/uploads/2022/02/tafia-been-on-it-grungecake-thumbnail.jpg" />
<meta property="og:image:secure_url" content="https://grungecake.com/wp-content/uploads/2022/02/tafia-been-on-it-grungecake-thumbnail.jpg" />
<meta property="og:image:width" content="1200" />
<meta property="og:image:height" content="1200" />
<meta property="og:image:alt" content="Watch Meek Mill&#8217;s new artist Tafia show us how he&#8217;s &#8216;Been On It&#8217;" />
<meta property="og:image:type" content="image/jpeg" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:title" content="Watch Meek Mill&#039;s new artist Tafia show us how he&#039;s &#039;Been On It&#039; - GRUNGECAKE" />
<meta name="twitter:description" content="He isn&#039;t quite like his competitors." />
<meta name="twitter:image" content="https://grungecake.com/wp-content/uploads/2022/02/tafia-been-on-it-grungecake-thumbnail.jpg" />
<!-- /Rank Math WordPress SEO plugin -->

<link rel='dns-prefetch' href='//stats.wp.com' />
<link rel='dns-prefetch' href='//secure.gravatar.com' />
<link rel='dns-prefetch' href='//www.googletagmanager.com' />
<link rel='dns-prefetch' href='//polyfill.io' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel='dns-prefetch' href='//c0.wp.com' />
<link rel='dns-prefetch' href='//pagead2.googlesyndication.com' />
<link rel='preconnect' href='https://fonts.gstatic.com' />
<link rel="alternate" type="application/rss+xml" title="GRUNGECAKE &raquo; Feed" href="https://grungecake.com/feed" />
<link rel="alternate" type="application/rss+xml" title="GRUNGECAKE &raquo; Comments Feed" href="https://grungecake.com/comments/feed" />
<link rel="alternate" type="application/rss+xml" title="GRUNGECAKE &raquo; Watch Meek Mill&#8217;s new artist Tafia show us how he&#8217;s &#8216;Been On It&#8217; Comments Feed" href="https://grungecake.com/tafia-been-on-it/articles/86973/feed" />
<script type="text/javascript">
window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/grungecake.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.9.1"}};
/*! This file is auto-generated */
!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
</script>
<!-- grungecake.com is managing ads with Advanced Ads --><script id="grung-ready">
			window.advanced_ads_ready=function(e,a){a=a||"complete";var d=function(e){return"interactive"===a?"loading"!==e:"complete"===e};d(document.readyState)?e():document.addEventListener("readystatechange",(function(a){d(a.target.readyState)&&e()}),{once:"interactive"===a})},window.advanced_ads_ready_queue=window.advanced_ads_ready_queue||[];		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='all-css-679941b5e71ed61cc9cc608edd8f9df5' href='https://grungecake.com/_static/??-eJytlFly2zAMhi9UGpPFSfPQ6VEyEAnLiLloCNCqbl9KsjK2GyXT1m8Eif/DRrLvjE1RKSp0vrQcBd5IO7QHCMkVTwKZPCo50yXRK2tjRb71fyI8DqmoaTM7EB08LY4crS+uQt8EAjlG8hRG5bnRVTll46lFO2wCxy/V9ezcPtdcp9anZFMIlC3BWCa2dLFpGp/sQaAp7B309mSbI0WXspiLcm4F/xAainnndpUge5iTACyaAqqyBaVfOtduenYt6cwSqDA47Yw+axmPNlo1u5SDeYb3Do/ymXStLJ1P6ATcEDGwneOZu6fH+5eXx+393VokQhmMJMvojewx12YU1RTlAVCEdI5JIo2JqHwkIweOkdxn0/wLKEauPeN6diOglEZs5oZuwFvz+git+3rJ6x3i0FCe5N83W1jGjjnUSvHi1jnMh38nTcX+HyKg7Oe61jhLv+Yp1f9lV7yv7SWK9XrHArs8ebopRsTjGiAge46T17w0k3LNXVjJZDoy9bJM5JS9ox0Wv6q8/ian+hw6N0xLju1Xytf62uA0dZ/aJBfGZ11aCGOVp/Xo+jP8qO9w+1xf4sPTb2RsOdQ=' type='text/css' media='all' />
<style id='easy-social-share-buttons-inline-css'>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</style>
<style id='site-reviews-inline-css'>
.gl-star-rating--stars[class*=" s"]>span,.glsr-star-empty{background-image:url(https://grungecake.com/wp-content/plugins/site-reviews/assets/images/star-empty.svg)!important}.glsr-field-is-invalid .gl-star-rating--stars[class*=" s"]>span{background-image:url(https://grungecake.com/wp-content/plugins/site-reviews/assets/images/star-error.svg)!important}.glsr-star-half{background-image:url(https://grungecake.com/wp-content/plugins/site-reviews/assets/images/star-half.svg)!important}.gl-star-rating--stars.s10>span:first-child,.gl-star-rating--stars.s20>span:nth-child(-1n+2),.gl-star-rating--stars.s30>span:nth-child(-1n+3),.gl-star-rating--stars.s40>span:nth-child(-1n+4),.gl-star-rating--stars.s50>span:nth-child(-1n+5),.gl-star-rating--stars.s60>span:nth-child(-1n+6),.gl-star-rating--stars.s70>span:nth-child(-1n+7),.gl-star-rating--stars.s80>span:nth-child(-1n+8),.gl-star-rating--stars.s90>span:nth-child(-1n+9),.gl-star-rating--stars.s100>span,.glsr-star-full{background-image:url(https://grungecake.com/wp-content/plugins/site-reviews/assets/images/star-full.svg)!important}

</style>
<style id='global-styles-inline-css'>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</style>
<style id='woocommerce-inline-inline-css'>
.woocommerce form .form-row .required { visibility: visible; }
</style>
<link rel='stylesheet' id='g1-main-css'  href='https://grungecake.com/wp-content/themes/bimber/css/8.5/styles/carmania/all-dark.min.css?ver=8.5' media='all' />
<link rel='stylesheet' id='bimber-single-css'  href='https://grungecake.com/wp-content/themes/bimber/css/8.5/styles/carmania/single-dark.min.css?ver=8.5' media='all' />
<link rel='stylesheet' id='bimber-google-fonts-css'  href='//fonts.googleapis.com/css?family=Fira+Sans%3A400%2C300%2C500%2C600%2C700%2C900%7CFira+Sans+Condensed%3A400%2C300%2C500%2C600%2C700%2C900&#038;subset&#038;display=swap&#038;ver=8.5' media='all' />
<link rel="stylesheet" type="text/css" href="https://grungecake.com/wp-content/plugins/smart-slider-3/Public/SmartSlider3/Application/Frontend/Assets/dist/smartslider.min.css?ver=5023544a" media="all">
<link rel="stylesheet" type="text/css" href="https://fonts.googleapis.com/css?display=swap&amp;family=DM+Sans%3A300%2C400%7CRoboto%3A300%2C400" media="all">
<style data-related="n2-ss-2">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</style>
<script id='jetpack_related-posts-js-extra'>
var related_posts_js_options = {"post_heading":"h4"};
</script>
<script type='text/javascript'  src='https://grungecake.com/wp-content/plugins/jetpack/_inc/build/related-posts/related-posts.min.js?m=1638896208'></script>
<script src='https://grungecake.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script type='text/javascript'  src='https://grungecake.com/wp-includes/js/jquery/jquery-migrate.min.js?m=1605690366'></script>
<script defer src='https://stats.wp.com/s-202208.js' id='woocommerce-analytics-js'></script>
<script type='text/javascript'  src='https://grungecake.com/wp-content/themes/bimber/js/modernizr/modernizr-custom.min.js?m=1601480911'></script>

<!-- Google Analytics snippet added by Site Kit -->
<script src='https://www.googletagmanager.com/gtag/js?id=UA-40407365-1' id='google_gtagjs-js' async></script>
<script id='google_gtagjs-js-after'>
window.dataLayer = window.dataLayer || [];function gtag(){dataLayer.push(arguments);}
gtag('set', 'linker', {"domains":["grungecake.com"]} );
gtag("js", new Date());
gtag("set", "developer_id.dZTNiMT", true);
gtag("config", "UA-40407365-1", {"anonymize_ip":true});
</script>

<!-- End Google Analytics snippet added by Site Kit -->
<script id='sib-front-js-js-extra'>
var sibErrMsg = {"invalidMail":"Please fill out valid email address","requiredField":"Please fill out required fields","invalidDateFormat":"Please fill out valid date format","invalidSMSFormat":"Please fill out valid phone number"};
var ajax_sib_front_object = {"ajax_url":"https:\/\/grungecake.com\/wp-admin\/admin-ajax.php","ajax_nonce":"c31c51d067","flag_url":"https:\/\/grungecake.com\/wp-content\/plugins\/mailin\/img\/flags\/"};
</script>
<script type='text/javascript'  src='https://grungecake.com/wp-content/plugins/mailin/js/mailin-front.js?m=1645524475'></script>
<script src='https://polyfill.io/v3/polyfill.min.js?version=3.109.0&#038;features=Array.prototype.find%2CCustomEvent%2CElement.prototype.closest%2CElement.prototype.dataset%2CEvent%2CMutationObserver%2CObject.assign%2CString.prototype.endsWith%2CURL%2CURLSearchParams%2CXMLHttpRequest&#038;flags=gated&#038;ver=5.9.1' id='site-reviews/polyfill-js'></script>
<link rel="https://api.w.org/" href="https://grungecake.com/wp-json/" /><link rel="alternate" type="application/json" href="https://grungecake.com/wp-json/wp/v2/posts/86973" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://grungecake.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://grungecake.com/wp-includes/wlwmanifest.xml" /> 
<link rel='shortlink' href='https://wp.me/pdkbZN-mCN' />
<link rel="alternate" type="application/json+oembed" href="https://grungecake.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fgrungecake.com%2Ftafia-been-on-it%2Farticles%2F86973" />
<link rel="alternate" type="text/xml+oembed" href="https://grungecake.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fgrungecake.com%2Ftafia-been-on-it%2Farticles%2F86973&#038;format=xml" />
<style>
.animatedfsmenu a,
.afs-cart-title {
    font-weight: 100 !important;

    }
</style>

<style>
.turbolinks-progress-bar,
.animatedfsmenu {
    background-color: #212121;
}

.animatedfsmenu.navbar-expand-md,
.animatedfsmenu.navbar-expand-ht {
    background-color: #ffcc33;
}

.animatedfsmenu button:focus,
.animatedfsmenu button:hover {
    background: #212121 !important;
}

.animatedfsmenu .animatedfsmenu-navbar-toggler {
    background: #212121;
}

.animatedfs_menu_list a,
.afsmenu_search input[type="text"],
.afs-cart-title {
    color: #FFFFFF !important;
}

.animatedfs_menu_list li>a:before,
.animatedfsmenu .animatedfsmenu-navbar-toggler .bar {
    background: #FFFFFF !important;
}

.animatedfsmenu .privacy_policy {
    color: #FFFFFF;
}

.animatedfsmenu .social-media li {
    border-color: #FFFFFF;
}

.animatedfsmenu.animation_background li>a:before,
.animatedfsmenu.animation_background__border_radius li>a:before {
    background: rgba(0,0,0,0.91) !important;
}
</style>

<div id="animatedfsmenu_css"
    class="animatedfsmenu   align_left   animatedfsmenu__opacity  animatedfsmenu__anchor animation_line">
    <div class="animatedfs_background"></div>
    <button
        class="animatedfsmenu-navbar-toggler right_top "
        type="button">
                <div class="bar top"></div>
        <div class="bar bot"></div>
        <div class="bar mid"></div>
            </button>

    <div class="navbar-collapse animatedfs_menu_list">
                <div class="afsmenu_search">
            <form action="https://grungecake.com" autocomplete="off">
                <input id="search" name="s" type="text" placeholder="Search something...">
                <div class="search_submit">
                    <i class="fas fa-search"></i>
                </div>
            </form>
        </div>
        <div class="menu-grungecake-menu-container"><ul id="menu-grungecake-menu" class="afsmenu"><li id="menu-item-75536" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-75536"><a href="https://grungecake.com">Home</a></li>
<li id="menu-item-76770" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-76770"><a href="mailto:assistant@grungecake.com">Contact</a></li>
<li id="menu-item-66675" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-66675"><a href="https://grungecake.com/category/music/premieres">Premieres</a></li>
<li id="menu-item-62328" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62328"><a href="https://grungecake.com/category/recording-academy">Recording Academy</a></li>
<li id="menu-item-61863" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-61863"><a href="https://grungecake.com/category/features/sound-searching-columns/song-of-the-day">Song of the Day</a></li>
<li id="menu-item-53656" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent afs-menu-item-has-children menu-item-53656"><a href="https://grungecake.com/category/music">Music</a>
<ul class="sub-menu">
	<li id="menu-item-56942" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56942"><a href="https://grungecake.com/category/music/music-videos">Music Videos</a></li>
</ul>
</li>
<li id="menu-item-83995" class="menu-item menu-item-type-custom menu-item-object-custom afs-menu-item-has-children menu-item-83995"><a href="#">Beauty</a>
<ul class="sub-menu">
	<li id="menu-item-83996" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-83996"><a href="#">Lip Gloss</a></li>
</ul>
</li>
<li id="menu-item-83992" class="menu-item menu-item-type-custom menu-item-object-custom afs-menu-item-has-children menu-item-83992"><a href="#">Agency</a>
<ul class="sub-menu">
	<li id="menu-item-83994" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-83994"><a href="#">Marketing</a></li>
	<li id="menu-item-83993" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-83993"><a href="#">Publishing</a></li>
	<li id="menu-item-83918" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-83918"><a title="The $100 Ad" href="https://grungecake.com/product/the-100-ad">The $100 Ad</a></li>
</ul>
</li>
<li id="menu-item-83990" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-83990"><a href="#">Magazine</a></li>
<li id="menu-item-83991" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-83991"><a href="#">Merch</a></li>
</ul></div>                <div class="social-media">
            <ul>
                                <li>
                    <a href="https://twitter.com/grungecake" title="Twitter"
                        target="_blank">
                        <i class="fa fa-twitter"></i>
                    </a>
                </li>
                                <li>
                    <a href="https://www.instagram.com/grungecake/?hl=en" title="Instagram"
                        target="_blank">
                        <i class="fa fa-instagram"></i>
                    </a>
                </li>
                            </ul>
        </div>
                
    </div>

</div>

				<style type="text/css">
					@font-face {font-family: "Breve Bold";font-display: auto;font-fallback: ;font-weight: 400;src: url(https://grungecake.com/wp-content/uploads/2019/10/BreveText-Bold.ttf) format('TrueType');} @font-face {font-family: "Breve Book";font-display: auto;font-fallback: ;font-weight: 400;src: url(https://grungecake.com/wp-content/uploads/2019/10/BreveText-Book.ttf) format('TrueType');} @font-face {font-family: "Breve Book Italic";font-display: auto;font-fallback: ;font-weight: 400;src: url(https://grungecake.com/wp-content/uploads/2019/10/BreveText-BookItalic.ttf) format('TrueType');} @font-face {font-family: "Chronicle Text G3 Roman Pro";font-display: auto;font-fallback: ;font-weight: 400;src: url(https://grungecake.com/wp-content/uploads/2020/10/ChronicleText-G3-Roman-Pro.ttf) format('TrueType');} @font-face {font-family: "Displace Serif SemiBold";font-display: auto;font-fallback: ;font-weight: 400;src: url(https://grungecake.com/wp-content/uploads/2021/03/Displace-Serif-SemiBold-Desktop.otf) format('OpenType');} @font-face {font-family: "DM Sans";font-display: auto;font-fallback: ;font-weight: 100;src: url(https://grungecake.com/wp-content/uploads/2021/12/DMSans-Regular.ttf) format('TrueType');} @font-face {font-family: "DM Sans Medium";font-display: auto;font-fallback: ;font-weight: 100;src: url(https://grungecake.com/wp-content/uploads/2021/12/DMSans-Medium.ttf) format('TrueType');} @font-face {font-family: "Druk Wide Medium";font-display: auto;font-fallback: ;font-weight: 400;src: url(https://grungecake.com/wp-content/uploads/2021/03/Druk-Wide-Medium-Desktop.otf) format('OpenType');} @font-face {font-family: "Druk Wide Web Medium Regular";font-display: auto;font-fallback: ;font-weight: 400;src: url(https://grungecake.com/wp-content/uploads/2020/10/Druk-Wide-Web-Medium-Regular.ttf) format('TrueType');} @font-face {font-family: "Graphik Web Bold Regular";font-display: auto;font-fallback: ;font-weight: 400;src: url(https://grungecake.com/wp-content/uploads/2020/10/Graphik-Web-Bold-Regular.ttf) format('TrueType');} @font-face {font-family: "LabGrotesque Black";font-display: auto;font-fallback: ;font-weight: 400;src: url(https://grungecake.com/wp-content/uploads/2019/10/LabGrotesque-Black.ttf) format('TrueType');} @font-face {font-family: "LabGrotesque Bold";font-display: auto;font-fallback: ;font-weight: 400;src: url(https://grungecake.com/wp-content/uploads/2019/10/LabGrotesque-Bold.ttf) format('TrueType');} @font-face {font-family: "Noe Regular";font-display: auto;font-fallback: ;font-weight: 400;src: url(https://grungecake.com/wp-content/uploads/2015/04/NoeText-Regular.ttf) format('TrueType');} @font-face {font-family: "Noe Semibold";font-display: swap;font-fallback: ;font-weight: 400;src: url(https://grungecake.com/wp-content/uploads/2015/04/NoeText-Semibold.ttf) format('TrueType');} @font-face {font-family: "Normalidad Text Regular";font-display: auto;font-fallback: ;font-weight: 400;src: url(https://grungecake.com/wp-content/uploads/2021/03/Normalidad-Text-Regular-Desktop.otf) format('OpenType');} @font-face {font-family: "Public Headline Light";font-display: auto;font-fallback: ;font-weight: 400;src: url(https://grungecake.com/wp-content/uploads/2020/12/PublicoHeadline-Light-Web.ttf) format('TrueType');} @font-face {font-family: "Publico Text Roman";font-display: auto;font-fallback: ;font-weight: 400;src: url(https://grungecake.com/wp-content/uploads/2020/12/PublicoText-Roman-Web.ttf) format('TrueType');}				</style>
				<meta name="generator" content="Site Kit by Google 1.68.0" />		<meta name="jetpack-boost-ready" content="true" />
		<style type='text/css'>img#wpstats{display:none}</style>
		<style>
	@font-face {
		font-family: "bimber";
							src:url("https://grungecake.com/wp-content/themes/bimber/css/8.5/bimber/fonts/bimber.eot");
			src:url("https://grungecake.com/wp-content/themes/bimber/css/8.5/bimber/fonts/bimber.eot?#iefix") format("embedded-opentype"),
			url("https://grungecake.com/wp-content/themes/bimber/css/8.5/bimber/fonts/bimber.woff") format("woff"),
			url("https://grungecake.com/wp-content/themes/bimber/css/8.5/bimber/fonts/bimber.ttf") format("truetype"),
			url("https://grungecake.com/wp-content/themes/bimber/css/8.5/bimber/fonts/bimber.svg#bimber") format("svg");
				font-weight: normal;
		font-style: normal;
		font-display: block;
	}
	</style>
	<meta name="theme-color" content="#212121" />
	<noscript><style>.woocommerce-product-gallery{ opacity: 1 !important; }</style></noscript>
	
<!-- Google AdSense snippet added by Site Kit -->
<meta name="google-adsense-platform-account" content="ca-host-pub-2644536267352236">
<meta name="google-adsense-platform-domain" content="sitekit.withgoogle.com">
<!-- End Google AdSense snippet added by Site Kit -->
		<style type="text/css">
			.recentcomments a {
				display: inline !important;
				padding: 0 !important;
				margin: 0 !important;
			}

			table.recentcommentsavatartop img.avatar, table.recentcommentsavatarend img.avatar {
				border: 0px;
				margin: 0;
			}

			table.recentcommentsavatartop a, table.recentcommentsavatarend a {
				border: 0px !important;
				background-color: transparent !important;
			}

			td.recentcommentsavatarend, td.recentcommentsavatartop {
				padding: 0px 0px 1px 0px;
				margin: 0px;
			}

			td.recentcommentstextend {
				border: none !important;
				padding: 0px 0px 2px 10px;
			}

			.rtl td.recentcommentstextend {
				padding: 0px 10px 2px 0px;
			}

			td.recentcommentstexttop {
				border: none;
				padding: 0px 0px 0px 10px;
			}

			.rtl td.recentcommentstexttop {
				padding: 0px 10px 0px 0px;
			}
		</style>
		<!-- All in one Favicon 4.7 -->
<!-- Google AdSense snippet added by Site Kit -->
<script async="async" src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js?client=ca-pub-7953118887885734" crossorigin="anonymous" type="text/javascript"></script>

<!-- End Google AdSense snippet added by Site Kit -->
<link rel="icon" href="https://grungecake.com/wp-content/uploads/2021/12/cropped-grungecake-logo-yellow-32x32.png" sizes="32x32" />
<link rel="icon" href="https://grungecake.com/wp-content/uploads/2021/12/cropped-grungecake-logo-yellow-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://grungecake.com/wp-content/uploads/2021/12/cropped-grungecake-logo-yellow-180x180.png" />
<meta name="msapplication-TileImage" content="https://grungecake.com/wp-content/uploads/2021/12/cropped-grungecake-logo-yellow-270x270.png" />
	<script>if("undefined"!=typeof localStorage){var nsfwItemId=document.getElementsByName("g1:nsfw-item-id");nsfwItemId=nsfwItemId.length>0?nsfwItemId[0].getAttribute("content"):"g1_nsfw_off",window.g1SwitchNSFW=function(e){e?(localStorage.setItem(nsfwItemId,1),document.documentElement.classList.add("g1-nsfw-off")):(localStorage.removeItem(nsfwItemId),document.documentElement.classList.remove("g1-nsfw-off"))};try{var nsfwmode=localStorage.getItem(nsfwItemId);window.g1SwitchNSFW(nsfwmode)}catch(e){}}</script>
	<link rel="stylesheet" type="text/css" id="wp-custom-css" href="https://grungecake.com/?custom-css=90ff469da7" /><!-- Your Google Analytics Plugin is missing the tracking ID -->

<!-- START - Open Graph and Twitter Card Tags 3.1.2 -->
 <!-- Facebook Open Graph -->
  <meta property="og:locale" content="en_GB"/>
  <meta property="og:site_name" content="GRUNGECAKE"/>
  <meta property="og:title" content="Watch Meek Mill&#039;s new artist Tafia show us how he&#039;s &#039;Been On It&#039;"/>
  <meta property="og:url" content="https://grungecake.com/tafia-been-on-it/articles/86973"/>
  <meta property="og:type" content="article"/>
  <meta property="og:description" content="He isn&#039;t quite like his competitors."/>
  <meta property="og:image" content="https://grungecake.com/wp-content/uploads/2022/02/tafia-been-on-it-grungecake-thumbnail.jpg"/>
  <meta property="og:image:url" content="https://grungecake.com/wp-content/uploads/2022/02/tafia-been-on-it-grungecake-thumbnail.jpg"/>
  <meta property="og:image:secure_url" content="https://grungecake.com/wp-content/uploads/2022/02/tafia-been-on-it-grungecake-thumbnail.jpg"/>
  <meta property="og:image:width" content="1200"/>
  <meta property="og:image:height" content="1200"/>
  <meta property="article:published_time" content="2022-02-25T02:32:20-05:00"/>
  <meta property="article:modified_time" content="2022-02-25T02:41:06-05:00" />
  <meta property="og:updated_time" content="2022-02-25T02:41:06-05:00" />
  <meta property="article:section" content="Music"/>
  <meta property="article:author" content="https://facebook.com/richardinebartee"/>
  <meta property="article:publisher" content="https://facebook.com/grungecake"/>
  <meta property="fb:admins" content="100000686899395"/>
 <!-- Google+ / Schema.org -->
 <!-- Twitter Cards -->
  <meta name="twitter:title" content="Watch Meek Mill&#039;s new artist Tafia show us how he&#039;s &#039;Been On It&#039;"/>
  <meta name="twitter:url" content="https://grungecake.com/tafia-been-on-it/articles/86973"/>
  <meta name="twitter:description" content="He isn&#039;t quite like his competitors."/>
  <meta name="twitter:image" content="https://grungecake.com/wp-content/uploads/2022/02/tafia-been-on-it-grungecake-thumbnail.jpg"/>
  <meta name="twitter:card" content="summary_large_image"/>
  <meta name="twitter:site" content="@grungecake"/>
 <!-- SEO -->
  <link rel="canonical" href="https://grungecake.com/tafia-been-on-it/articles/86973"/>
  <meta name="description" content="He isn&#039;t quite like his competitors."/>
  <meta name="author" content="Richardine Bartee"/>
  <meta name="publisher" content="GRUNGECAKE"/>
 <!-- Misc. tags -->
 <!-- is_singular -->
<!-- END - Open Graph and Twitter Card Tags 3.1.2 -->
	
<script>(function(){this._N2=this._N2||{_r:[],_d:[],r:function(){this._r.push(arguments)},d:function(){this._d.push(arguments)}}}).call(window);!function(a){a.indexOf("Safari")>0&&-1===a.indexOf("Chrome")&&document.documentElement.style.setProperty("--ss-safari-fix-225962","1px")}(navigator.userAgent);</script><script src="https://grungecake.com/wp-content/plugins/smart-slider-3/Public/SmartSlider3/Application/Frontend/Assets/dist/n2.min.js?ver=5023544a" defer async></script>
<script src="https://grungecake.com/wp-content/plugins/smart-slider-3/Public/SmartSlider3/Application/Frontend/Assets/dist/smartslider-frontend.min.js?ver=5023544a" defer async></script>
<script src="https://grungecake.com/wp-content/plugins/smart-slider-3/Public/SmartSlider3/Slider/SliderType/Block/Assets/dist/ss-block.min.js?ver=5023544a" defer async></script>
<script>_N2.r('documentReady',function(){_N2.r(["documentReady","smartslider-frontend","ss-block","SmartSliderWidget"],function(){new _N2.SmartSliderBlock('n2-ss-2',{"admin":false,"callbacks":"","background.video.mobile":1,"loadingTime":2000,"alias":{"id":0,"smoothScroll":0,"slideSwitch":0,"scroll":1},"align":"normal","isDelayed":0,"responsive":{"mediaQueries":{"all":false,"desktopportrait":["(min-width: 1200px)"],"tabletportrait":["(orientation: landscape) and (max-width: 1199px) and (min-width: 901px)","(orientation: portrait) and (max-width: 1199px) and (min-width: 701px)"],"mobileportrait":["(orientation: landscape) and (max-width: 900px)","(orientation: portrait) and (max-width: 700px)"]},"base":{"slideOuterWidth":1200,"slideOuterHeight":700,"sliderWidth":1200,"sliderHeight":700,"slideWidth":1200,"slideHeight":700},"hideOn":{"desktopLandscape":false,"desktopPortrait":false,"tabletLandscape":false,"tabletPortrait":false,"mobileLandscape":false,"mobilePortrait":false},"onResizeEnabled":true,"type":"fullwidth","sliderHeightBasedOn":"real","focusUser":1,"focusEdge":"auto","breakpoints":[{"device":"tabletPortrait","type":"max-screen-width","portraitWidth":1199,"landscapeWidth":1199},{"device":"mobilePortrait","type":"max-screen-width","portraitWidth":700,"landscapeWidth":900}],"enabledDevices":{"desktopLandscape":0,"desktopPortrait":1,"tabletLandscape":0,"tabletPortrait":1,"mobileLandscape":0,"mobilePortrait":1},"sizes":{"desktopPortrait":{"width":1200,"height":700,"max":3000,"min":1200},"tabletPortrait":{"width":701,"height":408,"customHeight":false,"max":1199,"min":701},"mobilePortrait":{"width":320,"height":186,"customHeight":false,"max":900,"min":320}},"overflowHiddenPage":0,"focus":{"offsetTop":"#wpadminbar","offsetBottom":""}},"controls":{"mousewheel":0,"touch":0,"keyboard":0,"blockCarouselInteraction":1},"playWhenVisible":1,"playWhenVisibleAt":0.5,"lazyLoad":0,"lazyLoadNeighbor":0,"blockrightclick":0,"maintainSession":0,"autoplay":{"enabled":0,"start":0,"duration":8000,"autoplayLoop":1,"allowReStart":0,"pause":{"click":1,"mouse":"enter","mediaStarted":1},"resume":{"click":0,"mouse":0,"mediaEnded":1,"slidechanged":0},"interval":1,"intervalModifier":"loop","intervalSlide":"current"},"perspective":1500,"layerMode":{"playOnce":0,"playFirstLayer":1,"mode":"skippable","inAnimation":"mainInEnd"},"initCallbacks":function(){new _N2.SmartSliderWidget(this,'shadow','.nextend-shadow')}})})});</script></head>

<body class="post-template-default single single-post postid-86973 single-format-standard wp-embed-responsive theme-bimber woocommerce-demo-store woocommerce-no-js g1-layout-boxed g1-hoverable g1-has-mobile-logo g1-sidebar-normal essb-7.4 aa-prefix-grung-" itemscope="&quot;&quot;" itemtype="http://schema.org/WebPage" >

<div class="g1-body-inner">

	<div id="page">
		

		

					<div class="g1-row g1-row-layout-page g1-hb-row g1-hb-row-normal g1-hb-row-a g1-hb-row-1 g1-hb-full g1-hb-sticky-off g1-hb-shadow-off">
			<div class="g1-row-inner">
				<div class="g1-column g1-dropable">
											<div class="g1-bin-1 g1-bin-grow-off">
							<div class="g1-bin g1-bin-align-left">
															</div>
						</div>
											<div class="g1-bin-2 g1-bin-grow-off">
							<div class="g1-bin g1-bin-align-center">
																	<div class="g1-hb-search-form g1-form-s  ">
	

<div role="search" class="search-form-wrapper">
	<form method="get"
	      class="g1-searchform-tpl-default g1-searchform-ajax search-form"
	      action="https://grungecake.com/">
		<label>
			<span class="screen-reader-text">Search for:</span>
			<input type="search" class="search-field"
			       placeholder="Search"
			       value="" name="s"
			       title="Search for:" />
		</label>
		<button class="search-submit">Search</button>
	</form>

			<div class="g1-searches g1-searches-ajax"></div>
	</div>
</div>
															</div>
						</div>
											<div class="g1-bin-3 g1-bin-grow-off">
							<div class="g1-bin g1-bin-align-right">
															</div>
						</div>
									</div>
			</div>
			<div class="g1-row-background"></div>
		</div>
				<div class="g1-sticky-top-wrapper g1-hb-row-2">
				<div class="g1-row g1-row-layout-page g1-hb-row g1-hb-row-normal g1-hb-row-b g1-hb-row-2 g1-hb-full g1-hb-sticky-on g1-hb-shadow-on">
			<div class="g1-row-inner">
				<div class="g1-column g1-dropable">
											<div class="g1-bin-1 g1-bin-grow-on">
							<div class="g1-bin g1-bin-align-left">
																	<div class="g1-id g1-id-desktop">
			<p class="g1-mega g1-mega-1st site-title">
	
			<a class="g1-logo-wrapper"
			   href="https://grungecake.com/" rel="home">
									<picture class="g1-logo g1-logo-default">
						<source media="(min-width: 1025px)" srcset="https://grungecake.com/wp-content/uploads/2021/12/grungecake-logo-apple-news-branding-yellow.png 2x,https://grungecake.com/wp-content/uploads/2021/12/grungecake-logo-apple-news-branding-yellow.png 1x">
						<img
							src="https://grungecake.com/wp-content/uploads/2021/12/grungecake-logo-apple-news-branding-yellow.png"
							width="550"
							height="100"
							alt="GRUNGECAKE" />
					</picture>

											<picture class="g1-logo g1-logo-inverted">
							<source id="g1-logo-inverted-source" media="(min-width: 1025px)" srcset="https://grungecake.com/wp-content/uploads/2021/06/grungecake-logo-type-black.png 2x,https://grungecake.com/wp-content/uploads/2021/06/grungecake-logo-type-black.png 1x" data-srcset="https://grungecake.com/wp-content/uploads/2021/06/grungecake-logo-type-black.png">
							<img
								id="g1-logo-inverted-img"
								class=""
								src="https://grungecake.com/wp-content/uploads/2021/06/grungecake-logo-type-black.png"
								data-src=""
								width="550"
								height="100"
								alt="" />
						</picture>
												</a>

			
			</p>
	
	</div>															</div>
						</div>
											<div class="g1-bin-2 g1-bin-grow-off">
							<div class="g1-bin g1-bin-align-center">
															</div>
						</div>
											<div class="g1-bin-3 g1-bin-grow-off">
							<div class="g1-bin g1-bin-align-right">
															</div>
						</div>
									</div>
			</div>
			<div class="g1-row-background"></div>
		</div>
				</div>
				<div class="g1-row g1-row-layout-page g1-hb-row g1-hb-row-normal g1-hb-row-c g1-hb-row-3 g1-hb-full g1-hb-sticky-off g1-hb-shadow-off">
			<div class="g1-row-inner">
				<div class="g1-column g1-dropable">
											<div class="g1-bin-1 g1-bin-grow-off">
							<div class="g1-bin g1-bin-align-left">
															</div>
						</div>
											<div class="g1-bin-2 g1-bin-grow-off">
							<div class="g1-bin g1-bin-align-center">
															</div>
						</div>
											<div class="g1-bin-3 g1-bin-grow-off">
							<div class="g1-bin g1-bin-align-right">
															</div>
						</div>
									</div>
			</div>
			<div class="g1-row-background"></div>
		</div>
					<div class="g1-sticky-top-wrapper g1-hb-row-1">
				<div class="g1-row g1-row-layout-page g1-hb-row g1-hb-row-mobile g1-hb-row-a g1-hb-row-1 g1-hb-boxed g1-hb-sticky-on g1-hb-shadow-off">
			<div class="g1-row-inner">
				<div class="g1-column g1-dropable">
											<div class="g1-bin-1 g1-bin-grow-off">
							<div class="g1-bin g1-bin-align-left">
															</div>
						</div>
											<div class="g1-bin-2 g1-bin-grow-off">
							<div class="g1-bin g1-bin-align-center">
															</div>
						</div>
											<div class="g1-bin-3 g1-bin-grow-off">
							<div class="g1-bin g1-bin-align-right">
															</div>
						</div>
									</div>
			</div>
			<div class="g1-row-background"></div>
		</div>
			<div class="g1-row g1-row-layout-page g1-hb-row g1-hb-row-mobile g1-hb-row-b g1-hb-row-2 g1-hb-boxed g1-hb-sticky-on g1-hb-shadow-off">
			<div class="g1-row-inner">
				<div class="g1-column g1-dropable">
											<div class="g1-bin-1 g1-bin-grow-off">
							<div class="g1-bin g1-bin-align-left">
															</div>
						</div>
											<div class="g1-bin-2 g1-bin-grow-on">
							<div class="g1-bin g1-bin-align-center">
																	<div class="g1-id g1-id-mobile">
			<p class="g1-mega g1-mega-1st site-title">
	
		<a class="g1-logo-wrapper"
		   href="https://grungecake.com/" rel="home">
							<picture class="g1-logo g1-logo-default">
					<source media="(max-width: 1024px)" srcset="https://grungecake.com/wp-content/uploads/2021/12/grungecake-logo-apple-news-branding-yellow.png 2x,https://grungecake.com/wp-content/uploads/2021/12/grungecake-logo-apple-news-branding-yellow.png 1x">
					<img
						src="https://grungecake.com/wp-content/uploads/2021/12/grungecake-logo-apple-news-branding-yellow.png"
						width="300"
						height="100"
						alt="GRUNGECAKE" />
				</picture>

									<picture class="g1-logo g1-logo-inverted">
						<source id="g1-logo-mobile-inverted-source" media="(max-width: 1024px)" srcset="https://grungecake.com/wp-content/uploads/2021/06/grungecake-logo-type-black.png 2x,https://grungecake.com/wp-content/uploads/2021/06/grungecake-logo-type-black.png 1x" data-srcset="https://grungecake.com/wp-content/uploads/2021/06/grungecake-logo-type-black.png">
						<img
							id="g1-logo-mobile-inverted-img"
							class=""
							src="https://grungecake.com/wp-content/uploads/2021/06/grungecake-logo-type-black.png"
							data-src=""
							width="300"
							height="100"
							alt="" />
					</picture>
									</a>

		
			</p>
	
	</div>															</div>
						</div>
											<div class="g1-bin-3 g1-bin-grow-off">
							<div class="g1-bin g1-bin-align-right">
															</div>
						</div>
									</div>
			</div>
			<div class="g1-row-background"></div>
		</div>
				</div>
				<div class="g1-row g1-row-layout-page g1-hb-row g1-hb-row-mobile g1-hb-row-c g1-hb-row-3 g1-hb-boxed g1-hb-sticky-off g1-hb-shadow-off">
			<div class="g1-row-inner">
				<div class="g1-column g1-dropable">
											<div class="g1-bin-1 g1-bin-grow-off">
							<div class="g1-bin g1-bin-align-left">
															</div>
						</div>
											<div class="g1-bin-2 g1-bin-grow-off">
							<div class="g1-bin g1-bin-align-center">
															</div>
						</div>
											<div class="g1-bin-3 g1-bin-grow-off">
							<div class="g1-bin g1-bin-align-right">
															</div>
						</div>
									</div>
			</div>
			<div class="g1-row-background"></div>
		</div>
	
		
				
		<div><ss3-force-full-width data-overflow-x="body" data-horizontal-selector="body"><div class="n2-section-smartslider fitvidsignore " data-ssid="2" tabindex="0" role="region" aria-label="Slider"><div class="n2-ss-margin" style="margin: 5px 5px 5px 5px;"><div id="n2-ss-2-align" class="n2-ss-align"><div class="n2-padding"><div id="n2-ss-2" data-creator="Smart Slider 3" data-responsive="fullwidth" class="n2-ss-slider n2-ow n2-has-hover n2notransition  "><div class="n2-ss-slider-wrapper-outside" style="grid-template-rows:1fr auto">
        <div class="n2-ss-slider-1 n2-ow" style="">
            <div class="n2-ss-slider-2 n2-ow">
                <div class="n2-ss-slide-backgrounds n2-ow-all"><div class="n2-ss-slide-background" data-public-id="1" data-mode="fill"><div data-color="RGBA(33,33,33,1)" style="background-color: RGBA(33,33,33,1);" class="n2-ss-slide-background-color"></div></div></div>                <div class="n2-ss-slider-3 n2-ow">
                    <svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 1200 700" data-related-device="desktopPortrait" class="n2-ow n2-ss-preserve-size n2-ss-preserve-size--slider n2-ss-slide-limiter"></svg><div data-first="1" data-slide-duration="0" data-id="3" data-slide-public-id="1" data-title="Olamide" data-haslink="1" onclick="" data-href="https://grungecake.com/olamide-interview/articles/79414" tabindex="0" role="button" data-n2click="url" data-force-pointer="" class="n2-ss-slide n2-ow  n2-ss-slide-3"><div role="note" class="n2-ss-slide--focus">Olamide</div><div class="n2-ss-layers-container n2-ss-slide-limiter n2-ow"><div class="n2-ss-layer n2-ow n-uc-48dyrtPVN6eF" data-sstype="slide" data-pm="default"><div class="n2-ss-layer n2-ow n-uc-115ebbdb3da08" data-pm="default" data-sstype="content" data-hasbackground="0"><div class="n2-ss-section-main-content n2-ss-layer-with-background n2-ss-layer-content n2-ow n-uc-115ebbdb3da08-inner"><div class="n2-ss-layer n2-ow n2-ss-layer--block n2-ss-has-self-align n-uc-19b000265ba67" data-pm="normal" data-sstype="row"><div class="n2-ss-layer-row n2-ss-layer-with-background n-uc-19b000265ba67-inner"><div class="n2-ss-layer-row-inner "><div class="n2-ss-layer n2-ow n-uc-1dc66901c7568" data-pm="default" data-sstype="col"><div class="n2-ss-layer-col n2-ss-layer-with-background n2-ss-layer-content n-uc-1dc66901c7568-inner"><div class="n2-ss-layer n2-ow n-uc-ikMr4aVsaSKd" data-pm="normal" data-sstype="layer"><div id="n2-ss-2item1" class="  n2-ss-item-content n2-ss-text n2-ow" style="display:block;"><a class="n2-ow n2-font-001d588a70a4315cc898a2ad9614317e-hover " style="display:block;" target="_top" href="https://grungecake.com/olamide-interview/articles/79414">Nigeria’s Olamide on breaking through in America, Afrorap, and his new album: UY Scuti (Interview)<br></a></div></div><div class="n2-ss-layer n2-ow n-uc-tiXixacIhR1v" data-pm="normal" data-sstype="layer"><div class="n2-ss-item-content n2-ss-text n2-ow-all"><div class=""><p class="n2-font-6d29f9f5c1a74589c43d57bd714d404b-paragraph   ">An in-person conversation with one of the world's greatest African artists, Olamide</p>
</div></div></div><div class="n2-ss-layer n2-ow n-uc-jjenuk9ULa4i" data-pm="normal" data-sstype="layer"><div class="n2-ss-button-container n2-ss-item-content n2-ow n2-font-b40c7a22e460eec854893742996f57cf-link  n2-ss-nowrap"><a class="n2-style-e4f3e7bec5d830ff851d237d79600df2-heading  n2-ow " href="https://grungecake.com/olamide-interview/articles/79414"><div><div>Read feature</div></div></a></div></div></div></div><div class="n2-ss-layer n2-ow n-uc-175bbf541cda5" data-pm="default" data-sstype="col"><div class="n2-ss-layer-col n2-ss-layer-with-background n2-ss-layer-content n-uc-175bbf541cda5-inner"><div class="n2-ss-layer n2-ow n-uc-2UR4TmQsf0mm" data-pm="normal" data-sstype="layer"><div class=" n2-ss-item-image-content n2-ss-item-content n2-ow-all"><img id="n2-ss-2item4" alt="" class="skip-lazy jetpack-lazy-image" width="1000" height="670" data-skip-lazy="1" src="https://i0.wp.com/grungecake.com/wp-content/uploads/2021/07/olamide-richardine-grungecake-nyc-thumbnail-03-scaled.jpg?resize=1000%2C670" data-recalc-dims="1" /></div></div></div></div></div></div></div><div class="n2-ss-layer n2-ow n-uc-WfieCc6gzLc4" data-pm="normal" data-sstype="layer"><div id="n2-ss-2item5" class="n2-font-577e3e94d392c80545fffaf7623e9404-hover   n2-ss-item-content n2-ss-text n2-ow" style="display:block;"></div></div><div class="n2-ss-layer n2-ow n2-ss-layer--block n2-ss-has-self-align n-uc-12d30399ac36d" data-pm="normal" data-sstype="row"><div class="n2-ss-layer-row n2-ss-layer-with-background n-uc-12d30399ac36d-inner"><div class="n2-ss-layer-row-inner "><div class="n2-ss-layer n2-ow n-uc-1baa4fd62c8c4" data-pm="default" data-sstype="col"><div class="n2-ss-layer-col n2-ss-layer-with-background n2-ss-layer-content n-uc-1baa4fd62c8c4-inner"></div></div><div class="n2-ss-layer n2-ow n-uc-157c1b6ac2ae4" data-pm="default" data-sstype="col"><div class="n2-ss-layer-col n2-ss-layer-with-background n2-ss-layer-content n-uc-157c1b6ac2ae4-inner"></div></div></div></div></div></div></div></div></div></div>                </div>
                            </div>
        </div>
        <div class="n2-ss-slider-controls n2-ss-slider-controls-below"><div class="n2-ss-widget nextend-shadow n2-ow-all" data-hide-desktopportrait="1" data-hide-tabletportrait="1" data-hide-mobileportrait="1"><img width="1000" height="45" style="display: block; width:100%;max-width:none;" class="nextend-shadow-image skip-lazy jetpack-lazy-image" loading="lazy" data-skip-lazy="1" src="https://i0.wp.com/grungecake.com/wp-content/plugins/smart-slider-3/Public/SmartSlider3/Widget/Shadow/ShadowImage/Assets/shadow/dark.png?resize=1000%2C45&#038;ssl=1" alt="Shadow" data-recalc-dims="1"></div></div></div></div><ss3-loader></ss3-loader></div></div><div class="n2_clear"></div></div></div></ss3-force-full-width></div>		

		

	
	<div class="g1-row g1-row-padding-m g1-row-layout-page">
		<div class="g1-row-background">
		</div>
		<div class="g1-row-inner">

			<div class="g1-column g1-column-2of3" id="primary">
				<div id="content" role="main">

					
<span class="bimber-url-waypoint" data-bimber-post-title="Watch Meek Mill&#8217;s new artist Tafia show us how he&#8217;s &#8216;Been On It&#8217;" data-bimber-post-url="https://grungecake.com/tafia-been-on-it/articles/86973"></span>
<article id="post-86973" class="entry-tpl-classic-v2 post-86973 post type-post status-publish format-standard has-post-thumbnail category-music tag-been-on-it tag-tafia" itemscope="" itemtype="http://schema.org/Article">
	<div class="entry-inner">
		
		<header class="entry-header entry-header-02">
			<div class="entry-before-title">
				
								</div>

			<h1 class="g1-mega g1-mega-1st entry-title" itemprop="headline">Watch Meek Mill&#8217;s new artist Tafia show us how he&#8217;s &#8216;Been On It&#8217;</h1>
			
							<p class="g1-meta g1-meta-m entry-meta entry-meta-m">
					<span class="entry-byline entry-byline-m ">
										<span class="entry-author" itemscope="" itemprop="author" itemtype="http://schema.org/Person">
	
		<span class="entry-meta-label">by</span>
			<a href="https://grungecake.com/author/richardine" title="Posts by Richardine Bartee" rel="author">
			
							<strong itemprop="name">Richardine Bartee</strong>
					</a>
	</span>
	
							<time class="entry-date" datetime="2022-02-25T02:32:20-05:00" itemprop="datePublished">25th February 2022, 2:32 AM</time>					</span>

					<span class="entry-stats entry-stats-m">

						
						
						
											</span>
				</p>
					</header>

		<div class="g1-wrapper-with-stickies">
			<div class="entry-essentials">
				
				<div class="entry-content g1-typography-xl" itemprop="articleBody">
					<div class="essb_links essb_counters essb_displayed_float essb_share essb_content_responsive essb_template_dark-retina essb_479123479 essb_size_xs essb_links_center essb_icon_animation11 print-no" id="essb_displayed_float_479123479" data-essb-postid="86973" data-essb-position="float" data-essb-button-style="button" data-essb-template="dark-retina" data-essb-counter-pos="hidden" data-essb-url="https://grungecake.com/tafia-been-on-it/articles/86973" data-essb-fullurl="https://grungecake.com/tafia-been-on-it/articles/86973" data-essb-instance="479123479"><ul class="essb_links_list"><li class="essb_item essb_totalcount_item" style="display: none !important;" style="display: none !important;" data-counter-pos="hidden"><span class="essb_totalcount essb_t_l" title="Total"><span class="essb_t_nb"></span></span></li><li class="essb_item essb_link_facebook nolightbox"> <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwp.me%2FpdkbZN-mCN&amp;t=Watch+Meek+Mill%5C%26%23039%3Bs+new+artist+Tafia+show+us+how+he%5C%26%23039%3Bs+%5C%26%23039%3BBeen+On+It%5C%26%23039%3B" title="Share on Facebook" onclick="essb.window(&#039;https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwp.me%2FpdkbZN-mCN&amp;t=Watch+Meek+Mill%5C%26%23039%3Bs+new+artist+Tafia+show+us+how+he%5C%26%23039%3Bs+%5C%26%23039%3BBeen+On+It%5C%26%23039%3B&#039;,&#039;facebook&#039;,&#039;479123479&#039;); return false;" target="_blank" rel="nofollow noopener" class="nolightbox"><span class="essb_icon essb_icon_facebook"></span><span class="essb_network_name">Facebook</span></a></li><li class="essb_item essb_link_twitter nolightbox"> <a href="#" title="Share on Twitter" onclick="essb.window(&#39;https://twitter.com/intent/tweet?text=Watch%20Meek%20Mill%27s%20new%20artist%20Tafia%20show%20us%20how%20he%27s%20%27Been%20On%20It%27&amp;url=https%3A%2F%2Fwp.me%2FpdkbZN-mCN&amp;counturl=https%3A%2F%2Fgrungecake.com%2Ftafia-been-on-it%2Farticles%2F86973&#39;,&#39;twitter&#39;,&#39;479123479&#39;); return false;" target="_blank" rel="nofollow" class="nolightbox" ><span class="essb_icon essb_icon_twitter"></span><span class="essb_network_name">Twitter</span></a></li><li class="essb_item essb_link_mail nolightbox"> <a href="#" title="Share on Email" onclick="essb_open_mailform(&#39;479123479&#39;); return false;" target="_blank" rel="nofollow" class="nolightbox" ><span class="essb_icon essb_icon_mail"></span><span class="essb_network_name">Email</span></a></li><li class="essb_item essb_link_linkedin nolightbox"> <a href="https://www.linkedin.com/shareArticle?mini=true&amp;ro=true&amp;trk=EasySocialShareButtons&amp;title=Watch+Meek+Mill%5C%26%23039%3Bs+new+artist+Tafia+show+us+how+he%5C%26%23039%3Bs+%5C%26%23039%3BBeen+On+It%5C%26%23039%3B&amp;url=https%3A%2F%2Fwp.me%2FpdkbZN-mCN" title="Share on LinkedIn" onclick="essb.window(&#039;https://www.linkedin.com/shareArticle?mini=true&amp;ro=true&amp;trk=EasySocialShareButtons&amp;title=Watch+Meek+Mill%5C%26%23039%3Bs+new+artist+Tafia+show+us+how+he%5C%26%23039%3Bs+%5C%26%23039%3BBeen+On+It%5C%26%23039%3B&amp;url=https%3A%2F%2Fwp.me%2FpdkbZN-mCN&#039;,&#039;linkedin&#039;,&#039;479123479&#039;); return false;" target="_blank" rel="nofollow noopener" class="nolightbox"><span class="essb_icon essb_icon_linkedin"></span><span class="essb_network_name">LinkedIn</span></a></li><li class="essb_item essb_link_whatsapp nolightbox"> <a href="whatsapp://send?text=Watch%20Meek%20Mill%27s%20new%20artist%20Tafia%20show%20us%20how%20he%27s%20%27Been%20On%20It%27%20https://wp.me/pdkbZN-mCN" title="Share on WhatsApp" onclick="essb.tracking_only(&#039;&#039;, &#039;whatsapp&#039;, &#039;479123479&#039;, true);" target="_blank" rel="nofollow" class="nolightbox"><span class="essb_icon essb_icon_whatsapp"></span><span class="essb_network_name">WhatsApp</span></a></li></ul><div class="essb_native_buttons essb_native_after_share"><ul class="essb_links"></ul></div></div><figure id="attachment_86975" aria-describedby="caption-attachment-86975" class="wp-caption aligncenter"><img data-attachment-id="86975" data-permalink="https://grungecake.com/tafia-been-on-it/articles/86973/tafia-been-on-it-grungecake-thumbnail" data-orig-file="https://grungecake.com/wp-content/uploads/2022/02/tafia-been-on-it-grungecake-thumbnail.jpg" data-orig-size="1200,1200" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="tafia-been-on-it-grungecake-thumbnail" data-image-description="" data-image-caption="&lt;p&gt;Photo: Courtesy of the publicist&lt;/p&gt;
" data-medium-file="https://grungecake.com/wp-content/uploads/2022/02/tafia-been-on-it-grungecake-thumbnail-300x300.jpg" data-large-file="https://grungecake.com/wp-content/uploads/2022/02/tafia-been-on-it-grungecake-thumbnail-1024x1024.jpg" src="https://grungecake.com/wp-content/uploads/2022/02/tafia-been-on-it-grungecake-thumbnail.jpg" alt="" width="1200" height="1200" class="size-full wp-image-86975" srcset="https://grungecake.com/wp-content/uploads/2022/02/tafia-been-on-it-grungecake-thumbnail.jpg 1200w, https://grungecake.com/wp-content/uploads/2022/02/tafia-been-on-it-grungecake-thumbnail-300x300.jpg 300w, https://grungecake.com/wp-content/uploads/2022/02/tafia-been-on-it-grungecake-thumbnail-1024x1024.jpg 1024w, https://grungecake.com/wp-content/uploads/2022/02/tafia-been-on-it-grungecake-thumbnail-290x290.jpg?crop=1 290w, https://grungecake.com/wp-content/uploads/2022/02/tafia-been-on-it-grungecake-thumbnail-192x192.jpg?crop=1 192w, https://grungecake.com/wp-content/uploads/2022/02/tafia-been-on-it-grungecake-thumbnail-384x384.jpg?crop=1 384w, https://grungecake.com/wp-content/uploads/2022/02/tafia-been-on-it-grungecake-thumbnail-110x110.jpg?crop=1 110w, https://grungecake.com/wp-content/uploads/2022/02/tafia-been-on-it-grungecake-thumbnail-220x220.jpg?crop=1 220w, https://grungecake.com/wp-content/uploads/2022/02/tafia-been-on-it-grungecake-thumbnail-561x561.jpg 561w, https://grungecake.com/wp-content/uploads/2022/02/tafia-been-on-it-grungecake-thumbnail-1122x1122.jpg 1122w, https://grungecake.com/wp-content/uploads/2022/02/tafia-been-on-it-grungecake-thumbnail-364x364.jpg 364w, https://grungecake.com/wp-content/uploads/2022/02/tafia-been-on-it-grungecake-thumbnail-728x728.jpg 728w, https://grungecake.com/wp-content/uploads/2022/02/tafia-been-on-it-grungecake-thumbnail-608x608.jpg 608w, https://grungecake.com/wp-content/uploads/2022/02/tafia-been-on-it-grungecake-thumbnail-758x758.jpg 758w, https://grungecake.com/wp-content/uploads/2022/02/tafia-been-on-it-grungecake-thumbnail-1152x1152.jpg 1152w, https://grungecake.com/wp-content/uploads/2022/02/tafia-been-on-it-grungecake-thumbnail-370x370.jpg?crop=1 370w, https://grungecake.com/wp-content/uploads/2022/02/tafia-been-on-it-grungecake-thumbnail-550x550.jpg 550w, https://grungecake.com/wp-content/uploads/2022/02/tafia-been-on-it-grungecake-thumbnail-100x100.jpg?crop=1 100w, https://grungecake.com/wp-content/uploads/2022/02/tafia-been-on-it-grungecake-thumbnail-50x50.jpg?crop=1 50w" sizes="(max-width: 1200px) 100vw, 1200px" /><figcaption id="caption-attachment-86975" class="wp-caption-text">Photo: Courtesy of the publicist</figcaption></figure>
<p>Are you a die-hard fan of Rap music? Then, you may have heard in 2019 that <a href="https://grungecake.com/meek-mill-blue-notes-2-lil-uzi-vert/articles/81851" target="_blank" rel="noopener">Meek Mill</a>&#8216;s record label made a <a href="https://www.rollingstone.com/pro/news/jay-z-meek-mill-roc-nation-dream-chasers-862692" target="_blank" rel="noopener">deal with Roc Nation</a>. <a href="https://www.instagram.com/tafia_official" target="_blank" rel="noopener">Tafia</a>, the Haitian-American artist who taught himself how to rap during a seven-year bid in federal prison, hails from the Northside of Miami, Florida. He isn&#8217;t quite like his competitors. In his hometown, he met Meek Mill on a yacht. They rode jet skis to meet him, and the rest is history.  </p>
<p>Tafia&#8217;s forthcoming project, &#8216;Mention My Name&#8217;, will be the first one to release under the new Dream Chaser Records (Roc Nation). The mixtape features the late Young Dolph, Vory, Jeremih, Nigeria&#8217;s Davido and Rob49. Check out the official video for the release below to watch the young artist riding around the hood in a foreign.</p>
<p><iframe loading="lazy" width="100%" height="315" src="https://www.youtube.com/embed/cNJiK_pRTH8" title="YouTube video player" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></p>
<hr />
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-86973" class="share-twitter sd-button no-icon" href="https://grungecake.com/tafia-been-on-it/articles/86973?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-86973" class="share-facebook sd-button no-icon" href="https://grungecake.com/tafia-been-on-it/articles/86973?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-linkedin"><a rel="nofollow noopener noreferrer" data-shared="sharing-linkedin-86973" class="share-linkedin sd-button no-icon" href="https://grungecake.com/tafia-been-on-it/articles/86973?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span>LinkedIn</span></a></li><li><a href="#" class="sharing-anchor sd-button share-more"><span>More</span></a></li><li class="share-end"></li></ul><div class="sharing-hidden"><div class="inner" style="display: none;"><ul><li class="share-tumblr"><a rel="nofollow noopener noreferrer" data-shared="" class="share-tumblr sd-button no-icon" href="https://grungecake.com/tafia-been-on-it/articles/86973?share=tumblr" target="_blank" title="Click to share on Tumblr"><span>Tumblr</span></a></li><li class="share-email"><a rel="nofollow noopener noreferrer" data-shared="" class="share-email sd-button no-icon" href="https://grungecake.com/tafia-been-on-it/articles/86973?share=email" target="_blank" title="Click to email this to a friend"><span>Email</span></a></li><li class="share-end"></li><li class="share-jetpack-whatsapp"><a rel="nofollow noopener noreferrer" data-shared="" class="share-jetpack-whatsapp sd-button no-icon" href="https://grungecake.com/tafia-been-on-it/articles/86973?share=jetpack-whatsapp" target="_blank" title="Click to share on WhatsApp"><span>WhatsApp</span></a></li><li class="share-print"><a rel="nofollow noopener noreferrer" data-shared="" class="share-print sd-button no-icon" href="https://grungecake.com/tafia-been-on-it/articles/86973#print" target="_blank" title="Click to print"><span>Print</span></a></li><li class="share-end"></li><li class="share-reddit"><a rel="nofollow noopener noreferrer" data-shared="" class="share-reddit sd-button no-icon" href="https://grungecake.com/tafia-been-on-it/articles/86973?share=reddit" target="_blank" title="Click to share on Reddit"><span>Reddit</span></a></li><li class="share-telegram"><a rel="nofollow noopener noreferrer" data-shared="" class="share-telegram sd-button no-icon" href="https://grungecake.com/tafia-been-on-it/articles/86973?share=telegram" target="_blank" title="Click to share on Telegram"><span>Telegram</span></a></li><li class="share-end"></li><li class="share-skype"><a rel="nofollow noopener noreferrer" data-shared="sharing-skype-86973" class="share-skype sd-button no-icon" href="https://grungecake.com/tafia-been-on-it/articles/86973?share=skype" target="_blank" title="Click to share on Skype"><span>Skype</span></a></li><li class="share-pinterest"><a rel="nofollow noopener noreferrer" data-shared="sharing-pinterest-86973" class="share-pinterest sd-button no-icon" href="https://grungecake.com/tafia-been-on-it/articles/86973?share=pinterest" target="_blank" title="Click to share on Pinterest"><span>Pinterest</span></a></li><li class="share-end"></li><li class="share-pocket"><a rel="nofollow noopener noreferrer" data-shared="" class="share-pocket sd-button no-icon" href="https://grungecake.com/tafia-been-on-it/articles/86973?share=pocket" target="_blank" title="Click to share on Pocket"><span>Pocket</span></a></li><li class="share-end"></li></ul></div></div></div></div></div>
<div id='jp-relatedposts' class='jp-relatedposts' >
	<h3 class="jp-relatedposts-headline"><em>Must-Read Articles</em></h3>
</div>				</div>
			</div>

			<div class="entry-actions">
							</div>
		</div>
	</div><!-- .todo -->

	<div class="entry-after-content">
			<section class="g1-row author-info" itemscope="" itemtype="http://schema.org/Person">
		<div class="g1-row-inner author-info-inner">
			<div class="g1-column author-overview">

				<figure class="author-avatar">
					<a href="https://grungecake.com/author/richardine">
						<img alt='' src='https://grungecake.com/wp-content/uploads/2022/01/richardine-bartee-2022-grungecake-ceo-80x80.jpg' srcset='https://grungecake.com/wp-content/uploads/2022/01/richardine-bartee-2022-grungecake-ceo-160x160.jpg 2x' class='avatar avatar-80 photo' height='80' width='80' loading='lazy'/>
					</a>
				</figure>

				<header>
										<h2 class="g1-gamma g1-gamma-1st author-title">Written by <a href="https://grungecake.com/author/richardine"><span itemprop="name">Richardine Bartee</span></a></h2>

									</header>

								<div itemprop="description" class="author-bio">
					<p>Her unprejudiced love for people, the arts, and business have taken her this far. Join Richardine on her journey as she writes history into existence, one article at a time. Richardine is a member of the Recording Academy/GRAMMYs, and a GRAMMY U Mentor. She is the Press Agent for <a href="https://smadelounge.co.uk">SMADE</a>/<a href="https://afronation.com">AFRO NATION FOUNDER</a>; Director of Content for <a href="https://www.dukeconcept.com">Duke Concept</a>; Follow her on <a href="https://instagram.com/richardinebartee">Instagram</a> and <a href="https://twitter.com/theyams">Twitter</a>.</p>
				</div>
				
				<div class="author-extras">
					<ul id="g1-social-icons-1" class="g1-socials-items g1-socials-items-tpl-grid">
			<li class="g1-socials-item g1-socials-item-twitter">
	   <a class="g1-socials-item-link" href="https://twitter.com/theyams/" target="_blank" rel="noopener">
		   <span class="g1-socials-item-icon g1-socials-item-icon-28 g1-socials-item-icon-text g1-socials-item-icon-twitter"></span>
		   <span class="g1-socials-item-tooltip">
			   <span class="g1-socials-item-tooltip-inner">twitter</span>
		   </span>
	   </a>
	</li>
			<li class="g1-socials-item g1-socials-item-instagram">
	   <a class="g1-socials-item-link" href="https://instagram.com/richardinebartee/" target="_blank" rel="noopener">
		   <span class="g1-socials-item-icon g1-socials-item-icon-28 g1-socials-item-icon-text g1-socials-item-icon-instagram"></span>
		   <span class="g1-socials-item-tooltip">
			   <span class="g1-socials-item-tooltip-inner">instagram</span>
		   </span>
	   </a>
	</li>
			<li class="g1-socials-item g1-socials-item-linkedin">
	   <a class="g1-socials-item-link" href="https://www.linkedin.com/in/richardinebartee/" target="_blank" rel="noopener">
		   <span class="g1-socials-item-icon g1-socials-item-icon-28 g1-socials-item-icon-text g1-socials-item-icon-linkedin"></span>
		   <span class="g1-socials-item-tooltip">
			   <span class="g1-socials-item-tooltip-inner">linkedin</span>
		   </span>
	   </a>
	</li>
	</ul>
				</div>
			</div>
		</div>
	</section>
<p class="entry-tags "><span class="entry-tags-inner"><a href="https://grungecake.com/tag/been-on-it" class="entry-tag entry-tag-17445">Been On It</a><a href="https://grungecake.com/tag/tafia" class="entry-tag entry-tag-17444">Tafia</a></span></p>


		<aside class="g1-more-from">
		<h2 class="g1-beta g1-beta-2nd g1-collection-title"><span>More From: <a href="https://grungecake.com/category/music">Music</a></span></h2>		<div class="g1-collection g1-collection-columns-2">
			<div class="g1-collection-viewport">
				<ul class="g1-collection-items">
					
						<li class="g1-collection-item g1-collection-item-1of3">
							
<article class="entry-tpl-grid entry-tpl-grid-m post-86962 post type-post status-publish format-standard has-post-thumbnail category-music tag-erica-banks tag-sgj-t tag-slim-waist">
	<div class="entry-featured-media " ><a title="Erica Banks shares spicy video for &#8216;Slim Waist&#8217; produced by SGT J: Watch" class="g1-frame" href="https://grungecake.com/erica-banks-slim-waist/articles/86962"><div class="g1-frame-inner"><img width="364" height="205" src="https://grungecake.com/wp-content/uploads/2022/02/erica-banks-slim-waist-grungecake-thumbnail-364x205.jpg?crop=1" class="attachment-bimber-grid-standard size-bimber-grid-standard wp-post-image" alt="" loading="lazy" srcset="https://grungecake.com/wp-content/uploads/2022/02/erica-banks-slim-waist-grungecake-thumbnail-364x205.jpg?crop=1 364w, https://grungecake.com/wp-content/uploads/2022/02/erica-banks-slim-waist-grungecake-thumbnail-192x108.jpg?crop=1 192w, https://grungecake.com/wp-content/uploads/2022/02/erica-banks-slim-waist-grungecake-thumbnail-384x216.jpg?crop=1 384w, https://grungecake.com/wp-content/uploads/2022/02/erica-banks-slim-waist-grungecake-thumbnail-728x409.jpg?crop=1 728w, https://grungecake.com/wp-content/uploads/2022/02/erica-banks-slim-waist-grungecake-thumbnail-561x316.jpg?crop=1 561w, https://grungecake.com/wp-content/uploads/2022/02/erica-banks-slim-waist-grungecake-thumbnail-1122x631.jpg?crop=1 1122w, https://grungecake.com/wp-content/uploads/2022/02/erica-banks-slim-waist-grungecake-thumbnail-758x426.jpg?crop=1 758w, https://grungecake.com/wp-content/uploads/2022/02/erica-banks-slim-waist-grungecake-thumbnail-1152x648.jpg?crop=1 1152w" sizes="(max-width: 364px) 100vw, 364px" data-attachment-id="86964" data-permalink="https://grungecake.com/erica-banks-slim-waist/articles/86962/erica-banks-slim-waist-grungecake-thumbnail" data-orig-file="https://grungecake.com/wp-content/uploads/2022/02/erica-banks-slim-waist-grungecake-thumbnail.jpg" data-orig-size="3000,3000" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="erica-banks-slim-waist-grungecake-thumbnail" data-image-description="" data-image-caption="&lt;p&gt;Photo: Courtesy of the label&lt;/p&gt;
" data-medium-file="https://grungecake.com/wp-content/uploads/2022/02/erica-banks-slim-waist-grungecake-thumbnail-300x300.jpg" data-large-file="https://grungecake.com/wp-content/uploads/2022/02/erica-banks-slim-waist-grungecake-thumbnail-1024x1024.jpg" /><span class="g1-frame-icon g1-frame-icon-"></span></div></a></div>
		
	<div class="entry-body">
		<header class="entry-header">
			<div class="entry-before-title">
				
							</div>

			<h3 class="g1-gamma g1-gamma-1st entry-title"><a href="https://grungecake.com/erica-banks-slim-waist/articles/86962" rel="bookmark">Erica Banks shares spicy video for &#8216;Slim Waist&#8217; produced by SGT J: Watch</a></h3>
					</header>

		
					<footer>
				<p class="g1-meta entry-meta entry-byline entry-byline-with-avatar">
								<span class="entry-author">
	
		<span class="entry-meta-label">by</span>
			<a href="https://grungecake.com/author/richardine" title="Posts by Richardine Bartee" rel="author">
			<img alt='' src='https://grungecake.com/wp-content/uploads/2022/01/richardine-bartee-2022-grungecake-ceo-30x30.jpg' srcset='https://grungecake.com/wp-content/uploads/2022/01/richardine-bartee-2022-grungecake-ceo-60x60.jpg 2x' class='avatar avatar-30 photo' height='30' width='30' loading='lazy'/>
							<strong>Richardine Bartee</strong>
					</a>
	</span>
	
					<time class="entry-date" datetime="2022-02-25T01:36:00-05:00">25th February 2022, 1:36 AM</time>				</p>
			</footer>
		
			</div>
</article>
						</li>

					
						<li class="g1-collection-item g1-collection-item-1of3">
							
<article class="entry-tpl-grid entry-tpl-grid-m post-86954 post type-post status-publish format-standard has-post-thumbnail category-music tag-laycon tag-made-kuti tag-new-dimension">
	<div class="entry-featured-media " ><a title="Nigerian star Laycon collaborates with Made Kuti for &#8216;New Dimension&#8217;: Listen" class="g1-frame" href="https://grungecake.com/laycon-new-dimension-made-kuti/articles/86954"><div class="g1-frame-inner"><img width="364" height="205" src="https://grungecake.com/wp-content/uploads/2022/02/laycon-new-dimension-made-kuti-grungecake-thumbnail-364x205.jpg?crop=1" class="attachment-bimber-grid-standard size-bimber-grid-standard wp-post-image" alt="" loading="lazy" srcset="https://grungecake.com/wp-content/uploads/2022/02/laycon-new-dimension-made-kuti-grungecake-thumbnail-364x205.jpg?crop=1 364w, https://grungecake.com/wp-content/uploads/2022/02/laycon-new-dimension-made-kuti-grungecake-thumbnail-192x108.jpg?crop=1 192w, https://grungecake.com/wp-content/uploads/2022/02/laycon-new-dimension-made-kuti-grungecake-thumbnail-384x216.jpg?crop=1 384w, https://grungecake.com/wp-content/uploads/2022/02/laycon-new-dimension-made-kuti-grungecake-thumbnail-728x409.jpg?crop=1 728w, https://grungecake.com/wp-content/uploads/2022/02/laycon-new-dimension-made-kuti-grungecake-thumbnail-561x316.jpg?crop=1 561w, https://grungecake.com/wp-content/uploads/2022/02/laycon-new-dimension-made-kuti-grungecake-thumbnail-1122x631.jpg?crop=1 1122w, https://grungecake.com/wp-content/uploads/2022/02/laycon-new-dimension-made-kuti-grungecake-thumbnail-758x426.jpg?crop=1 758w, https://grungecake.com/wp-content/uploads/2022/02/laycon-new-dimension-made-kuti-grungecake-thumbnail-1152x648.jpg?crop=1 1152w" sizes="(max-width: 364px) 100vw, 364px" data-attachment-id="86958" data-permalink="https://grungecake.com/laycon-new-dimension-made-kuti/articles/86954/laycon-new-dimension-made-kuti-grungecake-thumbnail" data-orig-file="https://grungecake.com/wp-content/uploads/2022/02/laycon-new-dimension-made-kuti-grungecake-thumbnail.jpg" data-orig-size="2100,2100" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="laycon-new-dimension-made-kuti-grungecake-thumbnail" data-image-description="" data-image-caption="&lt;p&gt;Photo: Courtesy of the artist&lt;/p&gt;
" data-medium-file="https://grungecake.com/wp-content/uploads/2022/02/laycon-new-dimension-made-kuti-grungecake-thumbnail-300x300.jpg" data-large-file="https://grungecake.com/wp-content/uploads/2022/02/laycon-new-dimension-made-kuti-grungecake-thumbnail-1024x1024.jpg" /><span class="g1-frame-icon g1-frame-icon-"></span></div></a></div>
		
	<div class="entry-body">
		<header class="entry-header">
			<div class="entry-before-title">
				
							</div>

			<h3 class="g1-gamma g1-gamma-1st entry-title"><a href="https://grungecake.com/laycon-new-dimension-made-kuti/articles/86954" rel="bookmark">Nigerian star Laycon collaborates with Made Kuti for &#8216;New Dimension&#8217;: Listen</a></h3>
					</header>

		
					<footer>
				<p class="g1-meta entry-meta entry-byline entry-byline-with-avatar">
								<span class="entry-author">
	
		<span class="entry-meta-label">by</span>
			<a href="https://grungecake.com/author/grungecake-staff" title="Posts by GRUNGECAKE" rel="author">
			<img alt='' src='https://grungecake.com/wp-content/uploads/2021/12/cropped-grungecake-logo-yellow-30x30.png' srcset='https://grungecake.com/wp-content/uploads/2021/12/cropped-grungecake-logo-yellow-60x60.png 2x' class='avatar avatar-30 photo' height='30' width='30' loading='lazy'/>
							<strong>GRUNGECAKE</strong>
					</a>
	</span>
	
					<time class="entry-date" datetime="2022-02-24T22:22:10-05:00">24th February 2022, 10:22 PM</time>				</p>
			</footer>
		
			</div>
</article>
						</li>

					
						<li class="g1-collection-item g1-collection-item-1of3">
							
<article class="entry-tpl-grid entry-tpl-grid-m post-86723 post type-post status-publish format-standard has-post-thumbnail category-music-videos tag-ayra-starr tag-beggie-beggie tag-ckay">
	<div class="entry-featured-media " ><a title="Nigerian rising star Ayra Starr teams up with CKay to share Nollywood-inspired ‘Beggie Beggie’: Watch" class="g1-frame" href="https://grungecake.com/ayra-starr-beggie-beggie-ckay/articles/86723"><div class="g1-frame-inner"><img width="364" height="205" src="https://grungecake.com/wp-content/uploads/2022/02/ayra-starr-beggie-beggie-ckay-grungecake-thumbnail-364x205.jpg?crop=1" class="attachment-bimber-grid-standard size-bimber-grid-standard wp-post-image" alt="" loading="lazy" srcset="https://grungecake.com/wp-content/uploads/2022/02/ayra-starr-beggie-beggie-ckay-grungecake-thumbnail-364x205.jpg?crop=1 364w, https://grungecake.com/wp-content/uploads/2022/02/ayra-starr-beggie-beggie-ckay-grungecake-thumbnail-192x108.jpg?crop=1 192w, https://grungecake.com/wp-content/uploads/2022/02/ayra-starr-beggie-beggie-ckay-grungecake-thumbnail-384x216.jpg?crop=1 384w, https://grungecake.com/wp-content/uploads/2022/02/ayra-starr-beggie-beggie-ckay-grungecake-thumbnail-728x409.jpg?crop=1 728w, https://grungecake.com/wp-content/uploads/2022/02/ayra-starr-beggie-beggie-ckay-grungecake-thumbnail-561x316.jpg?crop=1 561w, https://grungecake.com/wp-content/uploads/2022/02/ayra-starr-beggie-beggie-ckay-grungecake-thumbnail-758x426.jpg?crop=1 758w" sizes="(max-width: 364px) 100vw, 364px" data-attachment-id="86950" data-permalink="https://grungecake.com/ayra-starr-beggie-beggie-ckay/articles/86723/ayra-starr-beggie-beggie-ckay-grungecake-thumbnail" data-orig-file="https://grungecake.com/wp-content/uploads/2022/02/ayra-starr-beggie-beggie-ckay-grungecake-thumbnail.jpg" data-orig-size="1080,1349" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="ayra-starr-beggie-beggie-ckay-grungecake-thumbnail" data-image-description="" data-image-caption="&lt;p&gt;Photo: &lt;a href=&quot;https://www.instagram.com/p/CZKPm60I8xP&quot; target=&quot;_blank&quot; rel=&quot;noopener&quot;&gt;Instagram&lt;/a&gt;&lt;/p&gt;
" data-medium-file="https://grungecake.com/wp-content/uploads/2022/02/ayra-starr-beggie-beggie-ckay-grungecake-thumbnail-240x300.jpg" data-large-file="https://grungecake.com/wp-content/uploads/2022/02/ayra-starr-beggie-beggie-ckay-grungecake-thumbnail-820x1024.jpg" /><span class="g1-frame-icon g1-frame-icon-"></span></div></a></div>
		
	<div class="entry-body">
		<header class="entry-header">
			<div class="entry-before-title">
				
							</div>

			<h3 class="g1-gamma g1-gamma-1st entry-title"><a href="https://grungecake.com/ayra-starr-beggie-beggie-ckay/articles/86723" rel="bookmark">Nigerian rising star Ayra Starr teams up with CKay to share Nollywood-inspired ‘Beggie Beggie’: Watch</a></h3>
					</header>

		
					<footer>
				<p class="g1-meta entry-meta entry-byline entry-byline-with-avatar">
								<span class="entry-author">
	
		<span class="entry-meta-label">by</span>
			<a href="https://grungecake.com/author/mufaro-forbes-mujuru" title="Posts by Mufaro &quot;Forbes&quot; Mujuru" rel="author">
			<img alt='' src='https://grungecake.com/wp-content/uploads/2021/12/forbes-profile-icon-grungecake-30x30.png' srcset='https://grungecake.com/wp-content/uploads/2021/12/forbes-profile-icon-grungecake-60x60.png 2x' class='avatar avatar-30 photo' height='30' width='30' loading='lazy'/>
							<strong>Mufaro &quot;Forbes&quot; Mujuru</strong>
					</a>
	</span>
	
					<time class="entry-date" datetime="2022-02-24T21:46:42-05:00">24th February 2022, 9:46 PM</time>				</p>
			</footer>
		
			</div>
</article>
						</li>

					
						<li class="g1-collection-item g1-collection-item-1of3">
							
<article class="entry-tpl-grid entry-tpl-grid-m post-86929 post type-post status-publish format-standard has-post-thumbnail category-music tag-mufasa tag-tekno">
	<div class="entry-featured-media " ><a title="Afrobeats superstar Tekno shares video for latest club banger &#8216;Mufasa’: Watch" class="g1-frame" href="https://grungecake.com/tekno-mufasa/articles/86929"><div class="g1-frame-inner"><img width="364" height="205" src="https://grungecake.com/wp-content/uploads/2022/02/tekno-mufasa-grungecake-thumbnail-364x205.gif?crop=1" class="attachment-bimber-grid-standard size-bimber-grid-standard wp-post-image" alt="" loading="lazy" srcset="https://grungecake.com/wp-content/uploads/2022/02/tekno-mufasa-grungecake-thumbnail-364x205.gif?crop=1 364w, https://grungecake.com/wp-content/uploads/2022/02/tekno-mufasa-grungecake-thumbnail-300x169.gif 300w, https://grungecake.com/wp-content/uploads/2022/02/tekno-mufasa-grungecake-thumbnail-192x108.gif?crop=1 192w, https://grungecake.com/wp-content/uploads/2022/02/tekno-mufasa-grungecake-thumbnail-384x216.gif?crop=1 384w" sizes="(max-width: 364px) 100vw, 364px" data-attachment-id="86944" data-permalink="https://grungecake.com/tekno-mufasa/articles/86929/tekno-mufasa-grungecake-thumbnail" data-orig-file="https://grungecake.com/wp-content/uploads/2022/02/tekno-mufasa-grungecake-thumbnail.gif" data-orig-size="520,293" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="tekno-mufasa-grungecake-thumbnail" data-image-description="" data-image-caption="" data-medium-file="https://grungecake.com/wp-content/uploads/2022/02/tekno-mufasa-grungecake-thumbnail-300x169.gif" data-large-file="https://grungecake.com/wp-content/uploads/2022/02/tekno-mufasa-grungecake-thumbnail.gif" /><span class="g1-frame-icon g1-frame-icon-"></span></div></a></div>
		
	<div class="entry-body">
		<header class="entry-header">
			<div class="entry-before-title">
				
							</div>

			<h3 class="g1-gamma g1-gamma-1st entry-title"><a href="https://grungecake.com/tekno-mufasa/articles/86929" rel="bookmark">Afrobeats superstar Tekno shares video for latest club banger &#8216;Mufasa’: Watch</a></h3>
					</header>

		
					<footer>
				<p class="g1-meta entry-meta entry-byline entry-byline-with-avatar">
								<span class="entry-author">
	
		<span class="entry-meta-label">by</span>
			<a href="https://grungecake.com/author/mufaro-forbes-mujuru" title="Posts by Mufaro &quot;Forbes&quot; Mujuru" rel="author">
			<img alt='' src='https://grungecake.com/wp-content/uploads/2021/12/forbes-profile-icon-grungecake-30x30.png' srcset='https://grungecake.com/wp-content/uploads/2021/12/forbes-profile-icon-grungecake-60x60.png 2x' class='avatar avatar-30 photo' height='30' width='30' loading='lazy'/>
							<strong>Mufaro &quot;Forbes&quot; Mujuru</strong>
					</a>
	</span>
	
					<time class="entry-date" datetime="2022-02-24T21:08:43-05:00">24th February 2022, 9:08 PM</time>				</p>
			</footer>
		
			</div>
</article>
						</li>

					
						<li class="g1-collection-item g1-collection-item-1of3">
							
<article class="entry-tpl-grid entry-tpl-grid-m post-86936 post type-post status-publish format-standard has-post-thumbnail category-music tag-always tag-black-sherif tag-darkoo">
	<div class="entry-featured-media " ><a title="UK&#8217;s Darkoo shares video for &#8216;Always&#8217; featuring Ghana&#8217;s fast-rising artist Black Sherif" class="g1-frame" href="https://grungecake.com/darkoo-always-black-sherif/articles/86936"><div class="g1-frame-inner"><img width="364" height="205" src="https://grungecake.com/wp-content/uploads/2022/02/darkoo-always-black-sherif-grungecake-thumbnail-364x205.gif?crop=1" class="attachment-bimber-grid-standard size-bimber-grid-standard wp-post-image" alt="" loading="lazy" srcset="https://grungecake.com/wp-content/uploads/2022/02/darkoo-always-black-sherif-grungecake-thumbnail-364x205.gif?crop=1 364w, https://grungecake.com/wp-content/uploads/2022/02/darkoo-always-black-sherif-grungecake-thumbnail-300x169.gif 300w, https://grungecake.com/wp-content/uploads/2022/02/darkoo-always-black-sherif-grungecake-thumbnail-192x108.gif?crop=1 192w, https://grungecake.com/wp-content/uploads/2022/02/darkoo-always-black-sherif-grungecake-thumbnail-384x216.gif?crop=1 384w" sizes="(max-width: 364px) 100vw, 364px" data-attachment-id="86940" data-permalink="https://grungecake.com/darkoo-always-black-sherif/articles/86936/darkoo-always-black-sherif-grungecake-thumbnail" data-orig-file="https://grungecake.com/wp-content/uploads/2022/02/darkoo-always-black-sherif-grungecake-thumbnail.gif" data-orig-size="520,293" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="darkoo-always-black-sherif-grungecake-thumbnail" data-image-description="" data-image-caption="" data-medium-file="https://grungecake.com/wp-content/uploads/2022/02/darkoo-always-black-sherif-grungecake-thumbnail-300x169.gif" data-large-file="https://grungecake.com/wp-content/uploads/2022/02/darkoo-always-black-sherif-grungecake-thumbnail.gif" /><span class="g1-frame-icon g1-frame-icon-"></span></div></a></div>
		
	<div class="entry-body">
		<header class="entry-header">
			<div class="entry-before-title">
				
							</div>

			<h3 class="g1-gamma g1-gamma-1st entry-title"><a href="https://grungecake.com/darkoo-always-black-sherif/articles/86936" rel="bookmark">UK&#8217;s Darkoo shares video for &#8216;Always&#8217; featuring Ghana&#8217;s fast-rising artist Black Sherif</a></h3>
					</header>

		
					<footer>
				<p class="g1-meta entry-meta entry-byline entry-byline-with-avatar">
								<span class="entry-author">
	
		<span class="entry-meta-label">by</span>
			<a href="https://grungecake.com/author/richardine" title="Posts by Richardine Bartee" rel="author">
			<img alt='' src='https://grungecake.com/wp-content/uploads/2022/01/richardine-bartee-2022-grungecake-ceo-30x30.jpg' srcset='https://grungecake.com/wp-content/uploads/2022/01/richardine-bartee-2022-grungecake-ceo-60x60.jpg 2x' class='avatar avatar-30 photo' height='30' width='30' loading='lazy'/>
							<strong>Richardine Bartee</strong>
					</a>
	</span>
	
					<time class="entry-date" datetime="2022-02-24T20:12:33-05:00">24th February 2022, 8:12 PM</time>				</p>
			</footer>
		
			</div>
</article>
						</li>

									</ul>
			</div>
		</div>

					</aside>


	<meta itemprop="mainEntityOfPage" content="https://grungecake.com/tafia-been-on-it/articles/86973"/>
	<meta itemprop="dateModified"
	      content="2022-02-25T02:41:06"/>

	<span itemprop="publisher" itemscope itemtype="http://schema.org/Organization">
		<meta itemprop="name" content="GRUNGECAKE" />
		<meta itemprop="url" content="https://grungecake.com" />
		<span itemprop="logo" itemscope itemtype="http://schema.org/ImageObject">
			<meta itemprop="url" content="https://grungecake.com/wp-content/uploads/2021/12/grungecake-logo-apple-news-branding-yellow.png" />
		</span>
	</span>
			<span itemprop="image" itemscope itemtype="http://schema.org/ImageObject">
						<meta itemprop="url" content="https://grungecake.com/wp-content/uploads/2022/02/tafia-been-on-it-grungecake-thumbnail.jpg" />
			<meta itemprop="width" content="1200" />
			<meta itemprop="height" content="1200" />
		</span>
	<span class="bimber-load-next-post"><a data-bimber-analytics-href="https://grungecake.com/erica-banks-slim-waist/articles/86962" href="https://grungecake.com/erica-banks-slim-waist/articles/86962" rel="prev">Next post</a><i class="g1-collection-more-spinner"></i></span>	</div>
</article>


				</div><!-- #content -->
			</div><!-- #primary -->

			<div id="secondary" class="g1-sidebar g1-sidebar-padded g1-column g1-column-1of3">
	<aside id="search-9" class="widget widget_search"><header><h2 class="g1-delta g1-delta-2nd widgettitle"><span>Search GRUNGECAKE.com</span></h2></header>

<div role="search" class="search-form-wrapper">
	<form method="get"
	      class="g1-searchform-tpl-default g1-searchform-ajax search-form"
	      action="https://grungecake.com/">
		<label>
			<span class="screen-reader-text">Search for:</span>
			<input type="search" class="search-field"
			       placeholder="Search"
			       value="" name="s"
			       title="Search for:" />
		</label>
		<button class="search-submit">Search</button>
	</form>

			<div class="g1-searches g1-searches-ajax"></div>
	</div>
</aside><aside id="text-80028" class="widget widget_text"><header><h2 class="g1-delta g1-delta-2nd widgettitle"><span>Get in touch</span></h2></header>			<div class="textwidget"><div role="form" class="wpcf7" id="wpcf7-f85216-o1" lang="en-GB" dir="ltr">
<div class="screen-reader-response"><p role="status" aria-live="polite" aria-atomic="true"></p> <ul></ul></div>
<form action="/tafia-been-on-it/articles/86973#wpcf7-f85216-o1" method="post" class="wpcf7-form init" novalidate="novalidate" data-status="init">
<div style="display: none;">
<input type="hidden" name="_wpcf7" value="85216" />
<input type="hidden" name="_wpcf7_version" value="5.5.6" />
<input type="hidden" name="_wpcf7_locale" value="en_GB" />
<input type="hidden" name="_wpcf7_unit_tag" value="wpcf7-f85216-o1" />
<input type="hidden" name="_wpcf7_container_post" value="0" />
<input type="hidden" name="_wpcf7_posted_data_hash" value="" />
</div>
<p><label> Your name<br />
    <span class="wpcf7-form-control-wrap your-name"><input type="text" name="your-name" value="" size="40" class="wpcf7-form-control wpcf7-text wpcf7-validates-as-required" aria-required="true" aria-invalid="false" /></span> </label></p>
<p><label> Your email<br />
    <span class="wpcf7-form-control-wrap your-email"><input type="email" name="your-email" value="" size="40" class="wpcf7-form-control wpcf7-text wpcf7-email wpcf7-validates-as-required wpcf7-validates-as-email" aria-required="true" aria-invalid="false" /></span> </label></p>
<p><label> Subject<br />
    <span class="wpcf7-form-control-wrap your-subject"><input type="text" name="your-subject" value="" size="40" class="wpcf7-form-control wpcf7-text wpcf7-validates-as-required" aria-required="true" aria-invalid="false" /></span> </label></p>
<p><label> Your message (optional)<br />
    <span class="wpcf7-form-control-wrap your-message"><textarea name="your-message" cols="40" rows="10" class="wpcf7-form-control wpcf7-textarea" aria-invalid="false"></textarea></span> </label></p>
<p><input type="submit" value="Submit" class="wpcf7-form-control has-spinner wpcf7-submit" /></p>
<p style="display: none !important;"><label>&#916;<textarea name="_wpcf7_ak_hp_textarea" cols="45" rows="8" maxlength="100"></textarea></label><input type="hidden" id="ak_js_1" name="_wpcf7_ak_js" value="16"/><script>document.getElementById( "ak_js_1" ).setAttribute( "value", ( new Date() ).getTime() );</script></p><div class="wpcf7-response-output" aria-hidden="true"></div></form></div>
</div>
		</aside><aside id="bimber_widget_posts-80015" class="widget widget_bimber_widget_posts"><header><h2 class="g1-delta g1-delta-2nd widgettitle"><span>Sports News</span></h2></header>			<div id="g1-widget-posts-1"
			     class=" g1-widget-posts">
									<div class="g1-collection g1-collection-grid-xxs g1-collection-columns-2">
	
			<div class="g1-collection-viewport">
			<ul class="g1-collection-items">
									<li class="g1-collection-item">
						
<article class="entry-tpl-grid entry-tpl-grid-xxs post-86844 post type-post status-publish format-standard has-post-thumbnail category-sports category-athletes tag-brian-flores tag-nfl tag-steelers">
	<div class="entry-featured-media " ><a title="Brian Flores gets hired by the only black head coach in the NFL, Mike Tomlin, joining the Steelers" class="g1-frame" href="https://grungecake.com/brian-flores-joins-mike-tomlin-and-the-steelers/articles/86844"><div class="g1-frame-inner"><img width="364" height="205" src="https://grungecake.com/wp-content/uploads/2022/02/brian-flores-steelers-grungecake-thumbnail-364x205.jpg?crop=1" class="attachment-bimber-grid-standard size-bimber-grid-standard wp-post-image" alt="" loading="lazy" srcset="https://grungecake.com/wp-content/uploads/2022/02/brian-flores-steelers-grungecake-thumbnail-364x205.jpg?crop=1 364w, https://grungecake.com/wp-content/uploads/2022/02/brian-flores-steelers-grungecake-thumbnail-300x169.jpg 300w, https://grungecake.com/wp-content/uploads/2022/02/brian-flores-steelers-grungecake-thumbnail-1024x576.jpg 1024w, https://grungecake.com/wp-content/uploads/2022/02/brian-flores-steelers-grungecake-thumbnail-192x108.jpg?crop=1 192w, https://grungecake.com/wp-content/uploads/2022/02/brian-flores-steelers-grungecake-thumbnail-384x216.jpg?crop=1 384w, https://grungecake.com/wp-content/uploads/2022/02/brian-flores-steelers-grungecake-thumbnail-728x409.jpg?crop=1 728w, https://grungecake.com/wp-content/uploads/2022/02/brian-flores-steelers-grungecake-thumbnail-561x316.jpg?crop=1 561w, https://grungecake.com/wp-content/uploads/2022/02/brian-flores-steelers-grungecake-thumbnail-1122x631.jpg?crop=1 1122w, https://grungecake.com/wp-content/uploads/2022/02/brian-flores-steelers-grungecake-thumbnail-608x342.jpg 608w, https://grungecake.com/wp-content/uploads/2022/02/brian-flores-steelers-grungecake-thumbnail-758x426.jpg?crop=1 758w, https://grungecake.com/wp-content/uploads/2022/02/brian-flores-steelers-grungecake-thumbnail-1152x648.jpg?crop=1 1152w, https://grungecake.com/wp-content/uploads/2022/02/brian-flores-steelers-grungecake-thumbnail-550x309.jpg 550w, https://grungecake.com/wp-content/uploads/2022/02/brian-flores-steelers-grungecake-thumbnail.jpg 1280w" sizes="(max-width: 364px) 100vw, 364px" data-attachment-id="86846" data-permalink="https://grungecake.com/brian-flores-joins-mike-tomlin-and-the-steelers/articles/86844/brian-flores-steelers-grungecake-thumbnail" data-orig-file="https://grungecake.com/wp-content/uploads/2022/02/brian-flores-steelers-grungecake-thumbnail.jpg" data-orig-size="1280,720" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="brian-flores-steelers-grungecake-thumbnail" data-image-description="" data-image-caption="&lt;p&gt;Photo: &lt;a href=&quot;https://www.steelers.com/news/flores-named-senior-defensive-assistant-linebackers&quot; target=&quot;_blank&quot; rel=&quot;noopener&quot;&gt;Pittsburgh Steelers&lt;/a&gt;&lt;/p&gt;
" data-medium-file="https://grungecake.com/wp-content/uploads/2022/02/brian-flores-steelers-grungecake-thumbnail-300x169.jpg" data-large-file="https://grungecake.com/wp-content/uploads/2022/02/brian-flores-steelers-grungecake-thumbnail-1024x576.jpg" /><span class="g1-frame-icon g1-frame-icon-"></span></div></a></div>
		
	<div class="entry-body">
		<header class="entry-header">
			<div class="entry-before-title">
				
							</div>

		<h3 class="g1-epsilon g1-epsilon-1st entry-title"><a href="https://grungecake.com/brian-flores-joins-mike-tomlin-and-the-steelers/articles/86844" rel="bookmark">Brian Flores gets hired by the only black head coach in the NFL, Mike Tomlin, joining the Steelers</a></h3>		</header>

		
					<footer>
				<p class="g1-meta entry-meta entry-byline entry-byline-with-avatar">
								<span class="entry-author">
	
		<span class="entry-meta-label">by</span>
			<a href="https://grungecake.com/author/andy-alexis" title="Posts by Andy Alexis" rel="author">
			<img alt='' src='https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-30x30.png' srcset='https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-60x60.png 2x' class='avatar avatar-30 photo' height='30' width='30' loading='lazy'/>
							<strong>Andy Alexis</strong>
					</a>
	</span>
	
					<time class="entry-date" datetime="2022-02-20T17:00:16-05:00">20th February 2022, 5:00 PM</time>				</p>
			</footer>
		
			</div>
</article>
					</li>
									<li class="g1-collection-item">
						
<article class="entry-tpl-grid entry-tpl-grid-xxs post-86710 post type-post status-publish format-standard has-post-thumbnail category-sports category-athletes category-news tag-nfl tag-super-bowl tag-super-bowl-lvi">
	<div class="entry-featured-media " ><a title="Super Bowl Sunday is here" class="g1-frame" href="https://grungecake.com/super-bowl-sunday-2022/articles/86710"><div class="g1-frame-inner"><img width="364" height="205" src="https://grungecake.com/wp-content/uploads/2022/02/super-bowl-sunday-grungecake-thumbnail-364x205.jpg?crop=1" class="attachment-bimber-grid-standard size-bimber-grid-standard wp-post-image" alt="" loading="lazy" srcset="https://grungecake.com/wp-content/uploads/2022/02/super-bowl-sunday-grungecake-thumbnail-364x205.jpg?crop=1 364w, https://grungecake.com/wp-content/uploads/2022/02/super-bowl-sunday-grungecake-thumbnail-192x108.jpg?crop=1 192w, https://grungecake.com/wp-content/uploads/2022/02/super-bowl-sunday-grungecake-thumbnail-384x216.jpg?crop=1 384w, https://grungecake.com/wp-content/uploads/2022/02/super-bowl-sunday-grungecake-thumbnail-728x409.jpg?crop=1 728w, https://grungecake.com/wp-content/uploads/2022/02/super-bowl-sunday-grungecake-thumbnail-561x316.jpg?crop=1 561w, https://grungecake.com/wp-content/uploads/2022/02/super-bowl-sunday-grungecake-thumbnail-1122x631.jpg?crop=1 1122w, https://grungecake.com/wp-content/uploads/2022/02/super-bowl-sunday-grungecake-thumbnail-758x426.jpg?crop=1 758w, https://grungecake.com/wp-content/uploads/2022/02/super-bowl-sunday-grungecake-thumbnail-1152x648.jpg?crop=1 1152w" sizes="(max-width: 364px) 100vw, 364px" data-attachment-id="86714" data-permalink="https://grungecake.com/super-bowl-sunday-2022/articles/86710/super-bowl-sunday-grungecake-thumbnail" data-orig-file="https://grungecake.com/wp-content/uploads/2022/02/super-bowl-sunday-grungecake-thumbnail.jpg" data-orig-size="1200,800" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="super-bowl-sunday-grungecake-thumbnail" data-image-description="" data-image-caption="&lt;p&gt;Photo: &lt;a href=&quot;https://www.bleedinggreennation.com/2022/2/11/22925852/super-bowl-predictions-2022-picks-rams-vs-bengals-odds-preview-nfl-big-game-football-burrow-stafford&quot; target=&quot;_blank&quot; rel=&quot;noopener&quot;&gt;Bleeding Green Nation&lt;/a&gt;&lt;/p&gt;
" data-medium-file="https://grungecake.com/wp-content/uploads/2022/02/super-bowl-sunday-grungecake-thumbnail-300x200.jpg" data-large-file="https://grungecake.com/wp-content/uploads/2022/02/super-bowl-sunday-grungecake-thumbnail-1024x683.jpg" /><span class="g1-frame-icon g1-frame-icon-"></span></div></a></div>
		
	<div class="entry-body">
		<header class="entry-header">
			<div class="entry-before-title">
				
							</div>

		<h3 class="g1-epsilon g1-epsilon-1st entry-title"><a href="https://grungecake.com/super-bowl-sunday-2022/articles/86710" rel="bookmark">Super Bowl Sunday is here</a></h3>		</header>

		
					<footer>
				<p class="g1-meta entry-meta entry-byline entry-byline-with-avatar">
								<span class="entry-author">
	
		<span class="entry-meta-label">by</span>
			<a href="https://grungecake.com/author/andy-alexis" title="Posts by Andy Alexis" rel="author">
			<img alt='' src='https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-30x30.png' srcset='https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-60x60.png 2x' class='avatar avatar-30 photo' height='30' width='30' loading='lazy'/>
							<strong>Andy Alexis</strong>
					</a>
	</span>
	
					<time class="entry-date" datetime="2022-02-13T13:18:30-05:00">13th February 2022, 1:18 PM</time>				</p>
			</footer>
		
			</div>
</article>
					</li>
									<li class="g1-collection-item">
						
<article class="entry-tpl-grid entry-tpl-grid-xxs post-86667 post type-post status-publish format-standard has-post-thumbnail category-athletes category-sports tag-nba tag-trade-deadline">
	<div class="entry-featured-media " ><a title="Mayham at the NBA trade deadline" class="g1-frame" href="https://grungecake.com/nba-trade-deadline/articles/86667"><div class="g1-frame-inner"><img width="364" height="205" src="https://grungecake.com/wp-content/uploads/2022/02/nba-trade-deadline-grungecake-thumbnail-364x205.png?crop=1" class="attachment-bimber-grid-standard size-bimber-grid-standard wp-post-image" alt="" loading="lazy" srcset="https://grungecake.com/wp-content/uploads/2022/02/nba-trade-deadline-grungecake-thumbnail-364x205.png?crop=1 364w, https://grungecake.com/wp-content/uploads/2022/02/nba-trade-deadline-grungecake-thumbnail-192x108.png?crop=1 192w, https://grungecake.com/wp-content/uploads/2022/02/nba-trade-deadline-grungecake-thumbnail-384x216.png?crop=1 384w" sizes="(max-width: 364px) 100vw, 364px" data-attachment-id="86717" data-permalink="https://grungecake.com/nba-trade-deadline/articles/86667/nba-trade-deadline-grungecake-thumbnail" data-orig-file="https://grungecake.com/wp-content/uploads/2022/02/nba-trade-deadline-grungecake-thumbnail.png" data-orig-size="500,500" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="nba-trade-deadline-grungecake-thumbnail" data-image-description="" data-image-caption="" data-medium-file="https://grungecake.com/wp-content/uploads/2022/02/nba-trade-deadline-grungecake-thumbnail-300x300.png" data-large-file="https://grungecake.com/wp-content/uploads/2022/02/nba-trade-deadline-grungecake-thumbnail.png" /><span class="g1-frame-icon g1-frame-icon-"></span></div></a></div>
		
	<div class="entry-body">
		<header class="entry-header">
			<div class="entry-before-title">
				
							</div>

		<h3 class="g1-epsilon g1-epsilon-1st entry-title"><a href="https://grungecake.com/nba-trade-deadline/articles/86667" rel="bookmark">Mayham at the NBA trade deadline</a></h3>		</header>

		
					<footer>
				<p class="g1-meta entry-meta entry-byline entry-byline-with-avatar">
								<span class="entry-author">
	
		<span class="entry-meta-label">by</span>
			<a href="https://grungecake.com/author/andy-alexis" title="Posts by Andy Alexis" rel="author">
			<img alt='' src='https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-30x30.png' srcset='https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-60x60.png 2x' class='avatar avatar-30 photo' height='30' width='30' loading='lazy'/>
							<strong>Andy Alexis</strong>
					</a>
	</span>
	
					<time class="entry-date" datetime="2022-02-11T00:24:10-05:00">11th February 2022, 12:24 AM</time>				</p>
			</footer>
		
			</div>
</article>
					</li>
									<li class="g1-collection-item">
						
<article class="entry-tpl-grid entry-tpl-grid-xxs post-86662 post type-post status-publish format-standard has-post-thumbnail category-athletes category-sports tag-ben-simmons tag-james-harden tag-nba">
	<div class="entry-featured-media " ><a title="The blockbuster trade involving Ben Simmons and James Harden shakes the entire Eastern Conference" class="g1-frame" href="https://grungecake.com/ben-simmons-and-james-harden-trade/articles/86662"><div class="g1-frame-inner"><img width="364" height="205" src="https://grungecake.com/wp-content/uploads/2022/02/nets-sixers-trade-grungecake-thumbnail-364x205.jpg?crop=1" class="attachment-bimber-grid-standard size-bimber-grid-standard wp-post-image" alt="" loading="lazy" srcset="https://grungecake.com/wp-content/uploads/2022/02/nets-sixers-trade-grungecake-thumbnail-364x205.jpg?crop=1 364w, https://grungecake.com/wp-content/uploads/2022/02/nets-sixers-trade-grungecake-thumbnail-192x108.jpg?crop=1 192w, https://grungecake.com/wp-content/uploads/2022/02/nets-sixers-trade-grungecake-thumbnail-384x216.jpg?crop=1 384w, https://grungecake.com/wp-content/uploads/2022/02/nets-sixers-trade-grungecake-thumbnail-728x409.jpg?crop=1 728w, https://grungecake.com/wp-content/uploads/2022/02/nets-sixers-trade-grungecake-thumbnail-561x316.jpg?crop=1 561w, https://grungecake.com/wp-content/uploads/2022/02/nets-sixers-trade-grungecake-thumbnail-1122x631.jpg?crop=1 1122w, https://grungecake.com/wp-content/uploads/2022/02/nets-sixers-trade-grungecake-thumbnail-758x426.jpg?crop=1 758w, https://grungecake.com/wp-content/uploads/2022/02/nets-sixers-trade-grungecake-thumbnail-1152x648.jpg?crop=1 1152w" sizes="(max-width: 364px) 100vw, 364px" data-attachment-id="86665" data-permalink="https://grungecake.com/ben-simmons-and-james-harden-trade/articles/86662/nets-sixers-trade-grungecake-thumbnail" data-orig-file="https://grungecake.com/wp-content/uploads/2022/02/nets-sixers-trade-grungecake-thumbnail.jpg" data-orig-size="2000,1333" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="nets-sixers-trade-grungecake-thumbnail" data-image-description="" data-image-caption="&lt;p&gt;Photo: &lt;a href=&quot;https://nypost.com/2022/02/10/james-harden-traded-for-ben-simmons-in-nets-76ers-blockbuster/&quot; target=&quot;_blank&quot; rel=&quot;noopener&quot;&gt;New York Post&lt;/a&gt;&lt;/p&gt;
" data-medium-file="https://grungecake.com/wp-content/uploads/2022/02/nets-sixers-trade-grungecake-thumbnail-300x200.jpg" data-large-file="https://grungecake.com/wp-content/uploads/2022/02/nets-sixers-trade-grungecake-thumbnail-1024x682.jpg" /><span class="g1-frame-icon g1-frame-icon-"></span></div></a></div>
		
	<div class="entry-body">
		<header class="entry-header">
			<div class="entry-before-title">
				
							</div>

		<h3 class="g1-epsilon g1-epsilon-1st entry-title"><a href="https://grungecake.com/ben-simmons-and-james-harden-trade/articles/86662" rel="bookmark">The blockbuster trade involving Ben Simmons and James Harden shakes the entire Eastern Conference</a></h3>		</header>

		
					<footer>
				<p class="g1-meta entry-meta entry-byline entry-byline-with-avatar">
								<span class="entry-author">
	
		<span class="entry-meta-label">by</span>
			<a href="https://grungecake.com/author/andy-alexis" title="Posts by Andy Alexis" rel="author">
			<img alt='' src='https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-30x30.png' srcset='https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-60x60.png 2x' class='avatar avatar-30 photo' height='30' width='30' loading='lazy'/>
							<strong>Andy Alexis</strong>
					</a>
	</span>
	
					<time class="entry-date" datetime="2022-02-10T16:57:44-05:00">10th February 2022, 4:57 PM</time>				</p>
			</footer>
		
			</div>
</article>
					</li>
							</ul>
		</div>
	</div><!-- .g1-collection -->
							</div>
			</aside><aside id="bimber_widget_posts-8" class="widget widget_bimber_widget_posts"><header><h2 class="g1-delta g1-delta-2nd widgettitle"><span>New Project Streams</span></h2></header>			<div id="g1-widget-posts-1"
			     class=" g1-widget-posts">
									<div class="g1-collection g1-collection-grid-xxs g1-collection-columns-2">
	
			<div class="g1-collection-viewport">
			<ul class="g1-collection-items">
									<li class="g1-collection-item">
						
<article class="entry-tpl-grid entry-tpl-grid-xxs post-85156 post type-post status-publish format-standard has-post-thumbnail category-extended-plays category-music-videos tag-bensoul tag-matata tag-matatu">
	<div class="entry-featured-media " ><a title="Watch Kenyan musical group Matata&#8217;s video for &#8216;Matatu&#8217; featuring Bensoul" class="g1-frame" href="https://grungecake.com/matata-matatu-bensoul/articles/85156"><div class="g1-frame-inner"><img width="364" height="205" src="https://grungecake.com/wp-content/uploads/2021/12/matata-grungecake-thumbnail-364x205.jpg?crop=1" class="attachment-bimber-grid-standard size-bimber-grid-standard wp-post-image" alt="" loading="lazy" srcset="https://grungecake.com/wp-content/uploads/2021/12/matata-grungecake-thumbnail-364x205.jpg?crop=1 364w, https://grungecake.com/wp-content/uploads/2021/12/matata-grungecake-thumbnail-192x108.jpg?crop=1 192w, https://grungecake.com/wp-content/uploads/2021/12/matata-grungecake-thumbnail-384x216.jpg?crop=1 384w, https://grungecake.com/wp-content/uploads/2021/12/matata-grungecake-thumbnail-561x316.jpg?crop=1 561w" sizes="(max-width: 364px) 100vw, 364px" data-attachment-id="85158" data-permalink="https://grungecake.com/matata-matatu-bensoul/articles/85156/matata-grungecake-thumbnail" data-orig-file="https://grungecake.com/wp-content/uploads/2021/12/matata-grungecake-thumbnail.jpg" data-orig-size="640,640" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="matata-grungecake-thumbnail" data-image-description="" data-image-caption="&lt;p&gt;Photo: &lt;a href=&quot;https://www.instagram.com/p/CWmoiJZI5vd&quot; target=&quot;_blank&quot; rel=&quot;noopener&quot;&gt;Instagram&lt;/a&gt;&lt;/p&gt;
" data-medium-file="https://grungecake.com/wp-content/uploads/2021/12/matata-grungecake-thumbnail-300x300.jpg" data-large-file="https://grungecake.com/wp-content/uploads/2021/12/matata-grungecake-thumbnail.jpg" /><span class="g1-frame-icon g1-frame-icon-"></span></div></a></div>
		
	<div class="entry-body">
		<header class="entry-header">
			<div class="entry-before-title">
				
							</div>

		<h3 class="g1-epsilon g1-epsilon-1st entry-title"><a href="https://grungecake.com/matata-matatu-bensoul/articles/85156" rel="bookmark">Watch Kenyan musical group Matata&#8217;s video for &#8216;Matatu&#8217; featuring Bensoul</a></h3>		</header>

		
					<footer>
				<p class="g1-meta entry-meta entry-byline entry-byline-with-avatar">
								<span class="entry-author">
	
		<span class="entry-meta-label">by</span>
			<a href="https://grungecake.com/author/richardine" title="Posts by Richardine Bartee" rel="author">
			<img alt='' src='https://grungecake.com/wp-content/uploads/2022/01/richardine-bartee-2022-grungecake-ceo-30x30.jpg' srcset='https://grungecake.com/wp-content/uploads/2022/01/richardine-bartee-2022-grungecake-ceo-60x60.jpg 2x' class='avatar avatar-30 photo' height='30' width='30' loading='lazy'/>
							<strong>Richardine Bartee</strong>
					</a>
	</span>
	
									</p>
			</footer>
		
			</div>
</article>
					</li>
									<li class="g1-collection-item">
						
<article class="entry-tpl-grid entry-tpl-grid-xxs post-84106 post type-post status-publish format-standard has-post-thumbnail category-extended-plays category-news category-tours tag-back-on-my-baby-jesus-sht-again tag-dababy">
	<div class="entry-featured-media " ><a title="Listen to DaBaby&#8217;s surprise EP: Back On My Baby Jesus Sh!t Again" class="g1-frame" href="https://grungecake.com/dababy-back-on-my-baby-jesus-shit-again/articles/84106"><div class="g1-frame-inner"><img width="364" height="205" src="https://grungecake.com/wp-content/uploads/2021/11/dababy-back-on-my-baby-jesus-shit-again-grungecake-thumbnail-364x205.jpg?crop=1" class="attachment-bimber-grid-standard size-bimber-grid-standard wp-post-image" alt="" loading="lazy" srcset="https://grungecake.com/wp-content/uploads/2021/11/dababy-back-on-my-baby-jesus-shit-again-grungecake-thumbnail-364x205.jpg?crop=1 364w, https://grungecake.com/wp-content/uploads/2021/11/dababy-back-on-my-baby-jesus-shit-again-grungecake-thumbnail-192x108.jpg?crop=1 192w, https://grungecake.com/wp-content/uploads/2021/11/dababy-back-on-my-baby-jesus-shit-again-grungecake-thumbnail-384x216.jpg?crop=1 384w, https://grungecake.com/wp-content/uploads/2021/11/dababy-back-on-my-baby-jesus-shit-again-grungecake-thumbnail-728x409.jpg?crop=1 728w, https://grungecake.com/wp-content/uploads/2021/11/dababy-back-on-my-baby-jesus-shit-again-grungecake-thumbnail-561x316.jpg?crop=1 561w, https://grungecake.com/wp-content/uploads/2021/11/dababy-back-on-my-baby-jesus-shit-again-grungecake-thumbnail-1122x631.jpg?crop=1 1122w, https://grungecake.com/wp-content/uploads/2021/11/dababy-back-on-my-baby-jesus-shit-again-grungecake-thumbnail-758x426.jpg?crop=1 758w, https://grungecake.com/wp-content/uploads/2021/11/dababy-back-on-my-baby-jesus-shit-again-grungecake-thumbnail-1152x648.jpg?crop=1 1152w" sizes="(max-width: 364px) 100vw, 364px" data-attachment-id="84109" data-permalink="https://grungecake.com/dababy-back-on-my-baby-jesus-shit-again/articles/84106/dababy-back-on-my-baby-jesus-shit-again-grungecake-thumbnail" data-orig-file="https://grungecake.com/wp-content/uploads/2021/11/dababy-back-on-my-baby-jesus-shit-again-grungecake-thumbnail.jpg" data-orig-size="2046,2047" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="dababy-back-on-my-baby-jesus-shit-again-grungecake-thumbnail" data-image-description="" data-image-caption="&lt;p&gt;Photo: Courtesy of the publicist&lt;/p&gt;
" data-medium-file="https://grungecake.com/wp-content/uploads/2021/11/dababy-back-on-my-baby-jesus-shit-again-grungecake-thumbnail-300x300.jpg" data-large-file="https://grungecake.com/wp-content/uploads/2021/11/dababy-back-on-my-baby-jesus-shit-again-grungecake-thumbnail-1024x1024.jpg" /><span class="g1-frame-icon g1-frame-icon-"></span></div></a></div>
		
	<div class="entry-body">
		<header class="entry-header">
			<div class="entry-before-title">
				
							</div>

		<h3 class="g1-epsilon g1-epsilon-1st entry-title"><a href="https://grungecake.com/dababy-back-on-my-baby-jesus-shit-again/articles/84106" rel="bookmark">Listen to DaBaby&#8217;s surprise EP: Back On My Baby Jesus Sh!t Again</a></h3>		</header>

		
					<footer>
				<p class="g1-meta entry-meta entry-byline entry-byline-with-avatar">
								<span class="entry-author">
	
		<span class="entry-meta-label">by</span>
			<a href="https://grungecake.com/author/richardine" title="Posts by Richardine Bartee" rel="author">
			<img alt='' src='https://grungecake.com/wp-content/uploads/2022/01/richardine-bartee-2022-grungecake-ceo-30x30.jpg' srcset='https://grungecake.com/wp-content/uploads/2022/01/richardine-bartee-2022-grungecake-ceo-60x60.jpg 2x' class='avatar avatar-30 photo' height='30' width='30' loading='lazy'/>
							<strong>Richardine Bartee</strong>
					</a>
	</span>
	
									</p>
			</footer>
		
			</div>
</article>
					</li>
									<li class="g1-collection-item">
						
<article class="entry-tpl-grid entry-tpl-grid-xxs post-83958 post type-post status-publish format-standard has-post-thumbnail category-extended-plays category-news tag-ep tag-habits tag-maeta tag-sobs">
	<div class="entry-featured-media " ><a title="Roc Nation&#8217;s newest artist Maeta to perform live tomorrow night in New York City" class="g1-frame" href="https://grungecake.com/maeta-habits/articles/83958"><div class="g1-frame-inner"><img width="364" height="205" src="https://grungecake.com/wp-content/uploads/2021/11/maeta-grungecake-thumbnail-364x205.jpg?crop=1" class="attachment-bimber-grid-standard size-bimber-grid-standard wp-post-image" alt="" loading="lazy" srcset="https://grungecake.com/wp-content/uploads/2021/11/maeta-grungecake-thumbnail-364x205.jpg?crop=1 364w, https://grungecake.com/wp-content/uploads/2021/11/maeta-grungecake-thumbnail-192x108.jpg?crop=1 192w, https://grungecake.com/wp-content/uploads/2021/11/maeta-grungecake-thumbnail-384x216.jpg?crop=1 384w, https://grungecake.com/wp-content/uploads/2021/11/maeta-grungecake-thumbnail-561x316.jpg?crop=1 561w" sizes="(max-width: 364px) 100vw, 364px" data-attachment-id="83959" data-permalink="https://grungecake.com/maeta-habits/articles/83958/maeta-grungecake-thumbnail" data-orig-file="https://grungecake.com/wp-content/uploads/2021/11/maeta-grungecake-thumbnail.jpg" data-orig-size="640,640" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="maeta-grungecake-thumbnail" data-image-description="" data-image-caption="&lt;p&gt;Photo: &lt;a href=&quot;https://www.instagram.com/p/CVOVSlwFX4P&quot; target=&quot;_blank&quot; rel=&quot;noopener&quot;&gt;Instagram&lt;/a&gt;&lt;/p&gt;
" data-medium-file="https://grungecake.com/wp-content/uploads/2021/11/maeta-grungecake-thumbnail-300x300.jpg" data-large-file="https://grungecake.com/wp-content/uploads/2021/11/maeta-grungecake-thumbnail.jpg" /><span class="g1-frame-icon g1-frame-icon-"></span></div></a></div>
		
	<div class="entry-body">
		<header class="entry-header">
			<div class="entry-before-title">
				
							</div>

		<h3 class="g1-epsilon g1-epsilon-1st entry-title"><a href="https://grungecake.com/maeta-habits/articles/83958" rel="bookmark">Roc Nation&#8217;s newest artist Maeta to perform live tomorrow night in New York City</a></h3>		</header>

		
					<footer>
				<p class="g1-meta entry-meta entry-byline entry-byline-with-avatar">
								<span class="entry-author">
	
		<span class="entry-meta-label">by</span>
			<a href="https://grungecake.com/author/richardine" title="Posts by Richardine Bartee" rel="author">
			<img alt='' src='https://grungecake.com/wp-content/uploads/2022/01/richardine-bartee-2022-grungecake-ceo-30x30.jpg' srcset='https://grungecake.com/wp-content/uploads/2022/01/richardine-bartee-2022-grungecake-ceo-60x60.jpg 2x' class='avatar avatar-30 photo' height='30' width='30' loading='lazy'/>
							<strong>Richardine Bartee</strong>
					</a>
	</span>
	
									</p>
			</footer>
		
			</div>
</article>
					</li>
									<li class="g1-collection-item">
						
<article class="entry-tpl-grid entry-tpl-grid-xxs post-83841 post type-post status-publish format-standard has-post-thumbnail category-extended-plays category-music-reviews category-news tag-ash-lauryn tag-ep tag-truth">
	<div class="entry-featured-media " ><a title="Listen to Detroit-bred Electronic producer Ash Lauryn&#8217;s latest EP &#8216;Truth&#8217;" class="g1-frame" href="https://grungecake.com/ash-lauryn-truth-ep/articles/83841"><div class="g1-frame-inner"><img width="364" height="205" src="https://grungecake.com/wp-content/uploads/2021/11/ash-lauryn-grungecake-thumbnail-364x205.jpg?crop=1" class="attachment-bimber-grid-standard size-bimber-grid-standard wp-post-image" alt="" loading="lazy" srcset="https://grungecake.com/wp-content/uploads/2021/11/ash-lauryn-grungecake-thumbnail-364x205.jpg?crop=1 364w, https://grungecake.com/wp-content/uploads/2021/11/ash-lauryn-grungecake-thumbnail-192x108.jpg?crop=1 192w, https://grungecake.com/wp-content/uploads/2021/11/ash-lauryn-grungecake-thumbnail-384x216.jpg?crop=1 384w, https://grungecake.com/wp-content/uploads/2021/11/ash-lauryn-grungecake-thumbnail-728x409.jpg?crop=1 728w, https://grungecake.com/wp-content/uploads/2021/11/ash-lauryn-grungecake-thumbnail-561x316.jpg?crop=1 561w, https://grungecake.com/wp-content/uploads/2021/11/ash-lauryn-grungecake-thumbnail-758x426.jpg?crop=1 758w" sizes="(max-width: 364px) 100vw, 364px" data-attachment-id="83849" data-permalink="https://grungecake.com/ash-lauryn-truth-ep/articles/83841/ash-lauryn-grungecake-thumbnail-2" data-orig-file="https://grungecake.com/wp-content/uploads/2021/11/ash-lauryn-grungecake-thumbnail.jpg" data-orig-size="972,597" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="ash-lauryn-grungecake-thumbnail" data-image-description="" data-image-caption="&lt;p&gt;Photo: &lt;a href=&quot;https://www.insomniac.com/music/artists/ash-lauryn&quot;&gt;Insomnia&lt;/a&gt;&lt;/p&gt;
" data-medium-file="https://grungecake.com/wp-content/uploads/2021/11/ash-lauryn-grungecake-thumbnail-300x184.jpg" data-large-file="https://grungecake.com/wp-content/uploads/2021/11/ash-lauryn-grungecake-thumbnail.jpg" /><span class="g1-frame-icon g1-frame-icon-"></span></div></a></div>
		
	<div class="entry-body">
		<header class="entry-header">
			<div class="entry-before-title">
				
							</div>

		<h3 class="g1-epsilon g1-epsilon-1st entry-title"><a href="https://grungecake.com/ash-lauryn-truth-ep/articles/83841" rel="bookmark">Listen to Detroit-bred Electronic producer Ash Lauryn&#8217;s latest EP &#8216;Truth&#8217;</a></h3>		</header>

		
					<footer>
				<p class="g1-meta entry-meta entry-byline entry-byline-with-avatar">
								<span class="entry-author">
	
		<span class="entry-meta-label">by</span>
			<a href="https://grungecake.com/author/richardine" title="Posts by Richardine Bartee" rel="author">
			<img alt='' src='https://grungecake.com/wp-content/uploads/2022/01/richardine-bartee-2022-grungecake-ceo-30x30.jpg' srcset='https://grungecake.com/wp-content/uploads/2022/01/richardine-bartee-2022-grungecake-ceo-60x60.jpg 2x' class='avatar avatar-30 photo' height='30' width='30' loading='lazy'/>
							<strong>Richardine Bartee</strong>
					</a>
	</span>
	
									</p>
			</footer>
		
			</div>
</article>
					</li>
							</ul>
		</div>
	</div><!-- .g1-collection -->
							</div>
			</aside><aside id="bimber_widget_posts-80006" class="widget widget_bimber_widget_posts"><header><h2 class="g1-delta g1-delta-2nd widgettitle"><span>Songs of the Day</span></h2></header>			<div id="g1-widget-posts-1"
			     class=" g1-widget-posts">
									<div class="g1-collection g1-collection-grid-xxs g1-collection-columns-2">
	
			<div class="g1-collection-viewport">
			<ul class="g1-collection-items">
									<li class="g1-collection-item">
						
<article class="entry-tpl-grid entry-tpl-grid-xxs post-86688 post type-post status-publish format-standard has-post-thumbnail category-music category-song-of-the-day tag-basketmouth tag-listen tag-wande-coal">
	<div class="entry-featured-media " ><a title="Song of the Day: ‘Listen’ by Basketmouth featuring Wande Coal" class="g1-frame" href="https://grungecake.com/basketmouth-listen-wande-coal/articles/86688"><div class="g1-frame-inner"><img width="364" height="205" src="https://grungecake.com/wp-content/uploads/2022/02/basketmouth-grungecake-thumbnail-364x205.jpg?crop=1" class="attachment-bimber-grid-standard size-bimber-grid-standard wp-post-image" alt="" loading="lazy" srcset="https://grungecake.com/wp-content/uploads/2022/02/basketmouth-grungecake-thumbnail-364x205.jpg?crop=1 364w, https://grungecake.com/wp-content/uploads/2022/02/basketmouth-grungecake-thumbnail-192x108.jpg?crop=1 192w, https://grungecake.com/wp-content/uploads/2022/02/basketmouth-grungecake-thumbnail-384x216.jpg?crop=1 384w, https://grungecake.com/wp-content/uploads/2022/02/basketmouth-grungecake-thumbnail-561x316.jpg?crop=1 561w" sizes="(max-width: 364px) 100vw, 364px" data-attachment-id="86690" data-permalink="https://grungecake.com/basketmouth-listen-wande-coal/articles/86688/basketmouth-grungecake-thumbnail" data-orig-file="https://grungecake.com/wp-content/uploads/2022/02/basketmouth-grungecake-thumbnail.jpg" data-orig-size="640,640" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="basketmouth-grungecake-thumbnail" data-image-description="" data-image-caption="&lt;p&gt;Photo: Instagram&lt;/p&gt;
" data-medium-file="https://grungecake.com/wp-content/uploads/2022/02/basketmouth-grungecake-thumbnail-300x300.jpg" data-large-file="https://grungecake.com/wp-content/uploads/2022/02/basketmouth-grungecake-thumbnail.jpg" /><span class="g1-frame-icon g1-frame-icon-"></span></div></a></div>
		
	<div class="entry-body">
		<header class="entry-header">
			<div class="entry-before-title">
				
							</div>

		<h3 class="g1-epsilon g1-epsilon-1st entry-title"><a href="https://grungecake.com/basketmouth-listen-wande-coal/articles/86688" rel="bookmark">Song of the Day: ‘Listen’ by Basketmouth featuring Wande Coal</a></h3>		</header>

		
					<footer>
				<p class="g1-meta entry-meta entry-byline entry-byline-with-avatar">
								<span class="entry-author">
	
		<span class="entry-meta-label">by</span>
			<a href="https://grungecake.com/author/richardine" title="Posts by Richardine Bartee" rel="author">
			<img alt='' src='https://grungecake.com/wp-content/uploads/2022/01/richardine-bartee-2022-grungecake-ceo-30x30.jpg' srcset='https://grungecake.com/wp-content/uploads/2022/01/richardine-bartee-2022-grungecake-ceo-60x60.jpg 2x' class='avatar avatar-30 photo' height='30' width='30' loading='lazy'/>
							<strong>Richardine Bartee</strong>
					</a>
	</span>
	
					<time class="entry-date" datetime="2022-02-13T08:47:29-05:00">13th February 2022, 8:47 AM</time>				</p>
			</footer>
		
			</div>
</article>
					</li>
									<li class="g1-collection-item">
						
<article class="entry-tpl-grid entry-tpl-grid-xxs post-86470 post type-post status-publish format-standard has-post-thumbnail category-song-of-the-day category-music-videos tag-non-living-thing tag-oxlade tag-sarkodie">
	<div class="entry-featured-media " ><a title="Song of the Day: &#8216;Non Living Thing&#8217; featuring Oxlade by Sarkodie" class="g1-frame" href="https://grungecake.com/sarkodie-non-living-thing-oxlade/articles/86470"><div class="g1-frame-inner"><img width="364" height="205" src="https://grungecake.com/wp-content/uploads/2022/01/sarkodie-non-living-thing-oxlade-grungecake-thumbnail-364x205.gif?crop=1" class="attachment-bimber-grid-standard size-bimber-grid-standard wp-post-image" alt="" loading="lazy" srcset="https://grungecake.com/wp-content/uploads/2022/01/sarkodie-non-living-thing-oxlade-grungecake-thumbnail-364x205.gif?crop=1 364w, https://grungecake.com/wp-content/uploads/2022/01/sarkodie-non-living-thing-oxlade-grungecake-thumbnail-192x108.gif?crop=1 192w, https://grungecake.com/wp-content/uploads/2022/01/sarkodie-non-living-thing-oxlade-grungecake-thumbnail-384x216.gif?crop=1 384w" sizes="(max-width: 364px) 100vw, 364px" data-attachment-id="86485" data-permalink="https://grungecake.com/sarkodie-non-living-thing-oxlade/articles/86470/sarkodie-non-living-thing-oxlade-grungecake-thumbnail-2" data-orig-file="https://grungecake.com/wp-content/uploads/2022/01/sarkodie-non-living-thing-oxlade-grungecake-thumbnail.gif" data-orig-size="520,275" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="sarkodie-non-living-thing-oxlade-grungecake-thumbnail" data-image-description="" data-image-caption="" data-medium-file="https://grungecake.com/wp-content/uploads/2022/01/sarkodie-non-living-thing-oxlade-grungecake-thumbnail-300x159.gif" data-large-file="https://grungecake.com/wp-content/uploads/2022/01/sarkodie-non-living-thing-oxlade-grungecake-thumbnail.gif" /><span class="g1-frame-icon g1-frame-icon-"></span></div></a></div>
		
	<div class="entry-body">
		<header class="entry-header">
			<div class="entry-before-title">
				
							</div>

		<h3 class="g1-epsilon g1-epsilon-1st entry-title"><a href="https://grungecake.com/sarkodie-non-living-thing-oxlade/articles/86470" rel="bookmark">Song of the Day: &#8216;Non Living Thing&#8217; featuring Oxlade by Sarkodie</a></h3>		</header>

		
					<footer>
				<p class="g1-meta entry-meta entry-byline entry-byline-with-avatar">
								<span class="entry-author">
	
		<span class="entry-meta-label">by</span>
			<a href="https://grungecake.com/author/richardine" title="Posts by Richardine Bartee" rel="author">
			<img alt='' src='https://grungecake.com/wp-content/uploads/2022/01/richardine-bartee-2022-grungecake-ceo-30x30.jpg' srcset='https://grungecake.com/wp-content/uploads/2022/01/richardine-bartee-2022-grungecake-ceo-60x60.jpg 2x' class='avatar avatar-30 photo' height='30' width='30' loading='lazy'/>
							<strong>Richardine Bartee</strong>
					</a>
	</span>
	
					<time class="entry-date" datetime="2022-01-29T19:05:40-05:00">29th January 2022, 7:05 PM</time>				</p>
			</footer>
		
			</div>
</article>
					</li>
									<li class="g1-collection-item">
						
<article class="entry-tpl-grid entry-tpl-grid-xxs post-85733 post type-post status-publish format-standard has-post-thumbnail category-music-reviews category-song-of-the-day tag-drunk-text-me tag-lexi-jayde">
	<div class="entry-featured-media " ><a title="Song of the Day: &#8216;Drunk Text Me&#8217; by Lexi Jayde" class="g1-frame" href="https://grungecake.com/lexi-jayde-drunk-text-me/articles/85733"><div class="g1-frame-inner"><img width="354" height="199" src="https://grungecake.com/wp-content/uploads/2022/01/lexi-jayde-drunk-text-me-grungecake-thumbnail-354x199.jpg" class="attachment-bimber-grid-standard size-bimber-grid-standard wp-post-image" alt="" loading="lazy" srcset="https://grungecake.com/wp-content/uploads/2022/01/lexi-jayde-drunk-text-me-grungecake-thumbnail-354x199.jpg 354w, https://grungecake.com/wp-content/uploads/2022/01/lexi-jayde-drunk-text-me-grungecake-thumbnail-192x108.jpg?crop=1 192w, https://grungecake.com/wp-content/uploads/2022/01/lexi-jayde-drunk-text-me-grungecake-thumbnail-384x216.jpg?crop=1 384w, https://grungecake.com/wp-content/uploads/2022/01/lexi-jayde-drunk-text-me-grungecake-thumbnail-708x398.jpg 708w, https://grungecake.com/wp-content/uploads/2022/01/lexi-jayde-drunk-text-me-grungecake-thumbnail-543x305.jpg 543w, https://grungecake.com/wp-content/uploads/2022/01/lexi-jayde-drunk-text-me-grungecake-thumbnail-1086x611.jpg 1086w, https://grungecake.com/wp-content/uploads/2022/01/lexi-jayde-drunk-text-me-grungecake-thumbnail-732x412.jpg 732w, https://grungecake.com/wp-content/uploads/2022/01/lexi-jayde-drunk-text-me-grungecake-thumbnail-1110x624.jpg 1110w" sizes="(max-width: 354px) 100vw, 354px" data-attachment-id="85735" data-permalink="https://grungecake.com/lexi-jayde-drunk-text-me/articles/85733/lexi-jayde-drunk-text-me-grungecake-thumbnail" data-orig-file="https://grungecake.com/wp-content/uploads/2022/01/lexi-jayde-drunk-text-me-grungecake-thumbnail.jpg" data-orig-size="3000,3000" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="lexi-jayde-drunk-text-me-grungecake-thumbnail" data-image-description="" data-image-caption="&lt;p&gt;Photo: Courtesy of the publicist&lt;/p&gt;
" data-medium-file="https://grungecake.com/wp-content/uploads/2022/01/lexi-jayde-drunk-text-me-grungecake-thumbnail-300x300.jpg" data-large-file="https://grungecake.com/wp-content/uploads/2022/01/lexi-jayde-drunk-text-me-grungecake-thumbnail-1024x1024.jpg" /><span class="g1-frame-icon g1-frame-icon-"></span></div></a></div>
		
	<div class="entry-body">
		<header class="entry-header">
			<div class="entry-before-title">
				
							</div>

		<h3 class="g1-epsilon g1-epsilon-1st entry-title"><a href="https://grungecake.com/lexi-jayde-drunk-text-me/articles/85733" rel="bookmark">Song of the Day: &#8216;Drunk Text Me&#8217; by Lexi Jayde</a></h3>		</header>

		
					<footer>
				<p class="g1-meta entry-meta entry-byline entry-byline-with-avatar">
								<span class="entry-author">
	
		<span class="entry-meta-label">by</span>
			<a href="https://grungecake.com/author/richardine" title="Posts by Richardine Bartee" rel="author">
			<img alt='' src='https://grungecake.com/wp-content/uploads/2022/01/richardine-bartee-2022-grungecake-ceo-30x30.jpg' srcset='https://grungecake.com/wp-content/uploads/2022/01/richardine-bartee-2022-grungecake-ceo-60x60.jpg 2x' class='avatar avatar-30 photo' height='30' width='30' loading='lazy'/>
							<strong>Richardine Bartee</strong>
					</a>
	</span>
	
					<time class="entry-date" datetime="2022-01-07T06:23:30-05:00">7th January 2022, 6:23 AM</time>				</p>
			</footer>
		
			</div>
</article>
					</li>
									<li class="g1-collection-item">
						
<article class="entry-tpl-grid entry-tpl-grid-xxs post-84599 post type-post status-publish format-standard has-post-thumbnail category-music-reviews category-music-videos category-news category-song-of-the-day tag-good-morning-gorgeous tag-mary-j-blige">
	<div class="entry-featured-media " ><a title="Song of the Day: &#8216;Good Morning Gorgeous&#8217; by Mary J Blige" class="g1-frame" href="https://grungecake.com/mary-j-blige-good-morning-gorgeous/articles/84599"><div class="g1-frame-inner"><img width="364" height="205" src="https://grungecake.com/wp-content/uploads/2021/12/mary-j-blige-good-morning-gorgeous-grungecake-thumbnail-364x205.jpg?crop=1" class="attachment-bimber-grid-standard size-bimber-grid-standard wp-post-image" alt="" loading="lazy" srcset="https://grungecake.com/wp-content/uploads/2021/12/mary-j-blige-good-morning-gorgeous-grungecake-thumbnail-364x205.jpg?crop=1 364w, https://grungecake.com/wp-content/uploads/2021/12/mary-j-blige-good-morning-gorgeous-grungecake-thumbnail-192x108.jpg?crop=1 192w, https://grungecake.com/wp-content/uploads/2021/12/mary-j-blige-good-morning-gorgeous-grungecake-thumbnail-384x216.jpg?crop=1 384w, https://grungecake.com/wp-content/uploads/2021/12/mary-j-blige-good-morning-gorgeous-grungecake-thumbnail-561x316.jpg?crop=1 561w" sizes="(max-width: 364px) 100vw, 364px" data-attachment-id="84605" data-permalink="https://grungecake.com/mary-j-blige-good-morning-gorgeous/articles/84599/mary-j-blige-good-morning-gorgeous-grungecake-thumbnail" data-orig-file="https://grungecake.com/wp-content/uploads/2021/12/mary-j-blige-good-morning-gorgeous-grungecake-thumbnail.jpg" data-orig-size="640,640" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="mary-j-blige-good-morning-gorgeous-grungecake-thumbnail" data-image-description="" data-image-caption="&lt;p&gt;Photo: &lt;a href=&quot;https://open.spotify.com/album/0mDZswykT2LDXe3YGWZgbc&quot; target=&quot;_blank&quot; rel=&quot;noopener&quot;&gt;Spotify&lt;/a&gt;&lt;/p&gt;
" data-medium-file="https://grungecake.com/wp-content/uploads/2021/12/mary-j-blige-good-morning-gorgeous-grungecake-thumbnail-300x300.jpg" data-large-file="https://grungecake.com/wp-content/uploads/2021/12/mary-j-blige-good-morning-gorgeous-grungecake-thumbnail.jpg" /><span class="g1-frame-icon g1-frame-icon-"></span></div></a></div>
		
	<div class="entry-body">
		<header class="entry-header">
			<div class="entry-before-title">
				
							</div>

		<h3 class="g1-epsilon g1-epsilon-1st entry-title"><a href="https://grungecake.com/mary-j-blige-good-morning-gorgeous/articles/84599" rel="bookmark">Song of the Day: &#8216;Good Morning Gorgeous&#8217; by Mary J Blige</a></h3>		</header>

		
					<footer>
				<p class="g1-meta entry-meta entry-byline entry-byline-with-avatar">
								<span class="entry-author">
	
		<span class="entry-meta-label">by</span>
			<a href="https://grungecake.com/author/richardine" title="Posts by Richardine Bartee" rel="author">
			<img alt='' src='https://grungecake.com/wp-content/uploads/2022/01/richardine-bartee-2022-grungecake-ceo-30x30.jpg' srcset='https://grungecake.com/wp-content/uploads/2022/01/richardine-bartee-2022-grungecake-ceo-60x60.jpg 2x' class='avatar avatar-30 photo' height='30' width='30' loading='lazy'/>
							<strong>Richardine Bartee</strong>
					</a>
	</span>
	
					<time class="entry-date" datetime="2021-12-05T18:28:09-05:00">5th December 2021, 6:28 PM</time>				</p>
			</footer>
		
			</div>
</article>
					</li>
							</ul>
		</div>
	</div><!-- .g1-collection -->
							</div>
			</aside><aside id="bimber_widget_posts-80014" class="widget widget_bimber_widget_posts"><header><h2 class="g1-delta g1-delta-2nd widgettitle"><span>Albums to Consider</span></h2></header>			<div id="g1-widget-posts-1"
			     class=" g1-widget-posts">
									<div class="g1-collection g1-collection-grid-xxs g1-collection-columns-2">
	
			<div class="g1-collection-viewport">
			<ul class="g1-collection-items">
									<li class="g1-collection-item">
						
<article class="entry-tpl-grid entry-tpl-grid-xxs post-86627 post type-post status-publish format-standard has-post-thumbnail category-music-videos category-albums category-news tag-alien tag-beam tag-planet-beam">
	<div class="entry-featured-media " ><a title="After giving us ‘ALIEN’, BEAM takes us to ‘PLANET BEAM’: Watch" class="g1-frame" href="https://grungecake.com/beam-planet-beam/articles/86627"><div class="g1-frame-inner"><img width="364" height="205" src="https://grungecake.com/wp-content/uploads/2022/02/beam-grungecake-thumbnail-364x205.png?crop=1" class="attachment-bimber-grid-standard size-bimber-grid-standard wp-post-image" alt="" loading="lazy" srcset="https://grungecake.com/wp-content/uploads/2022/02/beam-grungecake-thumbnail-364x205.png?crop=1 364w, https://grungecake.com/wp-content/uploads/2022/02/beam-grungecake-thumbnail-192x108.png?crop=1 192w, https://grungecake.com/wp-content/uploads/2022/02/beam-grungecake-thumbnail-384x216.png?crop=1 384w, https://grungecake.com/wp-content/uploads/2022/02/beam-grungecake-thumbnail-728x409.png?crop=1 728w, https://grungecake.com/wp-content/uploads/2022/02/beam-grungecake-thumbnail-561x316.png?crop=1 561w, https://grungecake.com/wp-content/uploads/2022/02/beam-grungecake-thumbnail-758x426.png?crop=1 758w" sizes="(max-width: 364px) 100vw, 364px" data-attachment-id="86534" data-permalink="https://grungecake.com/beam-alien-announcement/articles/86410/beam-grungecake-thumbnail" data-orig-file="https://grungecake.com/wp-content/uploads/2022/02/beam-grungecake-thumbnail.png" data-orig-size="834,1254" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="beam-grungecake-thumbnail" data-image-description="" data-image-caption="&lt;p&gt;Photo: Courtesy of the label&lt;/p&gt;
" data-medium-file="https://grungecake.com/wp-content/uploads/2022/02/beam-grungecake-thumbnail-200x300.png" data-large-file="https://grungecake.com/wp-content/uploads/2022/02/beam-grungecake-thumbnail-681x1024.png" /><span class="g1-frame-icon g1-frame-icon-"></span></div></a></div>
		
	<div class="entry-body">
		<header class="entry-header">
			<div class="entry-before-title">
				
							</div>

		<h3 class="g1-epsilon g1-epsilon-1st entry-title"><a href="https://grungecake.com/beam-planet-beam/articles/86627" rel="bookmark">After giving us ‘ALIEN’, BEAM takes us to ‘PLANET BEAM’: Watch</a></h3>		</header>

		
					<footer>
				<p class="g1-meta entry-meta entry-byline entry-byline-with-avatar">
								<span class="entry-author">
	
		<span class="entry-meta-label">by</span>
			<a href="https://grungecake.com/author/mufaro-forbes-mujuru" title="Posts by Mufaro &quot;Forbes&quot; Mujuru" rel="author">
			<img alt='' src='https://grungecake.com/wp-content/uploads/2021/12/forbes-profile-icon-grungecake-30x30.png' srcset='https://grungecake.com/wp-content/uploads/2021/12/forbes-profile-icon-grungecake-60x60.png 2x' class='avatar avatar-30 photo' height='30' width='30' loading='lazy'/>
							<strong>Mufaro &quot;Forbes&quot; Mujuru</strong>
					</a>
	</span>
	
					<time class="entry-date" datetime="2022-02-11T16:49:56-05:00">11th February 2022, 4:49 PM</time>				</p>
			</footer>
		
			</div>
</article>
					</li>
									<li class="g1-collection-item">
						
<article class="entry-tpl-grid entry-tpl-grid-xxs post-86097 post type-post status-publish format-standard has-post-thumbnail category-albums tag-fiokee tag-man">
	<div class="entry-featured-media " ><a title="Listen to Nigerian guitarist Fiokee&#8217;s star-studded debut ‘MAN’" class="g1-frame" href="https://grungecake.com/fiokee-man/articles/86097"><div class="g1-frame-inner"><img width="364" height="205" src="https://grungecake.com/wp-content/uploads/2022/01/fiokee-man-grungecake-thumbnail-364x205.jpg?crop=1" class="attachment-bimber-grid-standard size-bimber-grid-standard wp-post-image" alt="" loading="lazy" srcset="https://grungecake.com/wp-content/uploads/2022/01/fiokee-man-grungecake-thumbnail-364x205.jpg?crop=1 364w, https://grungecake.com/wp-content/uploads/2022/01/fiokee-man-grungecake-thumbnail-192x108.jpg?crop=1 192w, https://grungecake.com/wp-content/uploads/2022/01/fiokee-man-grungecake-thumbnail-384x216.jpg?crop=1 384w, https://grungecake.com/wp-content/uploads/2022/01/fiokee-man-grungecake-thumbnail-561x316.jpg?crop=1 561w" sizes="(max-width: 364px) 100vw, 364px" data-attachment-id="86608" data-permalink="https://grungecake.com/fiokee-man/articles/86097/fiokee-man-grungecake-thumbnail" data-orig-file="https://grungecake.com/wp-content/uploads/2022/01/fiokee-man-grungecake-thumbnail.jpg" data-orig-size="640,640" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="fiokee-man-grungecake-thumbnail" data-image-description="" data-image-caption="&lt;p&gt;Photo: &lt;a href=&quot;https://open.spotify.com/album/2jYuXSwfh6qdqhrcRrplbO?si=U31CdjKLRomt4FzL3NKb_Q&quot; target=&quot;_blank&quot; rel=&quot;noopener&quot;&gt;Spotify&lt;/a&gt;&lt;/p&gt;
" data-medium-file="https://grungecake.com/wp-content/uploads/2022/01/fiokee-man-grungecake-thumbnail-300x300.jpg" data-large-file="https://grungecake.com/wp-content/uploads/2022/01/fiokee-man-grungecake-thumbnail.jpg" /><span class="g1-frame-icon g1-frame-icon-"></span></div></a></div>
		
	<div class="entry-body">
		<header class="entry-header">
			<div class="entry-before-title">
				
							</div>

		<h3 class="g1-epsilon g1-epsilon-1st entry-title"><a href="https://grungecake.com/fiokee-man/articles/86097" rel="bookmark">Listen to Nigerian guitarist Fiokee&#8217;s star-studded debut ‘MAN’</a></h3>		</header>

		
					<footer>
				<p class="g1-meta entry-meta entry-byline entry-byline-with-avatar">
								<span class="entry-author">
	
		<span class="entry-meta-label">by</span>
			<a href="https://grungecake.com/author/mufaro-forbes-mujuru" title="Posts by Mufaro &quot;Forbes&quot; Mujuru" rel="author">
			<img alt='' src='https://grungecake.com/wp-content/uploads/2021/12/forbes-profile-icon-grungecake-30x30.png' srcset='https://grungecake.com/wp-content/uploads/2021/12/forbes-profile-icon-grungecake-60x60.png 2x' class='avatar avatar-30 photo' height='30' width='30' loading='lazy'/>
							<strong>Mufaro &quot;Forbes&quot; Mujuru</strong>
					</a>
	</span>
	
					<time class="entry-date" datetime="2022-02-04T23:18:02-05:00">4th February 2022, 11:18 PM</time>				</p>
			</footer>
		
			</div>
</article>
					</li>
									<li class="g1-collection-item">
						
<article class="entry-tpl-grid entry-tpl-grid-xxs post-86568 post type-post status-publish format-standard has-post-thumbnail category-albums category-news tag-alien tag-beam">
	<div class="entry-featured-media " ><a title="Stream BEAM&#8217;s new album &#8216;ALIEN&#8217; featuring Justin Bieber, Jorja Smith and more" class="g1-frame" href="https://grungecake.com/beam-alien/articles/86568"><div class="g1-frame-inner"><img width="364" height="205" src="https://grungecake.com/wp-content/uploads/2022/02/beam-alien-grungecake-thumbnail-364x205.png?crop=1" class="attachment-bimber-grid-standard size-bimber-grid-standard wp-post-image" alt="" loading="lazy" srcset="https://grungecake.com/wp-content/uploads/2022/02/beam-alien-grungecake-thumbnail-364x205.png?crop=1 364w, https://grungecake.com/wp-content/uploads/2022/02/beam-alien-grungecake-thumbnail-192x108.png?crop=1 192w, https://grungecake.com/wp-content/uploads/2022/02/beam-alien-grungecake-thumbnail-384x216.png?crop=1 384w, https://grungecake.com/wp-content/uploads/2022/02/beam-alien-grungecake-thumbnail-728x409.png?crop=1 728w, https://grungecake.com/wp-content/uploads/2022/02/beam-alien-grungecake-thumbnail-561x316.png?crop=1 561w, https://grungecake.com/wp-content/uploads/2022/02/beam-alien-grungecake-thumbnail-1122x631.png?crop=1 1122w, https://grungecake.com/wp-content/uploads/2022/02/beam-alien-grungecake-thumbnail-758x426.png?crop=1 758w, https://grungecake.com/wp-content/uploads/2022/02/beam-alien-grungecake-thumbnail-1152x648.png?crop=1 1152w" sizes="(max-width: 364px) 100vw, 364px" data-attachment-id="86533" data-permalink="https://grungecake.com/beam-alien-announcement/articles/86410/beam-alien-grungecake-thumbnail" data-orig-file="https://grungecake.com/wp-content/uploads/2022/02/beam-alien-grungecake-thumbnail.png" data-orig-size="1198,1198" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="beam-alien-grungecake-thumbnail" data-image-description="" data-image-caption="&lt;p&gt;Photo: Courtesy of the label&lt;/p&gt;
" data-medium-file="https://grungecake.com/wp-content/uploads/2022/02/beam-alien-grungecake-thumbnail-300x300.png" data-large-file="https://grungecake.com/wp-content/uploads/2022/02/beam-alien-grungecake-thumbnail-1024x1024.png" /><span class="g1-frame-icon g1-frame-icon-"></span></div></a></div>
		
	<div class="entry-body">
		<header class="entry-header">
			<div class="entry-before-title">
				
							</div>

		<h3 class="g1-epsilon g1-epsilon-1st entry-title"><a href="https://grungecake.com/beam-alien/articles/86568" rel="bookmark">Stream BEAM&#8217;s new album &#8216;ALIEN&#8217; featuring Justin Bieber, Jorja Smith and more</a></h3>		</header>

		
					<footer>
				<p class="g1-meta entry-meta entry-byline entry-byline-with-avatar">
								<span class="entry-author">
	
		<span class="entry-meta-label">by</span>
			<a href="https://grungecake.com/author/richardine" title="Posts by Richardine Bartee" rel="author">
			<img alt='' src='https://grungecake.com/wp-content/uploads/2022/01/richardine-bartee-2022-grungecake-ceo-30x30.jpg' srcset='https://grungecake.com/wp-content/uploads/2022/01/richardine-bartee-2022-grungecake-ceo-60x60.jpg 2x' class='avatar avatar-30 photo' height='30' width='30' loading='lazy'/>
							<strong>Richardine Bartee</strong>
					</a>
	</span>
	
					<time class="entry-date" datetime="2022-02-04T16:42:12-05:00">4th February 2022, 4:42 PM</time>				</p>
			</footer>
		
			</div>
</article>
					</li>
									<li class="g1-collection-item">
						
<article class="entry-tpl-grid entry-tpl-grid-xxs post-86410 post type-post status-publish format-standard has-post-thumbnail category-music category-albums category-news tag-alien tag-beam tag-win">
	<div class="entry-featured-media " ><a title="Miami-based Jamaican artist BEAM&#8217;s debut album &#8216;ALIEN&#8217; features Justin Bieber" class="g1-frame" href="https://grungecake.com/beam-alien-announcement/articles/86410"><div class="g1-frame-inner"><img width="364" height="205" src="https://grungecake.com/wp-content/uploads/2022/02/beam-grungecake-thumbnail-364x205.png?crop=1" class="attachment-bimber-grid-standard size-bimber-grid-standard wp-post-image" alt="" loading="lazy" srcset="https://grungecake.com/wp-content/uploads/2022/02/beam-grungecake-thumbnail-364x205.png?crop=1 364w, https://grungecake.com/wp-content/uploads/2022/02/beam-grungecake-thumbnail-192x108.png?crop=1 192w, https://grungecake.com/wp-content/uploads/2022/02/beam-grungecake-thumbnail-384x216.png?crop=1 384w, https://grungecake.com/wp-content/uploads/2022/02/beam-grungecake-thumbnail-728x409.png?crop=1 728w, https://grungecake.com/wp-content/uploads/2022/02/beam-grungecake-thumbnail-561x316.png?crop=1 561w, https://grungecake.com/wp-content/uploads/2022/02/beam-grungecake-thumbnail-758x426.png?crop=1 758w" sizes="(max-width: 364px) 100vw, 364px" data-attachment-id="86534" data-permalink="https://grungecake.com/beam-alien-announcement/articles/86410/beam-grungecake-thumbnail" data-orig-file="https://grungecake.com/wp-content/uploads/2022/02/beam-grungecake-thumbnail.png" data-orig-size="834,1254" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="beam-grungecake-thumbnail" data-image-description="" data-image-caption="&lt;p&gt;Photo: Courtesy of the label&lt;/p&gt;
" data-medium-file="https://grungecake.com/wp-content/uploads/2022/02/beam-grungecake-thumbnail-200x300.png" data-large-file="https://grungecake.com/wp-content/uploads/2022/02/beam-grungecake-thumbnail-681x1024.png" /><span class="g1-frame-icon g1-frame-icon-"></span></div></a></div>
		
	<div class="entry-body">
		<header class="entry-header">
			<div class="entry-before-title">
				
							</div>

		<h3 class="g1-epsilon g1-epsilon-1st entry-title"><a href="https://grungecake.com/beam-alien-announcement/articles/86410" rel="bookmark">Miami-based Jamaican artist BEAM&#8217;s debut album &#8216;ALIEN&#8217; features Justin Bieber</a></h3>		</header>

		
					<footer>
				<p class="g1-meta entry-meta entry-byline entry-byline-with-avatar">
								<span class="entry-author">
	
		<span class="entry-meta-label">by</span>
			<a href="https://grungecake.com/author/richardine" title="Posts by Richardine Bartee" rel="author">
			<img alt='' src='https://grungecake.com/wp-content/uploads/2022/01/richardine-bartee-2022-grungecake-ceo-30x30.jpg' srcset='https://grungecake.com/wp-content/uploads/2022/01/richardine-bartee-2022-grungecake-ceo-60x60.jpg 2x' class='avatar avatar-30 photo' height='30' width='30' loading='lazy'/>
							<strong>Richardine Bartee</strong>
					</a>
	</span>
	
					<time class="entry-date" datetime="2022-02-02T18:03:51-05:00">2nd February 2022, 6:03 PM</time>				</p>
			</footer>
		
			</div>
</article>
					</li>
							</ul>
		</div>
	</div><!-- .g1-collection -->
							</div>
			</aside><aside id="bimber_widget_posts-80013" class="widget widget_bimber_widget_posts"><header><h2 class="g1-delta g1-delta-2nd widgettitle"><span>Recent Interviews</span></h2></header>			<div id="g1-widget-posts-1"
			     class=" g1-widget-posts">
									<div class="g1-collection g1-collection-grid-xxs g1-collection-columns-2">
	
			<div class="g1-collection-viewport">
			<ul class="g1-collection-items">
									<li class="g1-collection-item">
						
<article class="entry-tpl-grid entry-tpl-grid-xxs post-86737 post type-post status-publish format-standard has-post-thumbnail category-music category-interviews category-news tag-bad-news tag-plxygrnd">
	<div class="entry-featured-media " ><a title="South Africa&#8217;s producer duo PLXYGRND share musical origins, placements, and what&#8217;s to come (Interview)" class="g1-frame" href="https://grungecake.com/plxygrnd-interview/articles/86737"><div class="g1-frame-inner"><img width="364" height="205" src="https://grungecake.com/wp-content/uploads/2022/02/plxygrnd-grungecake-thumbnail-364x205.jpg?crop=1" class="attachment-bimber-grid-standard size-bimber-grid-standard wp-post-image" alt="" loading="lazy" srcset="https://grungecake.com/wp-content/uploads/2022/02/plxygrnd-grungecake-thumbnail-364x205.jpg?crop=1 364w, https://grungecake.com/wp-content/uploads/2022/02/plxygrnd-grungecake-thumbnail-192x108.jpg?crop=1 192w, https://grungecake.com/wp-content/uploads/2022/02/plxygrnd-grungecake-thumbnail-384x216.jpg?crop=1 384w, https://grungecake.com/wp-content/uploads/2022/02/plxygrnd-grungecake-thumbnail-728x409.jpg?crop=1 728w, https://grungecake.com/wp-content/uploads/2022/02/plxygrnd-grungecake-thumbnail-561x316.jpg?crop=1 561w, https://grungecake.com/wp-content/uploads/2022/02/plxygrnd-grungecake-thumbnail-1122x631.jpg?crop=1 1122w, https://grungecake.com/wp-content/uploads/2022/02/plxygrnd-grungecake-thumbnail-758x426.jpg?crop=1 758w, https://grungecake.com/wp-content/uploads/2022/02/plxygrnd-grungecake-thumbnail-1152x648.jpg?crop=1 1152w" sizes="(max-width: 364px) 100vw, 364px" data-attachment-id="86879" data-permalink="https://grungecake.com/plxygrnd-interview/articles/86737/plxygrnd-grungecake-thumbnail" data-orig-file="https://grungecake.com/wp-content/uploads/2022/02/plxygrnd-grungecake-thumbnail.jpg" data-orig-size="2048,2048" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="plxygrnd-grungecake-thumbnail" data-image-description="" data-image-caption="&lt;p&gt;Courtesy of the artists&lt;/p&gt;
" data-medium-file="https://grungecake.com/wp-content/uploads/2022/02/plxygrnd-grungecake-thumbnail-300x300.jpg" data-large-file="https://grungecake.com/wp-content/uploads/2022/02/plxygrnd-grungecake-thumbnail-1024x1024.jpg" /><span class="g1-frame-icon g1-frame-icon-"></span></div></a></div>
		
	<div class="entry-body">
		<header class="entry-header">
			<div class="entry-before-title">
				
							</div>

		<h3 class="g1-epsilon g1-epsilon-1st entry-title"><a href="https://grungecake.com/plxygrnd-interview/articles/86737" rel="bookmark">South Africa&#8217;s producer duo PLXYGRND share musical origins, placements, and what&#8217;s to come (Interview)</a></h3>		</header>

		
					<footer>
				<p class="g1-meta entry-meta entry-byline entry-byline-with-avatar">
								<span class="entry-author">
	
		<span class="entry-meta-label">by</span>
			<a href="https://grungecake.com/author/mufaro-forbes-mujuru" title="Posts by Mufaro &quot;Forbes&quot; Mujuru" rel="author">
			<img alt='' src='https://grungecake.com/wp-content/uploads/2021/12/forbes-profile-icon-grungecake-30x30.png' srcset='https://grungecake.com/wp-content/uploads/2021/12/forbes-profile-icon-grungecake-60x60.png 2x' class='avatar avatar-30 photo' height='30' width='30' loading='lazy'/>
							<strong>Mufaro &quot;Forbes&quot; Mujuru</strong>
					</a>
	</span>
	
					<time class="entry-date" datetime="2022-02-17T13:55:36-05:00">17th February 2022, 1:55 PM</time>				</p>
			</footer>
		
			</div>
</article>
					</li>
									<li class="g1-collection-item">
						
<article class="entry-tpl-grid entry-tpl-grid-xxs post-85856 post type-post status-publish format-standard has-post-thumbnail category-interviews category-news category-television tag-catching-up-with-richardine tag-dr-cheyenne-bryant tag-mtv tag-richardine tag-richardine-bartee tag-teen-mom">
	<div class="entry-featured-media " ><a title="Dr Cheyenne Bryant talks MTV&#8217;s Teen Mom Family Reunion, mental health and therapy (Interview)" class="g1-frame" href="https://grungecake.com/mtv-teen-mom-family-reunion-catching-up-with-richardine-launch/articles/85856"><div class="g1-frame-inner"><img width="364" height="205" src="https://grungecake.com/wp-content/uploads/2022/01/catching-up-with-richardine-mtv-teen-mom-family-reunion-grungecake-thumbnail-364x205.png?crop=1" class="attachment-bimber-grid-standard size-bimber-grid-standard wp-post-image" alt="" loading="lazy" srcset="https://grungecake.com/wp-content/uploads/2022/01/catching-up-with-richardine-mtv-teen-mom-family-reunion-grungecake-thumbnail-364x205.png?crop=1 364w, https://grungecake.com/wp-content/uploads/2022/01/catching-up-with-richardine-mtv-teen-mom-family-reunion-grungecake-thumbnail-192x108.png?crop=1 192w, https://grungecake.com/wp-content/uploads/2022/01/catching-up-with-richardine-mtv-teen-mom-family-reunion-grungecake-thumbnail-384x216.png?crop=1 384w, https://grungecake.com/wp-content/uploads/2022/01/catching-up-with-richardine-mtv-teen-mom-family-reunion-grungecake-thumbnail-728x409.png?crop=1 728w, https://grungecake.com/wp-content/uploads/2022/01/catching-up-with-richardine-mtv-teen-mom-family-reunion-grungecake-thumbnail-561x316.png?crop=1 561w, https://grungecake.com/wp-content/uploads/2022/01/catching-up-with-richardine-mtv-teen-mom-family-reunion-grungecake-thumbnail-758x426.png?crop=1 758w" sizes="(max-width: 364px) 100vw, 364px" data-attachment-id="85865" data-permalink="https://grungecake.com/mtv-teen-mom-family-reunion-catching-up-with-richardine-launch/articles/85856/catching-up-with-richardine-mtv-teen-mom-family-reunion-grungecake-thumbnail" data-orig-file="https://grungecake.com/wp-content/uploads/2022/01/catching-up-with-richardine-mtv-teen-mom-family-reunion-grungecake-thumbnail.png" data-orig-size="810,1438" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="catching-up-with-richardine-mtv-teen-mom-family-reunion-grungecake-thumbnail" data-image-description="" data-image-caption="" data-medium-file="https://grungecake.com/wp-content/uploads/2022/01/catching-up-with-richardine-mtv-teen-mom-family-reunion-grungecake-thumbnail-169x300.png" data-large-file="https://grungecake.com/wp-content/uploads/2022/01/catching-up-with-richardine-mtv-teen-mom-family-reunion-grungecake-thumbnail-577x1024.png" /><span class="g1-frame-icon g1-frame-icon-"></span></div></a></div>
		
	<div class="entry-body">
		<header class="entry-header">
			<div class="entry-before-title">
				
							</div>

		<h3 class="g1-epsilon g1-epsilon-1st entry-title"><a href="https://grungecake.com/mtv-teen-mom-family-reunion-catching-up-with-richardine-launch/articles/85856" rel="bookmark">Dr Cheyenne Bryant talks MTV&#8217;s Teen Mom Family Reunion, mental health and therapy (Interview)</a></h3>		</header>

		
					<footer>
				<p class="g1-meta entry-meta entry-byline entry-byline-with-avatar">
								<span class="entry-author">
	
		<span class="entry-meta-label">by</span>
			<a href="https://grungecake.com/author/richardine" title="Posts by Richardine Bartee" rel="author">
			<img alt='' src='https://grungecake.com/wp-content/uploads/2022/01/richardine-bartee-2022-grungecake-ceo-30x30.jpg' srcset='https://grungecake.com/wp-content/uploads/2022/01/richardine-bartee-2022-grungecake-ceo-60x60.jpg 2x' class='avatar avatar-30 photo' height='30' width='30' loading='lazy'/>
							<strong>Richardine Bartee</strong>
					</a>
	</span>
	
					<time class="entry-date" datetime="2022-01-11T16:41:40-05:00">11th January 2022, 4:41 PM</time>				</p>
			</footer>
		
			</div>
</article>
					</li>
									<li class="g1-collection-item">
						
<article class="entry-tpl-grid entry-tpl-grid-xxs post-83500 post type-post status-publish format-standard has-post-thumbnail category-interviews category-music category-music-videos tag-alcohol tag-joeboy tag-show-me tag-sip-alcohol tag-somewhere-between-beauty-magic tag-tempoe">
	<div class="entry-featured-media " ><a title="Nigeria has a humble music star on its hands, and his name is Joeboy (Interview)" class="g1-frame" href="https://grungecake.com/joeboy-interview/articles/83500"><div class="g1-frame-inner"><img width="364" height="205" src="https://grungecake.com/wp-content/uploads/2021/10/joeboy-richardine-grungecake-la-thumbnail-364x205.jpg?crop=1" class="attachment-bimber-grid-standard size-bimber-grid-standard wp-post-image" alt="" loading="lazy" srcset="https://grungecake.com/wp-content/uploads/2021/10/joeboy-richardine-grungecake-la-thumbnail-364x205.jpg?crop=1 364w, https://grungecake.com/wp-content/uploads/2021/10/joeboy-richardine-grungecake-la-thumbnail-192x108.jpg?crop=1 192w, https://grungecake.com/wp-content/uploads/2021/10/joeboy-richardine-grungecake-la-thumbnail-384x216.jpg?crop=1 384w, https://grungecake.com/wp-content/uploads/2021/10/joeboy-richardine-grungecake-la-thumbnail-728x409.jpg?crop=1 728w, https://grungecake.com/wp-content/uploads/2021/10/joeboy-richardine-grungecake-la-thumbnail-561x316.jpg?crop=1 561w, https://grungecake.com/wp-content/uploads/2021/10/joeboy-richardine-grungecake-la-thumbnail-1122x631.jpg?crop=1 1122w, https://grungecake.com/wp-content/uploads/2021/10/joeboy-richardine-grungecake-la-thumbnail-758x426.jpg?crop=1 758w, https://grungecake.com/wp-content/uploads/2021/10/joeboy-richardine-grungecake-la-thumbnail-1152x648.jpg?crop=1 1152w" sizes="(max-width: 364px) 100vw, 364px" data-attachment-id="83508" data-permalink="https://grungecake.com/joeboy-interview/articles/83500/joeboy-richardine-grungecake-la-thumbnail" data-orig-file="https://grungecake.com/wp-content/uploads/2021/10/joeboy-richardine-grungecake-la-thumbnail.jpg" data-orig-size="7360,4912" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;2.8&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;NIKON D800&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;1633782878&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;35&quot;,&quot;iso&quot;:&quot;400&quot;,&quot;shutter_speed&quot;:&quot;0.003125&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="joeboy-richardine-grungecake-la-thumbnail" data-image-description="" data-image-caption="&lt;p&gt;Photos: &lt;a href=&quot;https://www.instagram.com/onegungutty&quot; target=&quot;_blank&quot; rel=&quot;noopener&quot;&gt;George Lee for GRUNGECAKE&lt;/a&gt;&lt;/p&gt;
" data-medium-file="https://grungecake.com/wp-content/uploads/2021/10/joeboy-richardine-grungecake-la-thumbnail-300x200.jpg" data-large-file="https://grungecake.com/wp-content/uploads/2021/10/joeboy-richardine-grungecake-la-thumbnail-1024x683.jpg" /><span class="g1-frame-icon g1-frame-icon-"></span></div></a></div>
		
	<div class="entry-body">
		<header class="entry-header">
			<div class="entry-before-title">
				
							</div>

		<h3 class="g1-epsilon g1-epsilon-1st entry-title"><a href="https://grungecake.com/joeboy-interview/articles/83500" rel="bookmark">Nigeria has a humble music star on its hands, and his name is Joeboy (Interview)</a></h3>		</header>

		
					<footer>
				<p class="g1-meta entry-meta entry-byline entry-byline-with-avatar">
								<span class="entry-author">
	
		<span class="entry-meta-label">by</span>
			<a href="https://grungecake.com/author/richardine" title="Posts by Richardine Bartee" rel="author">
			<img alt='' src='https://grungecake.com/wp-content/uploads/2022/01/richardine-bartee-2022-grungecake-ceo-30x30.jpg' srcset='https://grungecake.com/wp-content/uploads/2022/01/richardine-bartee-2022-grungecake-ceo-60x60.jpg 2x' class='avatar avatar-30 photo' height='30' width='30' loading='lazy'/>
							<strong>Richardine Bartee</strong>
					</a>
	</span>
	
					<time class="entry-date" datetime="2021-10-18T14:18:24-05:00">18th October 2021, 2:18 PM</time>				</p>
			</footer>
		
			</div>
</article>
					</li>
									<li class="g1-collection-item">
						
<article class="entry-tpl-grid entry-tpl-grid-xxs post-82465 post type-post status-publish format-standard has-post-thumbnail category-albums category-interviews category-music-videos tag-cico-p tag-nawfjaxx tag-palm-angel tag-tampa">
	<div class="entry-featured-media " ><a title="East Texas rapper Cico P on his unique &#8216;Boogie Avenue&#8217; style, and juggling success and his personal life (Interview)" class="g1-frame" href="https://grungecake.com/cico-p-interview/articles/82465"><div class="g1-frame-inner"><img width="364" height="205" src="https://grungecake.com/wp-content/uploads/2021/09/cico-p-grungecake-thumbnail-profile-364x205.jpg?crop=1" class="attachment-bimber-grid-standard size-bimber-grid-standard wp-post-image" alt="" loading="lazy" srcset="https://grungecake.com/wp-content/uploads/2021/09/cico-p-grungecake-thumbnail-profile-364x205.jpg?crop=1 364w, https://grungecake.com/wp-content/uploads/2021/09/cico-p-grungecake-thumbnail-profile-192x108.jpg?crop=1 192w, https://grungecake.com/wp-content/uploads/2021/09/cico-p-grungecake-thumbnail-profile-384x216.jpg?crop=1 384w, https://grungecake.com/wp-content/uploads/2021/09/cico-p-grungecake-thumbnail-profile-728x409.jpg?crop=1 728w, https://grungecake.com/wp-content/uploads/2021/09/cico-p-grungecake-thumbnail-profile-561x316.jpg?crop=1 561w, https://grungecake.com/wp-content/uploads/2021/09/cico-p-grungecake-thumbnail-profile-1122x631.jpg?crop=1 1122w, https://grungecake.com/wp-content/uploads/2021/09/cico-p-grungecake-thumbnail-profile-758x426.jpg?crop=1 758w, https://grungecake.com/wp-content/uploads/2021/09/cico-p-grungecake-thumbnail-profile-1152x648.jpg?crop=1 1152w" sizes="(max-width: 364px) 100vw, 364px" data-attachment-id="82566" data-permalink="https://grungecake.com/cico-p-interview/articles/82465/cico-p-grungecake-thumbnail-profile" data-orig-file="https://grungecake.com/wp-content/uploads/2021/09/cico-p-grungecake-thumbnail-profile.jpg" data-orig-size="1708,2560" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="cico-p-grungecake-thumbnail-profile" data-image-description="" data-image-caption="" data-medium-file="https://grungecake.com/wp-content/uploads/2021/09/cico-p-grungecake-thumbnail-profile-200x300.jpg" data-large-file="https://grungecake.com/wp-content/uploads/2021/09/cico-p-grungecake-thumbnail-profile-683x1024.jpg" /><span class="g1-frame-icon g1-frame-icon-"></span></div></a></div>
		
	<div class="entry-body">
		<header class="entry-header">
			<div class="entry-before-title">
				
							</div>

		<h3 class="g1-epsilon g1-epsilon-1st entry-title"><a href="https://grungecake.com/cico-p-interview/articles/82465" rel="bookmark">East Texas rapper Cico P on his unique &#8216;Boogie Avenue&#8217; style, and juggling success and his personal life (Interview)</a></h3>		</header>

		
					<footer>
				<p class="g1-meta entry-meta entry-byline entry-byline-with-avatar">
								<span class="entry-author">
	
		<span class="entry-meta-label">by</span>
			<a href="https://grungecake.com/author/andy-alexis" title="Posts by Andy Alexis" rel="author">
			<img alt='' src='https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-30x30.png' srcset='https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-60x60.png 2x' class='avatar avatar-30 photo' height='30' width='30' loading='lazy'/>
							<strong>Andy Alexis</strong>
					</a>
	</span>
	
					<time class="entry-date" datetime="2021-09-21T18:00:38-05:00">21st September 2021, 6:00 PM</time>				</p>
			</footer>
		
			</div>
</article>
					</li>
							</ul>
		</div>
	</div><!-- .g1-collection -->
							</div>
			</aside></div><!-- #secondary -->

		</div>
	</div><!-- .g1-row -->


	<div class="g1-row g1-row-layout-page g1-row-padding-m g1-promoted-products-section g1-promoted-products-boxed">
		<div class="g1-row-inner">
			<div class="g1-column">
							</div>
		</div>
		<div class="g1-row-background">
		</div>
	</div>


		<div class="g1-footer g1-row g1-row-layout-page">
			<div class="g1-row-inner">
				<div class="g1-column">

					<p class="g1-footer-text">2007-2022 © GRUNGECAKE, INC. The material on this site may not be reproduced, distributed, transmitted, cached or otherwise used, except with the prior written permission of GRUNGECAKE.</p>

											<div class="g1-footer-social">
							<ul id="g1-social-icons-1" class="g1-socials-items g1-socials-items-tpl-grid">
			<li class="g1-socials-item g1-socials-item-facebook">
	   <a class="g1-socials-item-link" href="https://www.facebook.com/grungecake" target="_blank" rel="noopener">
		   <span class="g1-socials-item-icon g1-socials-item-icon-32 g1-socials-item-icon-text g1-socials-item-icon-facebook"></span>
		   <span class="g1-socials-item-tooltip">
			   <span class="g1-socials-item-tooltip-inner">Facebook</span>
		   </span>
	   </a>
	</li>
			<li class="g1-socials-item g1-socials-item-twitter">
	   <a class="g1-socials-item-link" href="https://twitter.com/grungecake" target="_blank" rel="noopener">
		   <span class="g1-socials-item-icon g1-socials-item-icon-32 g1-socials-item-icon-text g1-socials-item-icon-twitter"></span>
		   <span class="g1-socials-item-tooltip">
			   <span class="g1-socials-item-tooltip-inner">Twitter</span>
		   </span>
	   </a>
	</li>
			<li class="g1-socials-item g1-socials-item-instagram">
	   <a class="g1-socials-item-link" href="https://instagram.com/grungecake" target="_blank" rel="noopener">
		   <span class="g1-socials-item-icon g1-socials-item-icon-32 g1-socials-item-icon-text g1-socials-item-icon-instagram"></span>
		   <span class="g1-socials-item-tooltip">
			   <span class="g1-socials-item-tooltip-inner">Instagram</span>
		   </span>
	   </a>
	</li>
	</ul>
						</div>
					
					
					
			<a class="g1-footer-stamp" href="https://grungecake.com" title="GRUNGECAKE, INC">
			<img class="g1-footer-stamp-icon" width="400" height="50" src="https://grungecake.com/wp-content/uploads/2021/12/grungecake-logo-apple-news-branding-yellow.png" loading="lazy" srcset="https://grungecake.com/wp-content/uploads/2021/12/grungecake-logo-apple-news-branding-yellow.png 2x" alt="" />					<span class="g1-footer-stamp-label screen-reader-text">GRUNGECAKE, INC</span>
			</a>

				</div><!-- .g1-column -->
			</div>
			<div class="g1-row-background">
			</div>
		</div><!-- .g1-row -->

					<a href="#page" class="g1-back-to-top">Back to Top</a>
						</div><!-- #page -->

<div class="g1-canvas-overlay">
</div>

</div><!-- .g1-body-inner -->

<div id="g1-breakpoint-desktop">
</div>


<div class="g1-canvas g1-canvas-global g1-canvas-no-js">
	<div class="g1-canvas-inner">
		<div class="g1-canvas-content">
			<a class="g1-canvas-toggle" href="#">Close</a>

			

<div role="search" class="search-form-wrapper">
	<form method="get"
	      class="g1-searchform-tpl-default search-form"
	      action="https://grungecake.com/">
		<label>
			<span class="screen-reader-text">Search for:</span>
			<input type="search" class="search-field"
			       placeholder="Search"
			       value="" name="s"
			       title="Search for:" />
		</label>
		<button class="search-submit">Search</button>
	</form>

	</div>
	<!-- BEGIN .g1-primary-nav -->
	<nav id="g1-canvas-primary-nav" class="g1-primary-nav"><ul id="g1-canvas-primary-nav-menu" class="g1-primary-nav-menu g1-menu-v"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-75536"><a href="https://grungecake.com">Home</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-76770"><a href="mailto:assistant@grungecake.com">Contact</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-66675"><a href="https://grungecake.com/category/music/premieres">Premieres</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62328"><a href="https://grungecake.com/category/recording-academy">Recording Academy</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-61863"><a href="https://grungecake.com/category/features/sound-searching-columns/song-of-the-day">Song of the Day</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent afs-menu-item-has-children menu-item-53656"><a href="https://grungecake.com/category/music">Music</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56942"><a href="https://grungecake.com/category/music/music-videos">Music Videos</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom afs-menu-item-has-children menu-item-83995"><a href="#">Beauty</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-83996"><a href="#">Lip Gloss</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom afs-menu-item-has-children menu-item-83992"><a href="#">Agency</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-83994"><a href="#">Marketing</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-83993"><a href="#">Publishing</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-83918"><a title="The $100 Ad" href="https://grungecake.com/product/the-100-ad">The $100 Ad</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-83990"><a href="#">Magazine</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-83991"><a href="#">Merch</a></li>
</ul></nav>		<!-- END .g1-primary-nav -->
		
			<nav class="g1-quick-nav g1-quick-nav-short">
			<ul class="g1-quick-nav-menu g1-menu g1-menu-v g1-menu-with-icons">
				
				                    
					
					
											<li class="menu-item menu-item-type-g1-trending ">
							<a href="https://grungecake.com/s2">
								<span class="entry-flag entry-flag-trending"></span>
								s2							</a>
						</li>
					
							</ul>
		</nav>
	<ul id="g1-social-icons-2" class="g1-socials-items g1-socials-items-tpl-grid g1-socials-s">
			<li class="g1-socials-item g1-socials-item-facebook">
	   <a class="g1-socials-item-link" href="https://www.facebook.com/grungecake" target="_blank" rel="noopener">
		   <span class="g1-socials-item-icon g1-socials-item-icon-48 g1-socials-item-icon-text g1-socials-item-icon-facebook"></span>
		   <span class="g1-socials-item-tooltip">
			   <span class="g1-socials-item-tooltip-inner">Facebook</span>
		   </span>
	   </a>
	</li>
			<li class="g1-socials-item g1-socials-item-twitter">
	   <a class="g1-socials-item-link" href="https://twitter.com/grungecake" target="_blank" rel="noopener">
		   <span class="g1-socials-item-icon g1-socials-item-icon-48 g1-socials-item-icon-text g1-socials-item-icon-twitter"></span>
		   <span class="g1-socials-item-tooltip">
			   <span class="g1-socials-item-tooltip-inner">Twitter</span>
		   </span>
	   </a>
	</li>
			<li class="g1-socials-item g1-socials-item-instagram">
	   <a class="g1-socials-item-link" href="https://instagram.com/grungecake" target="_blank" rel="noopener">
		   <span class="g1-socials-item-icon g1-socials-item-icon-48 g1-socials-item-icon-text g1-socials-item-icon-instagram"></span>
		   <span class="g1-socials-item-tooltip">
			   <span class="g1-socials-item-tooltip-inner">Instagram</span>
		   </span>
	   </a>
	</li>
	</ul>
	<!-- BEGIN .g1-secondary-nav -->
			<!-- END .g1-secondary-nav -->
			</div>
							<div class="g1-canvas-background">
			</div>
			</div>
</div>
<!--  -->
<script defer id='bilmur' data-provider='wordpress.com' data-service='atomic' src='https://s0.wp.com/wp-content/js/bilmur.min.js?m=202208'></script>
<p class="woocommerce-store-notice demo_store" data-notice-id="832a02880a5123a06a9f2c910e8c03fb" style="display:none;">Welcome to GRUNGECAKE.com, a Recording Academy recognised brand known for global music discovery, unique PR strategies and short-stacked hearty articles. <a href="#" class="woocommerce-store-notice__dismiss-link">Dismiss</a></p>	<div style="display:none">
			<div class="grofile-hash-map-0721da3da13cd62a71e131418d4eeeb5">
		</div>
		<div class="grofile-hash-map-81c1f162ae15ca20f6113cc592ec82a5">
		</div>
		<div class="grofile-hash-map-ea4fef7f0dd6af6ab13219ecc5082bef">
		</div>
		<div class="grofile-hash-map-99be6450fcb4104fabedb113fe791c73">
		</div>
		</div>
			<script type="text/javascript">
		(function () {
			var c = document.body.className;
			c = c.replace(/woocommerce-no-js/, 'woocommerce-js');
			document.body.className = c;
		})();
	</script>
			<div id="jp-carousel-loading-overlay">
			<div id="jp-carousel-loading-wrapper">
				<span id="jp-carousel-library-loading">&nbsp;</span>
			</div>
		</div>
		<div class="jp-carousel-overlay jp-carousel-light" style="display: none;">

		<div class="jp-carousel-container jp-carousel-light">
			<!-- The Carousel Swiper -->
			<div
				class="jp-carousel-wrap swiper-container jp-carousel-swiper-container jp-carousel-transitions"
				itemscope
				itemtype="https://schema.org/ImageGallery">
				<div class="jp-carousel swiper-wrapper"></div>
				<div class="jp-swiper-button-prev swiper-button-prev">
					<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
						<mask id="maskPrev" mask-type="alpha" maskUnits="userSpaceOnUse" x="8" y="6" width="9" height="12">
							<path d="M16.2072 16.59L11.6496 12L16.2072 7.41L14.8041 6L8.8335 12L14.8041 18L16.2072 16.59Z" fill="white"/>
						</mask>
						<g mask="url(#maskPrev)">
							<rect x="0.579102" width="23.8823" height="24" fill="#FFFFFF"/>
						</g>
					</svg>
				</div>
				<div class="jp-swiper-button-next swiper-button-next">
					<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
						<mask id="maskNext" mask-type="alpha" maskUnits="userSpaceOnUse" x="8" y="6" width="8" height="12">
							<path d="M8.59814 16.59L13.1557 12L8.59814 7.41L10.0012 6L15.9718 12L10.0012 18L8.59814 16.59Z" fill="white"/>
						</mask>
						<g mask="url(#maskNext)">
							<rect x="0.34375" width="23.8822" height="24" fill="#FFFFFF"/>
						</g>
					</svg>
				</div>
			</div>
			<!-- The main close buton -->
			<div class="jp-carousel-close-hint">
				<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
					<mask id="maskClose" mask-type="alpha" maskUnits="userSpaceOnUse" x="5" y="5" width="15" height="14">
						<path d="M19.3166 6.41L17.9135 5L12.3509 10.59L6.78834 5L5.38525 6.41L10.9478 12L5.38525 17.59L6.78834 19L12.3509 13.41L17.9135 19L19.3166 17.59L13.754 12L19.3166 6.41Z" fill="white"/>
					</mask>
					<g mask="url(#maskClose)">
						<rect x="0.409668" width="23.8823" height="24" fill="#FFFFFF"/>
					</g>
				</svg>
			</div>
			<!-- Image info, comments and meta -->
			<div class="jp-carousel-info">
				<div class="jp-carousel-info-footer">
					<div class="jp-carousel-pagination-container">
						<div class="jp-swiper-pagination swiper-pagination"></div>
						<div class="jp-carousel-pagination"></div>
					</div>
					<div class="jp-carousel-photo-title-container">
						<h2 class="jp-carousel-photo-caption"></h2>
					</div>
					<div class="jp-carousel-photo-icons-container">
						<a href="#" class="jp-carousel-icon-btn jp-carousel-icon-info" aria-label="Toggle photo metadata visibility">
							<span class="jp-carousel-icon">
								<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
									<mask id="maskInfo" mask-type="alpha" maskUnits="userSpaceOnUse" x="2" y="2" width="21" height="20">
										<path fill-rule="evenodd" clip-rule="evenodd" d="M12.7537 2C7.26076 2 2.80273 6.48 2.80273 12C2.80273 17.52 7.26076 22 12.7537 22C18.2466 22 22.7046 17.52 22.7046 12C22.7046 6.48 18.2466 2 12.7537 2ZM11.7586 7V9H13.7488V7H11.7586ZM11.7586 11V17H13.7488V11H11.7586ZM4.79292 12C4.79292 16.41 8.36531 20 12.7537 20C17.142 20 20.7144 16.41 20.7144 12C20.7144 7.59 17.142 4 12.7537 4C8.36531 4 4.79292 7.59 4.79292 12Z" fill="white"/>
									</mask>
									<g mask="url(#maskInfo)">
										<rect x="0.8125" width="23.8823" height="24" fill="#FFFFFF"/>
									</g>
								</svg>
							</span>
						</a>
												<a href="#" class="jp-carousel-icon-btn jp-carousel-icon-comments" aria-label="Toggle photo comments visibility">
							<span class="jp-carousel-icon">
								<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
									<mask id="maskComments" mask-type="alpha" maskUnits="userSpaceOnUse" x="2" y="2" width="21" height="20">
										<path fill-rule="evenodd" clip-rule="evenodd" d="M4.3271 2H20.2486C21.3432 2 22.2388 2.9 22.2388 4V16C22.2388 17.1 21.3432 18 20.2486 18H6.31729L2.33691 22V4C2.33691 2.9 3.2325 2 4.3271 2ZM6.31729 16H20.2486V4H4.3271V18L6.31729 16Z" fill="white"/>
									</mask>
									<g mask="url(#maskComments)">
										<rect x="0.34668" width="23.8823" height="24" fill="#FFFFFF"/>
									</g>
								</svg>

								<span class="jp-carousel-has-comments-indicator" aria-label="This image has comments."></span>
							</span>
						</a>
											</div>
				</div>
				<div class="jp-carousel-info-extra">
					<div class="jp-carousel-info-content-wrapper">
						<div class="jp-carousel-photo-title-container">
							<h2 class="jp-carousel-photo-title"></h2>
						</div>
						<div class="jp-carousel-comments-wrapper">
															<div id="jp-carousel-comments-loading">
									<span>Loading Comments...</span>
								</div>
								<div class="jp-carousel-comments"></div>
								<div id="jp-carousel-comment-form-container">
									<span id="jp-carousel-comment-form-spinner">&nbsp;</span>
									<div id="jp-carousel-comment-post-results"></div>
																														<form id="jp-carousel-comment-form">
												<label for="jp-carousel-comment-form-comment-field" class="screen-reader-text">Write a Comment...</label>
												<textarea
													name="comment"
													class="jp-carousel-comment-form-field jp-carousel-comment-form-textarea"
													id="jp-carousel-comment-form-comment-field"
													placeholder="Write a Comment..."
												></textarea>
												<div id="jp-carousel-comment-form-submit-and-info-wrapper">
													<div id="jp-carousel-comment-form-commenting-as">
																													<fieldset>
																<label for="jp-carousel-comment-form-email-field">Email (Required)</label>
																<input type="text" name="email" class="jp-carousel-comment-form-field jp-carousel-comment-form-text-field" id="jp-carousel-comment-form-email-field" />
															</fieldset>
															<fieldset>
																<label for="jp-carousel-comment-form-author-field">Name (Required)</label>
																<input type="text" name="author" class="jp-carousel-comment-form-field jp-carousel-comment-form-text-field" id="jp-carousel-comment-form-author-field" />
															</fieldset>
															<fieldset>
																<label for="jp-carousel-comment-form-url-field">Website</label>
																<input type="text" name="url" class="jp-carousel-comment-form-field jp-carousel-comment-form-text-field" id="jp-carousel-comment-form-url-field" />
															</fieldset>
																											</div>
													<input
														type="submit"
														name="submit"
														class="jp-carousel-comment-form-button"
														id="jp-carousel-comment-form-button-submit"
														value="Post Comment" />
												</div>
											</form>
																											</div>
													</div>
						<div class="jp-carousel-image-meta">
							<div class="jp-carousel-title-and-caption">
								<div class="jp-carousel-photo-info">
									<h3 class="jp-carousel-caption" itemprop="caption description"></h3>
								</div>

								<div class="jp-carousel-photo-description"></div>
							</div>
							<ul class="jp-carousel-image-exif" style="display: none;"></ul>
							<a class="jp-carousel-image-download" target="_blank" style="display: none;">
								<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
									<mask id="mask0" mask-type="alpha" maskUnits="userSpaceOnUse" x="3" y="3" width="19" height="18">
										<path fill-rule="evenodd" clip-rule="evenodd" d="M5.84615 5V19H19.7775V12H21.7677V19C21.7677 20.1 20.8721 21 19.7775 21H5.84615C4.74159 21 3.85596 20.1 3.85596 19V5C3.85596 3.9 4.74159 3 5.84615 3H12.8118V5H5.84615ZM14.802 5V3H21.7677V10H19.7775V6.41L9.99569 16.24L8.59261 14.83L18.3744 5H14.802Z" fill="white"/>
									</mask>
									<g mask="url(#mask0)">
										<rect x="0.870605" width="23.8823" height="24" fill="#FFFFFF"/>
									</g>
								</svg>
								<span class="jp-carousel-download-text"></span>
							</a>
							<div class="jp-carousel-image-map" style="display: none;"></div>
						</div>
					</div>
				</div>
			</div>
		</div>

		</div>
		
	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/grungecake.com\/tafia-been-on-it\/articles\/86973":86973};
	</script>
					<div id="sharing_email" style="display: none;">
		<form action="/tafia-been-on-it/articles/86973" method="post">
			<label for="target_email">Send to Email Address</label>
			<input type="email" name="target_email" id="target_email" value="" />

			
				<label for="source_name">Your Name</label>
				<input type="text" name="source_name" id="source_name" value="" />

				<label for="source_email">Your Email Address</label>
				<input type="email" name="source_email" id="source_email" value="" />

						<input type="text" id="jetpack-source_f_name" name="source_f_name" class="input" value="" size="25" autocomplete="off" title="This field is for validation and should not be changed" />
			
			<img style="float: right; display: none" class="loading" src="https://grungecake.com/wp-content/plugins/jetpack/modules/sharedaddy/images/loading.gif" alt="loading" width="16" height="16" />
			<input type="submit" value="Send Email" class="sharing_send" />
			<a rel="nofollow" href="#cancel" class="sharing_cancel" role="button">Cancel</a>

			<div class="errors errors-1" style="display: none;">
				Post was not sent - check your email addresses!			</div>

			<div class="errors errors-2" style="display: none;">
				Email check failed, please try again			</div>

			<div class="errors errors-3" style="display: none;">
				Sorry, your blog cannot share posts by email.			</div>
		</form>
	</div>
		<link rel='stylesheet' id='all-css-744dfed63184fac2ef2c257681e6b95e' href='https://grungecake.com/_static/??-eJyVzMEOwiAQhOEXkm7Q1MaD8VnosmlQWAgD4fXrwR5N9Dp/vhnFcNYm2qjEvgUFPaUVxy9K2fcoIHY1d0gkjFCkmrWrjzIxcBp/6E8wx/DtYLMGmYOLbwsQuIqoWR0CTynor0xd4ezlII90t9eLXebbeV52ej5b4g==' type='text/css' media='all' />
<link rel='stylesheet' id='afsmenu-font-awesome-css'  href='//cdnjs.cloudflare.com/ajax/libs/font-awesome/4.7.0/css/font-awesome.min.css?ver=5.9.1' media='all' />
<script id='contact-form-7-js-extra'>
var wpcf7 = {"api":{"root":"https:\/\/grungecake.com\/wp-json\/","namespace":"contact-form-7\/v1"},"cached":"1"};
</script>
<script id='wc-add-to-cart-js-extra'>
var wc_add_to_cart_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/?wc-ajax=%%endpoint%%","i18n_view_cart":"View basket","cart_url":"https:\/\/grungecake.com","is_cart":"","cart_redirect_after_add":"no"};
</script>
<script id='woocommerce-js-extra'>
var woocommerce_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/?wc-ajax=%%endpoint%%"};
</script>
<script type='text/javascript'  src='https://grungecake.com/_static/??-eJydj11OAzEMhC+EN60E274gnjkABwiJt/I2sRfH6ba3ZwmVWIk/wZvH/mY0nicIwoZsbkr1QFxckOck4VhcpGJu/FiAZ8reSLgby808AXFINWJ5gxp8Qo6iTvGAjOpNFLSyUcYu02+u5TRJugyU0or+3I7NB4NBNMPOrcOII56/sc0iQXJGDeh8KWjNMb5U1Au09ypdZdfk0+MPJb5OG7Rh0fkYwQSCV/tzyFgWUI6Ey9S9T/8vsjpfQx7y/ba/veu3m32/ewVam8Et'></script>
<script id='wc-cart-fragments-js-extra'>
var wc_cart_fragments_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/?wc-ajax=%%endpoint%%","cart_hash_key":"wc_cart_hash_8aa51e7d337bd9a619bf9006a73e3b44","fragment_name":"wc_fragments_8aa51e7d337bd9a619bf9006a73e3b44","request_timeout":"5000"};
</script>
<script src='https://grungecake.com/wp-content/plugins/woocommerce/assets/js/frontend/cart-fragments.min.js?ver=6.2.1' id='wc-cart-fragments-js'></script>
<script id='wc-cart-fragments-js-after'>
		jQuery( 'body' ).bind( 'wc_fragments_refreshed', function() {
			var jetpackLazyImagesLoadEvent;
			try {
				jetpackLazyImagesLoadEvent = new Event( 'jetpack-lazy-images-load', {
					bubbles: true,
					cancelable: true
				} );
			} catch ( e ) {
				jetpackLazyImagesLoadEvent = document.createEvent( 'Event' )
				jetpackLazyImagesLoadEvent.initEvent( 'jetpack-lazy-images-load', true, true );
			}
			jQuery( 'body' ).get( 0 ).dispatchEvent( jetpackLazyImagesLoadEvent );
		} );
		
</script>
<script id='mailchimp-woocommerce-js-extra'>
var mailchimp_public_data = {"site_url":"https:\/\/grungecake.com","ajax_url":"https:\/\/grungecake.com\/wp-admin\/admin-ajax.php","language":"en","allowed_to_set_cookies":"1"};
</script>
<script type='text/javascript'  src='https://grungecake.com/wp-content/plugins/mailchimp-for-woocommerce/public/js/mailchimp-woocommerce-public.min.js?m=1637698708'></script>
<script src='https://secure.gravatar.com/js/gprofiles.js?ver=202208' id='grofiles-cards-js'></script>
<script id='wpgroho-js-extra'>
var WPGroHo = {"my_hash":""};
</script>
<script id='bimber-global-js-extra'>
var bimber_front_config = "{\"ajax_url\":\"https:\\\/\\\/grungecake.com\\\/wp-admin\\\/admin-ajax.php\",\"timeago\":\"on\",\"sharebar\":\"off\",\"i18n\":{\"menu\":{\"go_to\":\"Go to\"},\"newsletter\":{\"subscribe_mail_subject_tpl\":\"Check out this great article: %subject%\"},\"bp_profile_nav\":{\"more_link\":\"More\"}},\"comment_types\":[\"wp\"],\"auto_load_limit\":5,\"auto_play_videos\":\"\",\"use_gif_player\":true,\"setTargetBlank\":\"1\",\"useWaypoints\":\"1\",\"stack\":\"carmania\"}";
</script>
<script type='text/javascript'  src='https://grungecake.com/_static/??-eJydU+1uhCAQfKEqaWtM/zR9FoQ9XV1Yjo8Y3r7cVRN711avvxiWmQGGZXaVYhvBRuEo9WiDGCE6qSZhWCeCIGbXex64HsPT7Cq0ipIu5TEIxcYUZeXBUa4N2oWzOsYBTGF2aDrwF0GIqKZ8QqINPCIczwl8rh1JBQOTLtUNDvWyftwpogHZ8830QTGxkpeEbkxg9xBGRjUY0Cg38H8iqTVhKArwewYOVUwervFv8AOpzTI7RhvvC0dMCLseT8uwRwZ7TuhhHY/498SdpN0USOZry9y189edRMLS2N92/JlUWj/9QtLlRYRmU36G1Pkv0sA8reF9mPfntnl9a9q2efkETmddjw=='></script>
<script src='https://grungecake.com/wp-includes/js/dist/i18n.min.js?ver=30fcecb428a0e8383d3776bcdd3a7834' id='wp-i18n-js'></script>
<script id='wp-i18n-js-after'>
wp.i18n.setLocaleData( { 'text direction\u0004ltr': [ 'ltr' ] } );
</script>
<script id='wp-a11y-js-translations'>
( function( domain, translations ) {
	var localeData = translations.locale_data[ domain ] || translations.locale_data.messages;
	localeData[""].domain = domain;
	wp.i18n.setLocaleData( localeData, domain );
} )( "default", {"translation-revision-date":"2022-02-18 08:36:22+0000","generator":"GlotPress\/3.0.0-alpha.2","domain":"messages","locale_data":{"messages":{"":{"domain":"messages","plural-forms":"nplurals=2; plural=n != 1;","lang":"en_GB"},"Notifications":["Notifications"]}},"comment":{"reference":"wp-includes\/js\/dist\/a11y.js"}} );
</script>
<script src='https://grungecake.com/wp-includes/js/dist/a11y.min.js?ver=68e470cf840f69530e9db3be229ad4b6' id='wp-a11y-js'></script>
<script id='jquery-ui-autocomplete-js-extra'>
var uiAutocompleteL10n = {"noResults":"No results found.","oneResult":"1 result found. Use up and down arrow keys to navigate.","manyResults":"%d results found. Use up and down arrow keys to navigate.","itemSelected":"Item selected."};
</script>
<script type='text/javascript'  src='https://grungecake.com/_static/??wp-includes/js/jquery/ui/autocomplete.min.js,wp-content/themes/bimber/js/ajax-search.js,wp-content/themes/bimber/js/single.js?m=1643846642'></script>
<script src='https://grungecake.com/wp-content/plugins/easy-social-share-buttons3/assets/js/essb-core.min.js?ver=7.4' id='easy-social-share-buttons-core-js'></script>
<script id='easy-social-share-buttons-core-js-after'>
var essb_settings = {"ajax_url":"https:\/\/grungecake.com\/wp-admin\/admin-ajax.php","essb3_nonce":"811c506ef2","essb3_plugin_url":"https:\/\/grungecake.com\/wp-content\/plugins\/easy-social-share-buttons3","essb3_facebook_total":false,"essb3_admin_ajax":false,"essb3_internal_counter":true,"essb3_counter_button_min":0,"essb3_counter_total_min":50,"essb3_no_counter_mailprint":false,"essb3_single_ajax":false,"ajax_type":"wp","twitter_counter":"self","google_counter":"","essb3_stats":false,"essb3_ga":false,"blog_url":"https:\/\/grungecake.com\/","post_id":"86973"};
</script>
<script id='afsmenu-scripts-js-extra'>
var afsmenu = {"autohide_scroll":""};
</script>
<script type='text/javascript'  src='https://grungecake.com/_static/??-eJx9jc0OwiAMgF/IjuEWb8ZnKaxzLFAWWkZ8e52JMfHg/ftpG/jMSqxmi/UeWAyhPECyDxhBFiwErqpmlsGgCKmY9Q/UpcDdKqf2DetCicS4kByVQ24ePBb9wT5/5JBQaYK5xii+EDEk4mrm8ianI8G4v/RbutrLaEfbD/35CeNrS2k='></script>
<script id='site-reviews-js-before'>
window.hasOwnProperty("GLSR")||(window.GLSR={});GLSR.action="glsr_action";GLSR.ajaxpagination=["#wpadminbar",".site-navigation-fixed"];GLSR.ajaxurl="https://grungecake.com/wp-admin/admin-ajax.php";GLSR.nameprefix="site-reviews";GLSR.stars={"clearable":false,"tooltip":false};GLSR.state={"popstate":false};GLSR.urlparameter=true;GLSR.validationconfig={field:"glsr-field",form:"glsr-form","field_error":"glsr-field-is-invalid","field_message":"glsr-field-error","field_required":"glsr-required","field_valid":"glsr-field-is-valid","form_error":"glsr-form-is-invalid","form_message":"glsr-form-message","form_message_failed":"glsr-form-failed","form_message_success":"glsr-form-success","input_error":"glsr-is-invalid","input_valid":"glsr-is-valid"};GLSR.validationstrings={accepted:"This field must be accepted.",between:"This field value must be between %s and %s.",betweenlength:"This field must have between %s and %s characters.",email:"This field requires a valid e-mail address.",errors:"Please fix the submission errors.",max:"Maximum value for this field is %s.",maxlength:"This field allows a maximum of %s characters.",min:"Minimum value for this field is %s.",minlength:"This field requires a minimum of %s characters.",number:"This field requires a number.",pattern:"Please match the requested format.",regex:"Please match the requested format.",required:"This field is required.",tel:"This field requires a valid telephone number.",url:"This field requires a valid website URL (make sure it starts with http or https).",unsupported:"The review could not be submitted because this browser is too old. Please try again with a modern browser."};GLSR.version="5.21.3";
</script>
<script src='https://grungecake.com/wp-content/plugins/site-reviews/assets/scripts/site-reviews.js?ver=5.21.3' id='site-reviews-js'></script>
<script id='jetpack-carousel-js-extra'>
var jetpackSwiperLibraryPath = {"url":"https:\/\/grungecake.com\/wp-content\/plugins\/jetpack\/_inc\/build\/carousel\/swiper-bundle.min.js"};
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/grungecake.com\/wp-admin\/admin-ajax.php","nonce":"1df4b01c64","display_exif":"1","display_comments":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"white","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/grungecake.com\/wp-login.php?redirect_to=https%3A%2F%2Fgrungecake.com%2Ftafia-been-on-it%2Farticles%2F86973","blog_id":"1","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"]};
</script>
<script type='text/javascript'  src='https://grungecake.com/_static/??wp-content/plugins/jetpack/_inc/build/carousel/jetpack-carousel.min.js,wp-content/themes/bimber/js/back-to-top.js?m=1638896208'></script>
<script id='sharing-js-js-extra'>
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
</script>
<script src='https://grungecake.com/wp-content/plugins/jetpack/_inc/build/sharedaddy/sharing.min.js?ver=10.7-beta' id='sharing-js-js'></script>
<script id='sharing-js-js-after'>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</script>
<script>!function(){window.advanced_ads_ready_queue=window.advanced_ads_ready_queue||[],advanced_ads_ready_queue.push=window.advanced_ads_ready;for(var d=0,a=advanced_ads_ready_queue.length;d<a;d++)advanced_ads_ready(advanced_ads_ready_queue[d])}();</script><script src='https://stats.wp.com/e-202208.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:10.7-beta',blog:'196905043',post:'86973',tz:'-5',srv:'grungecake.com'} ]);
	_stq.push([ 'clickTrackerInit', '196905043', '86973' ]);
</script>
<div class="essb_mailform" data-error="Please fill all form fields"><div class="essb_mailform_header"><div class="heading">Send this to a friend</div></div><div class="essb_mailform_content"><input type="text" id="essb_mailform_from" class="essb_mailform_content_input" placeholder="Your email"/><input type="text" id="essb_mailform_from_name" class="essb_mailform_content_input" placeholder="Your name"/><input type="text" id="essb_mailform_to" class="essb_mailform_content_input" placeholder="Recipient email"/><div class="essb_mailform_content_buttons"><button id="essb_mailform_btn_submit" class="essb_mailform_content_button" onclick="essb_mailform_send();">Send</button><button id="essb_mailform_btn_cancel" class="essb_mailform_content_button" onclick="essb_close_mailform(); return false;">Cancel</button></div><input type="hidden" id="essb_mail_salt" value="1713924422"/><input type="hidden" id="essb_mail_instance" value=""/><input type="hidden" id="essb_mail_post" value=""/></div></div><div class="essb_mailform_shadow"></div><script type="text/javascript"></script></body>
</html>
<!--
	generated in 1.752 seconds
	248671 bytes batcached for 300 seconds
-->
