<style>
a:link, a:visited {
  background-color: transparent;
  color: #212121;
  text-align: none;
  text-decoration: underline;
	text-decoration-style: solid;
  text-decoration-thickness: 5px;
  text-decoration-color: none;
  display: inline-block;
}

a:hover, a:active {
	color: #FFFFFF !important;
	text-decoration: solid;
	text-decoration-thickness: 5px;
}
	.entry-content a {
    text-decoration: solid;
		text-decoration-thickness: 5px;
}
	
	
</style>

<script type="text/javascript" async="async" src="https://widgets.outbrain.com/outbrain.js"></script>


<center><script data-ad-client="ca-pub-7953118887885734" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script></center>

<!DOCTYPE html>
<!--[if IE 8]>
<html class="no-js g1-off-outside lt-ie10 lt-ie9" id="ie8" lang="en-GB"><![endif]-->
<!--[if IE 9]>
<html class="no-js g1-off-outside lt-ie10" id="ie9" lang="en-GB"><![endif]-->
<!--[if !IE]><!-->
<html class="no-js g1-off-outside" lang="en-GB"><!--<![endif]-->
<head>
	<meta charset="UTF-8"/>
	<link rel="profile" href="http://gmpg.org/xfn/11"/>
	<link rel="pingback" href="https://grungecake.com/xmlrpc.php"/>

	<title>Which NFL club best fit Odell Beckham Jr.? &#8211; GRUNGECAKE</title>
<meta name='robots' content='max-image-preview:large' />
<script>window._wca = window._wca || [];</script>

<meta name="viewport" content="initial-scale=1.0, minimum-scale=1.0, height=device-height, width=device-width" />
<link rel='dns-prefetch' href='//stats.wp.com' />
<link rel='dns-prefetch' href='//secure.gravatar.com' />
<link rel='dns-prefetch' href='//www.googletagmanager.com' />
<link rel='dns-prefetch' href='//polyfill.io' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel='dns-prefetch' href='//c0.wp.com' />
<link rel='dns-prefetch' href='//pagead2.googlesyndication.com' />
<link rel='preconnect' href='https://fonts.gstatic.com' />
<link rel="alternate" type="application/rss+xml" title="GRUNGECAKE &raquo; Feed" href="https://grungecake.com/feed" />
<link rel="alternate" type="application/rss+xml" title="GRUNGECAKE &raquo; Comments Feed" href="https://grungecake.com/comments/feed" />
<link rel="alternate" type="application/rss+xml" title="GRUNGECAKE &raquo; Which NFL club best fit Odell Beckham Jr.? Comments Feed" href="https://grungecake.com/which-nfl-club-best-fit-odell-beckham-jr/articles/83935/feed" />
<link rel="alternate" type="application/rss+xml" title="GRUNGECAKE &raquo; Stories Feed" href="https://grungecake.com/web-stories/feed/">		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/grungecake.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.8.1"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<!-- grungecake.com is managing ads with Advanced Ads --><script id="grung-ready">
			window.advanced_ads_ready=function(e,a){a=a||"complete";var d=function(e){return"interactive"===a?"loading"!==e:"complete"===e};d(document.readyState)?e():document.addEventListener("readystatechange",(function(a){d(a.target.readyState)&&e()}),{once:"interactive"===a})},window.advanced_ads_ready_queue=window.advanced_ads_ready_queue||[];		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='mediaelement-css'  href='https://c0.wp.com/c/5.8.1/wp-includes/js/mediaelement/mediaelementplayer-legacy.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='wp-mediaelement-css'  href='https://c0.wp.com/c/5.8.1/wp-includes/js/mediaelement/wp-mediaelement.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='wc-blocks-vendors-style-css'  href='https://c0.wp.com/p/woocommerce/5.8.0/packages/woocommerce-blocks/build/wc-blocks-vendors-style.css' type='text/css' media='all' />
<link rel='stylesheet' id='wc-blocks-style-css'  href='https://c0.wp.com/p/woocommerce/5.8.0/packages/woocommerce-blocks/build/wc-blocks-style.css' type='text/css' media='all' />
<link rel='stylesheet' id='mpp_gutenberg-css'  href='https://grungecake.com/wp-content/plugins/metronet-profile-picture/dist/blocks.style.build.css?ver=2.6.0' type='text/css' media='all' />
<link rel='stylesheet' id='wpcom-text-widget-styles-css'  href='https://grungecake.com/wp-content/mu-plugins/wpcomsh/vendor/automattic/text-media-widget-styles/css/widget-text.css?ver=20170607' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css'  href='https://grungecake.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.5.2' type='text/css' media='all' />
<style id='woocommerce-inline-inline-css' type='text/css'>
.woocommerce form .form-row .required { visibility: visible; }
</style>
<link rel='stylesheet' id='g1-main-css'  href='https://grungecake.com/wp-content/themes/bimber/css/8.5/styles/original-2018/all-dark.min.css?ver=8.5' type='text/css' media='all' />
<link rel='stylesheet' id='bimber-single-css'  href='https://grungecake.com/wp-content/themes/bimber/css/8.5/styles/original-2018/single-dark.min.css?ver=8.5' type='text/css' media='all' />
<link rel='stylesheet' id='bimber-google-fonts-css'  href='//fonts.googleapis.com/css?family=Roboto%3A400%2C300%2C500%2C600%2C700%2C900%7CSpartan%3A400%2C300%2C600%2C700%2C800&#038;subset&#038;display=swap&#038;ver=8.5' type='text/css' media='all' />
<link rel='stylesheet' id='bimber-dynamic-style-css'  href='https://grungecake.com/wp-content/uploads/dynamic-style-1635919379.css' type='text/css' media='all' />
<link rel='stylesheet' id='bimber-woocommerce-css'  href='https://grungecake.com/wp-content/themes/bimber/css/8.5/styles/original-2018/woocommerce-dark.min.css?ver=8.5' type='text/css' media='all' />
<link rel='stylesheet' id='bimber-mashshare-css'  href='https://grungecake.com/wp-content/themes/bimber/css/8.5/styles/original-2018/mashshare-dark.min.css?ver=8.5' type='text/css' media='all' />
<link rel='stylesheet' id='afsmenu-styles-css'  href='https://grungecake.com/wp-content/plugins/animated-fullscreen-menu/frontend/css/nav.css?ver=2.2.5' type='text/css' media='all' />
<link rel='stylesheet' id='site-reviews-css'  href='https://grungecake.com/wp-content/plugins/site-reviews/assets/styles/default.css?ver=5.16.2' type='text/css' media='all' />
<style id='site-reviews-inline-css' type='text/css'>
.gl-star-rating--stars[class*=" s"]>span,.glsr-star-empty{background-image:url(https://grungecake.com/wp-content/plugins/site-reviews/assets/images/star-empty.svg)!important}.glsr-field-is-invalid .gl-star-rating--stars[class*=" s"]>span{background-image:url(https://grungecake.com/wp-content/plugins/site-reviews/assets/images/star-error.svg)!important}.glsr-star-half{background-image:url(https://grungecake.com/wp-content/plugins/site-reviews/assets/images/star-half.svg)!important}.gl-star-rating--stars.s10>span:first-child,.gl-star-rating--stars.s20>span:nth-child(-1n+2),.gl-star-rating--stars.s30>span:nth-child(-1n+3),.gl-star-rating--stars.s40>span:nth-child(-1n+4),.gl-star-rating--stars.s50>span:nth-child(-1n+5),.gl-star-rating--stars.s60>span:nth-child(-1n+6),.gl-star-rating--stars.s70>span:nth-child(-1n+7),.gl-star-rating--stars.s80>span:nth-child(-1n+8),.gl-star-rating--stars.s90>span:nth-child(-1n+9),.gl-star-rating--stars.s100>span,.glsr-star-full{background-image:url(https://cdn.statically.io/img/grungecake.com/wp-content/plugins/site-reviews/assets/images/star-full.svg)!important}

</style>
<link rel='stylesheet' id='social-logos-css'  href='https://grungecake.com/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=10.4-a.1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://grungecake.com/wp-content/plugins/jetpack/css/jetpack.css?ver=10.4-a.1' type='text/css' media='all' />
<link rel="stylesheet" type="text/css" href="https://grungecake.com/wp-content/plugins/smart-slider-3/Public/SmartSlider3/Application/Frontend/Assets/dist/smartslider.min.css?ver=af21758e" media="all">
<link rel="stylesheet" type="text/css" href="https://fonts.googleapis.com/css?display=swap&amp;family=DM+Sans%3A300%2C400%7CRoboto%3A300%2C400" media="all">
<style data-related="n2-ss-2">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</style>
<script type='text/javascript' id='jetpack_related-posts-js-extra'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://grungecake.com/wp-content/plugins/jetpack/_inc/build/related-posts/related-posts.min.js?ver=20210930' id='jetpack_related-posts-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.8.1/wp-includes/js/jquery/jquery.min.js' id='jquery-core-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.8.1/wp-includes/js/jquery/jquery-migrate.min.js' id='jquery-migrate-js'></script>
<script defer type='text/javascript' src='https://stats.wp.com/s-202144.js' id='woocommerce-analytics-js'></script>
<script type='text/javascript' src='https://grungecake.com/wp-content/themes/bimber/js/modernizr/modernizr-custom.min.js?ver=3.3.0' id='modernizr-js'></script>

<!-- Google Analytics snippet added by Site Kit -->
<script type='text/javascript' src='https://www.googletagmanager.com/gtag/js?id=UA-40407365-1' id='google_gtagjs-js' async></script>
<script type='text/javascript' id='google_gtagjs-js-after'>
window.dataLayer = window.dataLayer || [];function gtag(){dataLayer.push(arguments);}
gtag('set', 'linker', {"domains":["grungecake.com"]} );
gtag("js", new Date());
gtag("set", "developer_id.dZTNiMT", true);
gtag("config", "UA-40407365-1", {"anonymize_ip":true});
</script>

<!-- End Google Analytics snippet added by Site Kit -->
<script type='text/javascript' src='https://polyfill.io/v3/polyfill.min.js?version=3.101.0&#038;features=Array.prototype.find%2CObject.assign%2CCustomEvent%2CElement.prototype.closest%2CElement.prototype.dataset%2CEvent%2CXMLHttpRequest%2CMutationObserver&#038;flags=gated&#038;ver=5.8.1' id='site-reviews/polyfill-js'></script>
<link rel="https://api.w.org/" href="https://grungecake.com/wp-json/" /><link rel="alternate" type="application/json" href="https://grungecake.com/wp-json/wp/v2/posts/83935" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://grungecake.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://grungecake.com/wp-includes/wlwmanifest.xml" /> 
<link rel="canonical" href="https://grungecake.com/which-nfl-club-best-fit-odell-beckham-jr/articles/83935" />
<link rel='shortlink' href='https://wp.me/pdkbZN-lPN' />
<link rel="alternate" type="application/json+oembed" href="https://grungecake.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fgrungecake.com%2Fwhich-nfl-club-best-fit-odell-beckham-jr%2Farticles%2F83935" />
<link rel="alternate" type="text/xml+oembed" href="https://grungecake.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fgrungecake.com%2Fwhich-nfl-club-best-fit-odell-beckham-jr%2Farticles%2F83935&#038;format=xml" />
<style>
.animatedfsmenu a,
.afs-cart-title {
    font-weight: 100 !important;

    }
</style>

<style>
.turbolinks-progress-bar,
.animatedfsmenu {
    background-color: #212121;
}

.animatedfsmenu.navbar-expand-md,
.animatedfsmenu.navbar-expand-ht {
    background-color: #ffcc33;
}

.animatedfsmenu button:focus,
.animatedfsmenu button:hover {
    background: #212121 !important;
}

.animatedfsmenu .animatedfsmenu-navbar-toggler {
    background: #212121;
}

.animatedfs_menu_list a,
.afsmenu_search input[type="text"],
.afs-cart-title {
    color: #FFFFFF !important;
}

.animatedfs_menu_list li>a:before,
.animatedfsmenu .animatedfsmenu-navbar-toggler .bar {
    background: #FFFFFF !important;
}

.animatedfsmenu .privacy_policy {
    color: #FFFFFF;
}

.animatedfsmenu .social-media li {
    border-color: #FFFFFF;
}

.animatedfsmenu.animation_background li>a:before,
.animatedfsmenu.animation_background__border_radius li>a:before {
    background: rgba(0,0,0,0.91) !important;
}
</style>

<div id="animatedfsmenu_css"
    class="animatedfsmenu   align_left   animatedfsmenu__opacity  animatedfsmenu__anchor animation_line">
    <div class="animatedfs_background"></div>
    <button
        class="animatedfsmenu-navbar-toggler right_top"
        type="button">
                <div class="bar top"></div>
        <div class="bar bot"></div>
        <div class="bar mid"></div>
            </button>

    <div class="navbar-collapse animatedfs_menu_list">
                <div class="afsmenu_search">
            <form action="https://grungecake.com" autocomplete="off">
                <input id="search" name="s" type="text" placeholder="Search something...">
                <div class="search_submit">
                    <i class="fas fa-search"></i>
                </div>
            </form>
        </div>
        <div class="menu-grungecake-menu-container"><ul id="menu-grungecake-menu" class="afsmenu"><li id="menu-item-75536" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-75536"><a href="https://grungecake.com">Home</a></li>
<li id="menu-item-76770" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-76770"><a href="mailto:assistant@grungecake.com">Contact</a></li>
<li id="menu-item-66675" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-66675"><a href="https://grungecake.com/category/music/premieres">Premieres</a></li>
<li id="menu-item-62328" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62328"><a href="https://grungecake.com/category/recording-academy">Recording Academy</a></li>
<li id="menu-item-58318" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-58318"><a href="https://grungecake.com/category/editorials/lists/playlists">Playlists</a></li>
<li id="menu-item-61863" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-61863"><a href="https://grungecake.com/category/features/sound-searching-columns/song-of-the-day">Song of the Day</a></li>
<li id="menu-item-53656" class="menu-item menu-item-type-taxonomy menu-item-object-category afs-menu-item-has-children menu-item-53656"><a href="https://grungecake.com/category/music">Music</a>
<ul class="sub-menu">
	<li id="menu-item-56942" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56942"><a href="https://grungecake.com/category/music/music-videos">Music Videos</a></li>
	<li id="menu-item-58314" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-58314"><a href="https://grungecake.com/category/music/streams-and-downloads">Streams and Downloads</a></li>
</ul>
</li>
<li id="menu-item-83918" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-83918"><a title="The $100 Ad" href="https://grungecake.com/product/the-100-ad">The $100 Ad</a></li>
</ul></div>                <div class="social-media">
            <ul>
                                <li>
                    <a href="https://twitter.com/grungecake" title="Twitter"
                        target="_blank">
                        <i class="fa fa-twitter"></i>
                    </a>
                </li>
                                <li>
                    <a href="https://www.instagram.com/grungecake/?hl=en" title="Instagram"
                        target="_blank">
                        <i class="fa fa-instagram"></i>
                    </a>
                </li>
                            </ul>
        </div>
                
    </div>

</div>

				<style type="text/css">
					@font-face {font-family: "Breve Bold";font-display: auto;font-fallback: ;font-weight: 400;src: url(https://grungecake.com/wp-content/uploads/2019/10/BreveText-Bold.ttf) format('TrueType');} @font-face {font-family: "Breve Book";font-display: auto;font-fallback: ;font-weight: 400;src: url(https://grungecake.com/wp-content/uploads/2019/10/BreveText-Book.ttf) format('TrueType');} @font-face {font-family: "Breve Book Italic";font-display: auto;font-fallback: ;font-weight: 400;src: url(https://grungecake.com/wp-content/uploads/2019/10/BreveText-BookItalic.ttf) format('TrueType');} @font-face {font-family: "Chronicle Text G3 Roman Pro";font-display: auto;font-fallback: ;font-weight: 400;src: url(https://grungecake.com/wp-content/uploads/2020/10/ChronicleText-G3-Roman-Pro.ttf) format('TrueType');} @font-face {font-family: "Displace Serif SemiBold";font-display: auto;font-fallback: ;font-weight: 400;src: url(https://grungecake.com/wp-content/uploads/2021/03/Displace-Serif-SemiBold-Desktop.otf) format('OpenType');} @font-face {font-family: "Druk Wide Medium";font-display: auto;font-fallback: ;font-weight: 400;src: url(https://grungecake.com/wp-content/uploads/2021/03/Druk-Wide-Medium-Desktop.otf) format('OpenType');} @font-face {font-family: "Druk Wide Web Medium Regular";font-display: auto;font-fallback: ;font-weight: 400;src: url(https://grungecake.com/wp-content/uploads/2020/10/Druk-Wide-Web-Medium-Regular.ttf) format('TrueType');} @font-face {font-family: "Graphik Web Bold Regular";font-display: auto;font-fallback: ;font-weight: 400;src: url(https://grungecake.com/wp-content/uploads/2020/10/Graphik-Web-Bold-Regular.ttf) format('TrueType');} @font-face {font-family: "LabGrotesque Black";font-display: auto;font-fallback: ;font-weight: 400;src: url(https://grungecake.com/wp-content/uploads/2019/10/LabGrotesque-Black.ttf) format('TrueType');} @font-face {font-family: "LabGrotesque Bold";font-display: auto;font-fallback: ;font-weight: 400;src: url(https://grungecake.com/wp-content/uploads/2019/10/LabGrotesque-Bold.ttf) format('TrueType');} @font-face {font-family: "Noe Regular";font-display: auto;font-fallback: ;font-weight: 400;src: url(https://grungecake.com/wp-content/uploads/2015/04/NoeText-Regular.ttf) format('TrueType');} @font-face {font-family: "Noe Semibold";font-display: swap;font-fallback: ;font-weight: 400;src: url(https://grungecake.com/wp-content/uploads/2015/04/NoeText-Semibold.ttf) format('TrueType');} @font-face {font-family: "Normalidad Text Regular";font-display: auto;font-fallback: ;font-weight: 400;src: url(https://grungecake.com/wp-content/uploads/2021/03/Normalidad-Text-Regular-Desktop.otf) format('OpenType');} @font-face {font-family: "Public Headline Light";font-display: auto;font-fallback: ;font-weight: 400;src: url(https://grungecake.com/wp-content/uploads/2020/12/PublicoHeadline-Light-Web.ttf) format('TrueType');} @font-face {font-family: "Publico Text Roman";font-display: auto;font-fallback: ;font-weight: 400;src: url(https://grungecake.com/wp-content/uploads/2020/12/PublicoText-Roman-Web.ttf) format('TrueType');}				</style>
				<meta name="generator" content="Site Kit by Google 1.44.0" /><script async src='https://s3.amazonaws.com/script-tags/prebidpubs.js'></script>
<script async src='https://securepubads.g.doubleclick.net/tag/js/gpt.js'></script>
<script src='https://s3.amazonaws.com/script-tags/grungecakebidders.js'></script>
<script>
var gptadslots = []; var googletag = googletag || {}; googletag.cmd = googletag.cmd || []; var pbjs = pbjs || {}; pbjs.que = pbjs.que || []; var adUnits = adUnits||[]; var HCMRT = HCMRT || 32000; var unitcheck = unitcheck || {}; var destroydfp=destroydfp ||[]; var refreshgptadslots=refreshgptadslots||[]; var refresher;
</script>
<script>buildDFPunits();pbjs.que.push(function(){pbjs.setConfig(prebidconfigs);pbjs.addAdUnits(adUnits);pbjs.requestBids({bidsBackHandler:initAdserver,timeout:PREBID_TIMEOUT});});setTimeout(function(){initAdserver();refresher=new RecurringTimer(refresherBids,HCMRT);},3000);</script><link rel="dns-prefetch" href="https://cdn.statically.io/" >
<link rel="preconnect" href="https://cdn.statically.io/" crossorigin>
        <style type='text/css'>img#wpstats{display:none}</style>
			<style>
	@font-face {
		font-family: "bimber";
							src:url("https://grungecake.com/wp-content/themes/bimber/css/8.5/bimber/fonts/bimber.eot");
			src:url("https://grungecake.com/wp-content/themes/bimber/css/8.5/bimber/fonts/bimber.eot?#iefix") format("embedded-opentype"),
			url("https://grungecake.com/wp-content/themes/bimber/css/8.5/bimber/fonts/bimber.woff") format("woff"),
			url("https://grungecake.com/wp-content/themes/bimber/css/8.5/bimber/fonts/bimber.ttf") format("truetype"),
			url("https://grungecake.com/wp-content/themes/bimber/css/8.5/bimber/fonts/bimber.svg#bimber") format("svg");
				font-weight: normal;
		font-style: normal;
		font-display: block;
	}
	</style>
	<meta name="theme-color" content="#212121" />
	<noscript><style>.woocommerce-product-gallery{ opacity: 1 !important; }</style></noscript>
	
<!-- Google AdSense snippet added by Site Kit -->
<meta name="google-adsense-platform-account" content="ca-host-pub-2644536267352236">
<meta name="google-adsense-platform-domain" content="sitekit.withgoogle.com">
<!-- End Google AdSense snippet added by Site Kit -->
		<style type="text/css">
			.recentcomments a {
				display: inline !important;
				padding: 0 !important;
				margin: 0 !important;
			}

			table.recentcommentsavatartop img.avatar, table.recentcommentsavatarend img.avatar {
				border: 0px;
				margin: 0;
			}

			table.recentcommentsavatartop a, table.recentcommentsavatarend a {
				border: 0px !important;
				background-color: transparent !important;
			}

			td.recentcommentsavatarend, td.recentcommentsavatartop {
				padding: 0px 0px 1px 0px;
				margin: 0px;
			}

			td.recentcommentstextend {
				border: none !important;
				padding: 0px 0px 2px 10px;
			}

			.rtl td.recentcommentstextend {
				padding: 0px 10px 2px 0px;
			}

			td.recentcommentstexttop {
				border: none;
				padding: 0px 0px 0px 10px;
			}

			.rtl td.recentcommentstexttop {
				padding: 0px 10px 0px 0px;
			}
		</style>
		<meta name="description" content="The Odell Beckham Jr. era in Cleveland has come to an end. On the day of his 29th birthday(Friday, Nov 5th), both Odell and the Browns signed a settlement agreement, finalizing Odell&#039;s release from the team and sending him to waivers on Monday. Lots of drama has been made in the past weeks about the&hellip;" />
			<style type="text/css">
				/* If html does not have either class, do not show lazy loaded images. */
				html:not( .jetpack-lazy-images-js-enabled ):not( .js ) .jetpack-lazy-image {
					display: none;
				}
			</style>
			<script>
				document.documentElement.classList.add(
					'jetpack-lazy-images-js-enabled'
				);
			</script>
		
<!-- Google AdSense snippet added by Site Kit -->
<script src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js?client=ca-pub-7953118887885734" crossorigin="anonymous" type="text/javascript"></script>

<!-- End Google AdSense snippet added by Site Kit -->

<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Which NFL club best fit Odell Beckham Jr.?" />
<meta property="og:url" content="https://grungecake.com/which-nfl-club-best-fit-odell-beckham-jr/articles/83935" />
<meta property="og:description" content="The Odell Beckham Jr. era in Cleveland has come to an end. On the day of his 29th birthday(Friday, Nov 5th), both Odell and the Browns signed a settlement agreement, finalizing Odell&#8217;s releas…" />
<meta property="article:published_time" content="2021-11-07T10:48:46+00:00" />
<meta property="article:modified_time" content="2021-11-07T10:48:46+00:00" />
<meta property="og:site_name" content="GRUNGECAKE" />
<meta property="og:image" content="https://grungecake.com/wp-content/uploads/2021/11/OBJ-grungecake-thumbnail.webp" />
<meta property="og:image:width" content="525" />
<meta property="og:image:height" content="350" />
<meta property="og:locale" content="en_GB" />
<meta name="twitter:site" content="@grungecake" />
<meta name="twitter:text:title" content="Which NFL club best fit Odell Beckham Jr.?" />
<meta name="twitter:image" content="https://grungecake.com/wp-content/uploads/2021/11/OBJ-grungecake-thumbnail.webp?w=640" />
<meta name="twitter:card" content="summary_large_image" />

<!-- End Jetpack Open Graph Tags -->
<link rel="icon" href="https://grungecake.com/wp-content/uploads/2020/10/cropped-g-favicon-grungecake-1-32x32.png" sizes="32x32" />
<link rel="icon" href="https://grungecake.com/wp-content/uploads/2020/10/cropped-g-favicon-grungecake-1-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://grungecake.com/wp-content/uploads/2020/10/cropped-g-favicon-grungecake-1-180x180.png" />
<meta name="msapplication-TileImage" content="https://grungecake.com/wp-content/uploads/2020/10/cropped-g-favicon-grungecake-1-270x270.png" />
	<script>if("undefined"!=typeof localStorage){var nsfwItemId=document.getElementsByName("g1:nsfw-item-id");nsfwItemId=nsfwItemId.length>0?nsfwItemId[0].getAttribute("content"):"g1_nsfw_off",window.g1SwitchNSFW=function(e){e?(localStorage.setItem(nsfwItemId,1),document.documentElement.classList.add("g1-nsfw-off")):(localStorage.removeItem(nsfwItemId),document.documentElement.classList.remove("g1-nsfw-off"))};try{var nsfwmode=localStorage.getItem(nsfwItemId);window.g1SwitchNSFW(nsfwmode)}catch(e){}}</script>
	<link rel="stylesheet" type="text/css" id="wp-custom-css" href="https://grungecake.com/?custom-css=844384094f" /><!-- Your Google Analytics Plugin is missing the tracking ID -->
<script>(function(){this._N2=this._N2||{_r:[],_d:[],r:function(){this._r.push(arguments)},d:function(){this._d.push(arguments)}}}).call(window);!function(a){a.indexOf("Safari")>0&&-1===a.indexOf("Chrome")&&document.documentElement.style.setProperty("--ss-safari-fix-225962","1px")}(navigator.userAgent);</script><script src="https://grungecake.com/wp-content/plugins/smart-slider-3/Public/SmartSlider3/Application/Frontend/Assets/dist/n2.min.js?ver=af21758e" defer async></script>
<script src="https://grungecake.com/wp-content/plugins/smart-slider-3/Public/SmartSlider3/Application/Frontend/Assets/dist/smartslider-frontend.min.js?ver=af21758e" defer async></script>
<script src="https://grungecake.com/wp-content/plugins/smart-slider-3/Public/SmartSlider3/Slider/SliderType/Block/Assets/dist/ss-block.min.js?ver=af21758e" defer async></script>
<script>_N2.r('documentReady',function(){_N2.r(["documentReady","smartslider-frontend","ss-block"],function(){new _N2.SmartSliderBlock('n2-ss-2',{"admin":false,"callbacks":"","background.video.mobile":1,"alias":{"id":0,"smoothScroll":0,"slideSwitch":0,"scroll":1},"align":"normal","isDelayed":0,"responsive":{"mediaQueries":{"all":false,"desktopportrait":["(min-width: 1200px)"],"tabletportrait":["(orientation: landscape) and (max-width: 1199px) and (min-width: 901px)","(orientation: portrait) and (max-width: 1199px) and (min-width: 701px)"],"mobileportrait":["(orientation: landscape) and (max-width: 900px)","(orientation: portrait) and (max-width: 700px)"]},"base":{"slideOuterWidth":1200,"slideOuterHeight":700,"sliderWidth":1200,"sliderHeight":700,"slideWidth":1200,"slideHeight":700},"hideOn":{"desktopLandscape":false,"desktopPortrait":false,"tabletLandscape":false,"tabletPortrait":false,"mobileLandscape":false,"mobilePortrait":false},"onResizeEnabled":true,"type":"auto","sliderHeightBasedOn":"real","focusUser":1,"focusEdge":"auto","breakpoints":[{"device":"tabletPortrait","type":"max-screen-width","portraitWidth":1199,"landscapeWidth":1199},{"device":"mobilePortrait","type":"max-screen-width","portraitWidth":700,"landscapeWidth":900}],"enabledDevices":{"desktopLandscape":0,"desktopPortrait":1,"tabletLandscape":0,"tabletPortrait":1,"mobileLandscape":0,"mobilePortrait":1},"sizes":{"desktopPortrait":{"width":1200,"height":700,"max":3000,"min":1200},"tabletPortrait":{"width":701,"height":408,"customHeight":false,"max":1199,"min":701},"mobilePortrait":{"width":320,"height":186,"customHeight":false,"max":900,"min":320}},"overflowHiddenPage":0,"focus":{"offsetTop":"#wpadminbar","offsetBottom":""}},"controls":{"mousewheel":0,"touch":0,"keyboard":0,"blockCarouselInteraction":1},"playWhenVisible":1,"playWhenVisibleAt":0.5,"lazyLoad":0,"lazyLoadNeighbor":0,"blockrightclick":0,"maintainSession":0,"autoplay":{"enabled":0,"start":0,"duration":8000,"autoplayLoop":1,"allowReStart":0,"pause":{"click":1,"mouse":"enter","mediaStarted":1},"resume":{"click":0,"mouse":0,"mediaEnded":1,"slidechanged":0},"interval":1,"intervalModifier":"loop","intervalSlide":"current"},"perspective":1500,"layerMode":{"playOnce":0,"playFirstLayer":1,"mode":"skippable","inAnimation":"mainInEnd"},"initCallbacks":function(){}})})});</script></head>

<body class="post-template-default single single-post postid-83935 single-format-standard wp-embed-responsive theme-bimber woocommerce-demo-store woocommerce-no-js g1-layout-boxed g1-hoverable g1-has-mobile-logo g1-sidebar-normal elementor-beta elementor-default elementor-kit-64326 aa-prefix-grung-" itemscope="&quot;&quot;" itemtype="http://schema.org/WebPage" >

<div class="g1-body-inner">

	<div id="page">
		

		

					<div class="g1-row g1-row-layout-page g1-hb-row g1-hb-row-normal g1-hb-row-a g1-hb-row-1 g1-hb-full g1-hb-sticky-off g1-hb-shadow-off">
			<div class="g1-row-inner">
				<div class="g1-column g1-dropable">
											<div class="g1-bin-1 g1-bin-grow-off">
							<div class="g1-bin g1-bin-align-left">
															</div>
						</div>
											<div class="g1-bin-2 g1-bin-grow-off">
							<div class="g1-bin g1-bin-align-center">
																	<div class="g1-hb-search-form g1-form-s">
	

<div role="search" class="search-form-wrapper">
	<form method="get"
	      class="g1-searchform-tpl-default g1-searchform-ajax search-form"
	      action="https://grungecake.com/">
		<label>
			<span class="screen-reader-text">Search for:</span>
			<input type="search" class="search-field"
			       placeholder="Search"
			       value="" name="s"
			       title="Search for:" />
		</label>
		<button class="search-submit">Search</button>
	</form>

			<div class="g1-searches g1-searches-ajax"></div>
	</div>
</div>
															</div>
						</div>
											<div class="g1-bin-3 g1-bin-grow-off">
							<div class="g1-bin g1-bin-align-right">
															</div>
						</div>
									</div>
			</div>
			<div class="g1-row-background"></div>
		</div>
				<div class="g1-sticky-top-wrapper g1-hb-row-2">
				<div class="g1-row g1-row-layout-page g1-hb-row g1-hb-row-normal g1-hb-row-b g1-hb-row-2 g1-hb-full g1-hb-sticky-on g1-hb-shadow-on">
			<div class="g1-row-inner">
				<div class="g1-column g1-dropable">
											<div class="g1-bin-1 g1-bin-grow-on">
							<div class="g1-bin g1-bin-align-left">
																	<div class="g1-id g1-id-desktop">
			<p class="g1-mega g1-mega-1st site-title">
	
			<a class="g1-logo-wrapper"
			   href="https://grungecake.com/" rel="home">
									<picture class="g1-logo g1-logo-default"><img
							src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw=="
							width="550"
							height="100"
							alt="GRUNGECAKE" sizes="(max-width: 2048px) 100vw, 2048px" data-loading="lazy" data-src="https://cdn.statically.io/img/grungecake.com/wp-content/uploads/2021/06/grungecake-logo-type-white.png?quality=100&f=auto" data-srcset="https://cdn.statically.io/img/grungecake.com/wp-content/uploads/2021/06/grungecake-logo-type-white.png?w=400&quality=100&f=auto 400w,
https://cdn.statically.io/img/grungecake.com/wp-content/uploads/2021/06/grungecake-logo-type-white.png?w=800&quality=100&f=auto 800w,
https://cdn.statically.io/img/grungecake.com/wp-content/uploads/2021/06/grungecake-logo-type-white.png?w=1400&quality=100&f=auto 1400w,
https://cdn.statically.io/img/grungecake.com/wp-content/uploads/2021/06/grungecake-logo-type-white.png?w=2000&quality=100&f=auto 2000w,
https://cdn.statically.io/img/grungecake.com/wp-content/uploads/2021/06/grungecake-logo-type-white.png?w=2048&quality=100&f=auto 2048w,
" /></picture>

											<picture class="g1-logo g1-logo-inverted"><img
								id="g1-logo-inverted-img"
								class=""
								src="https://cdn.statically.io/img/grungecake.com/wp-content/uploads/2021/06/grungecake-logo-type-black.png?quality=100&f=auto"
								data-src=""
								width="550"
								height="100"
								alt="" srcset="https://cdn.statically.io/img/grungecake.com/wp-content/uploads/2021/06/grungecake-logo-type-black.png?w=400&quality=100&f=auto 400w,
https://cdn.statically.io/img/grungecake.com/wp-content/uploads/2021/06/grungecake-logo-type-black.png?w=800&quality=100&f=auto 800w,
https://cdn.statically.io/img/grungecake.com/wp-content/uploads/2021/06/grungecake-logo-type-black.png?w=1400&quality=100&f=auto 1400w,
https://cdn.statically.io/img/grungecake.com/wp-content/uploads/2021/06/grungecake-logo-type-black.png?w=2000&quality=100&f=auto 2000w,
https://cdn.statically.io/img/grungecake.com/wp-content/uploads/2021/06/grungecake-logo-type-black.png?w=2048&quality=100&f=auto 2048w,
" sizes="(max-width: 2048px) 100vw, 2048px" /></picture>
												</a>

			
			</p>
	
	</div>															</div>
						</div>
											<div class="g1-bin-2 g1-bin-grow-off">
							<div class="g1-bin g1-bin-align-center">
															</div>
						</div>
											<div class="g1-bin-3 g1-bin-grow-off">
							<div class="g1-bin g1-bin-align-right">
															</div>
						</div>
									</div>
			</div>
			<div class="g1-row-background"></div>
		</div>
				</div>
				<div class="g1-row g1-row-layout-page g1-hb-row g1-hb-row-normal g1-hb-row-c g1-hb-row-3 g1-hb-full g1-hb-sticky-off g1-hb-shadow-off">
			<div class="g1-row-inner">
				<div class="g1-column g1-dropable">
											<div class="g1-bin-1 g1-bin-grow-off">
							<div class="g1-bin g1-bin-align-left">
															</div>
						</div>
											<div class="g1-bin-2 g1-bin-grow-off">
							<div class="g1-bin g1-bin-align-center">
															</div>
						</div>
											<div class="g1-bin-3 g1-bin-grow-off">
							<div class="g1-bin g1-bin-align-right">
															</div>
						</div>
									</div>
			</div>
			<div class="g1-row-background"></div>
		</div>
					<div class="g1-sticky-top-wrapper g1-hb-row-1">
				<div class="g1-row g1-row-layout-page g1-hb-row g1-hb-row-mobile g1-hb-row-a g1-hb-row-1 g1-hb-boxed g1-hb-sticky-on g1-hb-shadow-off">
			<div class="g1-row-inner">
				<div class="g1-column g1-dropable">
											<div class="g1-bin-1 g1-bin-grow-off">
							<div class="g1-bin g1-bin-align-left">
															</div>
						</div>
											<div class="g1-bin-2 g1-bin-grow-off">
							<div class="g1-bin g1-bin-align-center">
															</div>
						</div>
											<div class="g1-bin-3 g1-bin-grow-off">
							<div class="g1-bin g1-bin-align-right">
															</div>
						</div>
									</div>
			</div>
			<div class="g1-row-background"></div>
		</div>
			<div class="g1-row g1-row-layout-page g1-hb-row g1-hb-row-mobile g1-hb-row-b g1-hb-row-2 g1-hb-boxed g1-hb-sticky-on g1-hb-shadow-off">
			<div class="g1-row-inner">
				<div class="g1-column g1-dropable">
											<div class="g1-bin-1 g1-bin-grow-off">
							<div class="g1-bin g1-bin-align-left">
															</div>
						</div>
											<div class="g1-bin-2 g1-bin-grow-on">
							<div class="g1-bin g1-bin-align-center">
																	<div class="g1-id g1-id-mobile">
			<p class="g1-mega g1-mega-1st site-title">
	
		<a class="g1-logo-wrapper"
		   href="https://grungecake.com/" rel="home">
							<picture class="g1-logo g1-logo-default"><img
						src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw=="
						width="300"
						height="100"
						alt="GRUNGECAKE" sizes="(max-width: 2048px) 100vw, 2048px" data-loading="lazy" data-src="https://cdn.statically.io/img/grungecake.com/wp-content/uploads/2021/06/grungecake-logo-type-white.png?quality=100&f=auto" data-srcset="https://cdn.statically.io/img/grungecake.com/wp-content/uploads/2021/06/grungecake-logo-type-white.png?w=400&quality=100&f=auto 400w,
https://cdn.statically.io/img/grungecake.com/wp-content/uploads/2021/06/grungecake-logo-type-white.png?w=800&quality=100&f=auto 800w,
https://cdn.statically.io/img/grungecake.com/wp-content/uploads/2021/06/grungecake-logo-type-white.png?w=1400&quality=100&f=auto 1400w,
https://cdn.statically.io/img/grungecake.com/wp-content/uploads/2021/06/grungecake-logo-type-white.png?w=2000&quality=100&f=auto 2000w,
https://cdn.statically.io/img/grungecake.com/wp-content/uploads/2021/06/grungecake-logo-type-white.png?w=2048&quality=100&f=auto 2048w,
" /></picture>

									<picture class="g1-logo g1-logo-inverted"><img
							id="g1-logo-mobile-inverted-img"
							class=""
							src="https://cdn.statically.io/img/grungecake.com/wp-content/uploads/2021/06/grungecake-logo-type-black.png?quality=100&f=auto"
							data-src=""
							width="300"
							height="100"
							alt="" srcset="https://cdn.statically.io/img/grungecake.com/wp-content/uploads/2021/06/grungecake-logo-type-black.png?w=400&quality=100&f=auto 400w,
https://cdn.statically.io/img/grungecake.com/wp-content/uploads/2021/06/grungecake-logo-type-black.png?w=800&quality=100&f=auto 800w,
https://cdn.statically.io/img/grungecake.com/wp-content/uploads/2021/06/grungecake-logo-type-black.png?w=1400&quality=100&f=auto 1400w,
https://cdn.statically.io/img/grungecake.com/wp-content/uploads/2021/06/grungecake-logo-type-black.png?w=2000&quality=100&f=auto 2000w,
https://cdn.statically.io/img/grungecake.com/wp-content/uploads/2021/06/grungecake-logo-type-black.png?w=2048&quality=100&f=auto 2048w,
" sizes="(max-width: 2048px) 100vw, 2048px" /></picture>
									</a>

		
			</p>
	
	</div>															</div>
						</div>
											<div class="g1-bin-3 g1-bin-grow-off">
							<div class="g1-bin g1-bin-align-right">
															</div>
						</div>
									</div>
			</div>
			<div class="g1-row-background"></div>
		</div>
				</div>
				<div class="g1-row g1-row-layout-page g1-hb-row g1-hb-row-mobile g1-hb-row-c g1-hb-row-3 g1-hb-boxed g1-hb-sticky-off g1-hb-shadow-off">
			<div class="g1-row-inner">
				<div class="g1-column g1-dropable">
											<div class="g1-bin-1 g1-bin-grow-off">
							<div class="g1-bin g1-bin-align-left">
															</div>
						</div>
											<div class="g1-bin-2 g1-bin-grow-off">
							<div class="g1-bin g1-bin-align-center">
															</div>
						</div>
											<div class="g1-bin-3 g1-bin-grow-off">
							<div class="g1-bin g1-bin-align-right">
															</div>
						</div>
									</div>
			</div>
			<div class="g1-row-background"></div>
		</div>
	
		
				
		<div class="n2-section-smartslider fitvidsignore" data-ssid="2" tabindex="0" role="region" aria-label="Slider"><div class="n2-ss-margin" style="margin: 5px 5px 5px 5px;"><div id="n2-ss-2-align" class="n2-ss-align"><div class="n2-padding"><div id="n2-ss-2" data-creator="Smart Slider 3" data-responsive="auto" class="n2-ss-slider n2-ow n2-has-hover n2notransition">
        <div class="n2-ss-slider-1 n2-ow" style="">
            <div class="n2-ss-slider-2 n2-ow">
                <div class="n2-ss-slide-backgrounds n2-ow-all"><div class="n2-ss-slide-background" data-public-id="2" data-mode="fill"><div data-color="RGBA(33,33,33,1)" style="background-color: RGBA(33,33,33,1);" class="n2-ss-slide-background-color"></div></div></div>                <div class="n2-ss-slider-3 n2-ow">
                    <svg xmlns="http://www.w3.org/2000/svg" viewbox="0 0 1200 700" data-related-device="desktopPortrait" class="n2-ow n2-ss-preserve-size n2-ss-preserve-size--slider n2-ss-slide-limiter"></svg><div data-first="1" data-slide-duration="0" data-id="3" data-slide-public-id="2" data-title="Slide" data-haslink="1" onclick="" data-href="https://grungecake.com/olamide-interview/articles/79414" tabindex="0" role="button" data-n2click="url" data-force-pointer="" class="n2-ss-slide n2-ow  n2-ss-slide-3"><div role="note" class="n2-ss-slide--focus">Slide</div><div class="n2-ss-layers-container n2-ss-slide-limiter n2-ow"><div class="n2-ss-layer n2-ow n-uc-jQPO2vt555My" data-sstype="slide" data-pm="default"><div class="n2-ss-layer n2-ow n-uc-115ebbdb3da08" data-pm="default" data-sstype="content" data-hasbackground="0"><div class="n2-ss-section-main-content n2-ss-layer-with-background n2-ss-layer-content n2-ow n-uc-115ebbdb3da08-inner"><div class="n2-ss-layer n2-ow n2-ss-layer--block n2-ss-has-self-align n-uc-19b000265ba67" data-pm="normal" data-sstype="row"><div class="n2-ss-layer-row n2-ss-layer-with-background n-uc-19b000265ba67-inner"><div class="n2-ss-layer-row-inner"><div class="n2-ss-layer n2-ow n-uc-1dc66901c7568" data-pm="default" data-sstype="col"><div class="n2-ss-layer-col n2-ss-layer-with-background n2-ss-layer-content n-uc-1dc66901c7568-inner"><div class="n2-ss-layer n2-ow n-uc-ikMr4aVsaSKd" data-pm="normal" data-sstype="layer"><div id="n2-ss-2item6" class="n2-ss-item-content n2-ss-text n2-ow" style="display:block;"><a class="n2-ow n2-font-001d588a70a4315cc898a2ad9614317e-hover" style="display:block;" target="_top" href="https://grungecake.com/olamide-interview/articles/79414">Nigeria’s Olamide on breaking through in America, Afrorap, and his new album: UY Scuti (Interview)<br></a></div></div><div class="n2-ss-layer n2-ow n-uc-tiXixacIhR1v" data-pm="normal" data-sstype="layer"><div class="n2-ss-item-content n2-ss-text n2-ow-all"><div class=""><p class="n2-font-6d29f9f5c1a74589c43d57bd714d404b-paragraph">An in-person conversation with one of the world's greatest African artists, Olamide</p>
</div></div></div><div class="n2-ss-layer n2-ow n-uc-jjenuk9ULa4i" data-pm="normal" data-sstype="layer"><div class="n2-ss-button-container n2-ss-item-content n2-ow n2-font-b40c7a22e460eec854893742996f57cf-link  n2-ss-nowrap"><a class="n2-style-e4f3e7bec5d830ff851d237d79600df2-heading  n2-ow" href="https://grungecake.com/olamide-interview/articles/79414"><div><div>Read feature</div></div></a></div></div></div></div><div class="n2-ss-layer n2-ow n-uc-175bbf541cda5" data-pm="default" data-sstype="col"><div class="n2-ss-layer-col n2-ss-layer-with-background n2-ss-layer-content n-uc-175bbf541cda5-inner"><div class="n2-ss-layer n2-ow n-uc-2UR4TmQsf0mm" data-pm="normal" data-sstype="layer"><div class="n2-ss-item-image n2-ss-item-content n2-ow-all"><img id="n2-ss-2item9" alt="" class="skip-lazy jetpack-lazy-image" width="1000" height="670" data-skip-lazy="1" src="https://cdn.statically.io/img/i0.wp.com/grungecake.com/wp-content/uploads/2021/07/olamide-richardine-grungecake-nyc-thumbnail-03-scaled.jpg?resize=1000%2C670&quality=100&f=auto" data-recalc-dims="1" /></div></div></div></div></div></div></div><div class="n2-ss-layer n2-ow n2-ss-layer--block n2-ss-has-self-align n-uc-166d559e59eea" data-pm="normal" data-sstype="row"><div class="n2-ss-layer-row n2-ss-layer-with-background n-uc-166d559e59eea-inner"><div class="n2-ss-layer-row-inner"><div class="n2-ss-layer n2-ow n-uc-1d9487ace2c6a" data-pm="default" data-sstype="col"><div class="n2-ss-layer-col n2-ss-layer-with-background n2-ss-layer-content n-uc-1d9487ace2c6a-inner"></div></div><div class="n2-ss-layer n2-ow n-uc-1c24b48924eec" data-pm="default" data-sstype="col"><div class="n2-ss-layer-col n2-ss-layer-with-background n2-ss-layer-content n-uc-1c24b48924eec-inner"></div></div></div></div></div></div></div></div></div></div>                </div>
                            </div>
        </div>
        </div><ss3-loader></ss3-loader></div></div><div class="n2_clear"></div></div></div>		

		

	<div id="primary">
		<div id="content" role="main">

			<span class="bimber-url-waypoint" data-bimber-post-title="Which NFL club best fit Odell Beckham Jr.?" data-bimber-post-url="https://grungecake.com/which-nfl-club-best-fit-odell-beckham-jr/articles/83935"></span>


<article id="post-83935" class="entry-tpl-background-stretched-v2 post-83935 post type-post status-publish format-standard has-post-thumbnail category-athletes category-sports tag-cleveland-browns tag-nfl tag-odell-beckham-jr" itemscope="" itemtype="http://schema.org/Article">
	
	<div class="g1-row g1-row-layout-page entry-media-row entry-media-row-03">
				<style>
			#g1-background-media-6187c2f61207b {
				background-image: url( https://grungecake.com/wp-content/uploads/2021/11/OBJ-grungecake-thumbnail.webp );
			}
		</style>

		<div class="g1-row-inner">
			<div class="g1-column">

				<div class="g1-row g1-row-layout-page g1-row-1">
					<div class="g1-row-inner">
						<div class="g1-column g1-dark">

							
						</div>
					</div>
					<div class="g1-row-background">
					</div>
				</div><!-- .g1-row -->

				<div class="g1-row g1-row-layout-page g1-row-2">
					<div class="g1-row-inner">

						<div class="g1-column g1-column-2of3 g1-dark">
							<header class="entry-header">
								<div class="entry-before-title">
									<span class="entry-categories"><span class="entry-categories-inner"><span class="entry-categories-label">in</span> <a href="https://grungecake.com/category/sports/athletes" class="entry-category entry-category-item-477"><span itemprop="articleSection">Athletes</span></a>, <a href="https://grungecake.com/category/sports" class="entry-category entry-category-item-476"><span itemprop="articleSection">Sports</span></a></span></span>
																		</div>

								<h1 class="g1-giga g1-giga-1st entry-title" itemprop="headline">Which NFL club best fit Odell Beckham Jr.?</h1>
															</header>
						</div>

						<div class="g1-column g1-column-1of3 g1-dark">
							
			<div class="g1-meta entry-media-credit">
			Photo: <a href="https://www.denverpost.com/2021/11/05/pick-6-odds-odell-beckham-jr-rose-namajunas/" target="_blank" rel="noopener">Denver PostPitchfork</a>		</div>
							</div>

					</div>

					<div class="g1-row-background">
					</div>
				</div><!-- .g1-row -->

			</div>
		</div>

		<div class="g1-row-background">
		<div class="g1-row-background-media" id="g1-background-media-6187c2f61207b"></div>
		</div>

		<span class="g1-microdata" itemprop="image" itemscope itemtype="http://schema.org/ImageObject">
			<meta itemprop="url" content="https://grungecake.com/wp-content/uploads/2021/11/OBJ-grungecake-thumbnail.webp" />
			<meta itemprop="width" content="525" />
			<meta itemprop="height" content="350" />
		</span>
	</div><!-- g1-row -->

	<div class="g1-row g1-row-layout-page g1-row-padding-m">
		<div class="g1-row-background">
		</div>
		<div class="g1-row-inner">

			<div class="g1-column g1-column-2of3">
				<div class="entry-inner g1-card g1-card-solid">
					<header class="entry-header">
													<p class="g1-meta g1-meta-m entry-meta entry-meta-m">
								<span class="entry-byline entry-byline-m">
													<span class="entry-author" itemscope="" itemprop="author" itemtype="http://schema.org/Person">
	
		<span class="entry-meta-label">by</span>
			<a href="https://grungecake.com/author/andy-alexis" title="Posts by Andy Alexis" rel="author">
			
							<strong itemprop="name">Andy Alexis</strong>
					</a>
	</span>
	
										<time class="entry-date" datetime="2021-11-07T05:48:46-05:00" itemprop="datePublished">7th November 2021, 5:48 AM</time>								</span>

								<span class="entry-stats entry-stats-m">

									
									
									
																	</span>
							</p>
											</header>

					<div class="g1-wrapper-with-stickies">
						<div class="entry-essentials">
							<div class="entry-content g1-typography-xl" itemprop="articleBody">
								<figure id="attachment_83938" aria-describedby="caption-attachment-83938" class="wp-caption aligncenter"><img data-attachment-id="83938" data-permalink="https://grungecake.com/which-nfl-club-best-fit-odell-beckham-jr/articles/83935/obj-grungecake-thumbnail" data-orig-file="https://grungecake.com/wp-content/uploads/2021/11/OBJ-grungecake-thumbnail.webp" data-orig-size="525,350" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="OBJ-grungecake-thumbnail" data-image-description data-image-caption="&lt;p&gt;Photo: &lt;a href=&quot;https://www.denverpost.com/2021/11/05/pick-6-odds-odell-beckham-jr-rose-namajunas/&quot; target=&quot;_blank&quot; rel=&quot;noopener&quot;&gt;Denver PostPitchfork&lt;/a&gt;&lt;/p&gt;" data-medium-file="https://grungecake.com/wp-content/uploads/2021/11/OBJ-grungecake-thumbnail-300x200.webp" data-large-file="https://grungecake.com/wp-content/uploads/2021/11/OBJ-grungecake-thumbnail.webp" src="https://cdn.statically.io/img/grungecake.com/wp-content/uploads/2021/11/OBJ-grungecake-thumbnail.webp?quality=100&f=auto" alt width="525" height="350" class="size-full wp-image-83938 jetpack-lazy-image" data-lazy-srcset="https://grungecake.com/wp-content/uploads/2021/11/OBJ-grungecake-thumbnail.webp 525w, https://grungecake.com/wp-content/uploads/2021/11/OBJ-grungecake-thumbnail-300x200.webp 300w, https://grungecake.com/wp-content/uploads/2021/11/OBJ-grungecake-thumbnail-364x243.webp 364w, https://grungecake.com/wp-content/uploads/2021/11/OBJ-grungecake-thumbnail-150x100.webp 150w" data-lazy-sizes="(max-width: 525px) 100vw, 525px" data-lazy-src="https://grungecake.com/wp-content/uploads/2021/11/OBJ-grungecake-thumbnail.webp?is-pending-load=1" srcset=""><noscript><img data-attachment-id="83938" data-permalink="https://grungecake.com/which-nfl-club-best-fit-odell-beckham-jr/articles/83935/obj-grungecake-thumbnail" data-orig-file="https://grungecake.com/wp-content/uploads/2021/11/OBJ-grungecake-thumbnail.webp" data-orig-size="525,350" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="OBJ-grungecake-thumbnail" data-image-description="" data-image-caption="&lt;p&gt;Photo: &lt;a href=&quot;https://www.denverpost.com/2021/11/05/pick-6-odds-odell-beckham-jr-rose-namajunas/&quot; target=&quot;_blank&quot; rel=&quot;noopener&quot;&gt;Denver PostPitchfork&lt;/a&gt;&lt;/p&gt;" data-medium-file="https://grungecake.com/wp-content/uploads/2021/11/OBJ-grungecake-thumbnail-300x200.webp" data-large-file="https://grungecake.com/wp-content/uploads/2021/11/OBJ-grungecake-thumbnail.webp" src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw==" alt="" width="525" height="350" class="size-full wp-image-83938" sizes="(max-width: 525px) 100vw, 525px" data-loading="lazy" data-src="https://cdn.statically.io/img/grungecake.com/wp-content/uploads/2021/11/OBJ-grungecake-thumbnail.webp?quality=100&f=auto" data-srcset="https://cdn.statically.io/img/grungecake.com/wp-content/uploads/2021/11/OBJ-grungecake-thumbnail.webp?quality=100&f=auto 525w,
https://cdn.statically.io/img/grungecake.com/wp-content/uploads/2021/11/OBJ-grungecake-thumbnail-300x200.webp?quality=100&f=auto 300w,
https://cdn.statically.io/img/grungecake.com/wp-content/uploads/2021/11/OBJ-grungecake-thumbnail-364x243.webp?quality=100&f=auto 364w,
https://cdn.statically.io/img/grungecake.com/wp-content/uploads/2021/11/OBJ-grungecake-thumbnail-150x100.webp?quality=100&f=auto 150w,
" /></noscript><figcaption id="caption-attachment-83938" class="wp-caption-text">Photo: <a href="https://www.denverpost.com/2021/11/05/pick-6-odds-odell-beckham-jr-rose-namajunas/" target="_blank" rel="noopener">Denver PostPitchfork</a></figcaption></figure>
<p>The Odell Beckham Jr. era in Cleveland has come to an end. On the day of his 29th birthday(Friday, Nov 5th), both Odell and the Browns signed a settlement agreement, finalizing Odell&#8217;s release from the team and sending him to waivers on Monday. Lots of drama has been made in the past weeks about the relationship between quarterback Baker Mayfield and OBJ, but the bottom line is it&#8217;s over, and it is time to move on. So what does the future look like for the former Pro-Bowl wide receiver?</p>
<p>Since the news on Friday, Baltimore Ravens fans had been tweeting quarterback Lamar Jackson trying to get OBJ. Lamar replied on Twitter.</p>
<blockquote class="twitter-tweet">
<p lang="en" dir="ltr">I can’t do nothing for y’all @ the <a href="https://twitter.com/Ravens?ref_src=twsrc%5Etfw">@ravens</a> not meeee&#x1f923;&#x1f923; I can’t do nothing</p>
<p>&mdash; Lamar Jackson (@Lj_era8) <a href="https://twitter.com/Lj_era8/status/1456634385969655808?ref_src=twsrc%5Etfw">November 5, 2021</a></p></blockquote>
<p> <script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
<p>Such a talent would be a good fit for most NFL clubs, but here are the few I feel most enticing. </p>
<p>The Packers would be one of the first options. OBJ has never been on a team with a quarterback near the echelon of Aaron Rodgers, who&#8217;s a nine-time Pro-bowler and Superbowl champ. Odell would be the number two receiver behind Devonte Adams, but the combination of the two with Aaron Rodgers is something no defence would like to face.</p>
<p>They might not be a better offensive-minded coach in the NFL better than Saints head coach Sean Payton. If there is anyone who can utilize OBJ&#8217;s talent, it&#8217;s Sean. The Saints are sitting at the top of their division, sitting at 5-2 and with Michael Thomas done for the year, it&#8217;s perfect for Odell to step in as WR1.</p>
<p>The Las Vegas Raiders just lost their explosive wideout, Henry Ruggs III, to felony DUI charges. This year, Derek Carr has been playing his best football, and the Raiders are at the top of their AFC West at 5-2. A Signing of OBJ leading into the playoffs can start something special for the Raiders, considering everything that has transpired this season.</p>
<p>Patriots head coach Bill Belichick and Odell Beckham Jr. have both been fans of each other and long fantasized about being together for a long time. To witness what Bill had done with Hall-of-Famer Randy Moss later in his career was truly impressive. It can be interesting to see what can come out of the combination of Bill, Mac Jones and Odell.</p>
<p>A scary sight not just for the AFC but for the entire league is the pairing of Josh Allen, Stefon Diggs and Odell Beckham JR.​​ An already air-raided offensive added a weapon like OBJ almost seems unstoppable. </p>
<p>I can play fantasy football all day and name teams like the Bengals, Ravens, Rams and even Seahawks, but the reality is that the cost of claiming the three-time Pro Bowler for the remainder of the 2021 season is $7.25 million. Which team will deem OBJ worth it and can help be that final piece to a Superbowl?</p>
<p><iframe width="100%" height="315" src="https://www.youtube.com/embed/knUScvpT4U4" title="YouTube video player" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></p>
<hr />
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-83935" class="share-twitter sd-button no-icon" href="https://grungecake.com/which-nfl-club-best-fit-odell-beckham-jr/articles/83935?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-83935" class="share-facebook sd-button no-icon" href="https://grungecake.com/which-nfl-club-best-fit-odell-beckham-jr/articles/83935?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-linkedin"><a rel="nofollow noopener noreferrer" data-shared="sharing-linkedin-83935" class="share-linkedin sd-button no-icon" href="https://grungecake.com/which-nfl-club-best-fit-odell-beckham-jr/articles/83935?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span>LinkedIn</span></a></li><li><a href="#" class="sharing-anchor sd-button share-more"><span>More</span></a></li><li class="share-end"></li></ul><div class="sharing-hidden"><div class="inner" style="display: none;"><ul><li class="share-tumblr"><a rel="nofollow noopener noreferrer" data-shared="" class="share-tumblr sd-button no-icon" href="https://grungecake.com/which-nfl-club-best-fit-odell-beckham-jr/articles/83935?share=tumblr" target="_blank" title="Click to share on Tumblr"><span>Tumblr</span></a></li><li class="share-email"><a rel="nofollow noopener noreferrer" data-shared="" class="share-email sd-button no-icon" href="https://grungecake.com/which-nfl-club-best-fit-odell-beckham-jr/articles/83935?share=email" target="_blank" title="Click to email this to a friend"><span>Email</span></a></li><li class="share-end"></li><li class="share-jetpack-whatsapp"><a rel="nofollow noopener noreferrer" data-shared="" class="share-jetpack-whatsapp sd-button no-icon" href="https://grungecake.com/which-nfl-club-best-fit-odell-beckham-jr/articles/83935?share=jetpack-whatsapp" target="_blank" title="Click to share on WhatsApp"><span>WhatsApp</span></a></li><li class="share-print"><a rel="nofollow noopener noreferrer" data-shared="" class="share-print sd-button no-icon" href="https://grungecake.com/which-nfl-club-best-fit-odell-beckham-jr/articles/83935#print" target="_blank" title="Click to print"><span>Print</span></a></li><li class="share-end"></li><li class="share-reddit"><a rel="nofollow noopener noreferrer" data-shared="" class="share-reddit sd-button no-icon" href="https://grungecake.com/which-nfl-club-best-fit-odell-beckham-jr/articles/83935?share=reddit" target="_blank" title="Click to share on Reddit"><span>Reddit</span></a></li><li class="share-telegram"><a rel="nofollow noopener noreferrer" data-shared="" class="share-telegram sd-button no-icon" href="https://grungecake.com/which-nfl-club-best-fit-odell-beckham-jr/articles/83935?share=telegram" target="_blank" title="Click to share on Telegram"><span>Telegram</span></a></li><li class="share-end"></li><li class="share-skype"><a rel="nofollow noopener noreferrer" data-shared="sharing-skype-83935" class="share-skype sd-button no-icon" href="https://grungecake.com/which-nfl-club-best-fit-odell-beckham-jr/articles/83935?share=skype" target="_blank" title="Click to share on Skype"><span>Skype</span></a></li><li class="share-pinterest"><a rel="nofollow noopener noreferrer" data-shared="sharing-pinterest-83935" class="share-pinterest sd-button no-icon" href="https://grungecake.com/which-nfl-club-best-fit-odell-beckham-jr/articles/83935?share=pinterest" target="_blank" title="Click to share on Pinterest"><span>Pinterest</span></a></li><li class="share-end"></li><li class="share-pocket"><a rel="nofollow noopener noreferrer" data-shared="" class="share-pocket sd-button no-icon" href="https://grungecake.com/which-nfl-club-best-fit-odell-beckham-jr/articles/83935?share=pocket" target="_blank" title="Click to share on Pocket"><span>Pocket</span></a></li><li class="share-end"></li></ul></div></div></div></div></div>
<div id='jp-relatedposts' class='jp-relatedposts' >
	<h3 class="jp-relatedposts-headline"><em>Must-Read Articles</em></h3>
</div>							</div>
						</div>

						<div class="entry-actions">
													</div>
					</div>
				</div><!-- .todo -->

				<div class="entry-after-content">
						<section class="g1-row author-info" itemscope="" itemtype="http://schema.org/Person">
		<div class="g1-row-inner author-info-inner">
			<div class="g1-column author-overview">

				<figure class="author-avatar">
					<a href="https://grungecake.com/author/andy-alexis">
						<img width="80" height="80" src="https://cdn.statically.io/img/grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-96x96.png?quality=100&f=auto" class="avatar avatar-80 photo jetpack-lazy-image" alt="" data-attachment-id="81870" data-permalink="https://grungecake.com/andy-alexis-grungecake-hip-hop-editor-icon" data-orig-file="https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon.png" data-orig-size="941,941" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="andy-alexis-grungecake-hip-hop-editor-icon" data-image-description="" data-image-caption="" data-medium-file="https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-300x300.png" data-large-file="https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon.png" data-lazy-srcset="https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-96x96.png 96w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-300x300.png 300w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-290x290.png 290w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-768x768.png 768w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-192x192.png 192w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-384x384.png 384w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-110x110.png 110w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-220x220.png 220w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-561x561.png 561w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-364x364.png 364w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-728x728.png 728w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-608x608.png 608w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-758x758.png 758w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-150x150.png 150w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-24x24.png 24w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-48x48.png 48w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon.png 941w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-96x96.png?is-pending-load=1" srcset="" />
					</a>
				</figure>

				<header>
										<h2 class="g1-gamma g1-gamma-1st author-title">Written by <a href="https://grungecake.com/author/andy-alexis"><span itemprop="name">Andy Alexis</span></a></h2>

									</header>

								<div itemprop="description" class="author-bio">
					<p>I'm GRUNGECAKE’s Sports and Music Editor. Connect with me on <a href="https://www.instagram.com/ggandyzoe">Instagram</a>.</p>
				</div>
				
				<div class="author-extras">
									</div>
			</div>
		</div>
	</section>
<p class="entry-tags"><span class="entry-tags-inner"><a href="https://grungecake.com/tag/cleveland-browns" class="entry-tag entry-tag-16978">Cleveland Browns</a><a href="https://grungecake.com/tag/nfl" class="entry-tag entry-tag-16785">NFL</a><a href="https://grungecake.com/tag/odell-beckham-jr" class="entry-tag entry-tag-16979">Odell Beckham JR.</a></span></p>


		<aside class="g1-more-from">
		<h2 class="g1-delta g1-delta-2nd g1-collection-title"><span>More From: <a href="https://grungecake.com/category/sports/athletes">Athletes</a></span></h2>		<div class="g1-collection g1-collection-with-cards">
			<div class="g1-collection-viewport">
				<ul class="g1-collection-items">
					
						<li class="g1-collection-item">
							
<article class="entry-tpl-list-s g1-card g1-card-solid post-83885 post type-post status-publish format-standard has-post-thumbnail category-athletes category-news category-sports tag-atlanta-braves tag-mlb tag-the-astros tag-world-series">
	<div class="entry-featured-media" ><a title="Atlanta Braves: World Series Champions, after beating The Astros in 6 games" class="g1-frame" href="https://grungecake.com/atlanta-braves-win-world-series/articles/83885"><div class="g1-frame-inner"><img width="265" height="186" src="https://cdn.statically.io/img/grungecake.com/wp-content/uploads/2021/11/atlanta-braves-grungecake-thumbnail-265x186.jpg?crop=1&quality=100&f=auto" class="attachment-bimber-list-s size-bimber-list-s wp-post-image jetpack-lazy-image" alt="" data-attachment-id="83887" data-permalink="https://grungecake.com/atlanta-braves-win-world-series/articles/83885/atlanta-braves-grungecake-thumbnail" data-orig-file="https://grungecake.com/wp-content/uploads/2021/11/atlanta-braves-grungecake-thumbnail.jpg" data-orig-size="640,427" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="atlanta-braves-grungecake-thumbnail" data-image-description="" data-image-caption="&lt;p&gt;Photo: &lt;a href=&quot;https://sports.yahoo.com/where-to-shop-atlanta-braves-2021-world-series-championship-gear-035821307.html&quot; target=&quot;_blank&quot; rel=&quot;noopener&quot;&gt;Yahoo Sports&lt;/a&gt;&lt;/p&gt;" data-medium-file="https://grungecake.com/wp-content/uploads/2021/11/atlanta-braves-grungecake-thumbnail-300x200.jpg" data-large-file="https://grungecake.com/wp-content/uploads/2021/11/atlanta-braves-grungecake-thumbnail.jpg" data-lazy-srcset="https://grungecake.com/wp-content/uploads/2021/11/atlanta-braves-grungecake-thumbnail-265x186.jpg?crop=1 265w, https://grungecake.com/wp-content/uploads/2021/11/atlanta-braves-grungecake-thumbnail-531x371.jpg?crop=1 531w" data-lazy-sizes="(max-width: 265px) 100vw, 265px" data-lazy-src="https://grungecake.com/wp-content/uploads/2021/11/atlanta-braves-grungecake-thumbnail-265x186.jpg?crop=1&amp;is-pending-load=1" srcset="" /><span class="g1-frame-icon g1-frame-icon-"></span></div></a></div>
		
	<div class="entry-body">
		<header class="entry-header">
			<div class="entry-before-title">
				
							</div>

			<h3 class="g1-gamma g1-gamma-1st entry-title"><a href="https://grungecake.com/atlanta-braves-win-world-series/articles/83885" rel="bookmark">Atlanta Braves: World Series Champions, after beating The Astros in 6 games</a></h3>
					</header>

		
					<footer>
				<p class="g1-meta entry-meta entry-byline entry-byline-with-avatar">
								<span class="entry-author">
	
		<span class="entry-meta-label">by</span>
			<a href="https://grungecake.com/author/andy-alexis" title="Posts by Andy Alexis" rel="author">
			<img width="30" height="30" src="https://cdn.statically.io/img/grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-48x48.png?quality=100&f=auto" class="avatar avatar-30 photo jetpack-lazy-image" alt="" data-attachment-id="81870" data-permalink="https://grungecake.com/andy-alexis-grungecake-hip-hop-editor-icon" data-orig-file="https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon.png" data-orig-size="941,941" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="andy-alexis-grungecake-hip-hop-editor-icon" data-image-description="" data-image-caption="" data-medium-file="https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-300x300.png" data-large-file="https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon.png" data-lazy-srcset="https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-48x48.png 48w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-300x300.png 300w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-290x290.png 290w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-768x768.png 768w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-192x192.png 192w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-384x384.png 384w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-110x110.png 110w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-220x220.png 220w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-561x561.png 561w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-364x364.png 364w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-728x728.png 728w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-608x608.png 608w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-758x758.png 758w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-96x96.png 96w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-150x150.png 150w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-24x24.png 24w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon.png 941w" data-lazy-sizes="(max-width: 30px) 100vw, 30px" data-lazy-src="https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-48x48.png?is-pending-load=1" srcset="" />
							<strong>Andy Alexis</strong>
					</a>
	</span>
	
					<time class="entry-date" datetime="2021-11-03T01:41:17-05:00">3rd November 2021, 1:41 AM</time>				</p>
			</footer>
		
					<div class="entry-todome g1-dropable snax">
					<p class="entry-ctas">
		<a class="entry-cta g1-button g1-button-simple g1-button-s" href="https://grungecake.com/atlanta-braves-win-world-series/articles/83885">
			Read More		</a>
	</p>
	
				
							</div>
			</div>
</article>
						</li>

					
						<li class="g1-collection-item">
							
<article class="entry-tpl-list-s g1-card g1-card-solid post-83862 post type-post status-publish format-standard has-post-thumbnail category-athletes category-news category-sports tag-henry-ruggs-iii tag-las-vagas-raiders tag-nfl">
	<div class="entry-featured-media" ><a title="Las Vegas Raiders WR Henry Ruggs III charged with DUI, involving fatal car accident" class="g1-frame" href="https://grungecake.com/las-vegas-raiders-henry-ruggs-dui-charge/articles/83862"><div class="g1-frame-inner"><img width="265" height="186" src="https://cdn.statically.io/img/grungecake.com/wp-content/uploads/2021/11/henry-ruggs-grungecake-thumbnail-265x186.webp?crop=1&quality=100&f=auto" class="attachment-bimber-list-s size-bimber-list-s wp-post-image jetpack-lazy-image" alt="" data-attachment-id="83865" data-permalink="https://grungecake.com/las-vegas-raiders-henry-ruggs-dui-charge/articles/83862/henry-ruggs-grungecake-thumbnail" data-orig-file="https://grungecake.com/wp-content/uploads/2021/11/henry-ruggs-grungecake-thumbnail.webp" data-orig-size="2560,1440" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="henry-ruggs-grungecake-thumbnail" data-image-description="" data-image-caption="&lt;p&gt;Photo: &lt;a href=&quot;https://ktla.com/news/nationworld/raiders-wide-receiver-henry-ruggs-faces-dui-charge-in-vegas-crash-that-killed-woman-injured-2/&quot; target=&quot;_blank&quot; rel=&quot;noopener&quot;&gt;KTLA&lt;/a&gt;&lt;/p&gt;" data-medium-file="https://grungecake.com/wp-content/uploads/2021/11/henry-ruggs-grungecake-thumbnail-300x169.webp" data-large-file="https://grungecake.com/wp-content/uploads/2021/11/henry-ruggs-grungecake-thumbnail-1024x576.webp" data-lazy-srcset="https://grungecake.com/wp-content/uploads/2021/11/henry-ruggs-grungecake-thumbnail-265x186.webp?crop=1 265w, https://grungecake.com/wp-content/uploads/2021/11/henry-ruggs-grungecake-thumbnail-531x371.webp?crop=1 531w" data-lazy-sizes="(max-width: 265px) 100vw, 265px" data-lazy-src="https://grungecake.com/wp-content/uploads/2021/11/henry-ruggs-grungecake-thumbnail-265x186.webp?crop=1&amp;is-pending-load=1" srcset="" /><span class="g1-frame-icon g1-frame-icon-"></span></div></a></div>
		
	<div class="entry-body">
		<header class="entry-header">
			<div class="entry-before-title">
				
							</div>

			<h3 class="g1-gamma g1-gamma-1st entry-title"><a href="https://grungecake.com/las-vegas-raiders-henry-ruggs-dui-charge/articles/83862" rel="bookmark">Las Vegas Raiders WR Henry Ruggs III charged with DUI, involving fatal car accident</a></h3>
					</header>

		
					<footer>
				<p class="g1-meta entry-meta entry-byline entry-byline-with-avatar">
								<span class="entry-author">
	
		<span class="entry-meta-label">by</span>
			<a href="https://grungecake.com/author/andy-alexis" title="Posts by Andy Alexis" rel="author">
			<img width="30" height="30" src="https://cdn.statically.io/img/grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-48x48.png?quality=100&f=auto" class="avatar avatar-30 photo jetpack-lazy-image" alt="" data-attachment-id="81870" data-permalink="https://grungecake.com/andy-alexis-grungecake-hip-hop-editor-icon" data-orig-file="https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon.png" data-orig-size="941,941" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="andy-alexis-grungecake-hip-hop-editor-icon" data-image-description="" data-image-caption="" data-medium-file="https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-300x300.png" data-large-file="https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon.png" data-lazy-srcset="https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-48x48.png 48w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-300x300.png 300w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-290x290.png 290w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-768x768.png 768w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-192x192.png 192w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-384x384.png 384w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-110x110.png 110w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-220x220.png 220w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-561x561.png 561w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-364x364.png 364w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-728x728.png 728w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-608x608.png 608w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-758x758.png 758w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-96x96.png 96w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-150x150.png 150w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-24x24.png 24w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon.png 941w" data-lazy-sizes="(max-width: 30px) 100vw, 30px" data-lazy-src="https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-48x48.png?is-pending-load=1" srcset="" />
							<strong>Andy Alexis</strong>
					</a>
	</span>
	
					<time class="entry-date" datetime="2021-11-02T18:47:49-05:00">2nd November 2021, 6:47 PM</time>				</p>
			</footer>
		
					<div class="entry-todome g1-dropable snax">
					<p class="entry-ctas">
		<a class="entry-cta g1-button g1-button-simple g1-button-s" href="https://grungecake.com/las-vegas-raiders-henry-ruggs-dui-charge/articles/83862">
			Read More		</a>
	</p>
	
				
							</div>
			</div>
</article>
						</li>

					
						<li class="g1-collection-item">
							
<article class="entry-tpl-list-s g1-card g1-card-solid post-83830 post type-post status-publish format-standard has-post-thumbnail category-athletes category-news category-sports tag-james-harden tag-nba">
	<div class="entry-featured-media" ><a title="James Harden&#8217;s early-season struggles" class="g1-frame" href="https://grungecake.com/james-harden-early-season-struggles/articles/83830"><div class="g1-frame-inner"><img width="265" height="186" src="https://cdn.statically.io/img/grungecake.com/wp-content/uploads/2021/11/james-harden-grungecake-thumbnail-265x186.jpg?crop=1&quality=100&f=auto" class="attachment-bimber-list-s size-bimber-list-s wp-post-image jetpack-lazy-image" alt="" data-attachment-id="83832" data-permalink="https://grungecake.com/james-harden-early-season-struggles/articles/83830/james-harden-grungecake-thumbnail" data-orig-file="https://grungecake.com/wp-content/uploads/2021/11/james-harden-grungecake-thumbnail.jpg" data-orig-size="800,533" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="james-harden-grungecake-thumbnail" data-image-description="" data-image-caption="&lt;p&gt;Photo: &lt;a href=&quot;https://bleacherreport.com/articles/2949859-numbers-dont-lie-james-harden-nets-look-ordinary-without-the-free-throws&quot; target=&quot;_blank&quot; rel=&quot;noopener&quot;&gt;Bleacher Report&lt;/a&gt;&lt;/p&gt;" data-medium-file="https://grungecake.com/wp-content/uploads/2021/11/james-harden-grungecake-thumbnail-300x200.jpg" data-large-file="https://grungecake.com/wp-content/uploads/2021/11/james-harden-grungecake-thumbnail.jpg" data-lazy-srcset="https://grungecake.com/wp-content/uploads/2021/11/james-harden-grungecake-thumbnail-265x186.jpg?crop=1 265w, https://grungecake.com/wp-content/uploads/2021/11/james-harden-grungecake-thumbnail-531x371.jpg?crop=1 531w" data-lazy-sizes="(max-width: 265px) 100vw, 265px" data-lazy-src="https://grungecake.com/wp-content/uploads/2021/11/james-harden-grungecake-thumbnail-265x186.jpg?crop=1&amp;is-pending-load=1" srcset="" /><span class="g1-frame-icon g1-frame-icon-"></span></div></a></div>
		
	<div class="entry-body">
		<header class="entry-header">
			<div class="entry-before-title">
				
							</div>

			<h3 class="g1-gamma g1-gamma-1st entry-title"><a href="https://grungecake.com/james-harden-early-season-struggles/articles/83830" rel="bookmark">James Harden&#8217;s early-season struggles</a></h3>
					</header>

		
					<footer>
				<p class="g1-meta entry-meta entry-byline entry-byline-with-avatar">
								<span class="entry-author">
	
		<span class="entry-meta-label">by</span>
			<a href="https://grungecake.com/author/andy-alexis" title="Posts by Andy Alexis" rel="author">
			<img width="30" height="30" src="https://cdn.statically.io/img/grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-48x48.png?quality=100&f=auto" class="avatar avatar-30 photo jetpack-lazy-image" alt="" data-attachment-id="81870" data-permalink="https://grungecake.com/andy-alexis-grungecake-hip-hop-editor-icon" data-orig-file="https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon.png" data-orig-size="941,941" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="andy-alexis-grungecake-hip-hop-editor-icon" data-image-description="" data-image-caption="" data-medium-file="https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-300x300.png" data-large-file="https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon.png" data-lazy-srcset="https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-48x48.png 48w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-300x300.png 300w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-290x290.png 290w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-768x768.png 768w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-192x192.png 192w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-384x384.png 384w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-110x110.png 110w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-220x220.png 220w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-561x561.png 561w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-364x364.png 364w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-728x728.png 728w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-608x608.png 608w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-758x758.png 758w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-96x96.png 96w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-150x150.png 150w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-24x24.png 24w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon.png 941w" data-lazy-sizes="(max-width: 30px) 100vw, 30px" data-lazy-src="https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-48x48.png?is-pending-load=1" srcset="" />
							<strong>Andy Alexis</strong>
					</a>
	</span>
	
					<time class="entry-date" datetime="2021-11-01T16:11:59-05:00">1st November 2021, 4:11 PM</time>				</p>
			</footer>
		
					<div class="entry-todome g1-dropable snax">
					<p class="entry-ctas">
		<a class="entry-cta g1-button g1-button-simple g1-button-s" href="https://grungecake.com/james-harden-early-season-struggles/articles/83830">
			Read More		</a>
	</p>
	
				
							</div>
			</div>
</article>
						</li>

					
						<li class="g1-collection-item">
							
<article class="entry-tpl-list-s g1-card g1-card-solid post-83824 post type-post status-publish format-standard has-post-thumbnail category-athletes category-news category-sports tag-derrick-herny tag-nfl tag-tennessee-titans">
	<div class="entry-featured-media" ><a title="Tennessee Titans searching for replacement: RB Derrick Henry suffers potential season-ending foot injury" class="g1-frame" href="https://grungecake.com/derrick-henry-potential-season-ending-injury/articles/83824"><div class="g1-frame-inner"><img width="265" height="186" src="https://cdn.statically.io/img/grungecake.com/wp-content/uploads/2021/11/derrick-herny-grungecake-thumbnail-265x186.webp?crop=1&quality=100&f=auto" class="attachment-bimber-list-s size-bimber-list-s wp-post-image jetpack-lazy-image" alt="" data-attachment-id="83826" data-permalink="https://grungecake.com/derrick-henry-potential-season-ending-injury/articles/83824/derrick-herny-grungecake-thumbnail" data-orig-file="https://grungecake.com/wp-content/uploads/2021/11/derrick-herny-grungecake-thumbnail.webp" data-orig-size="1000,600" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="derrick-herny-grungecake-thumbnail" data-image-description="" data-image-caption="&lt;p&gt;Photo: &lt;a href=&quot;https://titanswire.usatoday.com/2021/10/31/derrick-henry-injury-update-tennessee-titans-week-8/&quot; target=&quot;_blank&quot; rel=&quot;noopener&quot;&gt;Titans Wire &#8211; USA Today&lt;/a&gt;&lt;/p&gt;" data-medium-file="https://grungecake.com/wp-content/uploads/2021/11/derrick-herny-grungecake-thumbnail-300x180.webp" data-large-file="https://grungecake.com/wp-content/uploads/2021/11/derrick-herny-grungecake-thumbnail.webp" data-lazy-srcset="https://grungecake.com/wp-content/uploads/2021/11/derrick-herny-grungecake-thumbnail-265x186.webp?crop=1 265w, https://grungecake.com/wp-content/uploads/2021/11/derrick-herny-grungecake-thumbnail-531x371.webp?crop=1 531w" data-lazy-sizes="(max-width: 265px) 100vw, 265px" data-lazy-src="https://grungecake.com/wp-content/uploads/2021/11/derrick-herny-grungecake-thumbnail-265x186.webp?crop=1&amp;is-pending-load=1" srcset="" /><span class="g1-frame-icon g1-frame-icon-"></span></div></a></div>
		
	<div class="entry-body">
		<header class="entry-header">
			<div class="entry-before-title">
				
							</div>

			<h3 class="g1-gamma g1-gamma-1st entry-title"><a href="https://grungecake.com/derrick-henry-potential-season-ending-injury/articles/83824" rel="bookmark">Tennessee Titans searching for replacement: RB Derrick Henry suffers potential season-ending foot injury</a></h3>
					</header>

		
					<footer>
				<p class="g1-meta entry-meta entry-byline entry-byline-with-avatar">
								<span class="entry-author">
	
		<span class="entry-meta-label">by</span>
			<a href="https://grungecake.com/author/andy-alexis" title="Posts by Andy Alexis" rel="author">
			<img width="30" height="30" src="https://cdn.statically.io/img/grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-48x48.png?quality=100&f=auto" class="avatar avatar-30 photo jetpack-lazy-image" alt="" data-attachment-id="81870" data-permalink="https://grungecake.com/andy-alexis-grungecake-hip-hop-editor-icon" data-orig-file="https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon.png" data-orig-size="941,941" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="andy-alexis-grungecake-hip-hop-editor-icon" data-image-description="" data-image-caption="" data-medium-file="https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-300x300.png" data-large-file="https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon.png" data-lazy-srcset="https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-48x48.png 48w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-300x300.png 300w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-290x290.png 290w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-768x768.png 768w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-192x192.png 192w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-384x384.png 384w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-110x110.png 110w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-220x220.png 220w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-561x561.png 561w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-364x364.png 364w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-728x728.png 728w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-608x608.png 608w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-758x758.png 758w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-96x96.png 96w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-150x150.png 150w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-24x24.png 24w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon.png 941w" data-lazy-sizes="(max-width: 30px) 100vw, 30px" data-lazy-src="https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-48x48.png?is-pending-load=1" srcset="" />
							<strong>Andy Alexis</strong>
					</a>
	</span>
	
					<time class="entry-date" datetime="2021-11-01T14:00:44-05:00">1st November 2021, 2:00 PM</time>				</p>
			</footer>
		
					<div class="entry-todome g1-dropable snax">
					<p class="entry-ctas">
		<a class="entry-cta g1-button g1-button-simple g1-button-s" href="https://grungecake.com/derrick-henry-potential-season-ending-injury/articles/83824">
			Read More		</a>
	</p>
	
				
							</div>
			</div>
</article>
						</li>

					
						<li class="g1-collection-item">
							
<article class="entry-tpl-list-s g1-card g1-card-solid post-83811 post type-post status-publish format-standard has-post-thumbnail category-athletes category-sports tag-michigan tag-michigan-state tag-ncaa tag-ohio-state tag-penn-state">
	<div class="entry-featured-media" ><a title="College Football Week 9 face-off: 6 Michigan @ 9 Michigan State &#038; 7 Penn State @ 5 Ohio State" class="g1-frame" href="https://grungecake.com/college-football-week-9-face-off/articles/83811"><div class="g1-frame-inner"><img width="265" height="186" src="https://cdn.statically.io/img/grungecake.com/wp-content/uploads/2021/10/ncaa-2-collage-grungecake-thumbnail-265x186.png?crop=1&quality=100&f=auto" class="attachment-bimber-list-s size-bimber-list-s wp-post-image jetpack-lazy-image" alt="" data-attachment-id="83816" data-permalink="https://grungecake.com/college-football-week-9-face-off/articles/83811/ncaa-2-collage-grungecake-thumbnail" data-orig-file="https://grungecake.com/wp-content/uploads/2021/10/ncaa-2-collage-grungecake-thumbnail.png" data-orig-size="500,500" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="ncaa-2-collage-grungecake-thumbnail" data-image-description="" data-image-caption="" data-medium-file="https://grungecake.com/wp-content/uploads/2021/10/ncaa-2-collage-grungecake-thumbnail-300x300.png?crop=1" data-large-file="https://grungecake.com/wp-content/uploads/2021/10/ncaa-2-collage-grungecake-thumbnail.png" data-lazy-src="https://grungecake.com/wp-content/uploads/2021/10/ncaa-2-collage-grungecake-thumbnail-265x186.png?crop=1&amp;is-pending-load=1" srcset="" /><span class="g1-frame-icon g1-frame-icon-"></span></div></a></div>
		
	<div class="entry-body">
		<header class="entry-header">
			<div class="entry-before-title">
				
							</div>

			<h3 class="g1-gamma g1-gamma-1st entry-title"><a href="https://grungecake.com/college-football-week-9-face-off/articles/83811" rel="bookmark">College Football Week 9 face-off: 6 Michigan @ 9 Michigan State &#038; 7 Penn State @ 5 Ohio State</a></h3>
					</header>

		
					<footer>
				<p class="g1-meta entry-meta entry-byline entry-byline-with-avatar">
								<span class="entry-author">
	
		<span class="entry-meta-label">by</span>
			<a href="https://grungecake.com/author/andy-alexis" title="Posts by Andy Alexis" rel="author">
			<img width="30" height="30" src="https://cdn.statically.io/img/grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-48x48.png?quality=100&f=auto" class="avatar avatar-30 photo jetpack-lazy-image" alt="" data-attachment-id="81870" data-permalink="https://grungecake.com/andy-alexis-grungecake-hip-hop-editor-icon" data-orig-file="https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon.png" data-orig-size="941,941" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="andy-alexis-grungecake-hip-hop-editor-icon" data-image-description="" data-image-caption="" data-medium-file="https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-300x300.png" data-large-file="https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon.png" data-lazy-srcset="https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-48x48.png 48w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-300x300.png 300w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-290x290.png 290w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-768x768.png 768w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-192x192.png 192w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-384x384.png 384w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-110x110.png 110w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-220x220.png 220w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-561x561.png 561w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-364x364.png 364w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-728x728.png 728w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-608x608.png 608w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-758x758.png 758w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-96x96.png 96w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-150x150.png 150w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-24x24.png 24w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon.png 941w" data-lazy-sizes="(max-width: 30px) 100vw, 30px" data-lazy-src="https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-48x48.png?is-pending-load=1" srcset="" />
							<strong>Andy Alexis</strong>
					</a>
	</span>
	
					<time class="entry-date" datetime="2021-10-30T05:15:00-05:00">30th October 2021, 5:15 AM</time>				</p>
			</footer>
		
					<div class="entry-todome g1-dropable snax">
					<p class="entry-ctas">
		<a class="entry-cta g1-button g1-button-simple g1-button-s" href="https://grungecake.com/college-football-week-9-face-off/articles/83811">
			Read More		</a>
	</p>
	
				
							</div>
			</div>
</article>
						</li>

									</ul>
			</div>
		</div>

					</aside>


	<meta itemprop="mainEntityOfPage" content="https://grungecake.com/which-nfl-club-best-fit-odell-beckham-jr/articles/83935"/>
	<meta itemprop="dateModified"
	      content="2021-11-07T05:48:46"/>

	<span itemprop="publisher" itemscope itemtype="http://schema.org/Organization">
		<meta itemprop="name" content="GRUNGECAKE" />
		<meta itemprop="url" content="https://grungecake.com" />
		<span itemprop="logo" itemscope itemtype="http://schema.org/ImageObject">
			<meta itemprop="url" content="https://grungecake.com/wp-content/uploads/2021/06/grungecake-logo-type-white.png" />
		</span>
	</span>
			<span itemprop="image" itemscope itemtype="http://schema.org/ImageObject">
						<meta itemprop="url" content="https://grungecake.com/wp-content/uploads/2021/11/OBJ-grungecake-thumbnail.webp" />
			<meta itemprop="width" content="525" />
			<meta itemprop="height" content="350" />
		</span>
	<span class="bimber-load-next-post"><a data-bimber-analytics-href="https://grungecake.com/atlanta-braves-win-world-series/articles/83885" href="https://grungecake.com/atlanta-braves-win-world-series/articles/83885" rel="prev">Next post</a><i class="g1-collection-more-spinner"></i></span>				</div>
			</div>

			<div id="secondary" class="g1-sidebar g1-with-cards g1-column g1-column-1of3">
	<aside id="search-9" class="widget g1-card g1-card-l g1-card-solid widget_search"><header><h2 class="g1-delta g1-delta-2nd widgettitle"><span>Search GRUNGECAKE.com</span></h2></header>

<div role="search" class="search-form-wrapper">
	<form method="get"
	      class="g1-searchform-tpl-default g1-searchform-ajax search-form"
	      action="https://grungecake.com/">
		<label>
			<span class="screen-reader-text">Search for:</span>
			<input type="search" class="search-field"
			       placeholder="Search"
			       value="" name="s"
			       title="Search for:" />
		</label>
		<button class="search-submit">Search</button>
	</form>

			<div class="g1-searches g1-searches-ajax"></div>
	</div>
</aside><aside id="bimber_widget_posts-80015" class="widget g1-card g1-card-l g1-card-solid widget_bimber_widget_posts"><header><h2 class="g1-delta g1-delta-2nd widgettitle"><span>Sports News</span></h2></header>			<div id="g1-widget-posts-1"
			     class="g1-widget-posts">
									<div class="g1-collection g1-collection-grid-xxs g1-collection-columns-2">
	
			<div class="g1-collection-viewport">
			<ul class="g1-collection-items">
									<li class="g1-collection-item">
						
<article class="entry-tpl-grid entry-tpl-grid-xxs post-83935 post type-post status-publish format-standard has-post-thumbnail category-athletes category-sports tag-cleveland-browns tag-nfl tag-odell-beckham-jr">
	<div class="entry-featured-media" ><a title="Which NFL club best fit Odell Beckham Jr.?" class="g1-frame" href="https://grungecake.com/which-nfl-club-best-fit-odell-beckham-jr/articles/83935"><div class="g1-frame-inner"><img width="364" height="205" src="https://cdn.statically.io/img/grungecake.com/wp-content/uploads/2021/11/OBJ-grungecake-thumbnail-364x205.webp?crop=1&quality=100&f=auto" class="attachment-bimber-grid-standard size-bimber-grid-standard wp-post-image jetpack-lazy-image" alt="" data-attachment-id="83938" data-permalink="https://grungecake.com/which-nfl-club-best-fit-odell-beckham-jr/articles/83935/obj-grungecake-thumbnail" data-orig-file="https://grungecake.com/wp-content/uploads/2021/11/OBJ-grungecake-thumbnail.webp" data-orig-size="525,350" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="OBJ-grungecake-thumbnail" data-image-description="" data-image-caption="&lt;p&gt;Photo: &lt;a href=&quot;https://www.denverpost.com/2021/11/05/pick-6-odds-odell-beckham-jr-rose-namajunas/&quot; target=&quot;_blank&quot; rel=&quot;noopener&quot;&gt;Denver PostPitchfork&lt;/a&gt;&lt;/p&gt;" data-medium-file="https://grungecake.com/wp-content/uploads/2021/11/OBJ-grungecake-thumbnail-300x200.webp" data-large-file="https://grungecake.com/wp-content/uploads/2021/11/OBJ-grungecake-thumbnail.webp" data-lazy-srcset="https://grungecake.com/wp-content/uploads/2021/11/OBJ-grungecake-thumbnail-364x205.webp?crop=1 364w, https://grungecake.com/wp-content/uploads/2021/11/OBJ-grungecake-thumbnail-192x108.webp?crop=1 192w, https://grungecake.com/wp-content/uploads/2021/11/OBJ-grungecake-thumbnail-384x216.webp?crop=1 384w" data-lazy-sizes="(max-width: 364px) 100vw, 364px" data-lazy-src="https://grungecake.com/wp-content/uploads/2021/11/OBJ-grungecake-thumbnail-364x205.webp?crop=1&amp;is-pending-load=1" srcset="" /><span class="g1-frame-icon g1-frame-icon-"></span></div></a></div>
		
	<div class="entry-body">
		<header class="entry-header">
			<div class="entry-before-title">
				
							</div>

		<h3 class="g1-epsilon g1-epsilon-1st entry-title"><a href="https://grungecake.com/which-nfl-club-best-fit-odell-beckham-jr/articles/83935" rel="bookmark">Which NFL club best fit Odell Beckham Jr.?</a></h3>		</header>

		
					<footer>
				<p class="g1-meta entry-meta entry-byline entry-byline-with-avatar">
								<span class="entry-author">
	
		<span class="entry-meta-label">by</span>
			<a href="https://grungecake.com/author/andy-alexis" title="Posts by Andy Alexis" rel="author">
			<img width="30" height="30" src="https://cdn.statically.io/img/grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-48x48.png?quality=100&f=auto" class="avatar avatar-30 photo jetpack-lazy-image" alt="" data-attachment-id="81870" data-permalink="https://grungecake.com/andy-alexis-grungecake-hip-hop-editor-icon" data-orig-file="https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon.png" data-orig-size="941,941" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="andy-alexis-grungecake-hip-hop-editor-icon" data-image-description="" data-image-caption="" data-medium-file="https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-300x300.png" data-large-file="https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon.png" data-lazy-srcset="https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-48x48.png 48w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-300x300.png 300w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-290x290.png 290w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-768x768.png 768w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-192x192.png 192w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-384x384.png 384w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-110x110.png 110w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-220x220.png 220w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-561x561.png 561w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-364x364.png 364w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-728x728.png 728w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-608x608.png 608w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-758x758.png 758w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-96x96.png 96w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-150x150.png 150w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-24x24.png 24w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon.png 941w" data-lazy-sizes="(max-width: 30px) 100vw, 30px" data-lazy-src="https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-48x48.png?is-pending-load=1" srcset="" />
							<strong>Andy Alexis</strong>
					</a>
	</span>
	
					<time class="entry-date" datetime="2021-11-07T05:48:46-05:00">7th November 2021, 5:48 AM</time>				</p>
			</footer>
		
			</div>
</article>
					</li>
									<li class="g1-collection-item">
						
<article class="entry-tpl-grid entry-tpl-grid-xxs post-83885 post type-post status-publish format-standard has-post-thumbnail category-athletes category-news category-sports tag-atlanta-braves tag-mlb tag-the-astros tag-world-series">
	<div class="entry-featured-media" ><a title="Atlanta Braves: World Series Champions, after beating The Astros in 6 games" class="g1-frame" href="https://grungecake.com/atlanta-braves-win-world-series/articles/83885"><div class="g1-frame-inner"><img width="364" height="205" src="https://cdn.statically.io/img/grungecake.com/wp-content/uploads/2021/11/atlanta-braves-grungecake-thumbnail-364x205.jpg?crop=1&quality=100&f=auto" class="attachment-bimber-grid-standard size-bimber-grid-standard wp-post-image jetpack-lazy-image" alt="" data-attachment-id="83887" data-permalink="https://grungecake.com/atlanta-braves-win-world-series/articles/83885/atlanta-braves-grungecake-thumbnail" data-orig-file="https://grungecake.com/wp-content/uploads/2021/11/atlanta-braves-grungecake-thumbnail.jpg" data-orig-size="640,427" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="atlanta-braves-grungecake-thumbnail" data-image-description="" data-image-caption="&lt;p&gt;Photo: &lt;a href=&quot;https://sports.yahoo.com/where-to-shop-atlanta-braves-2021-world-series-championship-gear-035821307.html&quot; target=&quot;_blank&quot; rel=&quot;noopener&quot;&gt;Yahoo Sports&lt;/a&gt;&lt;/p&gt;" data-medium-file="https://grungecake.com/wp-content/uploads/2021/11/atlanta-braves-grungecake-thumbnail-300x200.jpg" data-large-file="https://grungecake.com/wp-content/uploads/2021/11/atlanta-braves-grungecake-thumbnail.jpg" data-lazy-srcset="https://grungecake.com/wp-content/uploads/2021/11/atlanta-braves-grungecake-thumbnail-364x205.jpg?crop=1 364w, https://grungecake.com/wp-content/uploads/2021/11/atlanta-braves-grungecake-thumbnail-192x108.jpg?crop=1 192w, https://grungecake.com/wp-content/uploads/2021/11/atlanta-braves-grungecake-thumbnail-384x216.jpg?crop=1 384w, https://grungecake.com/wp-content/uploads/2021/11/atlanta-braves-grungecake-thumbnail-561x316.jpg?crop=1 561w" data-lazy-sizes="(max-width: 364px) 100vw, 364px" data-lazy-src="https://grungecake.com/wp-content/uploads/2021/11/atlanta-braves-grungecake-thumbnail-364x205.jpg?crop=1&amp;is-pending-load=1" srcset="" /><span class="g1-frame-icon g1-frame-icon-"></span></div></a></div>
		
	<div class="entry-body">
		<header class="entry-header">
			<div class="entry-before-title">
				
							</div>

		<h3 class="g1-epsilon g1-epsilon-1st entry-title"><a href="https://grungecake.com/atlanta-braves-win-world-series/articles/83885" rel="bookmark">Atlanta Braves: World Series Champions, after beating The Astros in 6 games</a></h3>		</header>

		
					<footer>
				<p class="g1-meta entry-meta entry-byline entry-byline-with-avatar">
								<span class="entry-author">
	
		<span class="entry-meta-label">by</span>
			<a href="https://grungecake.com/author/andy-alexis" title="Posts by Andy Alexis" rel="author">
			<img width="30" height="30" src="https://cdn.statically.io/img/grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-48x48.png?quality=100&f=auto" class="avatar avatar-30 photo jetpack-lazy-image" alt="" data-attachment-id="81870" data-permalink="https://grungecake.com/andy-alexis-grungecake-hip-hop-editor-icon" data-orig-file="https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon.png" data-orig-size="941,941" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="andy-alexis-grungecake-hip-hop-editor-icon" data-image-description="" data-image-caption="" data-medium-file="https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-300x300.png" data-large-file="https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon.png" data-lazy-srcset="https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-48x48.png 48w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-300x300.png 300w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-290x290.png 290w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-768x768.png 768w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-192x192.png 192w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-384x384.png 384w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-110x110.png 110w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-220x220.png 220w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-561x561.png 561w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-364x364.png 364w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-728x728.png 728w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-608x608.png 608w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-758x758.png 758w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-96x96.png 96w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-150x150.png 150w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-24x24.png 24w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon.png 941w" data-lazy-sizes="(max-width: 30px) 100vw, 30px" data-lazy-src="https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-48x48.png?is-pending-load=1" srcset="" />
							<strong>Andy Alexis</strong>
					</a>
	</span>
	
					<time class="entry-date" datetime="2021-11-03T01:41:17-05:00">3rd November 2021, 1:41 AM</time>				</p>
			</footer>
		
			</div>
</article>
					</li>
									<li class="g1-collection-item">
						
<article class="entry-tpl-grid entry-tpl-grid-xxs post-83862 post type-post status-publish format-standard has-post-thumbnail category-athletes category-news category-sports tag-henry-ruggs-iii tag-las-vagas-raiders tag-nfl">
	<div class="entry-featured-media" ><a title="Las Vegas Raiders WR Henry Ruggs III charged with DUI, involving fatal car accident" class="g1-frame" href="https://grungecake.com/las-vegas-raiders-henry-ruggs-dui-charge/articles/83862"><div class="g1-frame-inner"><img width="364" height="205" src="https://cdn.statically.io/img/grungecake.com/wp-content/uploads/2021/11/henry-ruggs-grungecake-thumbnail-364x205.webp?crop=1&quality=100&f=auto" class="attachment-bimber-grid-standard size-bimber-grid-standard wp-post-image jetpack-lazy-image" alt="" data-attachment-id="83865" data-permalink="https://grungecake.com/las-vegas-raiders-henry-ruggs-dui-charge/articles/83862/henry-ruggs-grungecake-thumbnail" data-orig-file="https://grungecake.com/wp-content/uploads/2021/11/henry-ruggs-grungecake-thumbnail.webp" data-orig-size="2560,1440" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="henry-ruggs-grungecake-thumbnail" data-image-description="" data-image-caption="&lt;p&gt;Photo: &lt;a href=&quot;https://ktla.com/news/nationworld/raiders-wide-receiver-henry-ruggs-faces-dui-charge-in-vegas-crash-that-killed-woman-injured-2/&quot; target=&quot;_blank&quot; rel=&quot;noopener&quot;&gt;KTLA&lt;/a&gt;&lt;/p&gt;" data-medium-file="https://grungecake.com/wp-content/uploads/2021/11/henry-ruggs-grungecake-thumbnail-300x169.webp" data-large-file="https://grungecake.com/wp-content/uploads/2021/11/henry-ruggs-grungecake-thumbnail-1024x576.webp" data-lazy-srcset="https://grungecake.com/wp-content/uploads/2021/11/henry-ruggs-grungecake-thumbnail-364x205.webp?crop=1 364w, https://grungecake.com/wp-content/uploads/2021/11/henry-ruggs-grungecake-thumbnail-300x169.webp 300w, https://grungecake.com/wp-content/uploads/2021/11/henry-ruggs-grungecake-thumbnail-1024x576.webp 1024w, https://grungecake.com/wp-content/uploads/2021/11/henry-ruggs-grungecake-thumbnail-768x432.webp 768w, https://grungecake.com/wp-content/uploads/2021/11/henry-ruggs-grungecake-thumbnail-1536x864.webp 1536w, https://grungecake.com/wp-content/uploads/2021/11/henry-ruggs-grungecake-thumbnail-2048x1152.webp 2048w, https://grungecake.com/wp-content/uploads/2021/11/henry-ruggs-grungecake-thumbnail-192x108.webp?crop=1 192w, https://grungecake.com/wp-content/uploads/2021/11/henry-ruggs-grungecake-thumbnail-384x216.webp?crop=1 384w, https://grungecake.com/wp-content/uploads/2021/11/henry-ruggs-grungecake-thumbnail-728x409.webp?crop=1 728w, https://grungecake.com/wp-content/uploads/2021/11/henry-ruggs-grungecake-thumbnail-561x316.webp?crop=1 561w, https://grungecake.com/wp-content/uploads/2021/11/henry-ruggs-grungecake-thumbnail-1122x631.webp?crop=1 1122w, https://grungecake.com/wp-content/uploads/2021/11/henry-ruggs-grungecake-thumbnail-608x342.webp 608w, https://grungecake.com/wp-content/uploads/2021/11/henry-ruggs-grungecake-thumbnail-758x426.webp?crop=1 758w, https://grungecake.com/wp-content/uploads/2021/11/henry-ruggs-grungecake-thumbnail-1152x648.webp?crop=1 1152w, https://grungecake.com/wp-content/uploads/2021/11/henry-ruggs-grungecake-thumbnail-550x309.webp 550w, https://grungecake.com/wp-content/uploads/2021/11/henry-ruggs-grungecake-thumbnail-150x84.webp 150w" data-lazy-sizes="(max-width: 364px) 100vw, 364px" data-lazy-src="https://grungecake.com/wp-content/uploads/2021/11/henry-ruggs-grungecake-thumbnail-364x205.webp?crop=1&amp;is-pending-load=1" srcset="" /><span class="g1-frame-icon g1-frame-icon-"></span></div></a></div>
		
	<div class="entry-body">
		<header class="entry-header">
			<div class="entry-before-title">
				
							</div>

		<h3 class="g1-epsilon g1-epsilon-1st entry-title"><a href="https://grungecake.com/las-vegas-raiders-henry-ruggs-dui-charge/articles/83862" rel="bookmark">Las Vegas Raiders WR Henry Ruggs III charged with DUI, involving fatal car accident</a></h3>		</header>

		
					<footer>
				<p class="g1-meta entry-meta entry-byline entry-byline-with-avatar">
								<span class="entry-author">
	
		<span class="entry-meta-label">by</span>
			<a href="https://grungecake.com/author/andy-alexis" title="Posts by Andy Alexis" rel="author">
			<img width="30" height="30" src="https://cdn.statically.io/img/grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-48x48.png?quality=100&f=auto" class="avatar avatar-30 photo jetpack-lazy-image" alt="" data-attachment-id="81870" data-permalink="https://grungecake.com/andy-alexis-grungecake-hip-hop-editor-icon" data-orig-file="https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon.png" data-orig-size="941,941" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="andy-alexis-grungecake-hip-hop-editor-icon" data-image-description="" data-image-caption="" data-medium-file="https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-300x300.png" data-large-file="https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon.png" data-lazy-srcset="https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-48x48.png 48w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-300x300.png 300w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-290x290.png 290w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-768x768.png 768w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-192x192.png 192w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-384x384.png 384w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-110x110.png 110w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-220x220.png 220w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-561x561.png 561w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-364x364.png 364w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-728x728.png 728w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-608x608.png 608w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-758x758.png 758w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-96x96.png 96w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-150x150.png 150w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-24x24.png 24w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon.png 941w" data-lazy-sizes="(max-width: 30px) 100vw, 30px" data-lazy-src="https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-48x48.png?is-pending-load=1" srcset="" />
							<strong>Andy Alexis</strong>
					</a>
	</span>
	
					<time class="entry-date" datetime="2021-11-02T18:47:49-05:00">2nd November 2021, 6:47 PM</time>				</p>
			</footer>
		
			</div>
</article>
					</li>
									<li class="g1-collection-item">
						
<article class="entry-tpl-grid entry-tpl-grid-xxs post-83830 post type-post status-publish format-standard has-post-thumbnail category-athletes category-news category-sports tag-james-harden tag-nba">
	<div class="entry-featured-media" ><a title="James Harden&#8217;s early-season struggles" class="g1-frame" href="https://grungecake.com/james-harden-early-season-struggles/articles/83830"><div class="g1-frame-inner"><img width="364" height="205" src="https://cdn.statically.io/img/grungecake.com/wp-content/uploads/2021/11/james-harden-grungecake-thumbnail-364x205.jpg?crop=1&quality=100&f=auto" class="attachment-bimber-grid-standard size-bimber-grid-standard wp-post-image jetpack-lazy-image" alt="" data-attachment-id="83832" data-permalink="https://grungecake.com/james-harden-early-season-struggles/articles/83830/james-harden-grungecake-thumbnail" data-orig-file="https://grungecake.com/wp-content/uploads/2021/11/james-harden-grungecake-thumbnail.jpg" data-orig-size="800,533" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="james-harden-grungecake-thumbnail" data-image-description="" data-image-caption="&lt;p&gt;Photo: &lt;a href=&quot;https://bleacherreport.com/articles/2949859-numbers-dont-lie-james-harden-nets-look-ordinary-without-the-free-throws&quot; target=&quot;_blank&quot; rel=&quot;noopener&quot;&gt;Bleacher Report&lt;/a&gt;&lt;/p&gt;" data-medium-file="https://grungecake.com/wp-content/uploads/2021/11/james-harden-grungecake-thumbnail-300x200.jpg" data-large-file="https://grungecake.com/wp-content/uploads/2021/11/james-harden-grungecake-thumbnail.jpg" data-lazy-srcset="https://grungecake.com/wp-content/uploads/2021/11/james-harden-grungecake-thumbnail-364x205.jpg?crop=1 364w, https://grungecake.com/wp-content/uploads/2021/11/james-harden-grungecake-thumbnail-192x108.jpg?crop=1 192w, https://grungecake.com/wp-content/uploads/2021/11/james-harden-grungecake-thumbnail-384x216.jpg?crop=1 384w, https://grungecake.com/wp-content/uploads/2021/11/james-harden-grungecake-thumbnail-728x409.jpg?crop=1 728w, https://grungecake.com/wp-content/uploads/2021/11/james-harden-grungecake-thumbnail-561x316.jpg?crop=1 561w, https://grungecake.com/wp-content/uploads/2021/11/james-harden-grungecake-thumbnail-758x426.jpg?crop=1 758w" data-lazy-sizes="(max-width: 364px) 100vw, 364px" data-lazy-src="https://grungecake.com/wp-content/uploads/2021/11/james-harden-grungecake-thumbnail-364x205.jpg?crop=1&amp;is-pending-load=1" srcset="" /><span class="g1-frame-icon g1-frame-icon-"></span></div></a></div>
		
	<div class="entry-body">
		<header class="entry-header">
			<div class="entry-before-title">
				
							</div>

		<h3 class="g1-epsilon g1-epsilon-1st entry-title"><a href="https://grungecake.com/james-harden-early-season-struggles/articles/83830" rel="bookmark">James Harden&#8217;s early-season struggles</a></h3>		</header>

		
					<footer>
				<p class="g1-meta entry-meta entry-byline entry-byline-with-avatar">
								<span class="entry-author">
	
		<span class="entry-meta-label">by</span>
			<a href="https://grungecake.com/author/andy-alexis" title="Posts by Andy Alexis" rel="author">
			<img width="30" height="30" src="https://cdn.statically.io/img/grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-48x48.png?quality=100&f=auto" class="avatar avatar-30 photo jetpack-lazy-image" alt="" data-attachment-id="81870" data-permalink="https://grungecake.com/andy-alexis-grungecake-hip-hop-editor-icon" data-orig-file="https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon.png" data-orig-size="941,941" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="andy-alexis-grungecake-hip-hop-editor-icon" data-image-description="" data-image-caption="" data-medium-file="https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-300x300.png" data-large-file="https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon.png" data-lazy-srcset="https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-48x48.png 48w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-300x300.png 300w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-290x290.png 290w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-768x768.png 768w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-192x192.png 192w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-384x384.png 384w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-110x110.png 110w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-220x220.png 220w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-561x561.png 561w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-364x364.png 364w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-728x728.png 728w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-608x608.png 608w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-758x758.png 758w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-96x96.png 96w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-150x150.png 150w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-24x24.png 24w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon.png 941w" data-lazy-sizes="(max-width: 30px) 100vw, 30px" data-lazy-src="https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-48x48.png?is-pending-load=1" srcset="" />
							<strong>Andy Alexis</strong>
					</a>
	</span>
	
					<time class="entry-date" datetime="2021-11-01T16:11:59-05:00">1st November 2021, 4:11 PM</time>				</p>
			</footer>
		
			</div>
</article>
					</li>
							</ul>
		</div>
	</div><!-- .g1-collection -->
							</div>
			</aside><aside id="bimber_widget_posts-80014" class="widget g1-card g1-card-l g1-card-solid widget_bimber_widget_posts"><header><h2 class="g1-delta g1-delta-2nd widgettitle"><span>Albums to Consider</span></h2></header>			<div id="g1-widget-posts-1"
			     class="g1-widget-posts">
									<div class="g1-collection g1-collection-grid-xxs g1-collection-columns-2">
	
			<div class="g1-collection-viewport">
			<ul class="g1-collection-items">
									<li class="g1-collection-item">
						
<article class="entry-tpl-grid entry-tpl-grid-xxs post-83790 post type-post status-publish format-standard has-post-thumbnail category-albums category-music category-music-videos tag-2-big-2-ignore tag-fake-smiles tag-t-rell">
	<div class="entry-featured-media" ><a title="T-Rell displays next level vulnerability on video &#8216;Fake Smiles&#8217;" class="g1-frame" href="https://grungecake.com/t-rell-fake-smiles/articles/83790"><div class="g1-frame-inner"><img width="364" height="205" src="https://cdn.statically.io/img/grungecake.com/wp-content/uploads/2021/10/t-rell-grungecake-thumbnail-364x205.gif?crop=1&quality=100&f=auto" class="attachment-bimber-grid-standard size-bimber-grid-standard wp-post-image jetpack-lazy-image" alt="" data-attachment-id="83792" data-permalink="https://grungecake.com/t-rell-fake-smiles/articles/83790/t-rell-grungecake-thumbnail" data-orig-file="https://grungecake.com/wp-content/uploads/2021/10/t-rell-grungecake-thumbnail.gif" data-orig-size="640,325" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="t-rell-grungecake-thumbnail" data-image-description="" data-image-caption="&lt;p&gt;GIF: Courtesy of publicist&lt;/p&gt;" data-medium-file="https://grungecake.com/wp-content/uploads/2021/10/t-rell-grungecake-thumbnail-300x152.gif" data-large-file="https://grungecake.com/wp-content/uploads/2021/10/t-rell-grungecake-thumbnail.gif" data-lazy-srcset="https://grungecake.com/wp-content/uploads/2021/10/t-rell-grungecake-thumbnail-364x205.gif?crop=1 364w, https://grungecake.com/wp-content/uploads/2021/10/t-rell-grungecake-thumbnail-192x108.gif?crop=1 192w, https://grungecake.com/wp-content/uploads/2021/10/t-rell-grungecake-thumbnail-384x216.gif?crop=1 384w, https://grungecake.com/wp-content/uploads/2021/10/t-rell-grungecake-thumbnail-561x316.gif?crop=1 561w" data-lazy-sizes="(max-width: 364px) 100vw, 364px" data-lazy-src="https://grungecake.com/wp-content/uploads/2021/10/t-rell-grungecake-thumbnail-364x205.gif?crop=1&amp;is-pending-load=1" srcset="" /><span class="g1-frame-icon g1-frame-icon-"></span></div></a></div>
		
	<div class="entry-body">
		<header class="entry-header">
			<div class="entry-before-title">
				
							</div>

		<h3 class="g1-epsilon g1-epsilon-1st entry-title"><a href="https://grungecake.com/t-rell-fake-smiles/articles/83790" rel="bookmark">T-Rell displays next level vulnerability on video &#8216;Fake Smiles&#8217;</a></h3>		</header>

		
					<footer>
				<p class="g1-meta entry-meta entry-byline entry-byline-with-avatar">
								<span class="entry-author">
	
		<span class="entry-meta-label">by</span>
			<a href="https://grungecake.com/author/andy-alexis" title="Posts by Andy Alexis" rel="author">
			<img width="30" height="30" src="https://cdn.statically.io/img/grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-48x48.png?quality=100&f=auto" class="avatar avatar-30 photo jetpack-lazy-image" alt="" data-attachment-id="81870" data-permalink="https://grungecake.com/andy-alexis-grungecake-hip-hop-editor-icon" data-orig-file="https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon.png" data-orig-size="941,941" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="andy-alexis-grungecake-hip-hop-editor-icon" data-image-description="" data-image-caption="" data-medium-file="https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-300x300.png" data-large-file="https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon.png" data-lazy-srcset="https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-48x48.png 48w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-300x300.png 300w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-290x290.png 290w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-768x768.png 768w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-192x192.png 192w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-384x384.png 384w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-110x110.png 110w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-220x220.png 220w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-561x561.png 561w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-364x364.png 364w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-728x728.png 728w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-608x608.png 608w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-758x758.png 758w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-96x96.png 96w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-150x150.png 150w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-24x24.png 24w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon.png 941w" data-lazy-sizes="(max-width: 30px) 100vw, 30px" data-lazy-src="https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-48x48.png?is-pending-load=1" srcset="" />
							<strong>Andy Alexis</strong>
					</a>
	</span>
	
					<time class="entry-date" datetime="2021-11-03T13:45:59-05:00">3rd November 2021, 1:45 PM</time>				</p>
			</footer>
		
			</div>
</article>
					</li>
									<li class="g1-collection-item">
						
<article class="entry-tpl-grid entry-tpl-grid-xxs post-83772 post type-post status-publish format-standard has-post-thumbnail category-albums category-music-videos category-news category-streams-and-downloads tag-cash-out tag-red-inf tag-the-most-high tag-ufo-fev">
	<div class="entry-featured-media" ><a title="Rising Hip-Hop star UFO FEV kicks back in Queens for &#8216;Cash Out&#8217; visual featuring Red Inf: Watch" class="g1-frame" href="https://grungecake.com/ufo-fev-cash-out-red-inf/articles/83772"><div class="g1-frame-inner"><img width="364" height="205" src="https://cdn.statically.io/img/grungecake.com/wp-content/uploads/2021/10/ufo-fev-cash-out-red-inf-grungecake-thumbnail-364x205.gif?crop=1&quality=100&f=auto" class="attachment-bimber-grid-standard size-bimber-grid-standard wp-post-image jetpack-lazy-image" alt="" data-attachment-id="83774" data-permalink="https://grungecake.com/ufo-fev-cash-out-red-inf/articles/83772/ufo-fev-cash-out-red-inf-grungecake-thumbnail" data-orig-file="https://grungecake.com/wp-content/uploads/2021/10/ufo-fev-cash-out-red-inf-grungecake-thumbnail.gif" data-orig-size="520,293" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="ufo-fev-cash-out-red-inf-grungecake-thumbnail" data-image-description="" data-image-caption="" data-medium-file="https://grungecake.com/wp-content/uploads/2021/10/ufo-fev-cash-out-red-inf-grungecake-thumbnail-300x169.gif" data-large-file="https://grungecake.com/wp-content/uploads/2021/10/ufo-fev-cash-out-red-inf-grungecake-thumbnail.gif" data-lazy-srcset="https://grungecake.com/wp-content/uploads/2021/10/ufo-fev-cash-out-red-inf-grungecake-thumbnail-364x205.gif?crop=1 364w, https://grungecake.com/wp-content/uploads/2021/10/ufo-fev-cash-out-red-inf-grungecake-thumbnail-300x169.gif 300w, https://grungecake.com/wp-content/uploads/2021/10/ufo-fev-cash-out-red-inf-grungecake-thumbnail-192x108.gif?crop=1 192w, https://grungecake.com/wp-content/uploads/2021/10/ufo-fev-cash-out-red-inf-grungecake-thumbnail-384x216.gif?crop=1 384w, https://grungecake.com/wp-content/uploads/2021/10/ufo-fev-cash-out-red-inf-grungecake-thumbnail-150x85.gif 150w" data-lazy-sizes="(max-width: 364px) 100vw, 364px" data-lazy-src="https://grungecake.com/wp-content/uploads/2021/10/ufo-fev-cash-out-red-inf-grungecake-thumbnail-364x205.gif?crop=1&amp;is-pending-load=1" srcset="" /><span class="g1-frame-icon g1-frame-icon-"></span></div></a></div>
		
	<div class="entry-body">
		<header class="entry-header">
			<div class="entry-before-title">
				
							</div>

		<h3 class="g1-epsilon g1-epsilon-1st entry-title"><a href="https://grungecake.com/ufo-fev-cash-out-red-inf/articles/83772" rel="bookmark">Rising Hip-Hop star UFO FEV kicks back in Queens for &#8216;Cash Out&#8217; visual featuring Red Inf: Watch</a></h3>		</header>

		
					<footer>
				<p class="g1-meta entry-meta entry-byline entry-byline-with-avatar">
								<span class="entry-author">
	
		<span class="entry-meta-label">by</span>
			<a href="https://grungecake.com/author/richardine" title="Posts by Richardine Bartee" rel="author">
			<img width="30" height="30" src="https://cdn.statically.io/img/grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-48x48.png?quality=100&f=auto" class="avatar avatar-30 photo jetpack-lazy-image" alt="" data-attachment-id="81818" data-permalink="https://grungecake.com/richardine-bartee-social-media-icon-september" data-orig-file="https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september.png" data-orig-size="400,400" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="richardine-bartee-social-media-icon-september" data-image-description="" data-image-caption="" data-medium-file="https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-300x300.png" data-large-file="https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september.png" data-lazy-srcset="https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-48x48.png 48w, https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-300x300.png 300w, https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-290x290.png 290w, https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-192x192.png 192w, https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-384x384.png 384w, https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-110x110.png 110w, https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-220x220.png 220w, https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-364x364.png 364w, https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-96x96.png 96w, https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-150x150.png 150w, https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-24x24.png 24w, https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september.png 400w" data-lazy-sizes="(max-width: 30px) 100vw, 30px" data-lazy-src="https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-48x48.png?is-pending-load=1" srcset="" />
							<strong>Richardine Bartee</strong>
					</a>
	</span>
	
					<time class="entry-date" datetime="2021-10-28T09:06:07-05:00">28th October 2021, 9:06 AM</time>				</p>
			</footer>
		
			</div>
</article>
					</li>
									<li class="g1-collection-item">
						
<article class="entry-tpl-grid entry-tpl-grid-xxs post-83593 post type-post status-publish format-standard has-post-thumbnail category-albums category-music category-music-videos tag-a-gangstas-pain tag-moneybagg-yo">
	<div class="entry-featured-media" ><a title="Moneybagg yo release a deluxe version to ‘A Gangsta’s Pain’, along with music video ‘Switches &#038; Dracs’ f/ Lil Durk and EST Gee." class="g1-frame" href="https://grungecake.com/moneybagg-yo-a-gangstas-pain-reloaded/articles/83593"><div class="g1-frame-inner"><img width="349" height="205" src="https://cdn.statically.io/img/grungecake.com/wp-content/uploads/2021/10/moneybagg-yo-gangstas-pain-349x205.jpg?quality=100&f=auto" class="attachment-bimber-grid-standard size-bimber-grid-standard wp-post-image jetpack-lazy-image" alt="" data-attachment-id="83598" data-permalink="https://grungecake.com/moneybagg-yo-a-gangstas-pain-reloaded/articles/83593/moneybagg-yo-gangstas-pain" data-orig-file="https://grungecake.com/wp-content/uploads/2021/10/moneybagg-yo-gangstas-pain.jpg" data-orig-size="349,349" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="moneybagg-yo-gangsta&#8217;s-pain" data-image-description="" data-image-caption="&lt;p&gt;Photo: Courtesy of Publicist &lt;/p&gt;" data-medium-file="https://grungecake.com/wp-content/uploads/2021/10/moneybagg-yo-gangstas-pain-300x300.jpg?crop=1" data-large-file="https://grungecake.com/wp-content/uploads/2021/10/moneybagg-yo-gangstas-pain.jpg" data-lazy-src="https://grungecake.com/wp-content/uploads/2021/10/moneybagg-yo-gangstas-pain-349x205.jpg?is-pending-load=1" srcset="" /><span class="g1-frame-icon g1-frame-icon-"></span></div></a></div>
		
	<div class="entry-body">
		<header class="entry-header">
			<div class="entry-before-title">
				
							</div>

		<h3 class="g1-epsilon g1-epsilon-1st entry-title"><a href="https://grungecake.com/moneybagg-yo-a-gangstas-pain-reloaded/articles/83593" rel="bookmark">Moneybagg yo release a deluxe version to ‘A Gangsta’s Pain’, along with music video ‘Switches &#038; Dracs’ f/ Lil Durk and EST Gee.</a></h3>		</header>

		
					<footer>
				<p class="g1-meta entry-meta entry-byline entry-byline-with-avatar">
								<span class="entry-author">
	
		<span class="entry-meta-label">by</span>
			<a href="https://grungecake.com/author/andy-alexis" title="Posts by Andy Alexis" rel="author">
			<img width="30" height="30" src="https://cdn.statically.io/img/grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-48x48.png?quality=100&f=auto" class="avatar avatar-30 photo jetpack-lazy-image" alt="" data-attachment-id="81870" data-permalink="https://grungecake.com/andy-alexis-grungecake-hip-hop-editor-icon" data-orig-file="https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon.png" data-orig-size="941,941" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="andy-alexis-grungecake-hip-hop-editor-icon" data-image-description="" data-image-caption="" data-medium-file="https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-300x300.png" data-large-file="https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon.png" data-lazy-srcset="https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-48x48.png 48w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-300x300.png 300w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-290x290.png 290w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-768x768.png 768w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-192x192.png 192w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-384x384.png 384w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-110x110.png 110w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-220x220.png 220w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-561x561.png 561w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-364x364.png 364w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-728x728.png 728w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-608x608.png 608w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-758x758.png 758w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-96x96.png 96w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-150x150.png 150w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-24x24.png 24w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon.png 941w" data-lazy-sizes="(max-width: 30px) 100vw, 30px" data-lazy-src="https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-48x48.png?is-pending-load=1" srcset="" />
							<strong>Andy Alexis</strong>
					</a>
	</span>
	
					<time class="entry-date" datetime="2021-10-23T00:00:23-05:00">23rd October 2021, 12:00 AM</time>				</p>
			</footer>
		
			</div>
</article>
					</li>
									<li class="g1-collection-item">
						
<article class="entry-tpl-grid entry-tpl-grid-xxs post-83385 post type-post status-publish format-standard has-post-thumbnail category-albums category-streams-and-downloads tag-dom-kennedy tag-from-the-westside-with-love-three">
	<div class="entry-featured-media" ><a title="Stream Dom Kennedy&#8217;s new album &#8216;From the Westside With Love Three&#8217;" class="g1-frame" href="https://grungecake.com/dom-kennedy-from-the-westside-with-love-three/articles/83385"><div class="g1-frame-inner"><img width="364" height="205" src="https://cdn.statically.io/img/grungecake.com/wp-content/uploads/2021/10/dom-kennedy-2021-grungecake-thumbnail-364x205.jpeg?crop=1&quality=100&f=auto" class="attachment-bimber-grid-standard size-bimber-grid-standard wp-post-image jetpack-lazy-image" alt="" data-attachment-id="83403" data-permalink="https://grungecake.com/dom-kennedy-from-the-westside-with-love-three/articles/83385/dom-kennedy-2021-grungecake-thumbnail" data-orig-file="https://grungecake.com/wp-content/uploads/2021/10/dom-kennedy-2021-grungecake-thumbnail.jpeg" data-orig-size="2560,1707" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="dom-kennedy-2021-grungecake-thumbnail" data-image-description="" data-image-caption="&lt;p&gt;Photo: Courtesy of the publicist&lt;/p&gt;" data-medium-file="https://grungecake.com/wp-content/uploads/2021/10/dom-kennedy-2021-grungecake-thumbnail-300x200.jpeg" data-large-file="https://grungecake.com/wp-content/uploads/2021/10/dom-kennedy-2021-grungecake-thumbnail-1024x683.jpeg" data-lazy-srcset="https://grungecake.com/wp-content/uploads/2021/10/dom-kennedy-2021-grungecake-thumbnail-364x205.jpeg?crop=1 364w, https://grungecake.com/wp-content/uploads/2021/10/dom-kennedy-2021-grungecake-thumbnail-192x108.jpeg?crop=1 192w, https://grungecake.com/wp-content/uploads/2021/10/dom-kennedy-2021-grungecake-thumbnail-384x216.jpeg?crop=1 384w, https://grungecake.com/wp-content/uploads/2021/10/dom-kennedy-2021-grungecake-thumbnail-728x409.jpeg?crop=1 728w, https://grungecake.com/wp-content/uploads/2021/10/dom-kennedy-2021-grungecake-thumbnail-561x316.jpeg?crop=1 561w, https://grungecake.com/wp-content/uploads/2021/10/dom-kennedy-2021-grungecake-thumbnail-1122x631.jpeg?crop=1 1122w, https://grungecake.com/wp-content/uploads/2021/10/dom-kennedy-2021-grungecake-thumbnail-758x426.jpeg?crop=1 758w, https://grungecake.com/wp-content/uploads/2021/10/dom-kennedy-2021-grungecake-thumbnail-1152x648.jpeg?crop=1 1152w" data-lazy-sizes="(max-width: 364px) 100vw, 364px" data-lazy-src="https://grungecake.com/wp-content/uploads/2021/10/dom-kennedy-2021-grungecake-thumbnail-364x205.jpeg?crop=1&amp;is-pending-load=1" srcset="" /><span class="g1-frame-icon g1-frame-icon-"></span></div></a></div>
		
	<div class="entry-body">
		<header class="entry-header">
			<div class="entry-before-title">
				
							</div>

		<h3 class="g1-epsilon g1-epsilon-1st entry-title"><a href="https://grungecake.com/dom-kennedy-from-the-westside-with-love-three/articles/83385" rel="bookmark">Stream Dom Kennedy&#8217;s new album &#8216;From the Westside With Love Three&#8217;</a></h3>		</header>

		
					<footer>
				<p class="g1-meta entry-meta entry-byline entry-byline-with-avatar">
								<span class="entry-author">
	
		<span class="entry-meta-label">by</span>
			<a href="https://grungecake.com/author/richardine" title="Posts by Richardine Bartee" rel="author">
			<img width="30" height="30" src="https://cdn.statically.io/img/grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-48x48.png?quality=100&f=auto" class="avatar avatar-30 photo jetpack-lazy-image" alt="" data-attachment-id="81818" data-permalink="https://grungecake.com/richardine-bartee-social-media-icon-september" data-orig-file="https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september.png" data-orig-size="400,400" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="richardine-bartee-social-media-icon-september" data-image-description="" data-image-caption="" data-medium-file="https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-300x300.png" data-large-file="https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september.png" data-lazy-srcset="https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-48x48.png 48w, https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-300x300.png 300w, https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-290x290.png 290w, https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-192x192.png 192w, https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-384x384.png 384w, https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-110x110.png 110w, https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-220x220.png 220w, https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-364x364.png 364w, https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-96x96.png 96w, https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-150x150.png 150w, https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-24x24.png 24w, https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september.png 400w" data-lazy-sizes="(max-width: 30px) 100vw, 30px" data-lazy-src="https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-48x48.png?is-pending-load=1" srcset="" />
							<strong>Richardine Bartee</strong>
					</a>
	</span>
	
					<time class="entry-date" datetime="2021-10-15T20:35:48-05:00">15th October 2021, 8:35 PM</time>				</p>
			</footer>
		
			</div>
</article>
					</li>
							</ul>
		</div>
	</div><!-- .g1-collection -->
							</div>
			</aside><aside id="bimber_widget_posts-80006" class="widget g1-card g1-card-l g1-card-solid widget_bimber_widget_posts"><header><h2 class="g1-delta g1-delta-2nd widgettitle"><span>Songs of the Day</span></h2></header>			<div id="g1-widget-posts-1"
			     class="g1-widget-posts">
									<div class="g1-collection g1-collection-grid-xxs g1-collection-columns-2">
	
			<div class="g1-collection-viewport">
			<ul class="g1-collection-items">
									<li class="g1-collection-item">
						
<article class="entry-tpl-grid entry-tpl-grid-xxs post-83176 post type-post status-publish format-standard has-post-thumbnail category-music-reviews category-song-of-the-day category-streams-and-downloads tag-azanti tag-time-difference">
	<div class="entry-featured-media" ><a title="Song of the Day: &#8216;Time Difference&#8217; by Azanti" class="g1-frame" href="https://grungecake.com/azanti-time-difference/articles/83176"><div class="g1-frame-inner"><img width="364" height="205" src="https://cdn.statically.io/img/grungecake.com/wp-content/uploads/2021/10/azanti-azanti-grungecake-thumbnail-364x205.webp?crop=1&quality=100&f=auto" class="attachment-bimber-grid-standard size-bimber-grid-standard wp-post-image jetpack-lazy-image" alt="" data-attachment-id="83179" data-permalink="https://grungecake.com/azanti-time-difference/articles/83176/azanti-azanti-grungecake-thumbnail" data-orig-file="https://grungecake.com/wp-content/uploads/2021/10/azanti-azanti-grungecake-thumbnail.webp" data-orig-size="540,540" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="azanti-azanti-grungecake-thumbnail" data-image-description="" data-image-caption="&lt;p&gt;Photo: &lt;a href=&quot;https://music.apple.com/us/album/azanti/1582646918&quot; target=&quot;_blank&quot; rel=&quot;noopener&quot;&gt;Apple Music&lt;/a&gt;&lt;/p&gt;" data-medium-file="https://grungecake.com/wp-content/uploads/2021/10/azanti-azanti-grungecake-thumbnail-300x300.webp?crop=1" data-large-file="https://grungecake.com/wp-content/uploads/2021/10/azanti-azanti-grungecake-thumbnail.webp" data-lazy-srcset="https://grungecake.com/wp-content/uploads/2021/10/azanti-azanti-grungecake-thumbnail-364x205.webp?crop=1 364w, https://grungecake.com/wp-content/uploads/2021/10/azanti-azanti-grungecake-thumbnail-192x108.webp?crop=1 192w, https://grungecake.com/wp-content/uploads/2021/10/azanti-azanti-grungecake-thumbnail-384x216.webp?crop=1 384w" data-lazy-sizes="(max-width: 364px) 100vw, 364px" data-lazy-src="https://grungecake.com/wp-content/uploads/2021/10/azanti-azanti-grungecake-thumbnail-364x205.webp?crop=1&amp;is-pending-load=1" srcset="" /><span class="g1-frame-icon g1-frame-icon-"></span></div></a></div>
		
	<div class="entry-body">
		<header class="entry-header">
			<div class="entry-before-title">
				
							</div>

		<h3 class="g1-epsilon g1-epsilon-1st entry-title"><a href="https://grungecake.com/azanti-time-difference/articles/83176" rel="bookmark">Song of the Day: &#8216;Time Difference&#8217; by Azanti</a></h3>		</header>

		
					<footer>
				<p class="g1-meta entry-meta entry-byline entry-byline-with-avatar">
								<span class="entry-author">
	
		<span class="entry-meta-label">by</span>
			<a href="https://grungecake.com/author/richardine" title="Posts by Richardine Bartee" rel="author">
			<img width="30" height="30" src="https://cdn.statically.io/img/grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-48x48.png?quality=100&f=auto" class="avatar avatar-30 photo jetpack-lazy-image" alt="" data-attachment-id="81818" data-permalink="https://grungecake.com/richardine-bartee-social-media-icon-september" data-orig-file="https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september.png" data-orig-size="400,400" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="richardine-bartee-social-media-icon-september" data-image-description="" data-image-caption="" data-medium-file="https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-300x300.png" data-large-file="https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september.png" data-lazy-srcset="https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-48x48.png 48w, https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-300x300.png 300w, https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-290x290.png 290w, https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-192x192.png 192w, https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-384x384.png 384w, https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-110x110.png 110w, https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-220x220.png 220w, https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-364x364.png 364w, https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-96x96.png 96w, https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-150x150.png 150w, https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-24x24.png 24w, https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september.png 400w" data-lazy-sizes="(max-width: 30px) 100vw, 30px" data-lazy-src="https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-48x48.png?is-pending-load=1" srcset="" />
							<strong>Richardine Bartee</strong>
					</a>
	</span>
	
					<time class="entry-date" datetime="2021-10-08T14:26:08-05:00">8th October 2021, 2:26 PM</time>				</p>
			</footer>
		
			</div>
</article>
					</li>
									<li class="g1-collection-item">
						
<article class="entry-tpl-grid entry-tpl-grid-xxs post-82135 post type-post status-publish format-standard has-post-thumbnail category-music-reviews category-music-videos category-song-of-the-day tag-little-simz tag-point-and-kill tag-sometimes-i-might-be-introvert">
	<div class="entry-featured-media" ><a title="Song of the Day: &#8216;Point and Kill&#8217; by Little Simz featuring Obongjayar" class="g1-frame" href="https://grungecake.com/little-simz-point-and-kill-obongjayar/articles/82135"><div class="g1-frame-inner"><img width="364" height="205" src="https://cdn.statically.io/img/grungecake.com/wp-content/uploads/2021/09/little-simz-point-and-kill-obongjayar-grungecake-thumbnail-364x205.jpg?quality=100&f=auto" class="attachment-bimber-grid-standard size-bimber-grid-standard wp-post-image jetpack-lazy-image" alt="" data-attachment-id="82136" data-permalink="https://grungecake.com/little-simz-point-and-kill-obongjayar/articles/82135/little-simz-point-and-kill-obongjayar-grungecake-thumbnail" data-orig-file="https://grungecake.com/wp-content/uploads/2021/09/little-simz-point-and-kill-obongjayar-grungecake-thumbnail.jpg" data-orig-size="640,640" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="little-simz-point-and-kill-obongjayar-grungecake-thumbnail" data-image-description="" data-image-caption="&lt;p&gt;Photo: &lt;a href=&quot;https://www.instagram.com/p/CS61hyAt9Se&quot; target=&quot;_blank&quot; rel=&quot;noopener noreferrer&quot;&gt;Instagram&lt;/a&gt;&lt;/p&gt;" data-medium-file="https://grungecake.com/wp-content/uploads/2021/09/little-simz-point-and-kill-obongjayar-grungecake-thumbnail-300x300.jpg" data-large-file="https://grungecake.com/wp-content/uploads/2021/09/little-simz-point-and-kill-obongjayar-grungecake-thumbnail.jpg" data-lazy-srcset="https://grungecake.com/wp-content/uploads/2021/09/little-simz-point-and-kill-obongjayar-grungecake-thumbnail-364x205.jpg 364w, https://grungecake.com/wp-content/uploads/2021/09/little-simz-point-and-kill-obongjayar-grungecake-thumbnail-192x108.jpg 192w, https://grungecake.com/wp-content/uploads/2021/09/little-simz-point-and-kill-obongjayar-grungecake-thumbnail-384x216.jpg 384w, https://grungecake.com/wp-content/uploads/2021/09/little-simz-point-and-kill-obongjayar-grungecake-thumbnail-561x316.jpg 561w" data-lazy-sizes="(max-width: 364px) 100vw, 364px" data-lazy-src="https://grungecake.com/wp-content/uploads/2021/09/little-simz-point-and-kill-obongjayar-grungecake-thumbnail-364x205.jpg?is-pending-load=1" srcset="" /><span class="g1-frame-icon g1-frame-icon-"></span></div></a></div>
		
	<div class="entry-body">
		<header class="entry-header">
			<div class="entry-before-title">
				
							</div>

		<h3 class="g1-epsilon g1-epsilon-1st entry-title"><a href="https://grungecake.com/little-simz-point-and-kill-obongjayar/articles/82135" rel="bookmark">Song of the Day: &#8216;Point and Kill&#8217; by Little Simz featuring Obongjayar</a></h3>		</header>

		
					<footer>
				<p class="g1-meta entry-meta entry-byline entry-byline-with-avatar">
								<span class="entry-author">
	
		<span class="entry-meta-label">by</span>
			<a href="https://grungecake.com/author/richardine" title="Posts by Richardine Bartee" rel="author">
			<img width="30" height="30" src="https://cdn.statically.io/img/grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-48x48.png?quality=100&f=auto" class="avatar avatar-30 photo jetpack-lazy-image" alt="" data-attachment-id="81818" data-permalink="https://grungecake.com/richardine-bartee-social-media-icon-september" data-orig-file="https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september.png" data-orig-size="400,400" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="richardine-bartee-social-media-icon-september" data-image-description="" data-image-caption="" data-medium-file="https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-300x300.png" data-large-file="https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september.png" data-lazy-srcset="https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-48x48.png 48w, https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-300x300.png 300w, https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-290x290.png 290w, https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-192x192.png 192w, https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-384x384.png 384w, https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-110x110.png 110w, https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-220x220.png 220w, https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-364x364.png 364w, https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-96x96.png 96w, https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-150x150.png 150w, https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-24x24.png 24w, https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september.png 400w" data-lazy-sizes="(max-width: 30px) 100vw, 30px" data-lazy-src="https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-48x48.png?is-pending-load=1" srcset="" />
							<strong>Richardine Bartee</strong>
					</a>
	</span>
	
					<time class="entry-date" datetime="2021-09-10T19:30:33-05:00">10th September 2021, 7:30 PM</time>				</p>
			</footer>
		
			</div>
</article>
					</li>
									<li class="g1-collection-item">
						
<article class="entry-tpl-grid entry-tpl-grid-xxs post-80140 post type-post status-publish format-standard has-post-thumbnail category-music-reviews category-music-videos category-song-of-the-day tag-hennessy tag-loui">
	<div class="entry-featured-media" ><a title="Song of the Day: &#8216;Hennessy&#8217; by Loui" class="g1-frame" href="https://grungecake.com/loui-hennessy/articles/80140"><div class="g1-frame-inner"><img width="364" height="205" src="https://cdn.statically.io/img/grungecake.com/wp-content/uploads/2021/07/loui-grungecake-thumbnail-364x205.jpg?quality=100&f=auto" class="attachment-bimber-grid-standard size-bimber-grid-standard wp-post-image jetpack-lazy-image" alt="" data-attachment-id="80141" data-permalink="https://grungecake.com/loui-hennessy/articles/80140/loui-grungecake-thumbnail" data-orig-file="https://grungecake.com/wp-content/uploads/2021/07/loui-grungecake-thumbnail.jpg" data-orig-size="1080,1350" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="loui-grungecake-thumbnail" data-image-description="" data-image-caption="&lt;p&gt;Photo: Courtesy of &lt;a href=&quot;https://www.instagram.com/p/CR6Hr62r3T8/&quot; target=&quot;_blank&quot; rel=&quot;noopener noreferrer&quot;&gt;Instagram&lt;/a&gt;&lt;/p&gt;" data-medium-file="https://grungecake.com/wp-content/uploads/2021/07/loui-grungecake-thumbnail-240x300.jpg" data-large-file="https://grungecake.com/wp-content/uploads/2021/07/loui-grungecake-thumbnail-819x1024.jpg" data-lazy-srcset="https://grungecake.com/wp-content/uploads/2021/07/loui-grungecake-thumbnail-364x205.jpg 364w, https://grungecake.com/wp-content/uploads/2021/07/loui-grungecake-thumbnail-192x108.jpg 192w, https://grungecake.com/wp-content/uploads/2021/07/loui-grungecake-thumbnail-384x216.jpg 384w, https://grungecake.com/wp-content/uploads/2021/07/loui-grungecake-thumbnail-728x409.jpg 728w, https://grungecake.com/wp-content/uploads/2021/07/loui-grungecake-thumbnail-561x316.jpg 561w, https://grungecake.com/wp-content/uploads/2021/07/loui-grungecake-thumbnail-758x426.jpg 758w" data-lazy-sizes="(max-width: 364px) 100vw, 364px" data-lazy-src="https://grungecake.com/wp-content/uploads/2021/07/loui-grungecake-thumbnail-364x205.jpg?is-pending-load=1" srcset="" /><span class="g1-frame-icon g1-frame-icon-"></span></div></a></div>
		
	<div class="entry-body">
		<header class="entry-header">
			<div class="entry-before-title">
				
							</div>

		<h3 class="g1-epsilon g1-epsilon-1st entry-title"><a href="https://grungecake.com/loui-hennessy/articles/80140" rel="bookmark">Song of the Day: &#8216;Hennessy&#8217; by Loui</a></h3>		</header>

		
					<footer>
				<p class="g1-meta entry-meta entry-byline entry-byline-with-avatar">
								<span class="entry-author">
	
		<span class="entry-meta-label">by</span>
			<a href="https://grungecake.com/author/richardine" title="Posts by Richardine Bartee" rel="author">
			<img width="30" height="30" src="https://cdn.statically.io/img/grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-48x48.png?quality=100&f=auto" class="avatar avatar-30 photo jetpack-lazy-image" alt="" data-attachment-id="81818" data-permalink="https://grungecake.com/richardine-bartee-social-media-icon-september" data-orig-file="https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september.png" data-orig-size="400,400" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="richardine-bartee-social-media-icon-september" data-image-description="" data-image-caption="" data-medium-file="https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-300x300.png" data-large-file="https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september.png" data-lazy-srcset="https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-48x48.png 48w, https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-300x300.png 300w, https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-290x290.png 290w, https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-192x192.png 192w, https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-384x384.png 384w, https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-110x110.png 110w, https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-220x220.png 220w, https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-364x364.png 364w, https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-96x96.png 96w, https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-150x150.png 150w, https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-24x24.png 24w, https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september.png 400w" data-lazy-sizes="(max-width: 30px) 100vw, 30px" data-lazy-src="https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-48x48.png?is-pending-load=1" srcset="" />
							<strong>Richardine Bartee</strong>
					</a>
	</span>
	
					<time class="entry-date" datetime="2021-07-30T11:37:07-05:00">30th July 2021, 11:37 AM</time>				</p>
			</footer>
		
			</div>
</article>
					</li>
									<li class="g1-collection-item">
						
<article class="entry-tpl-grid entry-tpl-grid-xxs post-79107 post type-post status-publish format-standard has-post-thumbnail category-music-reviews category-song-of-the-day category-streams-and-downloads tag-el-michels-affair tag-games-people-play tag-lady-wray tag-nicole-wray">
	<div class="entry-featured-media" ><a title="Song of the Day: &#8216;Games People Play&#8217; by Lady Wray" class="g1-frame" href="https://grungecake.com/lady-wray-games-people-play/articles/79107"><div class="g1-frame-inner"><img width="364" height="205" src="https://cdn.statically.io/img/grungecake.com/wp-content/uploads/2021/07/lady-wray-grungecake-thumbnail-364x205.jpg?quality=100&f=auto" class="attachment-bimber-grid-standard size-bimber-grid-standard wp-post-image jetpack-lazy-image" alt="" data-attachment-id="79108" data-permalink="https://grungecake.com/lady-wray-games-people-play/articles/79107/lady-wray-grungecake-thumbnail" data-orig-file="https://grungecake.com/wp-content/uploads/2021/07/lady-wray-grungecake-thumbnail.jpg" data-orig-size="1440,1079" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;8&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;NIKON D90&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;946689236&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;50&quot;,&quot;iso&quot;:&quot;200&quot;,&quot;shutter_speed&quot;:&quot;0.008&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="lady-wray-grungecake-thumbnail" data-image-description="" data-image-caption="&lt;p&gt;Photo: Courtesy of the label&lt;/p&gt;" data-medium-file="https://grungecake.com/wp-content/uploads/2021/07/lady-wray-grungecake-thumbnail-300x225.jpg" data-large-file="https://grungecake.com/wp-content/uploads/2021/07/lady-wray-grungecake-thumbnail-1024x767.jpg" data-lazy-srcset="https://grungecake.com/wp-content/uploads/2021/07/lady-wray-grungecake-thumbnail-364x205.jpg 364w, https://grungecake.com/wp-content/uploads/2021/07/lady-wray-grungecake-thumbnail-192x108.jpg 192w, https://grungecake.com/wp-content/uploads/2021/07/lady-wray-grungecake-thumbnail-384x216.jpg 384w, https://grungecake.com/wp-content/uploads/2021/07/lady-wray-grungecake-thumbnail-728x409.jpg 728w, https://grungecake.com/wp-content/uploads/2021/07/lady-wray-grungecake-thumbnail-561x316.jpg 561w, https://grungecake.com/wp-content/uploads/2021/07/lady-wray-grungecake-thumbnail-1122x631.jpg 1122w, https://grungecake.com/wp-content/uploads/2021/07/lady-wray-grungecake-thumbnail-758x426.jpg 758w, https://grungecake.com/wp-content/uploads/2021/07/lady-wray-grungecake-thumbnail-1152x648.jpg 1152w" data-lazy-sizes="(max-width: 364px) 100vw, 364px" data-lazy-src="https://grungecake.com/wp-content/uploads/2021/07/lady-wray-grungecake-thumbnail-364x205.jpg?is-pending-load=1" srcset="" /><span class="g1-frame-icon g1-frame-icon-"></span></div></a></div>
		
	<div class="entry-body">
		<header class="entry-header">
			<div class="entry-before-title">
				
							</div>

		<h3 class="g1-epsilon g1-epsilon-1st entry-title"><a href="https://grungecake.com/lady-wray-games-people-play/articles/79107" rel="bookmark">Song of the Day: &#8216;Games People Play&#8217; by Lady Wray</a></h3>		</header>

		
					<footer>
				<p class="g1-meta entry-meta entry-byline entry-byline-with-avatar">
								<span class="entry-author">
	
		<span class="entry-meta-label">by</span>
			<a href="https://grungecake.com/author/richardine" title="Posts by Richardine Bartee" rel="author">
			<img width="30" height="30" src="https://cdn.statically.io/img/grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-48x48.png?quality=100&f=auto" class="avatar avatar-30 photo jetpack-lazy-image" alt="" data-attachment-id="81818" data-permalink="https://grungecake.com/richardine-bartee-social-media-icon-september" data-orig-file="https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september.png" data-orig-size="400,400" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="richardine-bartee-social-media-icon-september" data-image-description="" data-image-caption="" data-medium-file="https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-300x300.png" data-large-file="https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september.png" data-lazy-srcset="https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-48x48.png 48w, https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-300x300.png 300w, https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-290x290.png 290w, https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-192x192.png 192w, https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-384x384.png 384w, https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-110x110.png 110w, https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-220x220.png 220w, https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-364x364.png 364w, https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-96x96.png 96w, https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-150x150.png 150w, https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-24x24.png 24w, https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september.png 400w" data-lazy-sizes="(max-width: 30px) 100vw, 30px" data-lazy-src="https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-48x48.png?is-pending-load=1" srcset="" />
							<strong>Richardine Bartee</strong>
					</a>
	</span>
	
					<time class="entry-date" datetime="2021-07-08T09:36:11-05:00">8th July 2021, 9:36 AM</time>				</p>
			</footer>
		
			</div>
</article>
					</li>
							</ul>
		</div>
	</div><!-- .g1-collection -->
							</div>
			</aside><aside id="text-124" class="widget g1-card g1-card-l g1-card-solid widget_text"><header><h2 class="g1-delta g1-delta-2nd widgettitle"><span>Advertisement</span></h2></header>			<div class="textwidget"><div class="OUTBRAIN" data-widget-id="TS_1" data-src=" " data-ob-template="GrungeCake.com"></div>
</div>
		</aside><aside id="bimber_widget_posts-8" class="widget g1-card g1-card-l g1-card-solid widget_bimber_widget_posts"><header><h2 class="g1-delta g1-delta-2nd widgettitle"><span>New Project Streams</span></h2></header>			<div id="g1-widget-posts-1"
			     class="g1-widget-posts">
									<div class="g1-collection g1-collection-grid-xxs g1-collection-columns-2">
	
			<div class="g1-collection-viewport">
			<ul class="g1-collection-items">
									<li class="g1-collection-item">
						
<article class="entry-tpl-grid entry-tpl-grid-xxs post-83841 post type-post status-publish format-standard has-post-thumbnail category-extended-plays category-music-reviews category-news category-streams-and-downloads tag-ash-lauryn tag-ep tag-truth">
	<div class="entry-featured-media" ><a title="Listen to Detroit-bred Electronic producer Ash Lauryn&#8217;s latest EP &#8216;Truth&#8217;" class="g1-frame" href="https://grungecake.com/ash-lauryn-truth-ep/articles/83841"><div class="g1-frame-inner"><img width="364" height="205" src="https://cdn.statically.io/img/grungecake.com/wp-content/uploads/2021/11/ash-lauryn-grungecake-thumbnail-364x205.jpg?crop=1&quality=100&f=auto" class="attachment-bimber-grid-standard size-bimber-grid-standard wp-post-image jetpack-lazy-image" alt="" data-attachment-id="83849" data-permalink="https://grungecake.com/ash-lauryn-truth-ep/articles/83841/ash-lauryn-grungecake-thumbnail-2" data-orig-file="https://grungecake.com/wp-content/uploads/2021/11/ash-lauryn-grungecake-thumbnail.jpg" data-orig-size="972,597" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="ash-lauryn-grungecake-thumbnail" data-image-description="" data-image-caption="&lt;p&gt;Photo: &lt;a href=&quot;https://www.insomniac.com/music/artists/ash-lauryn&quot;&gt;Insomnia&lt;/a&gt;&lt;/p&gt;" data-medium-file="https://grungecake.com/wp-content/uploads/2021/11/ash-lauryn-grungecake-thumbnail-300x184.jpg" data-large-file="https://grungecake.com/wp-content/uploads/2021/11/ash-lauryn-grungecake-thumbnail.jpg" data-lazy-srcset="https://grungecake.com/wp-content/uploads/2021/11/ash-lauryn-grungecake-thumbnail-364x205.jpg?crop=1 364w, https://grungecake.com/wp-content/uploads/2021/11/ash-lauryn-grungecake-thumbnail-192x108.jpg?crop=1 192w, https://grungecake.com/wp-content/uploads/2021/11/ash-lauryn-grungecake-thumbnail-384x216.jpg?crop=1 384w, https://grungecake.com/wp-content/uploads/2021/11/ash-lauryn-grungecake-thumbnail-728x409.jpg?crop=1 728w, https://grungecake.com/wp-content/uploads/2021/11/ash-lauryn-grungecake-thumbnail-561x316.jpg?crop=1 561w, https://grungecake.com/wp-content/uploads/2021/11/ash-lauryn-grungecake-thumbnail-758x426.jpg?crop=1 758w" data-lazy-sizes="(max-width: 364px) 100vw, 364px" data-lazy-src="https://grungecake.com/wp-content/uploads/2021/11/ash-lauryn-grungecake-thumbnail-364x205.jpg?crop=1&amp;is-pending-load=1" srcset="" /><span class="g1-frame-icon g1-frame-icon-"></span></div></a></div>
		
	<div class="entry-body">
		<header class="entry-header">
			<div class="entry-before-title">
				
							</div>

		<h3 class="g1-epsilon g1-epsilon-1st entry-title"><a href="https://grungecake.com/ash-lauryn-truth-ep/articles/83841" rel="bookmark">Listen to Detroit-bred Electronic producer Ash Lauryn&#8217;s latest EP &#8216;Truth&#8217;</a></h3>		</header>

		
					<footer>
				<p class="g1-meta entry-meta entry-byline entry-byline-with-avatar">
								<span class="entry-author">
	
		<span class="entry-meta-label">by</span>
			<a href="https://grungecake.com/author/richardine" title="Posts by Richardine Bartee" rel="author">
			<img width="30" height="30" src="https://cdn.statically.io/img/grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-48x48.png?quality=100&f=auto" class="avatar avatar-30 photo jetpack-lazy-image" alt="" data-attachment-id="81818" data-permalink="https://grungecake.com/richardine-bartee-social-media-icon-september" data-orig-file="https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september.png" data-orig-size="400,400" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="richardine-bartee-social-media-icon-september" data-image-description="" data-image-caption="" data-medium-file="https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-300x300.png" data-large-file="https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september.png" data-lazy-srcset="https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-48x48.png 48w, https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-300x300.png 300w, https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-290x290.png 290w, https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-192x192.png 192w, https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-384x384.png 384w, https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-110x110.png 110w, https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-220x220.png 220w, https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-364x364.png 364w, https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-96x96.png 96w, https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-150x150.png 150w, https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-24x24.png 24w, https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september.png 400w" data-lazy-sizes="(max-width: 30px) 100vw, 30px" data-lazy-src="https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-48x48.png?is-pending-load=1" srcset="" />
							<strong>Richardine Bartee</strong>
					</a>
	</span>
	
									</p>
			</footer>
		
			</div>
</article>
					</li>
									<li class="g1-collection-item">
						
<article class="entry-tpl-grid entry-tpl-grid-xxs post-83747 post type-post status-publish format-standard has-post-thumbnail category-extended-plays category-news category-streams-and-downloads tag-buju tag-sorry-im-late">
	<div class="entry-featured-media" ><a title="Stream Nigerian rising artist Buju&#8217;s seven-track project &#8216;Sorry I&#8217;m Late&#8217;" class="g1-frame" href="https://grungecake.com/buju-sorry-im-late/articles/83747"><div class="g1-frame-inner"><img width="364" height="205" src="https://cdn.statically.io/img/grungecake.com/wp-content/uploads/2021/10/buju-sorry-im-late-grungecake-thumbnail-364x205.png?crop=1&quality=100&f=auto" class="attachment-bimber-grid-standard size-bimber-grid-standard wp-post-image jetpack-lazy-image" alt="" data-attachment-id="83750" data-permalink="https://grungecake.com/buju-sorry-im-late/articles/83747/buju-sorry-im-late-grungecake-thumbnail" data-orig-file="https://grungecake.com/wp-content/uploads/2021/10/buju-sorry-im-late-grungecake-thumbnail.png" data-orig-size="1934,1940" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="buju-sorry-im-late-grungecake-thumbnail" data-image-description="" data-image-caption="&lt;p&gt;Photo: &lt;a href=&quot;https://music.apple.com/us/album/sorry-im-late/1581689107&quot; target=&quot;_blank&quot; rel=&quot;noopener&quot;&gt;Apple Music&lt;/a&gt;&lt;/p&gt;" data-medium-file="https://grungecake.com/wp-content/uploads/2021/10/buju-sorry-im-late-grungecake-thumbnail-300x300.png?crop=1" data-large-file="https://grungecake.com/wp-content/uploads/2021/10/buju-sorry-im-late-grungecake-thumbnail-1021x1024.png" data-lazy-srcset="https://grungecake.com/wp-content/uploads/2021/10/buju-sorry-im-late-grungecake-thumbnail-364x205.png?crop=1 364w, https://grungecake.com/wp-content/uploads/2021/10/buju-sorry-im-late-grungecake-thumbnail-192x108.png?crop=1 192w, https://grungecake.com/wp-content/uploads/2021/10/buju-sorry-im-late-grungecake-thumbnail-384x216.png?crop=1 384w, https://grungecake.com/wp-content/uploads/2021/10/buju-sorry-im-late-grungecake-thumbnail-728x409.png?crop=1 728w, https://grungecake.com/wp-content/uploads/2021/10/buju-sorry-im-late-grungecake-thumbnail-561x316.png?crop=1 561w, https://grungecake.com/wp-content/uploads/2021/10/buju-sorry-im-late-grungecake-thumbnail-1122x631.png?crop=1 1122w, https://grungecake.com/wp-content/uploads/2021/10/buju-sorry-im-late-grungecake-thumbnail-758x426.png?crop=1 758w, https://grungecake.com/wp-content/uploads/2021/10/buju-sorry-im-late-grungecake-thumbnail-1152x648.png?crop=1 1152w" data-lazy-sizes="(max-width: 364px) 100vw, 364px" data-lazy-src="https://grungecake.com/wp-content/uploads/2021/10/buju-sorry-im-late-grungecake-thumbnail-364x205.png?crop=1&amp;is-pending-load=1" srcset="" /><span class="g1-frame-icon g1-frame-icon-"></span></div></a></div>
		
	<div class="entry-body">
		<header class="entry-header">
			<div class="entry-before-title">
				
							</div>

		<h3 class="g1-epsilon g1-epsilon-1st entry-title"><a href="https://grungecake.com/buju-sorry-im-late/articles/83747" rel="bookmark">Stream Nigerian rising artist Buju&#8217;s seven-track project &#8216;Sorry I&#8217;m Late&#8217;</a></h3>		</header>

		
					<footer>
				<p class="g1-meta entry-meta entry-byline entry-byline-with-avatar">
								<span class="entry-author">
	
		<span class="entry-meta-label">by</span>
			<a href="https://grungecake.com/author/richardine" title="Posts by Richardine Bartee" rel="author">
			<img width="30" height="30" src="https://cdn.statically.io/img/grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-48x48.png?quality=100&f=auto" class="avatar avatar-30 photo jetpack-lazy-image" alt="" data-attachment-id="81818" data-permalink="https://grungecake.com/richardine-bartee-social-media-icon-september" data-orig-file="https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september.png" data-orig-size="400,400" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="richardine-bartee-social-media-icon-september" data-image-description="" data-image-caption="" data-medium-file="https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-300x300.png" data-large-file="https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september.png" data-lazy-srcset="https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-48x48.png 48w, https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-300x300.png 300w, https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-290x290.png 290w, https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-192x192.png 192w, https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-384x384.png 384w, https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-110x110.png 110w, https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-220x220.png 220w, https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-364x364.png 364w, https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-96x96.png 96w, https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-150x150.png 150w, https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-24x24.png 24w, https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september.png 400w" data-lazy-sizes="(max-width: 30px) 100vw, 30px" data-lazy-src="https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-48x48.png?is-pending-load=1" srcset="" />
							<strong>Richardine Bartee</strong>
					</a>
	</span>
	
									</p>
			</footer>
		
			</div>
</article>
					</li>
									<li class="g1-collection-item">
						
<article class="entry-tpl-grid entry-tpl-grid-xxs post-83696 post type-post status-publish format-standard has-post-thumbnail category-extended-plays category-news category-streams-and-downloads tag-amerado tag-ep tag-patience">
	<div class="entry-featured-media" ><a title="Stream Ghanaian artist Amerado&#8217;s brand new extended play: Patience" class="g1-frame" href="https://grungecake.com/amerado-patience/articles/83696"><div class="g1-frame-inner"><img width="364" height="205" src="https://cdn.statically.io/img/grungecake.com/wp-content/uploads/2021/10/amerado-grungecake-thumbnail-364x205.jpg?crop=1&quality=100&f=auto" class="attachment-bimber-grid-standard size-bimber-grid-standard wp-post-image jetpack-lazy-image" alt="" data-attachment-id="83697" data-permalink="https://grungecake.com/amerado-patience/articles/83696/amerado-grungecake-thumbnail" data-orig-file="https://grungecake.com/wp-content/uploads/2021/10/amerado-grungecake-thumbnail.jpg" data-orig-size="1367,1097" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="amerado-grungecake-thumbnail" data-image-description="" data-image-caption="&lt;p&gt;Photo: Courtesy of the artist&lt;/p&gt;" data-medium-file="https://grungecake.com/wp-content/uploads/2021/10/amerado-grungecake-thumbnail-300x241.jpg" data-large-file="https://grungecake.com/wp-content/uploads/2021/10/amerado-grungecake-thumbnail-1024x822.jpg" data-lazy-srcset="https://grungecake.com/wp-content/uploads/2021/10/amerado-grungecake-thumbnail-364x205.jpg?crop=1 364w, https://grungecake.com/wp-content/uploads/2021/10/amerado-grungecake-thumbnail-192x108.jpg?crop=1 192w, https://grungecake.com/wp-content/uploads/2021/10/amerado-grungecake-thumbnail-384x216.jpg?crop=1 384w, https://grungecake.com/wp-content/uploads/2021/10/amerado-grungecake-thumbnail-728x409.jpg?crop=1 728w, https://grungecake.com/wp-content/uploads/2021/10/amerado-grungecake-thumbnail-561x316.jpg?crop=1 561w, https://grungecake.com/wp-content/uploads/2021/10/amerado-grungecake-thumbnail-1122x631.jpg?crop=1 1122w, https://grungecake.com/wp-content/uploads/2021/10/amerado-grungecake-thumbnail-758x426.jpg?crop=1 758w, https://grungecake.com/wp-content/uploads/2021/10/amerado-grungecake-thumbnail-1152x648.jpg?crop=1 1152w" data-lazy-sizes="(max-width: 364px) 100vw, 364px" data-lazy-src="https://grungecake.com/wp-content/uploads/2021/10/amerado-grungecake-thumbnail-364x205.jpg?crop=1&amp;is-pending-load=1" srcset="" /><span class="g1-frame-icon g1-frame-icon-"></span></div></a></div>
		
	<div class="entry-body">
		<header class="entry-header">
			<div class="entry-before-title">
				
							</div>

		<h3 class="g1-epsilon g1-epsilon-1st entry-title"><a href="https://grungecake.com/amerado-patience/articles/83696" rel="bookmark">Stream Ghanaian artist Amerado&#8217;s brand new extended play: Patience</a></h3>		</header>

		
					<footer>
				<p class="g1-meta entry-meta entry-byline entry-byline-with-avatar">
								<span class="entry-author">
	
		<span class="entry-meta-label">by</span>
			<a href="https://grungecake.com/author/richardine" title="Posts by Richardine Bartee" rel="author">
			<img width="30" height="30" src="https://cdn.statically.io/img/grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-48x48.png?quality=100&f=auto" class="avatar avatar-30 photo jetpack-lazy-image" alt="" data-attachment-id="81818" data-permalink="https://grungecake.com/richardine-bartee-social-media-icon-september" data-orig-file="https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september.png" data-orig-size="400,400" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="richardine-bartee-social-media-icon-september" data-image-description="" data-image-caption="" data-medium-file="https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-300x300.png" data-large-file="https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september.png" data-lazy-srcset="https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-48x48.png 48w, https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-300x300.png 300w, https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-290x290.png 290w, https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-192x192.png 192w, https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-384x384.png 384w, https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-110x110.png 110w, https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-220x220.png 220w, https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-364x364.png 364w, https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-96x96.png 96w, https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-150x150.png 150w, https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-24x24.png 24w, https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september.png 400w" data-lazy-sizes="(max-width: 30px) 100vw, 30px" data-lazy-src="https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-48x48.png?is-pending-load=1" srcset="" />
							<strong>Richardine Bartee</strong>
					</a>
	</span>
	
									</p>
			</footer>
		
			</div>
</article>
					</li>
									<li class="g1-collection-item">
						
<article class="entry-tpl-grid entry-tpl-grid-xxs post-81541 post type-post status-publish format-standard has-post-thumbnail category-extended-plays category-music-reviews category-news category-streams-and-downloads tag-peer-pressure tag-ray-vaughn tag-top-dawg-entertainment">
	<div class="entry-featured-media" ><a title="Top Dawg Entertainment new signee Ray Vaughn unlocks new EP ‘Peer Pressure’: Stream" class="g1-frame" href="https://grungecake.com/ray-vaughn-peer-pressure/articles/81541"><div class="g1-frame-inner"><img width="364" height="205" src="https://cdn.statically.io/img/grungecake.com/wp-content/uploads/2021/08/ray-vaughn-peer-pressure-grungecake-thumbnail-364x205.jpg?quality=100&f=auto" class="attachment-bimber-grid-standard size-bimber-grid-standard wp-post-image jetpack-lazy-image" alt="" data-attachment-id="81548" data-permalink="https://grungecake.com/ray-vaughn-peer-pressure/articles/81541/ray-vaughn-peer-pressure-grungecake-thumbnail" data-orig-file="https://grungecake.com/wp-content/uploads/2021/08/ray-vaughn-peer-pressure-grungecake-thumbnail-scaled.jpg" data-orig-size="2560,2560" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;1623775284&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="ray-vaughn-peer-pressure-grungecake-thumbnail" data-image-description="" data-image-caption="&lt;p&gt;Photo: Courtesy of the publicist&lt;/p&gt;" data-medium-file="https://grungecake.com/wp-content/uploads/2021/08/ray-vaughn-peer-pressure-grungecake-thumbnail-300x300.jpg" data-large-file="https://grungecake.com/wp-content/uploads/2021/08/ray-vaughn-peer-pressure-grungecake-thumbnail-1024x1024.jpg" data-lazy-srcset="https://grungecake.com/wp-content/uploads/2021/08/ray-vaughn-peer-pressure-grungecake-thumbnail-364x205.jpg 364w, https://grungecake.com/wp-content/uploads/2021/08/ray-vaughn-peer-pressure-grungecake-thumbnail-192x108.jpg 192w, https://grungecake.com/wp-content/uploads/2021/08/ray-vaughn-peer-pressure-grungecake-thumbnail-384x216.jpg 384w, https://grungecake.com/wp-content/uploads/2021/08/ray-vaughn-peer-pressure-grungecake-thumbnail-728x409.jpg 728w, https://grungecake.com/wp-content/uploads/2021/08/ray-vaughn-peer-pressure-grungecake-thumbnail-561x316.jpg 561w, https://grungecake.com/wp-content/uploads/2021/08/ray-vaughn-peer-pressure-grungecake-thumbnail-1122x631.jpg 1122w, https://grungecake.com/wp-content/uploads/2021/08/ray-vaughn-peer-pressure-grungecake-thumbnail-758x426.jpg 758w, https://grungecake.com/wp-content/uploads/2021/08/ray-vaughn-peer-pressure-grungecake-thumbnail-1152x648.jpg 1152w" data-lazy-sizes="(max-width: 364px) 100vw, 364px" data-lazy-src="https://grungecake.com/wp-content/uploads/2021/08/ray-vaughn-peer-pressure-grungecake-thumbnail-364x205.jpg?is-pending-load=1" srcset="" /><span class="g1-frame-icon g1-frame-icon-"></span></div></a></div>
		
	<div class="entry-body">
		<header class="entry-header">
			<div class="entry-before-title">
				
							</div>

		<h3 class="g1-epsilon g1-epsilon-1st entry-title"><a href="https://grungecake.com/ray-vaughn-peer-pressure/articles/81541" rel="bookmark">Top Dawg Entertainment new signee Ray Vaughn unlocks new EP ‘Peer Pressure’: Stream</a></h3>		</header>

		
					<footer>
				<p class="g1-meta entry-meta entry-byline entry-byline-with-avatar">
								<span class="entry-author">
	
		<span class="entry-meta-label">by</span>
			<a href="https://grungecake.com/author/ralph-okobz" title="Posts by Ralph Okobz" rel="author">
			<img alt src="https://cdn.statically.io/img/secure.gravatar.com/avatar/081650baa2df29195d5a328ae7d5beb1?s=30&#038;d=blank&#038;r=g&quality=100&f=auto" class="avatar avatar-30 photo jetpack-lazy-image" height="30" width="30" data-lazy-srcset="https://secure.gravatar.com/avatar/081650baa2df29195d5a328ae7d5beb1?s=60&#038;d=blank&#038;r=g 2x" data-lazy-src="https://secure.gravatar.com/avatar/081650baa2df29195d5a328ae7d5beb1?s=30&amp;is-pending-load=1#038;d=blank&#038;r=g" srcset=""><noscript><img alt='' src='data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw==' class='avatar avatar-30 photo' height='30' width='30' data-loading="lazy" data-src="https://cdn.statically.io/img/secure.gravatar.com/avatar/081650baa2df29195d5a328ae7d5beb1?s=30&#038;d=blank&#038;r=g&quality=100&f=auto" data-srcset="" /></noscript>
							<strong>Ralph Okobz</strong>
					</a>
	</span>
	
									</p>
			</footer>
		
			</div>
</article>
					</li>
							</ul>
		</div>
	</div><!-- .g1-collection -->
							</div>
			</aside><aside id="bimber_widget_posts-80013" class="widget g1-card g1-card-l g1-card-solid widget_bimber_widget_posts"><header><h2 class="g1-delta g1-delta-2nd widgettitle"><span>Recent Interviews</span></h2></header>			<div id="g1-widget-posts-1"
			     class="g1-widget-posts">
									<div class="g1-collection g1-collection-grid-xxs g1-collection-columns-2">
	
			<div class="g1-collection-viewport">
			<ul class="g1-collection-items">
									<li class="g1-collection-item">
						
<article class="entry-tpl-grid entry-tpl-grid-xxs post-83500 post type-post status-publish format-standard has-post-thumbnail category-interviews category-music category-music-videos category-streams-and-downloads tag-alcohol tag-joeboy tag-show-me tag-sip-alcohol tag-somewhere-between-beauty-magic tag-tempoe">
	<div class="entry-featured-media" ><a title="Nigeria has a humble music star on its hands, and his name is Joeboy: (Interview)" class="g1-frame" href="https://grungecake.com/joeboy-interview/articles/83500"><div class="g1-frame-inner"><img width="364" height="205" src="https://cdn.statically.io/img/grungecake.com/wp-content/uploads/2021/10/joeboy-richardine-grungecake-la-thumbnail-364x205.jpg?crop=1&quality=100&f=auto" class="attachment-bimber-grid-standard size-bimber-grid-standard wp-post-image jetpack-lazy-image" alt="" data-attachment-id="83508" data-permalink="https://grungecake.com/joeboy-interview/articles/83500/joeboy-richardine-grungecake-la-thumbnail" data-orig-file="https://grungecake.com/wp-content/uploads/2021/10/joeboy-richardine-grungecake-la-thumbnail.jpg" data-orig-size="7360,4912" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;2.8&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;NIKON D800&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;1633782878&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;35&quot;,&quot;iso&quot;:&quot;400&quot;,&quot;shutter_speed&quot;:&quot;0.003125&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="joeboy-richardine-grungecake-la-thumbnail" data-image-description="" data-image-caption="&lt;p&gt;Photos: &lt;a href=&quot;https://www.instagram.com/onegungutty&quot; target=&quot;_blank&quot; rel=&quot;noopener&quot;&gt;George Lee for GRUNGECAKE&lt;/a&gt;&lt;/p&gt;" data-medium-file="https://grungecake.com/wp-content/uploads/2021/10/joeboy-richardine-grungecake-la-thumbnail-300x200.jpg" data-large-file="https://grungecake.com/wp-content/uploads/2021/10/joeboy-richardine-grungecake-la-thumbnail-1024x683.jpg" data-lazy-srcset="https://grungecake.com/wp-content/uploads/2021/10/joeboy-richardine-grungecake-la-thumbnail-364x205.jpg?crop=1 364w, https://grungecake.com/wp-content/uploads/2021/10/joeboy-richardine-grungecake-la-thumbnail-192x108.jpg?crop=1 192w, https://grungecake.com/wp-content/uploads/2021/10/joeboy-richardine-grungecake-la-thumbnail-384x216.jpg?crop=1 384w, https://grungecake.com/wp-content/uploads/2021/10/joeboy-richardine-grungecake-la-thumbnail-728x409.jpg?crop=1 728w, https://grungecake.com/wp-content/uploads/2021/10/joeboy-richardine-grungecake-la-thumbnail-561x316.jpg?crop=1 561w, https://grungecake.com/wp-content/uploads/2021/10/joeboy-richardine-grungecake-la-thumbnail-1122x631.jpg?crop=1 1122w, https://grungecake.com/wp-content/uploads/2021/10/joeboy-richardine-grungecake-la-thumbnail-758x426.jpg?crop=1 758w, https://grungecake.com/wp-content/uploads/2021/10/joeboy-richardine-grungecake-la-thumbnail-1152x648.jpg?crop=1 1152w" data-lazy-sizes="(max-width: 364px) 100vw, 364px" data-lazy-src="https://grungecake.com/wp-content/uploads/2021/10/joeboy-richardine-grungecake-la-thumbnail-364x205.jpg?crop=1&amp;is-pending-load=1" srcset="" /><span class="g1-frame-icon g1-frame-icon-"></span></div></a></div>
		
	<div class="entry-body">
		<header class="entry-header">
			<div class="entry-before-title">
				
							</div>

		<h3 class="g1-epsilon g1-epsilon-1st entry-title"><a href="https://grungecake.com/joeboy-interview/articles/83500" rel="bookmark">Nigeria has a humble music star on its hands, and his name is Joeboy: (Interview)</a></h3>		</header>

		
					<footer>
				<p class="g1-meta entry-meta entry-byline entry-byline-with-avatar">
								<span class="entry-author">
	
		<span class="entry-meta-label">by</span>
			<a href="https://grungecake.com/author/richardine" title="Posts by Richardine Bartee" rel="author">
			<img width="30" height="30" src="https://cdn.statically.io/img/grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-48x48.png?quality=100&f=auto" class="avatar avatar-30 photo jetpack-lazy-image" alt="" data-attachment-id="81818" data-permalink="https://grungecake.com/richardine-bartee-social-media-icon-september" data-orig-file="https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september.png" data-orig-size="400,400" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="richardine-bartee-social-media-icon-september" data-image-description="" data-image-caption="" data-medium-file="https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-300x300.png" data-large-file="https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september.png" data-lazy-srcset="https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-48x48.png 48w, https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-300x300.png 300w, https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-290x290.png 290w, https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-192x192.png 192w, https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-384x384.png 384w, https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-110x110.png 110w, https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-220x220.png 220w, https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-364x364.png 364w, https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-96x96.png 96w, https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-150x150.png 150w, https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-24x24.png 24w, https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september.png 400w" data-lazy-sizes="(max-width: 30px) 100vw, 30px" data-lazy-src="https://grungecake.com/wp-content/uploads/2021/09/richardine-bartee-social-media-icon-september-48x48.png?is-pending-load=1" srcset="" />
							<strong>Richardine Bartee</strong>
					</a>
	</span>
	
					<time class="entry-date" datetime="2021-10-18T14:18:24-05:00">18th October 2021, 2:18 PM</time>				</p>
			</footer>
		
			</div>
</article>
					</li>
									<li class="g1-collection-item">
						
<article class="entry-tpl-grid entry-tpl-grid-xxs post-82465 post type-post status-publish format-standard has-post-thumbnail category-albums category-interviews category-music-videos tag-cico-p tag-nawfjaxx tag-palm-angel tag-tampa">
	<div class="entry-featured-media" ><a title="East Texas rapper Cico P on his unique &#8216;Boogie Avenue&#8217; style, and juggling success and his personal life (Interview)" class="g1-frame" href="https://grungecake.com/cico-p-interview/articles/82465"><div class="g1-frame-inner"><img width="364" height="205" src="https://cdn.statically.io/img/grungecake.com/wp-content/uploads/2021/09/cico-p-grungecake-thumbnail-profile-364x205.jpg?crop=1&quality=100&f=auto" class="attachment-bimber-grid-standard size-bimber-grid-standard wp-post-image jetpack-lazy-image" alt="" data-attachment-id="82566" data-permalink="https://grungecake.com/cico-p-interview/articles/82465/cico-p-grungecake-thumbnail-profile" data-orig-file="https://grungecake.com/wp-content/uploads/2021/09/cico-p-grungecake-thumbnail-profile.jpg" data-orig-size="1708,2560" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="cico-p-grungecake-thumbnail-profile" data-image-description="" data-image-caption="" data-medium-file="https://grungecake.com/wp-content/uploads/2021/09/cico-p-grungecake-thumbnail-profile-200x300.jpg" data-large-file="https://grungecake.com/wp-content/uploads/2021/09/cico-p-grungecake-thumbnail-profile-683x1024.jpg" data-lazy-srcset="https://grungecake.com/wp-content/uploads/2021/09/cico-p-grungecake-thumbnail-profile-364x205.jpg?crop=1 364w, https://grungecake.com/wp-content/uploads/2021/09/cico-p-grungecake-thumbnail-profile-192x108.jpg?crop=1 192w, https://grungecake.com/wp-content/uploads/2021/09/cico-p-grungecake-thumbnail-profile-384x216.jpg?crop=1 384w, https://grungecake.com/wp-content/uploads/2021/09/cico-p-grungecake-thumbnail-profile-728x409.jpg?crop=1 728w, https://grungecake.com/wp-content/uploads/2021/09/cico-p-grungecake-thumbnail-profile-561x316.jpg?crop=1 561w, https://grungecake.com/wp-content/uploads/2021/09/cico-p-grungecake-thumbnail-profile-1122x631.jpg?crop=1 1122w, https://grungecake.com/wp-content/uploads/2021/09/cico-p-grungecake-thumbnail-profile-758x426.jpg?crop=1 758w, https://grungecake.com/wp-content/uploads/2021/09/cico-p-grungecake-thumbnail-profile-1152x648.jpg?crop=1 1152w" data-lazy-sizes="(max-width: 364px) 100vw, 364px" data-lazy-src="https://grungecake.com/wp-content/uploads/2021/09/cico-p-grungecake-thumbnail-profile-364x205.jpg?crop=1&amp;is-pending-load=1" srcset="" /><span class="g1-frame-icon g1-frame-icon-"></span></div></a></div>
		
	<div class="entry-body">
		<header class="entry-header">
			<div class="entry-before-title">
				
							</div>

		<h3 class="g1-epsilon g1-epsilon-1st entry-title"><a href="https://grungecake.com/cico-p-interview/articles/82465" rel="bookmark">East Texas rapper Cico P on his unique &#8216;Boogie Avenue&#8217; style, and juggling success and his personal life (Interview)</a></h3>		</header>

		
					<footer>
				<p class="g1-meta entry-meta entry-byline entry-byline-with-avatar">
								<span class="entry-author">
	
		<span class="entry-meta-label">by</span>
			<a href="https://grungecake.com/author/andy-alexis" title="Posts by Andy Alexis" rel="author">
			<img width="30" height="30" src="https://cdn.statically.io/img/grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-48x48.png?quality=100&f=auto" class="avatar avatar-30 photo jetpack-lazy-image" alt="" data-attachment-id="81870" data-permalink="https://grungecake.com/andy-alexis-grungecake-hip-hop-editor-icon" data-orig-file="https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon.png" data-orig-size="941,941" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="andy-alexis-grungecake-hip-hop-editor-icon" data-image-description="" data-image-caption="" data-medium-file="https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-300x300.png" data-large-file="https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon.png" data-lazy-srcset="https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-48x48.png 48w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-300x300.png 300w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-290x290.png 290w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-768x768.png 768w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-192x192.png 192w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-384x384.png 384w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-110x110.png 110w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-220x220.png 220w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-561x561.png 561w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-364x364.png 364w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-728x728.png 728w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-608x608.png 608w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-758x758.png 758w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-96x96.png 96w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-150x150.png 150w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-24x24.png 24w, https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon.png 941w" data-lazy-sizes="(max-width: 30px) 100vw, 30px" data-lazy-src="https://grungecake.com/wp-content/uploads/2021/09/andy-alexis-grungecake-hip-hop-editor-icon-48x48.png?is-pending-load=1" srcset="" />
							<strong>Andy Alexis</strong>
					</a>
	</span>
	
					<time class="entry-date" datetime="2021-09-21T18:00:38-05:00">21st September 2021, 6:00 PM</time>				</p>
			</footer>
		
			</div>
</article>
					</li>
									<li class="g1-collection-item">
						
<article class="entry-tpl-grid entry-tpl-grid-xxs post-78323 post type-post status-publish format-standard has-post-thumbnail category-albums category-interviews category-music-videos category-streams-and-downloads tag-citizen-of-the-world tag-dem-mama-records tag-king-perryy">
	<div class="entry-featured-media" ><a title="King Perryy talks latest album ‘Citizen of the World’, being borderless, and going abroad (Interview)" class="g1-frame" href="https://grungecake.com/king-perryy-interview/articles/78323"><div class="g1-frame-inner"><img width="364" height="205" src="https://cdn.statically.io/img/grungecake.com/wp-content/uploads/2021/07/king-perryy-grungecake-thumbnail-364x205.jpg?quality=100&f=auto" class="attachment-bimber-grid-standard size-bimber-grid-standard wp-post-image jetpack-lazy-image" alt="" data-attachment-id="79427" data-permalink="https://grungecake.com/king-perryy-yawa-video-teaser/articles/79425/king-perryy-grungecake-thumbnail" data-orig-file="https://grungecake.com/wp-content/uploads/2021/07/king-perryy-grungecake-thumbnail.jpg" data-orig-size="1242,1321" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;1626267654&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="king-perryy-grungecake-thumbnail" data-image-description="" data-image-caption="&lt;p&gt;Photo: &lt;a href=&quot;https://www.instagram.com/p/CLzCSMvlf9o/&quot; target=&quot;_blank&quot; rel=&quot;noopener noreferrer&quot;&gt;Instagram&lt;/a&gt;&lt;/p&gt;" data-medium-file="https://grungecake.com/wp-content/uploads/2021/07/king-perryy-grungecake-thumbnail-282x300.jpg" data-large-file="https://grungecake.com/wp-content/uploads/2021/07/king-perryy-grungecake-thumbnail-963x1024.jpg" data-lazy-srcset="https://grungecake.com/wp-content/uploads/2021/07/king-perryy-grungecake-thumbnail-364x205.jpg 364w, https://grungecake.com/wp-content/uploads/2021/07/king-perryy-grungecake-thumbnail-192x108.jpg 192w, https://grungecake.com/wp-content/uploads/2021/07/king-perryy-grungecake-thumbnail-384x216.jpg 384w, https://grungecake.com/wp-content/uploads/2021/07/king-perryy-grungecake-thumbnail-728x409.jpg 728w, https://grungecake.com/wp-content/uploads/2021/07/king-perryy-grungecake-thumbnail-561x316.jpg 561w, https://grungecake.com/wp-content/uploads/2021/07/king-perryy-grungecake-thumbnail-1122x631.jpg 1122w, https://grungecake.com/wp-content/uploads/2021/07/king-perryy-grungecake-thumbnail-758x426.jpg 758w, https://grungecake.com/wp-content/uploads/2021/07/king-perryy-grungecake-thumbnail-1152x648.jpg 1152w" data-lazy-sizes="(max-width: 364px) 100vw, 364px" data-lazy-src="https://grungecake.com/wp-content/uploads/2021/07/king-perryy-grungecake-thumbnail-364x205.jpg?is-pending-load=1" srcset="" /><span class="g1-frame-icon g1-frame-icon-"></span></div></a></div>
		
	<div class="entry-body">
		<header class="entry-header">
			<div class="entry-before-title">
				
							</div>

		<h3 class="g1-epsilon g1-epsilon-1st entry-title"><a href="https://grungecake.com/king-perryy-interview/articles/78323" rel="bookmark">King Perryy talks latest album ‘Citizen of the World’, being borderless, and going abroad (Interview)</a></h3>		</header>

		
					<footer>
				<p class="g1-meta entry-meta entry-byline entry-byline-with-avatar">
								<span class="entry-author">
	
		<span class="entry-meta-label">by</span>
			<a href="https://grungecake.com/author/ralph-okobz" title="Posts by Ralph Okobz" rel="author">
			<img alt src="https://cdn.statically.io/img/secure.gravatar.com/avatar/081650baa2df29195d5a328ae7d5beb1?s=30&#038;d=blank&#038;r=g&quality=100&f=auto" class="avatar avatar-30 photo jetpack-lazy-image" height="30" width="30" data-lazy-srcset="https://secure.gravatar.com/avatar/081650baa2df29195d5a328ae7d5beb1?s=60&#038;d=blank&#038;r=g 2x" data-lazy-src="https://secure.gravatar.com/avatar/081650baa2df29195d5a328ae7d5beb1?s=30&amp;is-pending-load=1#038;d=blank&#038;r=g" srcset=""><noscript><img alt='' src='data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw==' class='avatar avatar-30 photo' height='30' width='30' data-loading="lazy" data-src="https://cdn.statically.io/img/secure.gravatar.com/avatar/081650baa2df29195d5a328ae7d5beb1?s=30&#038;d=blank&#038;r=g&quality=100&f=auto" data-srcset="" /></noscript>
							<strong>Ralph Okobz</strong>
					</a>
	</span>
	
					<time class="entry-date" datetime="2021-07-30T17:24:46-05:00">30th July 2021, 5:24 PM</time>				</p>
			</footer>
		
			</div>
</article>
					</li>
									<li class="g1-collection-item">
						
<article class="entry-tpl-grid entry-tpl-grid-xxs post-79784 post type-post status-publish format-standard has-post-thumbnail category-interviews category-music-videos category-streams-and-downloads tag-somebody tag-trayc-selasi">
	<div class="entry-featured-media" ><a title="Ghanaian singer Trayc Selasi talks personal style, &#8216;Somebody&#8217;, and the GMAAs (Interview)" class="g1-frame" href="https://grungecake.com/trayc-selasi-interview/articles/79784"><div class="g1-frame-inner"><img width="364" height="205" src="https://cdn.statically.io/img/grungecake.com/wp-content/uploads/2021/07/trayc-selasi-grungecake-thumbnail-364x205.jpg?quality=100&f=auto" class="attachment-bimber-grid-standard size-bimber-grid-standard wp-post-image jetpack-lazy-image" alt="" data-attachment-id="79167" data-permalink="https://grungecake.com/trayc-selasi-somebody-video/articles/79166/trayc-selasi-grungecake-thumbnail" data-orig-file="https://grungecake.com/wp-content/uploads/2021/07/trayc-selasi-grungecake-thumbnail.jpg" data-orig-size="1000,1498" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="trayc-selasi-grungecake-thumbnail" data-image-description="" data-image-caption="&lt;p&gt;Photo: Courtesy of the publicist&lt;/p&gt;" data-medium-file="https://grungecake.com/wp-content/uploads/2021/07/trayc-selasi-grungecake-thumbnail-200x300.jpg" data-large-file="https://grungecake.com/wp-content/uploads/2021/07/trayc-selasi-grungecake-thumbnail-684x1024.jpg" data-lazy-srcset="https://grungecake.com/wp-content/uploads/2021/07/trayc-selasi-grungecake-thumbnail-364x205.jpg 364w, https://grungecake.com/wp-content/uploads/2021/07/trayc-selasi-grungecake-thumbnail-192x108.jpg 192w, https://grungecake.com/wp-content/uploads/2021/07/trayc-selasi-grungecake-thumbnail-384x216.jpg 384w, https://grungecake.com/wp-content/uploads/2021/07/trayc-selasi-grungecake-thumbnail-728x409.jpg 728w, https://grungecake.com/wp-content/uploads/2021/07/trayc-selasi-grungecake-thumbnail-561x316.jpg 561w, https://grungecake.com/wp-content/uploads/2021/07/trayc-selasi-grungecake-thumbnail-758x426.jpg 758w" data-lazy-sizes="(max-width: 364px) 100vw, 364px" data-lazy-src="https://grungecake.com/wp-content/uploads/2021/07/trayc-selasi-grungecake-thumbnail-364x205.jpg?is-pending-load=1" srcset="" /><span class="g1-frame-icon g1-frame-icon-"></span></div></a></div>
		
	<div class="entry-body">
		<header class="entry-header">
			<div class="entry-before-title">
				
							</div>

		<h3 class="g1-epsilon g1-epsilon-1st entry-title"><a href="https://grungecake.com/trayc-selasi-interview/articles/79784" rel="bookmark">Ghanaian singer Trayc Selasi talks personal style, &#8216;Somebody&#8217;, and the GMAAs (Interview)</a></h3>		</header>

		
					<footer>
				<p class="g1-meta entry-meta entry-byline entry-byline-with-avatar">
								<span class="entry-author">
	
		<span class="entry-meta-label">by</span>
			<a href="https://grungecake.com/author/remyd" title="Posts by ReMyD" rel="author">
			<img width="30" height="30" src="https://cdn.statically.io/img/grungecake.com/wp-content/uploads/2021/06/redd-remyd-grungecake-thumbnail-48x48.jpeg?quality=100&f=auto" class="avatar avatar-30 photo jetpack-lazy-image" alt="" data-attachment-id="78215" data-permalink="https://grungecake.com/redd-remyd-grungecake-thumbnail" data-orig-file="https://grungecake.com/wp-content/uploads/2021/06/redd-remyd-grungecake-thumbnail-scaled.jpeg" data-orig-size="2560,1920" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="redd-remyd-grungecake-thumbnail" data-image-description="" data-image-caption="" data-medium-file="https://grungecake.com/wp-content/uploads/2021/06/redd-remyd-grungecake-thumbnail-300x225.jpeg" data-large-file="https://grungecake.com/wp-content/uploads/2021/06/redd-remyd-grungecake-thumbnail-1024x768.jpeg" data-lazy-srcset="https://grungecake.com/wp-content/uploads/2021/06/redd-remyd-grungecake-thumbnail-48x48.jpeg 48w, https://grungecake.com/wp-content/uploads/2021/06/redd-remyd-grungecake-thumbnail-290x290.jpeg 290w, https://grungecake.com/wp-content/uploads/2021/06/redd-remyd-grungecake-thumbnail-192x192.jpeg 192w, https://grungecake.com/wp-content/uploads/2021/06/redd-remyd-grungecake-thumbnail-384x384.jpeg 384w, https://grungecake.com/wp-content/uploads/2021/06/redd-remyd-grungecake-thumbnail-110x110.jpeg 110w, https://grungecake.com/wp-content/uploads/2021/06/redd-remyd-grungecake-thumbnail-220x220.jpeg 220w, https://grungecake.com/wp-content/uploads/2021/06/redd-remyd-grungecake-thumbnail-24x24.jpeg 24w, https://grungecake.com/wp-content/uploads/2021/06/redd-remyd-grungecake-thumbnail-96x96.jpeg 96w, https://grungecake.com/wp-content/uploads/2021/06/redd-remyd-grungecake-thumbnail-150x150.jpeg 150w, https://grungecake.com/wp-content/uploads/2021/06/redd-remyd-grungecake-thumbnail-300x300.jpeg 300w" data-lazy-sizes="(max-width: 30px) 100vw, 30px" data-lazy-src="https://grungecake.com/wp-content/uploads/2021/06/redd-remyd-grungecake-thumbnail-48x48.jpeg?is-pending-load=1" srcset="" />
							<strong>ReMyD</strong>
					</a>
	</span>
	
					<time class="entry-date" datetime="2021-07-24T01:13:47-05:00">24th July 2021, 1:13 AM</time>				</p>
			</footer>
		
			</div>
</article>
					</li>
							</ul>
		</div>
	</div><!-- .g1-collection -->
							</div>
			</aside></div><!-- #secondary -->

		</div>
	</div><!-- g1-row -->
</article>


		</div><!-- #content -->
	</div><!-- #primary -->



		<div class="g1-footer g1-row g1-row-layout-page">
			<div class="g1-row-inner">
				<div class="g1-column">

					<p class="g1-footer-text">2007-2021 © GRUNGECAKE, INC. The material on this site may not be reproduced, distributed, transmitted, cached or otherwise used, except with the prior written permission of GRUNGECAKE.</p>

					
					
					
			<a class="g1-footer-stamp" href="https://grungecake.com" title="GRUNGECAKE, INC">
			<img class="g1-footer-stamp-icon" width="400" height="50" src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw==" loading="lazy" alt="" data-loading="lazy" data-src="https://cdn.statically.io/img/grungecake.com/wp-content/uploads/2021/06/grungecake-logo-type-white.png?quality=100&f=auto" data-srcset="" />					<span class="g1-footer-stamp-label screen-reader-text">GRUNGECAKE, INC</span>
			</a>

				</div><!-- .g1-column -->
			</div>
			<div class="g1-row-background">
			</div>
		</div><!-- .g1-row -->

					<a href="#page" class="g1-back-to-top">Back to Top</a>
						</div><!-- #page -->

<div class="g1-canvas-overlay">
</div>

</div><!-- .g1-body-inner -->

<div id="g1-breakpoint-desktop">
</div>


<div class="g1-canvas g1-canvas-global g1-canvas-no-js">
	<div class="g1-canvas-inner">
		<div class="g1-canvas-content">
			<a class="g1-canvas-toggle" href="#">Close</a>

				<!-- BEGIN .g1-primary-nav -->
	<nav id="g1-canvas-primary-nav" class="g1-primary-nav"><ul id="g1-canvas-primary-nav-menu" class="g1-primary-nav-menu g1-menu-v"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-75536"><a href="https://grungecake.com">Home</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-76770"><a href="mailto:assistant@grungecake.com">Contact</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-66675"><a href="https://grungecake.com/category/music/premieres">Premieres</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62328"><a href="https://grungecake.com/category/recording-academy">Recording Academy</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-58318"><a href="https://grungecake.com/category/editorials/lists/playlists">Playlists</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-61863"><a href="https://grungecake.com/category/features/sound-searching-columns/song-of-the-day">Song of the Day</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category afs-menu-item-has-children menu-item-53656"><a href="https://grungecake.com/category/music">Music</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56942"><a href="https://grungecake.com/category/music/music-videos">Music Videos</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-58314"><a href="https://grungecake.com/category/music/streams-and-downloads">Streams and Downloads</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-83918"><a title="The $100 Ad" href="https://grungecake.com/product/the-100-ad">The $100 Ad</a></li>
</ul></nav>		<!-- END .g1-primary-nav -->
	<ul id="g1-social-icons-1" class="g1-socials-items g1-socials-items-tpl-grid">
			<li class="g1-socials-item g1-socials-item-facebook">
	   <a class="g1-socials-item-link" href="https://www.facebook.com/grungecake" target="_blank" rel="noopener">
		   <span class="g1-socials-item-icon g1-socials-item-icon-48 g1-socials-item-icon-text g1-socials-item-icon-facebook"></span>
		   <span class="g1-socials-item-tooltip">
			   <span class="g1-socials-item-tooltip-inner">Facebook</span>
		   </span>
	   </a>
	</li>
			<li class="g1-socials-item g1-socials-item-twitter">
	   <a class="g1-socials-item-link" href="https://twitter.com/grungecake" target="_blank" rel="noopener">
		   <span class="g1-socials-item-icon g1-socials-item-icon-48 g1-socials-item-icon-text g1-socials-item-icon-twitter"></span>
		   <span class="g1-socials-item-tooltip">
			   <span class="g1-socials-item-tooltip-inner">Twitter</span>
		   </span>
	   </a>
	</li>
			<li class="g1-socials-item g1-socials-item-instagram">
	   <a class="g1-socials-item-link" href="https://instagram.com/grungecake" target="_blank" rel="noopener">
		   <span class="g1-socials-item-icon g1-socials-item-icon-48 g1-socials-item-icon-text g1-socials-item-icon-instagram"></span>
		   <span class="g1-socials-item-tooltip">
			   <span class="g1-socials-item-tooltip-inner">Instagram</span>
		   </span>
	   </a>
	</li>
	</ul>
	<!-- BEGIN .g1-secondary-nav -->
			<!-- END .g1-secondary-nav -->
	

<div role="search" class="search-form-wrapper">
	<form method="get"
	      class="g1-searchform-tpl-default search-form"
	      action="https://grungecake.com/">
		<label>
			<span class="screen-reader-text">Search for:</span>
			<input type="search" class="search-field"
			       placeholder="Search"
			       value="" name="s"
			       title="Search for:" />
		</label>
		<button class="search-submit">Search</button>
	</form>

	</div>
		</div>
							<div class="g1-canvas-background">
			</div>
			</div>
</div>
<!--  -->
<script defer id='bilmur' data-provider='wordpress.com' data-service='atomic' src='https://s0.wp.com/wp-content/js/bilmur.min.js?m=202144'></script>
 <!--Bottom of the page/End of Page-->
<div style="bottom: 0px;text-align: center;position:fixed;z-index: 27;margin: 0 auto;width: 100%;background: white;border-top: 5px solid black;">
  <span data-bg="https://s3.amazonaws.com/script-tags/close2.png" class="" id="hcmcloseButton" style="background:none;z-index: 2147;position:fixed;background-size: contain;background-repeat: no-repeat;width: 25px;height: 25px;display: block;background-image: url(https://cdn.statically.io/img/s3.amazonaws.com/script-tags/close2.png?quality=100);right: 0px;" data-loading="lazy-background"></span>
  <div id='gpt-adslot-10' >
        <script>
            googletag.cmd.push(function() { googletag.display('gpt-adslot-10'); });
        </script>
    </div>
<script>
    document.getElementById('hcmcloseButton').onclick = function(e){ this.parentElement.remove()}
    </script>
</div><p class="woocommerce-store-notice demo_store" data-notice-id="790251442dc1b943af3a1e96eb8640b5" style="display:none;">Welcome to GRUNGECAKE.com, a Recording Academy recognised brand known for global music discovery, unique PR strategies, short-stacked hearty articles. <a href="#" class="woocommerce-store-notice__dismiss-link">Dismiss</a></p>	<div style="display:none">
	<div class="grofile-hash-map-99be6450fcb4104fabedb113fe791c73">
	</div>
	<div class="grofile-hash-map-a782d1cb4381f310f294361d3aee7256">
	</div>
	<div class="grofile-hash-map-081650baa2df29195d5a328ae7d5beb1">
	</div>
	<div class="grofile-hash-map-4e4aafab52cd480cc8d2f5e95ca61ae5">
	</div>
	</div>
	<script type="text/javascript">
		(function () {
			var c = document.body.className;
			c = c.replace(/woocommerce-no-js/, 'woocommerce-js');
			document.body.className = c;
		})();
	</script>
			<div id="jp-carousel-loading-overlay">
			<div id="jp-carousel-loading-wrapper">
				<span id="jp-carousel-library-loading">&nbsp;</span>
			</div>
		</div>
		<div class="jp-carousel-overlay jp-carousel-light" style="display: none;">

		<div class="jp-carousel-container jp-carousel-light">
			<!-- The Carousel Swiper -->
			<div
				class="jp-carousel-wrap swiper-container jp-carousel-swiper-container jp-carousel-transitions"
				itemscope
				itemtype="https://schema.org/ImageGallery">
				<div class="jp-carousel swiper-wrapper"></div>
				<div class="jp-swiper-button-prev swiper-button-prev">
					<svg width="25" height="24" viewbox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
						<mask id="maskPrev" mask-type="alpha" maskunits="userSpaceOnUse" x="8" y="6" width="9" height="12">
							<path d="M16.2072 16.59L11.6496 12L16.2072 7.41L14.8041 6L8.8335 12L14.8041 18L16.2072 16.59Z" fill="white"/>
						</mask>
						<g mask="url(#maskPrev)">
							<rect x="0.579102" width="23.8823" height="24" fill="#FFFFFF"/>
						</g>
					</svg>
				</div>
				<div class="jp-swiper-button-next swiper-button-next">
					<svg width="25" height="24" viewbox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
						<mask id="maskNext" mask-type="alpha" maskunits="userSpaceOnUse" x="8" y="6" width="8" height="12">
							<path d="M8.59814 16.59L13.1557 12L8.59814 7.41L10.0012 6L15.9718 12L10.0012 18L8.59814 16.59Z" fill="white"/>
						</mask>
						<g mask="url(#maskNext)">
							<rect x="0.34375" width="23.8822" height="24" fill="#FFFFFF"/>
						</g>
					</svg>
				</div>
			</div>
			<!-- The main close buton -->
			<div class="jp-carousel-close-hint">
				<svg width="25" height="24" viewbox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
					<mask id="maskClose" mask-type="alpha" maskunits="userSpaceOnUse" x="5" y="5" width="15" height="14">
						<path d="M19.3166 6.41L17.9135 5L12.3509 10.59L6.78834 5L5.38525 6.41L10.9478 12L5.38525 17.59L6.78834 19L12.3509 13.41L17.9135 19L19.3166 17.59L13.754 12L19.3166 6.41Z" fill="white"/>
					</mask>
					<g mask="url(#maskClose)">
						<rect x="0.409668" width="23.8823" height="24" fill="#FFFFFF"/>
					</g>
				</svg>
			</div>
			<!-- Image info, comments and meta -->
			<div class="jp-carousel-info">
				<div class="jp-carousel-info-footer">
					<div class="jp-carousel-pagination-container">
						<div class="jp-swiper-pagination swiper-pagination"></div>
						<div class="jp-carousel-pagination"></div>
					</div>
					<div class="jp-carousel-photo-title-container">
						<h2 class="jp-carousel-photo-caption"></h2>
					</div>
					<div class="jp-carousel-photo-icons-container">
						<a href="#" class="jp-carousel-icon-btn jp-carousel-icon-info" aria-label="Toggle photo metadata visibility">
							<span class="jp-carousel-icon">
								<svg width="25" height="24" viewbox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
									<mask id="maskInfo" mask-type="alpha" maskunits="userSpaceOnUse" x="2" y="2" width="21" height="20">
										<path fill-rule="evenodd" clip-rule="evenodd" d="M12.7537 2C7.26076 2 2.80273 6.48 2.80273 12C2.80273 17.52 7.26076 22 12.7537 22C18.2466 22 22.7046 17.52 22.7046 12C22.7046 6.48 18.2466 2 12.7537 2ZM11.7586 7V9H13.7488V7H11.7586ZM11.7586 11V17H13.7488V11H11.7586ZM4.79292 12C4.79292 16.41 8.36531 20 12.7537 20C17.142 20 20.7144 16.41 20.7144 12C20.7144 7.59 17.142 4 12.7537 4C8.36531 4 4.79292 7.59 4.79292 12Z" fill="white"/>
									</mask>
									<g mask="url(#maskInfo)">
										<rect x="0.8125" width="23.8823" height="24" fill="#FFFFFF"/>
									</g>
								</svg>
							</span>
						</a>
												<a href="#" class="jp-carousel-icon-btn jp-carousel-icon-comments" aria-label="Toggle photo comments visibility">
							<span class="jp-carousel-icon">
								<svg width="25" height="24" viewbox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
									<mask id="maskComments" mask-type="alpha" maskunits="userSpaceOnUse" x="2" y="2" width="21" height="20">
										<path fill-rule="evenodd" clip-rule="evenodd" d="M4.3271 2H20.2486C21.3432 2 22.2388 2.9 22.2388 4V16C22.2388 17.1 21.3432 18 20.2486 18H6.31729L2.33691 22V4C2.33691 2.9 3.2325 2 4.3271 2ZM6.31729 16H20.2486V4H4.3271V18L6.31729 16Z" fill="white"/>
									</mask>
									<g mask="url(#maskComments)">
										<rect x="0.34668" width="23.8823" height="24" fill="#FFFFFF"/>
									</g>
								</svg>

								<span class="jp-carousel-has-comments-indicator" aria-label="This image has comments."></span>
							</span>
						</a>
											</div>
				</div>
				<div class="jp-carousel-info-extra">
					<div class="jp-carousel-info-content-wrapper">
						<div class="jp-carousel-photo-title-container">
							<h2 class="jp-carousel-photo-title"></h2>
						</div>
						<div class="jp-carousel-comments-wrapper">
															<div id="jp-carousel-comments-loading">
									<span>Loading Comments...</span>
								</div>
								<div class="jp-carousel-comments"></div>
								<div id="jp-carousel-comment-form-container">
									<span id="jp-carousel-comment-form-spinner">&nbsp;</span>
									<div id="jp-carousel-comment-post-results"></div>
																														<form id="jp-carousel-comment-form">
												<label for="jp-carousel-comment-form-comment-field" class="screen-reader-text">Write a Comment...</label>
												<textarea
													name="comment"
													class="jp-carousel-comment-form-field jp-carousel-comment-form-textarea"
													id="jp-carousel-comment-form-comment-field"
													placeholder="Write a Comment..."
												></textarea>
												<div id="jp-carousel-comment-form-submit-and-info-wrapper">
													<div id="jp-carousel-comment-form-commenting-as">
																													<fieldset>
																<label for="jp-carousel-comment-form-email-field">Email (Required)</label>
																<input type="text" name="email" class="jp-carousel-comment-form-field jp-carousel-comment-form-text-field" id="jp-carousel-comment-form-email-field" />
															</fieldset>
															<fieldset>
																<label for="jp-carousel-comment-form-author-field">Name (Required)</label>
																<input type="text" name="author" class="jp-carousel-comment-form-field jp-carousel-comment-form-text-field" id="jp-carousel-comment-form-author-field" />
															</fieldset>
															<fieldset>
																<label for="jp-carousel-comment-form-url-field">Website</label>
																<input type="text" name="url" class="jp-carousel-comment-form-field jp-carousel-comment-form-text-field" id="jp-carousel-comment-form-url-field" />
															</fieldset>
																											</div>
													<input
														type="submit"
														name="submit"
														class="jp-carousel-comment-form-button"
														id="jp-carousel-comment-form-button-submit"
														value="Post Comment" />
												</div>
											</form>
																											</div>
													</div>
						<div class="jp-carousel-image-meta">
							<div class="jp-carousel-title-and-caption">
								<div class="jp-carousel-photo-info">
									<h3 class="jp-carousel-caption" itemprop="caption description"></h3>
								</div>

								<div class="jp-carousel-photo-description"></div>
							</div>
							<ul class="jp-carousel-image-exif" style="display: none;"></ul>
							<a class="jp-carousel-image-download" target="_blank" style="display: none;">
								<svg width="25" height="24" viewbox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
									<mask id="mask0" mask-type="alpha" maskunits="userSpaceOnUse" x="3" y="3" width="19" height="18">
										<path fill-rule="evenodd" clip-rule="evenodd" d="M5.84615 5V19H19.7775V12H21.7677V19C21.7677 20.1 20.8721 21 19.7775 21H5.84615C4.74159 21 3.85596 20.1 3.85596 19V5C3.85596 3.9 4.74159 3 5.84615 3H12.8118V5H5.84615ZM14.802 5V3H21.7677V10H19.7775V6.41L9.99569 16.24L8.59261 14.83L18.3744 5H14.802Z" fill="white"/>
									</mask>
									<g mask="url(#mask0)">
										<rect x="0.870605" width="23.8823" height="24" fill="#FFFFFF"/>
									</g>
								</svg>
								<span class="jp-carousel-download-text"></span>
							</a>
							<div class="jp-carousel-image-map" style="display: none;"></div>
						</div>
					</div>
				</div>
			</div>
		</div>

		</div>
		
	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/grungecake.com\/which-nfl-club-best-fit-odell-beckham-jr\/articles\/83935":83935};
	</script>
					<div id="sharing_email" style="display: none;">
		<form action="/which-nfl-club-best-fit-odell-beckham-jr/articles/83935" method="post">
			<label for="target_email">Send to Email Address</label>
			<input type="email" name="target_email" id="target_email" value="" />

			
				<label for="source_name">Your Name</label>
				<input type="text" name="source_name" id="source_name" value="" />

				<label for="source_email">Your Email Address</label>
				<input type="email" name="source_email" id="source_email" value="" />

						<input type="text" id="jetpack-source_f_name" name="source_f_name" class="input" value="" size="25" autocomplete="off" title="This field is for validation and should not be changed" />
			
			<img style="float: right; display: none" class="loading" src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw==" alt="loading" width="16" height="16" data-loading="lazy" data-src="https://cdn.statically.io/img/grungecake.com/wp-content/plugins/jetpack/modules/sharedaddy/images/loading.gif?quality=100&f=auto" />
			<input type="submit" value="Send Email" class="sharing_send" />
			<a rel="nofollow" href="#cancel" class="sharing_cancel" role="button">Cancel</a>

			<div class="errors errors-1" style="display: none;">
				Post was not sent - check your email addresses!			</div>

			<div class="errors errors-2" style="display: none;">
				Email check failed, please try again			</div>

			<div class="errors errors-3" style="display: none;">
				Sorry, your blog cannot share posts by email.			</div>
		</form>
	</div>
		<link rel='stylesheet' id='afsmenu-font-awesome-css'  href='//cdnjs.cloudflare.com/ajax/libs/font-awesome/4.7.0/css/font-awesome.min.css?ver=5.8.1' type='text/css' media='all' />
<link rel='stylesheet' id='g1-socials-basic-screen-css'  href='https://grungecake.com/wp-content/plugins/g1-socials/css/screen-basic.min.css?ver=1.2.24' type='text/css' media='all' />
<link rel='stylesheet' id='g1-socials-snapcode-css'  href='https://grungecake.com/wp-content/plugins/g1-socials/css/snapcode.min.css?ver=1.2.24' type='text/css' media='all' />
<script type='text/javascript' src='https://grungecake.com/wp-content/plugins/metronet-profile-picture/js/mpp-frontend.js?ver=2.6.0' id='mpp_gutenberg_tabs-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.8.1/wp-includes/js/dist/vendor/regenerator-runtime.min.js' id='regenerator-runtime-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.8.1/wp-includes/js/dist/vendor/wp-polyfill.min.js' id='wp-polyfill-js'></script>
<script type='text/javascript' id='contact-form-7-js-extra'>
/* <![CDATA[ */
var wpcf7 = {"api":{"root":"https:\/\/grungecake.com\/wp-json\/","namespace":"contact-form-7\/v1"},"cached":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://grungecake.com/wp-content/plugins/contact-form-7/includes/js/index.js?ver=5.5.2' id='contact-form-7-js'></script>
<script type='text/javascript' src='https://c0.wp.com/p/woocommerce/5.8.0/assets/js/jquery-blockui/jquery.blockUI.min.js' id='jquery-blockui-js'></script>
<script type='text/javascript' id='wc-add-to-cart-js-extra'>
/* <![CDATA[ */
var wc_add_to_cart_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/?wc-ajax=%%endpoint%%","i18n_view_cart":"View basket","cart_url":"https:\/\/grungecake.com","is_cart":"","cart_redirect_after_add":"no"};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/p/woocommerce/5.8.0/assets/js/frontend/add-to-cart.min.js' id='wc-add-to-cart-js'></script>
<script type='text/javascript' src='https://c0.wp.com/p/woocommerce/5.8.0/assets/js/js-cookie/js.cookie.min.js' id='js-cookie-js'></script>
<script type='text/javascript' id='woocommerce-js-extra'>
/* <![CDATA[ */
var woocommerce_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/?wc-ajax=%%endpoint%%"};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/p/woocommerce/5.8.0/assets/js/frontend/woocommerce.min.js' id='woocommerce-js'></script>
<script type='text/javascript' id='wc-cart-fragments-js-extra'>
/* <![CDATA[ */
var wc_cart_fragments_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/?wc-ajax=%%endpoint%%","cart_hash_key":"wc_cart_hash_8aa51e7d337bd9a619bf9006a73e3b44","fragment_name":"wc_fragments_8aa51e7d337bd9a619bf9006a73e3b44","request_timeout":"5000"};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/p/woocommerce/5.8.0/assets/js/frontend/cart-fragments.min.js' id='wc-cart-fragments-js'></script>
<script type='text/javascript' id='wc-cart-fragments-js-after'>
		jQuery( 'body' ).bind( 'wc_fragments_refreshed', function() {
			var jetpackLazyImagesLoadEvent;
			try {
				jetpackLazyImagesLoadEvent = new Event( 'jetpack-lazy-images-load', {
					bubbles: true,
					cancelable: true
				} );
			} catch ( e ) {
				jetpackLazyImagesLoadEvent = document.createEvent( 'Event' )
				jetpackLazyImagesLoadEvent.initEvent( 'jetpack-lazy-images-load', true, true );
			}
			jQuery( 'body' ).get( 0 ).dispatchEvent( jetpackLazyImagesLoadEvent );
		} );
		
</script>
<script type='text/javascript' src='https://secure.gravatar.com/js/gprofiles.js?ver=202144' id='grofiles-cards-js'></script>
<script type='text/javascript' id='wpgroho-js-extra'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://grungecake.com/wp-content/plugins/jetpack/modules/wpgroho.js?ver=10.4-a.1' id='wpgroho-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.8.1/wp-includes/js/comment-reply.min.js' id='comment-reply-js'></script>
<script type='text/javascript' src='https://grungecake.com/wp-content/themes/bimber/js/stickyfill/stickyfill.min.js?ver=2.0.3' id='stickyfill-js'></script>
<script type='text/javascript' src='https://grungecake.com/wp-content/themes/bimber/js/jquery.placeholder/placeholders.jquery.min.js?ver=4.0.1' id='jquery-placeholder-js'></script>
<script type='text/javascript' src='https://grungecake.com/wp-content/themes/bimber/js/jquery.timeago/jquery.timeago.js?ver=1.5.2' id='jquery-timeago-js'></script>
<script type='text/javascript' src='https://grungecake.com/wp-content/themes/bimber/js/jquery.timeago/locales/jquery.timeago.en.js' id='jquery-timeago-en-js'></script>
<script type='text/javascript' src='https://grungecake.com/wp-content/themes/bimber/js/matchmedia/matchmedia.js' id='match-media-js'></script>
<script type='text/javascript' src='https://grungecake.com/wp-content/themes/bimber/js/matchmedia/matchmedia.addlistener.js' id='match-media-add-listener-js'></script>
<script type='text/javascript' src='https://grungecake.com/wp-content/themes/bimber/js/picturefill/picturefill.min.js?ver=2.3.1' id='picturefill-js'></script>
<script type='text/javascript' src='https://grungecake.com/wp-content/themes/bimber/js/jquery.waypoints/jquery.waypoints.min.js?ver=4.0.0' id='jquery-waypoints-js'></script>
<script type='text/javascript' src='https://grungecake.com/wp-content/themes/bimber/js/libgif/libgif.js' id='libgif-js'></script>
<script type='text/javascript' src='https://grungecake.com/wp-content/themes/bimber/js/enquire/enquire.min.js?ver=2.1.2' id='enquire-js'></script>
<script type='text/javascript' id='bimber-global-js-extra'>
/* <![CDATA[ */
var bimber_front_config = "{\"ajax_url\":\"https:\\\/\\\/grungecake.com\\\/wp-admin\\\/admin-ajax.php\",\"timeago\":\"on\",\"sharebar\":\"off\",\"i18n\":{\"menu\":{\"go_to\":\"Go to\"},\"newsletter\":{\"subscribe_mail_subject_tpl\":\"Check out this great article: %subject%\"},\"bp_profile_nav\":{\"more_link\":\"More\"}},\"comment_types\":[\"wp\"],\"auto_load_limit\":5,\"auto_play_videos\":\"1\",\"use_gif_player\":true,\"setTargetBlank\":\"1\",\"useWaypoints\":\"1\",\"stack\":\"original-2018\"}";
/* ]]> */
</script>
<script type='text/javascript' src='https://grungecake.com/wp-content/themes/bimber/js/global.js?ver=8.5' id='bimber-global-js'></script>
<script type='text/javascript' src='https://grungecake.com/wp-content/themes/bimber/js/players.js?ver=8.5' id='bimber-players-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.8.1/wp-includes/js/jquery/ui/core.min.js' id='jquery-ui-core-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.8.1/wp-includes/js/jquery/ui/menu.min.js' id='jquery-ui-menu-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.8.1/wp-includes/js/dist/dom-ready.min.js' id='wp-dom-ready-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.8.1/wp-includes/js/dist/hooks.min.js' id='wp-hooks-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.8.1/wp-includes/js/dist/i18n.min.js' id='wp-i18n-js'></script>
<script type='text/javascript' id='wp-i18n-js-after'>
wp.i18n.setLocaleData( { 'text direction\u0004ltr': [ 'ltr' ] } );
</script>
<script type='text/javascript' id='wp-a11y-js-translations'>
( function( domain, translations ) {
	var localeData = translations.locale_data[ domain ] || translations.locale_data.messages;
	localeData[""].domain = domain;
	wp.i18n.setLocaleData( localeData, domain );
} )( "default", {"translation-revision-date":"2021-09-01 21:02:00+0000","generator":"GlotPress\/3.0.0-alpha.2","domain":"messages","locale_data":{"messages":{"":{"domain":"messages","plural-forms":"nplurals=2; plural=n != 1;","lang":"en_GB"},"Notifications":["Notifications"]}},"comment":{"reference":"wp-includes\/js\/dist\/a11y.js"}} );
</script>
<script type='text/javascript' src='https://c0.wp.com/c/5.8.1/wp-includes/js/dist/a11y.min.js' id='wp-a11y-js'></script>
<script type='text/javascript' id='jquery-ui-autocomplete-js-extra'>
/* <![CDATA[ */
var uiAutocompleteL10n = {"noResults":"No results found.","oneResult":"1 result found. Use up and down arrow keys to navigate.","manyResults":"%d results found. Use up and down arrow keys to navigate.","itemSelected":"Item selected."};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/c/5.8.1/wp-includes/js/jquery/ui/autocomplete.min.js' id='jquery-ui-autocomplete-js'></script>
<script type='text/javascript' src='https://grungecake.com/wp-content/themes/bimber/js/ajax-search.js?ver=8.5' id='bimber-ajax-search-js'></script>
<script type='text/javascript' src='https://grungecake.com/wp-content/themes/bimber/js/single.js?ver=8.5' id='bimber-single-js'></script>
<script type='text/javascript' src='https://grungecake.com/wp-content/plugins/jetpack/vendor/automattic/jetpack-lazy-images/src/../dist/intersection-observer.js?ver=1.1.3' id='jetpack-lazy-images-polyfill-intersectionobserver-js'></script>
<script type='text/javascript' id='jetpack-lazy-images-js-extra'>
/* <![CDATA[ */
var jetpackLazyImagesL10n = {"loading_warning":"Images are still loading. Please cancel your print and try again."};
/* ]]> */
</script>
<script type='text/javascript' src='https://grungecake.com/wp-content/plugins/jetpack/vendor/automattic/jetpack-lazy-images/src/../dist/lazy-images.js?ver=1.1.3' id='jetpack-lazy-images-js'></script>
<script type='text/javascript' src='https://grungecake.com/wp-content/themes/bimber/js/wc-cart.js?ver=8.5' id='bimber-wc-cart-js'></script>
<script type='text/javascript' id='afsmenu-scripts-js-extra'>
/* <![CDATA[ */
var afsmenu = {"autohide_scroll":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://grungecake.com/wp-content/plugins/animated-fullscreen-menu/frontend/js/nav.js?ver=2.2.5' id='afsmenu-scripts-js'></script>
<script type='text/javascript' id='site-reviews-js-before'>
window.hasOwnProperty("GLSR")||(window.GLSR={});GLSR.action="glsr_action";GLSR.ajaxpagination=["#wpadminbar",".site-navigation-fixed"];GLSR.ajaxurl="https://grungecake.com/wp-admin/admin-ajax.php";GLSR.nameprefix="site-reviews";GLSR.stars={"clearable":false,"tooltip":false};GLSR.urlparameter=true;GLSR.validationconfig={field:"glsr-field",form:"glsr-form","field_error":"glsr-field-is-invalid","field_message":"glsr-field-error","field_required":"glsr-required","field_valid":"glsr-field-is-valid","form_error":"glsr-form-is-invalid","form_message":"glsr-form-message","form_message_failed":"glsr-form-failed","form_message_success":"glsr-form-success","input_error":"glsr-is-invalid","input_valid":"glsr-is-valid"};GLSR.validationstrings={accepted:"This field must be accepted.",between:"This field value must be between %s and %s.",betweenlength:"This field must have between %s and %s characters.",email:"This field requires a valid e-mail address.",errors:"Please fix the submission errors.",max:"Maximum value for this field is %s.",maxlength:"This field allows a maximum of %s characters.",min:"Minimum value for this field is %s.",minlength:"This field requires a minimum of %s characters.",number:"This field requires a number.",required:"This field is required.",unsupported:"The review could not be submitted because this browser is too old. Please try again with a modern browser."};
</script>
<script type='text/javascript' src='https://grungecake.com/wp-content/plugins/site-reviews/assets/scripts/site-reviews.js?ver=5.16.2' id='site-reviews-js'></script>
<script type='text/javascript' id='site-reviews-js-after'>
function glsr_init_elementor(){GLSR.Event.trigger("site-reviews/init")}"undefined"!==typeof jQuery&&(jQuery(window).on("elementor/frontend/init",function(){elementorFrontend.hooks.addAction("frontend/element_ready/site_reviews.default",glsr_init_elementor);elementorFrontend.hooks.addAction("frontend/element_ready/site_reviews_form.default",glsr_init_elementor)}));
</script>
<script type='text/javascript' src='https://c0.wp.com/c/5.8.1/wp-includes/js/wp-embed.min.js' id='wp-embed-js'></script>
<script type='text/javascript' id='jetpack-carousel-js-extra'>
/* <![CDATA[ */
var jetpackSwiperLibraryPath = {"url":"https:\/\/grungecake.com\/wp-content\/plugins\/jetpack\/_inc\/build\/carousel\/swiper-bundle.min.js"};
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/grungecake.com\/wp-admin\/admin-ajax.php","nonce":"6609dbe1ad","display_exif":"1","display_comments":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"white","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/grungecake.com\/wp-login.php?redirect_to=https%3A%2F%2Fgrungecake.com%2Fwhich-nfl-club-best-fit-odell-beckham-jr%2Farticles%2F83935","blog_id":"1","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"]};
/* ]]> */
</script>
<script type='text/javascript' src='https://grungecake.com/wp-content/plugins/jetpack/_inc/build/carousel/jetpack-carousel.min.js?ver=10.4-a.1' id='jetpack-carousel-js'></script>
<script type='text/javascript' src='https://grungecake.com/wp-content/themes/bimber/js/back-to-top.js?ver=8.5' id='bimber-back-to-top-js'></script>
<script type='text/javascript' id='sharing-js-js-extra'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://grungecake.com/wp-content/plugins/jetpack/_inc/build/sharedaddy/sharing.min.js?ver=10.4-a.1' id='sharing-js-js'></script>
<script type='text/javascript' id='sharing-js-js-after'>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</script>
<script type="text/javascript" id="flying-images">"use strict";window.FIConfig={lazyMethod:"javascript",lazyMargin:500};var flyingImages=function(){var a=document.querySelectorAll("[data-loading=\"lazy\"]");if(window.FIConfig.lazyMethod.includes("native")&&"loading"in HTMLImageElement.prototype)a.forEach(function(a){a.removeAttribute("data-loading"),a.setAttribute("loading","lazy"),a.dataset.srcset&&(a.srcset=a.dataset.srcset),a.src=a.dataset.src});else if(window.IntersectionObserver){var b=new IntersectionObserver(function(a){a.forEach(function(a){a.isIntersecting&&(b.unobserve(a.target),a.target.dataset.srcset&&(a.target.srcset=a.target.dataset.srcset),a.target.src=a.target.dataset.src,a.target.classList.add("lazyloaded"),a.target.removeAttribute("data-loading"))})},{rootMargin:window.FIConfig.lazyMargin+"px"});a.forEach(function(a){b.observe(a)})}else for(var c=0;c<a.length;c++)a[c].dataset.srcset&&(a[c].srcset=a[c].dataset.srcset),a[c].src=a[c].dataset.src};flyingImages();function throttle(a,b){var c=!1;return function(){c||(a.apply(null,arguments),c=!0,setTimeout(function(){c=!1},b))}}var dynamicContentObserver=new MutationObserver(throttle(flyingImages,125));dynamicContentObserver.observe(document.body,{attributes:!0,childList:!0,subtree:!0}),function(){var a=document.querySelectorAll("[data-loading=\"lazy-background\"]");if(window.IntersectionObserver){var d=new IntersectionObserver(function(a){a.forEach(function(a){if(a.isIntersecting){d.unobserve(a.target);var b=a.target.getAttribute("style"),c=b.replace("background:none;","");a.target.setAttribute("style",c),a.target.removeAttribute("data-loading")}})},{rootMargin:window.FIConfig.lazyMargin+"px"});a.forEach(function(a){d.observe(a)})}else for(var e=0;e<a.length;e++){var b=a[e].target.getAttribute("style"),c=b.replace("background:none;","");a[e].target.setAttribute("style",c),a[e].target.removeAttribute("data-loading")}}();</script>
    <script>!function(){window.advanced_ads_ready_queue=window.advanced_ads_ready_queue||[],advanced_ads_ready_queue.push=window.advanced_ads_ready;for(var d=0,a=advanced_ads_ready_queue.length;d<a;d++)advanced_ads_ready(advanced_ads_ready_queue[d])}();</script><script src='https://stats.wp.com/e-202144.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:10.4-a.1',blog:'196905043',post:'83935',tz:'-5',srv:'grungecake.com'} ]);
	_stq.push([ 'clickTrackerInit', '196905043', '83935' ]);
</script>
</body>
</html>